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IN THIS CHAPTER, YOU WILL LEARN HOW  TO 

▪ Identify the editions and features of Visio 2013. 

▪ Get started with Visio 2013. 

▪ Explore, minimize, and restore the Visio ribbon. 

▪ Understand tool tabs and add-in tabs. 

▪ Understand shapes, masters, stencils, and templates. 

▪ Explore the drawing window and manage the Shapes window. 

▪ Pan and zoom in Visio. 

Microsoft Visio is the premier application for creating business diagrams of all types, 

ranging from flowcharts, network diagrams, and organization charts, to floor plans and 

brainstorming diagrams. Even though this book contains dozens of examples and sample 

diagrams, it can only scratch the surface of the hundreds of types of diagrams you can cre- 

ate with Visio. 

Microsoft Visio 2013 continues the use of the fluent user interface (UI), otherwise known 

as the ribbon, that was introduced with Visio 2010. Regardless of what you might think of 

the ribbon in other Microsoft Office applications, it feels right at home in Visio, primarily 

because the goal of a ribbon-style interface is a visual presentation of a related group of 

functions, and Visio is, first and foremost, a visual product. 

 

In this chapter, you will learn that there are three editions of Visio 2013, and will discover 

what’s new in the 2013 release of the product. You will launch Visio and explore the 

Backstage view and will then explore the tabs on the Visio ribbon. You will compare the 

permanent tabs on the ribbon with tool tabs sets and add-in tabs. You will learn about 

stencils, templates, masters, and shapes and how to manage the various windows that 

comprise the Visio user interface. Finally, you will learn how to pan and zoom the diagram 

in the drawing window. 

A visual orientation to a 
visual product 
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PRACTICE FILES You don’t need any practice files to complete the exercises in this chapter. 
 

 

 
 

Identifying the editions of Visio  2013 
Visio 2013 is available in three editions. The first two editions utilize the traditional desktop 

software purchase and installation model and mirror the two editions that were offered in 

most prior Visio releases. The third edition is part of the Office 365 suite of subscription- 

based applications. 

▪ Visio Standard 2013 Visio Standard is the starter edition of Visio. It provides signifi- 
cant capability for creating business diagrams and includes 26 templates for creating 

diagrams in six categories. 

▪ Visio Professional 2013 Visio Professional expands on the Standard edition by 
offering more than four dozen additional templates for a total of 76 across eight 

categories. In addition, Visio Pro includes the ability to link diagrams to a wide variety 

of data sources, and includes a diagram validation capability that is especially well- 

suited for the expanded set of business process diagrams it supports. 

▪ Visio Pro for Office 365 This new edition of Visio 2013 provides the identical fea- 
tures and templates as Visio Professional 2013. The key differences in this edition are 

in packaging and delivery, because it is part of Microsoft Office 365. Office 365 is a cloud-

based subscription service. Instead  of  purchasing  Visio  Pro  for  Office  365,  you pay a 

monthly subscription and can install the software on up to five computers run-    ning 

Windows 7 or Windows 8. Each time you install, you automatically receive the latest 

updates. 

 

 

Identifying new features of Visio  2013 
If you have used any previous version of Visio, you will find a rich set of new features de- 

scribed in the sections that follow. Even if you’ve never used Visio, it will still be worth read- 

ing through the features described here in order to learn more about the capabilities of the 

software. 
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If you are upgrading from Visio 2010 
Visio 2010 introduced the ribbon user interface and a long list of new features. Visio 2013 

continues the momentum with another long list of enhancements and new capabilities. 

TIP The data-connected sample diagrams that were included with Visio 2010 and 1  
Visio 2007 are no longer included with Visio 2013. In addition, the database reverse 

engineering add-in is no longer packaged with Visio 2013. 

▪ Updated, modern shapes Hundreds of shapes have been completely redesigned 
for Visio 2013 to make your diagrams look fresh and modern, and to accommodate 

Visio 2013 themes. The new shapes are included with the stencils used in many fam- 

iliar templates, enhancing the appearance of Basic Network, Organization Chart, 

Timeline,  Workflow,  and  SharePoint  Workflow  diagrams,  among  others. 

▪ Professional appearance Visio 2013 themes have been dramatically enhanced, 
making it easier than ever to produce eye-catching yet professional-looking dia- 

grams. In addition, themes have been supplemented with pre-designed visual 

variants that let you add your personal touch. Further, you can apply effects like 

reflection,  glow,  and  bevel  to  provide  additional emphasis. 

▪ Integration with the cloud The Open, Save, and Save As pages in the Visio 2013 
Backstage view provide easy access to your SkyDrive account, as well as to Microsoft 

SharePoint and SharePoint Online sites. 

▪ Improved integration with SharePoint Publishing Visio diagrams to SharePoint is 
easier than ever because SharePoint 2013 can open Visio files directly. Diagrams pub- 

lished to SharePoint can be viewed using almost any web browser. 

▪ Collaboration (commenting)  Multiple people can read and add comments to 
a Visio diagram using either Visio or a web browser when diagrams are stored in 

SharePoint or SharePoint Online. 

▪ Change shape With Visio 2013, you can replace one shape with another, and the 
new shape will retain the connections, text, and data from the original shape. 

▪ Duplicate page You can create a duplicate copy of any Visio page with two clicks. 

▪ Enhanced template and shape search It’s easier in Visio 2013 to locate the right 
template to begin a new diagram or to find exactly the right shape to enhance your 

diagram. Search results are sorted and filtered more effectively and duplicate results 

are eliminated. 
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▪ Organization charts with photos The Organization Chart wizard has been en- 
hanced in Visio 2013 to provide bulk import of photographs. 

▪ Improved Mini Toolbar The Mini Toolbar that appears when you right-click either 
the drawing page or a shape has been revamped, further streamlining many actions 

and reducing mouse movement. The Drawing Tools, Connector Tool, Change Shape, 

Shape Styles, and alignment features have been added to the Mini Toolbar. 

▪ Enhanced touch support Visio 2013 recognizes a greater array of gestures and 
touch for easier use on tablets and computers with touch screens. 

▪ New file format All previous versions of Visio stored drawings in a proprietary file 

format. Visio 2013 joins other members of the Microsoft Office family in using   the 

Open Packaging Convention, an XML-based format. The new .vsdx file format makes  

the contents of Visio drawings more accessible to other applications for a variety of 

purposes, including integration with SharePoint as described previously and following. 

 

The following features are available only in the Professional edition of Visio 2013. 

▪ Collaboration (coauthoring) Multiple authors can edit the same Visio 2013 
document simultaneously when the document is stored on SkyDrive, SharePoint, 

or SharePoint Online in Office  365. 

▪ SharePoint Workflow integration Visio 2013 supports the Microsoft .NET 
Framework  4  workflows  that  are  supported  in  SharePoint  2013.  In   addition, 

Microsoft SharePoint Designer 2013 can open and manipulate Visio 2013 files 

directly. Consequently, you can use Visio’s visual workflow design features to 

create workflows in both Visio and SharePoint Designer, and then execute them 

with SharePoint Workflow. 

▪ Updated BPMN and UML templates The Business Process Model and Notation 
(BPMN)  template  now  conforms  to  version  2.0  of  that  standard,  and  the   Unified 

Modeling Language (UML) templates conform to UML version 2.4. 

 
SEE ALSO The Visio product team wrote a series of blog posts describing the new features 

in Visio 2013. Refer to blogs.office.com/b/visio/archive/2013/03/19/recapping-posts-on-the- 

new-visio.aspx for a summary. 

 

If you are upgrading from Visio 2007 
Visio 2010 was the most significant upgrade to the capabilities of Visio in years. If you are 

upgrading from Visio 2007, you will benefit from the following features in addition to ev- 

erything listed in the previous section. 
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▪ New user interface Visio 2010 is the first version of the product to incorporate the 

ribbon user interface (UI) and the Backstage view. In addition, the Shapes window 

presents stencils more logically and can be minimized so it occupies less screen real 

estate. 

▪ Enhanced user experience Live Preview is a tremendous addition to Visio 2010, 1  
because it enables you to view potential changes in color, fill pattern, font size,   shape 

type, data graphics, and more, before you commit to the change. Visio 2010 also 

reduces required mouse movement with features like AutoConnect and Quick Shapes 

(refer to next bullet), and the Mini Toolbar. 

▪ Diagramming support  Multiple features whose names begin with Auto or Quick 

suggest that creating and organizing Visio 2010 diagrams is even easier, and it’s 

true. AutoConnect and Quick Shapes add new connectors and shapes; AutoAdd and 

AutoDelete simplify adding and removing shapes on the page; AutoSize expands and 

contracts Visio page dimensions. In addition, the Add page button creates new pages 

with a single click, and enhanced copy/paste enables you to control where shapes 

will be pasted. Finally, the enhanced Dynamic Grid provides excellent visual feedback 

when placing or moving shapes, dramatically reducing the need to nudge and reposi- 

tion shapes after they are on the page. 

▪ Structured diagrams Visio 2010 introduces a new type of shape called a container 
that provides more than just a visual grouping for a set of shapes. Shapes in a con- 

tainer know they are contained, and the container knows the members that reside 

within it. Consequently, when you move, copy, or delete a container, all of the mem- 

bers go with it. However, unlike a group shape, the member shapes are accessible 

with a single click just as if the container were not there. 

In most containers, you can place member shapes wherever you’d like. However, a list 

is a special type of container that maintains members in ordered sequence. Each list 

member knows exactly where it resides within the list. 

The third structured diagram element is a new type of callout. The purpose of a call- 

out is still the same—to add annotations to shapes on the page—but both the call- 

out and the target shape are aware of each other, which dramatically improves shape 

behavior. 

Not only do containers, lists, and callouts enable users to make more effective dia- 

grams more easily, they also provide significant opportunities to Visio developers for 

building location-aware shapes and for writing code that takes advantage of diagram 

structure. 
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▪ Enhanced appearance Visio 2010 themes and effects add a new professional ap- 
pearance to your diagrams. The themes gallery, with Live Preview, lets you sample 

more than two dozen coordinated sets of colors, fonts, patterns, and effects before 

choosing the one that is just right for your diagram. 

▪ Improved CAD support Visio 2010 supports import, conversion, and export of 
newer  file  types  from  Autodesk’s  AutoCAD software. 

▪ Save as PDF or XPS The software to save diagrams in Portable Document Format 
(PDF)  or  XML  Paper  Specification  (XPS)  format  is  now  bundled  with Visio. 

 

The following features are available only in the Professional or Premium editions of Visio 2010. 

▪ Dynamic web diagrams Previous versions of Visio have allowed you to save a Visio 
drawing as a set of webpages but with one key limitation: if the diagram changed, 

you needed to republish the website. Visio 2010, in conjunction with Visio Services 

on SharePoint 2010, introduces the ability to create dynamic websites from data- 

connected diagrams. Now, many changes to the diagram, or to the data behind the 

diagram, appear automatically for anyone viewing your diagram with a web browser. 

▪ Business process Several new features add to your ability to create business process 
diagrams in Visio 2010: a BPMN template that conforms to the 1.2 version of the 

BPMN standard; a feature that automatically creates subprocess pages for flowcharts 

and BPMN diagrams; and a new interchange file type that lets you create SharePoint 

Workflow diagrams in Visio and export them to SharePoint Designer (you can also 

import SharePoint Workflow diagrams into Visio to view graphical representations of 

the workflows). 

▪ Diagram validation You can ensure that your diagrams meet a minimum set of 
predefined conditions before you publish or distribute them using diagram valida- 

tion rules. Four Visio 2010 templates—Basic Flowchart, Cross Functional Flowchart, 

Microsoft SharePoint Workflow, and BPMN—include predefined validation  rule  sets.  

You can edit the existing rule sets or create your own. 

 

If you are upgrading from Visio 2003 
Visio 2007 Professional introduced an important set of data-related enhancements that 

significantly improved your ability to create data-rich diagrams and to visualize that data 

creatively and effectively. 

▪ Themes Visio 2007 introduces themes—a fast way to add style and a professionally 
designed look to your diagrams. 
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▪ AutoConnect You no longer need to return to the stencil every time you want to 
add a shape to the page. When you click one of the four AutoConnect arrows that 

appear when you point to an existing shape on the drawing page, Visio adds a con- 

nector and a copy of the currently selected master shape in the stencil. 

▪ Save as PDF or XPS After downloading a free, add-in available from Microsoft, you 1  
can save Visio diagrams in either PDF or XPS format. 

▪ Sample diagrams Visio 2007 includes five sample diagrams in the new Getting 
Started category on the startup screen. In the Professional edition, the diagrams 

are connected to data in Excel workbooks that are also included with Visio. 
 

The following features are available only in the Professional edition of Visio 2007. 

▪ Data linking  A new linking wizard dramatically simplifies the task of linking shapes     
on the drawing page to data that resides in Microsoft Excel, Access, SQL Server, 

SharePoint lists, or almost any ODBC or OLEDB-compatible database. No program- 

ming is required to establish connections or to refresh a diagram when the underlying 

data changes. 

▪ Data graphics You can use Visio 2007 data graphics to visualize data by displaying 
text or a graphic that is based on the data inside the shape. 

▪ PivotDiagrams You can build tree-structured data views using the new Pivot- 
Diagram template. 

▪ ITIL and Value Stream mapping New templates enable you to create two impor- 
tant types of diagrams: Information Technology Infrastructure Library (ITIL) process 

maps and Value Stream maps. 
 

 

Working with the  ribbon 
The Office ribbon is a dynamic user interface element; its appearance changes if the width 

of the window in which it is being viewed changes. As a result, a button might be large or 

small, it might or might not have a label, or it might even be an entry in a list. 

 

For example, when sufficient horizontal space is available, the buttons on the Home tab are 

spread out, and the available commands in each group are visible. 
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If you decrease the horizontal space available to the ribbon, small button labels disappear 

and groups of buttons might hide under one button that represents the entire  group. 

 

Compare the arrangement of buttons in the Font and Paragraph groups in the preceding 

and following graphics, for example. Also, in the following graphic, notice that the captions 

for the rightmost buttons in the Arrange group have disappeared, and that the Arrange 

group has been collapsed to a single button. Collapsed buttons and groups retain all of 

their functions, as the submenu beneath the Arrange button demonstrates. 

 

 
 

When the ribbon becomes too narrow to display all of the groups, a scroll arrow appears at 

its right end. Clicking the scroll arrow displays additional groups. 

 

 
 

The width of the ribbon depends on three factors: 

▪ Program window width Maximizing the program window provides the most space 
for the ribbon. To maximize the window, click the Maximize button, drag the borders 

of a nonmaximized window, or drag the window to the top of the screen. 
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▪ Screen resolution Screen resolution is the size of your screen display expressed as 
pixels wide × pixels high. Your screen resolution options are dependent on the display 

adapter installed in your computer, and on your monitor. Common screen resolutions 

range from 800 × 600 to 2560 × 1600. The greater the number of pixels wide (the 

first number), the greater the number of buttons that can be shown on   the ribbon. 1  
To change your screen resolution: 

a. Display the Screen Resolution control panel item in one of the following ways: 

▪ Right-click the Windows desktop, and then click Screen Resolution. 

▪ Type screen resolution in Windows 8 Search, and then click Adjust screen reso- 
lution in the Settings results. 

▪ Open the Display control panel item, and then click Adjust resolution. 

b. On the Screen Resolution page, click the Resolution arrow, click or drag to select 

the screen resolution you want, and then click Apply or OK. 
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▪ The magnification of your screen display If you change the screen magnification 
setting in Windows, text and user interface elements are larger and therefore more 

legible, but fewer elements fit on the screen. You can set the magnification from 100 

to 500 percent. 

You can change the screen magnification from the Display page of the Appearance 

and Personalization control panel item. You can display the Display page directly 

from Control Panel or by using one of the following methods: 

▪ Right-click the Windows desktop, click Personalize, and then in the lower-left 

corner of the Personalization window, click Display. 

▪ Type display in Windows 8 Search, and then click Display in the Settings results. 
 

 

To change the screen magnification to 125 or 150 percent, click that option on the 

Display page. To select another magnification, click the Custom sizing options link 

and then, in the Custom sizing options dialog box, click the magnification you want 

in the drop-down list or drag the ruler to change the magnification even  more. 



Getting started with Visio 2013 13  

After you click OK in the Custom sizing options dialog box, the custom magnification 

is shown on the Display page along with any warnings about possible problems with 

selecting that magnification. Click Apply on the Display page to apply the selected 

magnification. 

 1  
Adapting  exercise steps 

The Visio ribbon consists of multiple tabs, each of which contains a set of related 

functions. The function buttons on any one tab are organized into named groups. 

Consequently, the instructions in the book that guide you to a specific function or 

button will include three parts. For example: 

On the Home tab, in the Tools group, click the Pointer Tool button. 

 

The screen shots shown in this book were captured at a screen resolution of 1024 × 

768, at 100% magnification. If your settings are different, the ribbon on your screen 

might not look the same as the one shown in this book, but you can easily adapt the 

steps to locate the command. 

 

For example, if a button appears differently on your screen than it does in this book, 

start by clicking the specified tab, and then locate the specified group. If a group has 

been collapsed into a group list or under a group button, click the list or button to 

display the group’s commands. If you can’t immediately identify the button you want, 

point to likely candidates to display their names in ScreenTips. 

 

Instructions in this book are based on traditional keyboard and mouse input methods. 

If you’re using Visio on a touch-enabled device, you might be taking action by tap- 

ping with your finger or with a stylus. If so, substitute a tapping action any time you’re 

instructed to click a user interface element. Also note that when you’re instructed to 

type information in Visio, you can do so by typing on a keyboard, tapping in the entry 

field under discussion to display and use the onscreen keyboard, or even speaking 

aloud, depending on your computer setup and your personal preferences. 

 
 

 

Getting started with Visio 2013 
When you start Visio 2013, it presents a startup page that is new to this version of Visio and 

is common to both the Standard and Professional editions of Visio 2013. 



14 Chapter 1 A visual orientation to a visual product  

 
 

Key sections of the start page are described in the following list. 

▪ In the narrower left column is a list of recently opened diagrams. Clicking any dia- 
gram name opens it again. 

If you want to open a diagram that is not on the Recent list, click the Open Other 

Drawings button at the bottom of the list and Visio will take you to the Open page 

that is described in the next section. 

▪ In the wider right column is a collection of thumbnails representing recently used or 
recommended templates. 

▪ Above the template thumbnails are four important ways to find Visio   templates. 

▪ You can type any words into the Search for online templates box and Visio will 
present templates that match your keywords. 

▪ You can click any word in the Suggested searches list to initiate an online search 
for matching templates. 
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▪ Featured is the default selection for the template thumbnails that appear in the 
main part of the page (refer to the preceding graphic). The presentation of thumb- 

nails is dynamic; the templates you use most frequently will rise to the top. 

▪ Clicking Categories presents a set of template categories that are the same as 

the categories in previous versions of Visio: Business, Flowchart, General, Maps 1  
and Floor Plans, Network, and Schedule. The Professional edition also includes 

Engineering, and Software and Database categories. 

At the end of the template categories list is an additional entry called New from ex- 

isting. Clicking this thumbnail enables you to select any existing Visio diagram. Visio 

will then open a copy of the diagram as a new document and will leave the original 

untouched. 
 

 
 

SEE ALSO Microsoft has published a series of quick-start guides for the programs in 

the Office family at office.microsoft.com/en-us/support/office-2013-quick-start-guides- 

HA103673669.aspx. 

 

Exploring the Backstage view 
The Backstage view is the central location for managing files and setting the options that 

control how Visio 2013 operates. You access the Backstage view by clicking the File tab at 

the top left of the Visio window. 

 

Of the 11 pages in the Backstage view, only four—New, Open, Account, and Options—are 

available if you do not have a diagram open. The remaining seven appear when you open a 

diagram. 

 

TIP If you are in the Backstage view and have a diagram open, you can return to the 

diagram by clicking the left-pointing arrow in the upper-left corner of the Visio window. 

If you don’t have a diagram open, clicking the arrow will return you to the start screen. 

 

The pages in the Backstage view are described in the following sections. 

 

IMPORTANT Clicking a suggested search term will not produce the same result as 

selecting a template category of the same name. For example, clicking the Flowchart 

search term will yield some of the same templates that you  will  find  in  the  template 

category named Flowchart, however, it will also return several—or several hundred— 

additional  templates,  both  for  Visio  and  for  other  programs  in  the  Office suite. 
 

If you would like to locate Visio 2013 templates using a method that is most like what 

you are familiar with from a previous version of Visio, click Categories and then select 

the desired template category. 
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Info 

When you have a diagram open and click the File tab, Visio presents the Info page. 

 

 
 

The center section of the page includes four command buttons. 

▪ You will learn more about the Remove Personal Information button in Chapter 8, 
“Printing, reusing, and sharing diagrams.” 

▪ You can click the Reduce File Size button if document size is a major consideration. 

▪ The Check Compatibility button checks the current diagram for features that are not 
compatible with previous versions of Visio. 

▪ You will learn about the SharePoint publishing settings behind the Set Publish 
Options and Check Data Connections button in Chapter 13, “Collaborating on 

and publishing diagrams.” 
 

The right side of the page provides information about the open document, along with a 

Properties list that you can use to view and set additional document properties. You will 

use the Properties list in several places in this book, including Chapter 7, “Adding and using 

hyperlinks,” and Chapter 8. 
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SEE ALSO If you open a file from a previous version of Visio, it will open in compatibility 

mode, and an additional button, labeled Convert, will appear at the top of the Info page. 

Refer to “The Visio 2013 file formats” in the Appendix for more information about working 

with files from previous versions of Visio. 

New 
1  

The New page provides access to both built-in templates and online templates. You access 

built-in templates by clicking a diagram thumbnail in the lower part of the page. You can 

either type your own search terms or use the predefined search terms at the top of the 

page to locate templates from Office.com. 

 

 

 
The preceding graphic displays Featured diagrams, while the following graphic shows the 

template Categories for Visio Standard. Be sure to read about the difference between 

featured templates and template categories at the beginning of the “Getting started with 

Visio 2013” section. 
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Clicking any template category displays thumbnails for the diagrams in that category. 
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If you click once on a diagram thumbnail, Visio displays information about that template, as 

shown in the following graphic. If you double-click a diagram thumbnail, Visio launches a 

new diagram. 

 1  

 

 

 

 

 

 
TIP When you create a new diagram, Visio names it Drawingn, where n is a sequence num- 

ber that is incremented for each new drawing created within one Visio session. Closing and 

restarting Visio always resets the sequence number to 1. 

 

Visio templates are provided in two different sets of measurement units. 

▪ Metric Metric drawings are sized using International Standards Organization (ISO) 
specified paper sizes; the default size is usually A4. Metric templates also include 

other ISO drawing and paper sizes. All measurements are in millimeters or other met- 

ric measurement units. 

▪ US Units Diagrams created with US Units use the 8.5-by-11-inch, letter-sized paper 
that is common in the United States and parts of Canada and Mexico. Templates cre- 

ated for US Units also include additional drawing and paper sizes that are common in 

those countries. The default measurement units are inches and feet. 

 

Depending on your system configuration, you might be offered a choice between the two, 

as shown in the preceding graphic. 



20 Chapter 1 A visual orientation to a visual product  

Open 

The Open page provides access to previously stored Visio diagrams. 

 
TIP If you are familiar with the Backstage view in Visio 2010, you will notice that there is 

no longer a separate Recent page in the Visio 2013 Backstage view; Recent drawings are 

available on the Open page instead. 

 

 

 
One of the first things you’ll notice on the Visio 2013 Open page is that the buttons in the 

center column make it just as easy to access diagrams stored on SharePoint or SkyDrive as it 

is to open documents on your computer. Simply click any of the location buttons in the cen- 

ter column to display a list of recently used folders along with a Browse button for that lo- 

cation. The page that results from clicking the button for the Visio Step By Step SharePoint 

Online site is shown in the following graphic. 
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 1  

 

 

 

 

 
 

Click Add A Place to pin additional SkyDrive or SharePoint Online locations to the 

Open page. 

 

When you click the Browse button on the Open page, Visio displays the Windows Open 

dialog box. The file type filter in the Open dialog is preset to display Visio drawings, tem- 

plates, and stencils that were created in the new Visio 2013 file format, as well as those 

created with previous versions of Visio. 

 

SEE ALSO To learn more about the new Visio file formats and about opening and con- 

verting files created in previous versions of Visio, refer to “The Visio 2013 file formats” 

in the Appendix. 

 

Save 

Clicking Save for a previously unsaved diagram displays the Save As page shown in the fol- 

lowing section. Clicking Save for a previously saved diagram simply saves the changes. 

 

Save As 

On the Save As page, you can choose a local or remote location and then either select a 

recent folder or use the Browse button to navigate to the desired location. 
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Print 

The Print page provides a print preview and printing options. You will learn about print 

options in Chapter 8. 
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Share 

The Share page offers two techniques for sharing your Visio drawing. 
 

You can click Invite People to publicize your diagram via email or social media. The first step 

is to click the Save To Cloud button to store your diagram to either SkyDrive or SharePoint. 1  
After the save operation completes, Visio provides an email form and several buttons you 

can use to share links to your diagram. 

 

 
 

You can click the Email button to share your diagram using any of the options listed on the 

right side of the following graphic. 
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Export 

The Export page enables you to create a PDF or XPS document as well as to save in a 

wide variety of other file formats. You will learn about exporting to other file formats in 

Chapter 8, “Printing, reusing, and sharing diagrams,” and Chapter 12, “Creating and validat- 

ing process diagrams.” 
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Close 

There is no Close page—clicking Close simply closes the active diagram. 

 
Account 

The Account page summarizes information about the Microsoft Account (formerly known 1  
as Live ID) that you have linked to Visio. Links in the Account column enable you to change 

your Microsoft Account details and to switch to another Microsoft Account if you have 

more than one. The same column provides drop-down lists you can use to alter the Office 

Background and Office Theme used for Visio and all other Office applications. 

 

 
 

Clicking the About Visio button in the right-hand column displays version information and 

your product ID. The upper portion of the About Microsoft Visio dialog box is shown in the 

following graphic. 

 

TIP The About Microsoft Visio dialog box does not indicate whether you are running the 

Standard or Professional edition of Visio. However, that information is displayed in the title 

bar of the Visio window as shown in the preceding graphic. 
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Options 

The Options button opens a dialog box that contains dozens of settings you can use to cus- 

tomize the operation of Visio. Many people use Visio 2013 without ever needing to change 

any of these options, but it’s a good idea to examine the option categories for potential 

future use. 
 

 

▪ General Type your user name and initials as well as set various global options, 
including Live Preview and the Visio window color scheme. 

▪ Proofing  Set autocorrect, spelling, and grammar options. 

▪ Save Set the default Visio save format (Visio Document; Visio Macro-Enabled 
Document; Visio 2003-2010 Document) and the document management check 

out/check in options. 

▪ Language Set editing, display, help, and ScreenTip language parameters. 



Exploring the Visio ribbon 27  

▪ Advanced Set dozens of options in five categories: Editing, Display, Save/Open, 

Shape Search, and General. 

▪ Customize Ribbon Add/rearrange commands on built-in ribbon tabs; create new 
tabs and commands. 

▪ Quick Access Toolbar Add/remove command buttons on the Quick Access Toolbar. 1 
▪ Add-ins View and add/delete Visio add-ins. 

▪ Trust Center View and edit macro settings and other trust-related options. 

Exploring  the  Visio ribbon 
Earlier in this chapter, the graphics in “Working with the ribbon” demonstrated how the 

appearance of the ribbon can change depending on the width of the Visio window. 

 

In this exercise, the width of the ribbon will remain constant at 1024 pixels and you will 

explore each of the Visio tabs. 
 

 
 

SET UP If Visio is already running, click File, and then click New. If Visio is not running, 

start it. On either the New or startup page, double-click the Basic Diagram thumbnail. 
 

1 Click the Home tab if it is not already selected. 

The Home tab is just what it sounds like: a place where you will spend a consider- 

able amount of time. The Home tab contains the largest number of buttons by far, 

because the Visio team at Microsoft tried to fit as many of the most frequently used 

functions as possible onto this tab. You’ll find sets of related buttons organized into 

groups called Clipboard, Font, Paragraph, Tools, Shape Styles, Arrange, and Editing. 
 

 
 

You will use buttons on this tab in most of the exercises in this book. 

 

IMPORTANT Most of the screen shots in this book feature the Professional edition ribbon. 

Consequently, there might be tabs, buttons, or options in the screen shots that don’t apply if 

you are using the Standard edition. In general, you can ignore any buttons or tabs that do not 

appear on your computer screen. Where necessary, the text will distinguish those exercises or 

functions  that  can  only  be  performed  with  a  specific  Visio  2013 edition. 
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TIP Many of the groups on the Visio tabs include a small arrow in the lower-right 

corner of the group (refer to the Font, Paragraph, and Shape Styles groups above). 

The arrow button, known as the dialog box launcher, opens a dialog box that provides 

detailed control over multiple functions related to that group. In many cases, the 

dialog box that opens will look familiar to experienced Visio users, because it is the 

same one that was used in previous Visio versions. 

2 Click the Insert tab to access the Pages, Illustrations, Diagram Parts, Links, and Text 

groups. Many of the functions available on this tab mirror the items on the Insert 

menu in Visio 2007 and earlier. 
 

 

You will use buttons on this tab in multiple chapters including Chapter 3, “Adding so- 

phistication to your drawings,” and Chapter 11, “Adding structure to your diagrams.” 

TIP Ribbon buttons that display a downward-pointing arrow behave in one of two 

ways. When you point to some buttons, like the Container button on the left in the 

following graphic, the entire button is illuminated. Clicking this type of button always 

presents a set of options related to the button title. 

 

When you point to other buttons, like the Text Box button in the following graphic 

on the right, only half of the button is illuminated. Clicking the half without the arrow 

performs the default action for the button. Clicking the half with the arrow presents a 

menu of options. 

 

 
 

3 Click the Design tab to change Page Setup, select Themes or Variants, create or edit 

page Backgrounds, and change page Layout. 
 

 

You will use buttons on this tab in various exercises, including those in Chapter 3, “Adding 

sophistication to your drawings,” and Chapter 5, “Adding style, color, and themes.” 
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4 Click the Data tab. 

 
 

On the Data tab, you can establish and maintain links to External Data, Display 

Data using data graphics, and Show/Hide both the Shape Data and External Data 1  
windows. 

 

 

You will use buttons on this tab primarily in Chapter 6, “Entering, linking, and report- 

ing on data,” and Chapter 10, “Visualizing your data.” 

5 Click the Process tab. 

 
 

In the Subprocess group, you can create a new subprocess or link to an existing one. 

In the Diagram Validation group, you can validate a drawing against a set of busi- 

ness rules and manage validation issues. You can also import or export a SharePoint 

Workflow from this tab. 
 

 

You will use buttons on this tab in Chapters 12 and 13. 

6 Click the Review tab for access to functions for Proofing, Language, Comments, and 

Reports. 
 

 

You will use buttons on this tab in various exercises, including those in Chapters 3 

and 6. 

 

IMPORTANT This tab is available only in the Professional edition. 

 

IMPORTANT This tab is available only in the Professional edition. 
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7 Click the View tab. 

As the name suggests, most of the buttons on this tab affect which Visio features are 

visible on the screen: 

▪ The lone button in the Views group sets Visio into full-screen display mode. 

KEYBOARD SHORTCUT Press F5 to enter or exit full-screen view mode. 

▪ The Show group controls which drawing aids and task panes are visible. 

▪ Use the Zoom buttons to change the magnification level in the drawing window. 

▪ The Visual Aids group enables and disables various on-screen drawings aids. 

▪ Use the Window buttons to arrange or select among multiple windows when you 
have more than one drawing open. 

▪ The Macros group provides access to the Visio macro programming window and 
to a list of pre-programmed add-ons that enhance the capabilities of Visio. 

 

You will use buttons on this tab in exercises later in this chapter and throughout the 

rest of the book. 

CLEAN UP Close the Drawing1 drawing. It is not necessary to save your changes. 

TIP The buttons and controls on all ribbon tabs display pop-up tooltip text when you point 

to them. If you are unsure of the function of any button, just point to the button to view the 

tooltip. 

SEE ALSO If you are familiar with versions of Visio prior to Visio 2010 and would like help 

shifting from toolbars and menus to the ribbon, Microsoft has created an interactive guide 

to the ribbon for each product in the Office suite. When you click a toolbar or menu item 

in the guide, it will display the appropriate ribbon button. You can find the Visio guide at 

office.microsoft.com/en-us/visio-help/learn-where-menu-and-toolbar-commands-are-in- office-

2010-and-related-products-HA101794130.aspx.   Although   this   guide   was   created for 

Visio 2010, the Visio 2013 ribbon is sufficiently similar that you will still find the guide  to 

be helpful. 
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Where are the keyboard  shortcuts? 
If you are accustomed to using keyboard shortcuts, you’ll be happy to know that they 

still exist in Visio 2013. Most shortcuts are the same as in previous versions of Visio, 

although some were changed to make them consistent with other applications in the 

Office suite. 

 

The keyboard shortcut letters appear when you press the Alt key. The following 

graphic shows the shortcut letter associated with each tab on the Visio 2013 ribbon. 

Notice, too, that each button on the Quick Access Toolbar has been assigned a short- 

cut number based on its position within the Quick Access Toolbar. 

 

 

 

 

 

Pressing the letter or number for any displayed shortcut key opens the relevant tab 

and displays the shortcut keys for that tab. For example, pressing the N key when in 

the view shown in the previous graphic displays the Insert tab and the shortcut letters 

shown in the following graphic. 

 

 

 

 

 
 

TIP Previous versions of Visio used the capital letter I as the shortcut key for the Insert 

menu. Visio 2013 uses the keyboard shortcut N to be consistent with other Office 

applications. 

 
 
 

 

 1  
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Understanding tool tabs and add-in    tabs 
All of the ribbon tabs shown in the preceding sections are visible 100 percent of the time as 

you run Visio. However, there are two types of tabs that only appear when necessary. 

A Tool tab set only appears in a particular drawing context, usually when a specific type of 

shape is selected on the drawing page. Tool tab sets usually appear to the right of the View 

tab and are not activated automatically, that is, you must click the tab to view its contents. 

A tool tab set includes a colored header and may contain one or more tool tabs under the 

header. Here are examples of two tool tab sets: 

▪ Picture Tools This tool tab set appears whenever you insert or select a graphic on a 
Visio drawing page. The green Picture Tools header contains a Format tool tab, which 

includes buttons to crop, rotate, and otherwise modify a picture. 
 

 

▪ Container Tools This tool tab set appears whenever you insert or select a Visio con- 

tainer. The orange Container Tools header contains a Format tool tab, which includes 

buttons to size and style containers, and to control container membership. You will 

learn about containers in Chapter 11. 
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Add-in tabs are associated with software that adds capabilities to Visio. Some add-ins are 

packaged with Visio by Microsoft; others are sold by third-party software vendors. 

Unlike tool tabs, add-in tabs look and behave exactly like permanent Visio tabs with one 

primary exception: they appear when an add-in application is active and disappear when it 

is not. Here are two examples: 1  
▪ Org Chart This add-in is included with Visio and is activated whenever you create 

or edit a drawing that uses either of the Visio organization chart templates. You will 

learn about organization charts in Chapter 4. 
 

 

▪ TaskMap This third-party add-in provides easy-to-use process mapping, analysis, 
and improvement functions that can be used with any edition of Visio. 

 

 
 

SEE ALSO For more information about the TaskMap add-in, go to www.taskmap.com. 
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Minimizing and restoring the Visio   ribbon 
Because the ribbon takes a reasonable amount of space at the top of the Visio window, you 

may want to minimize it if you need more space for the drawing page. The key to doing so 

is a very small up arrow located in the lower-right corner of the ribbon. 

 

 
 

Clicking this button minimizes the ribbon as shown in the following graphic. To temporarily 

display a tab when it’s minimized, click the tab name. 

 

 
 

To restore the ribbon to normal operation after it has been minimized, click the pushpin 

located in the lower-right corner of the ribbon. 
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Understanding shapes, masters, stencils, 
and templates 

Before you explore the rest of Visio, it’s helpful to understand a number of commonly used 1  
terms: 

▪ Master An object in a Visio stencil. The vast majority of people who create diagrams 
with Visio use the masters that ship with Visio or that they download from the Inter- 

net. You can create new masters; however, the techniques for doing so are outside the 

scope of this book. 

▪ Stencil  A collection of masters. 

▪ Shape An object on a Visio drawing page. Often you create shapes by dragging a 
master from a stencil to the drawing page; however, you can also create shapes in 

other ways. (You will learn more about shapes in Chapter 2, “Creating a new diagram,” 

and throughout this book.) 

A shape can be very simple: a line, a polygon, an image. A shape can also be a so- 

phisticated object that changes appearance or behavior as data values change, as its 

position on the page changes, or as properties of another shape change—the pos- 

sibilities are endless. 

▪ Template A Visio document that includes one or more drawing pages with preset di- 
mensions and measurement units. A template may also include one or more stencils; 

it may include background pages and designs; its pages may contain shapes or text. A 

template may also include special software that only operates in that template. 

▪ Workspace A collection of Visio windows and window settings. At minimum, the 
workspace consists of the drawing window and the zoom settings for the pages in 

the drawing; frequently, it also includes a Shapes window containing one or more 

stencils. The workspace can also include the Shape Data, Size & Position, or Pan & 

Zoom windows. Unless you have changed the default action, Visio saves the on-screen 

workspace whenever you save the document. As a result, when you next open the 

same document, the same collection of windows is restored. 

 

TIP Despite the distinction made in this list between a master and a shape, you will find 

that many people refer to an object in a stencil as a shape. Indeed, when you think about 

it, the window that displays stencils is called the Shapes window! Consequently, unless the 

distinction is important in a specific context, the text in this book will refer to shapes in a 

stencil and to shapes on the drawing page. 



36 Chapter 1 A visual orientation to a visual product  

Exploring  the  drawing window 
When you start Visio, two windows normally appear below the ribbon. 

 

 

▪ The Shapes window on the left contains one or more stencils, each represented by 

a header bar containing the name of the stencil. Depending on the number of open 

stencils in the Shapes window, a scroll bar might appear at the right of the headers. 

You will investigate the Shapes window in the next section of this chapter. 

TIP The width of the Shapes window is adjustable, so the one on your system may be 

wider or narrower than the one that appears in the preceding graphic. 
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▪ The larger window on the right is called the drawing window because it contains the 

drawing page. The drawing window is bounded on the top and left by rulers  that 

display inches, millimeters, or whatever units you have selected (or your template has 

selected) for measuring page dimensions. 

TIP All previous versions of Visio displayed the grid on the drawing page by default. 1  
However, in Visio 2013, the opposite is true. To make the grid visible, click Grid in the 

Show group on the View tab. 
 

At the lower left of the drawing window is a set of page controls. 
 

 

▪ A Page name tabs display the name of each page and the active page name is dis- 

played in a different color. Click any tab to change to that page. Right-click any page 

name tab to access page management functions including the new Duplicate Page 

function. 

▪ B Click the All button to display a list of all pages in the diagram. The name of the 
active page is highlighted in the list. 

▪ C Click the Insert Page button to add a new page. 

Below the Shapes and drawing windows is a status bar that contains a variety of indica- 

tors, buttons, and controls. The buttons and indicators on the left end of the status bar are 

context sensitive, so they will show different information depending on the state of the 

drawing. 
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If nothing is selected on the drawing page, the left end of the status bar looks like the fol- 

lowing graphic. 
 

 

▪ A The Page Number button shows which page is active and displays the total num- 

ber of pages in the current drawing; click this button to open the Page dialog box. 

▪ B The Language area displays the language of the current drawing; the drawing lan- 
guage is normally derived from Windows or Visio language settings. 

▪ C Click the Macros button to start the macro recorder. 

If you have selected a shape on the drawing page, the left end of the status bar looks like 

the following graphic instead. 
 

 

▪ A Same as previous A. 

▪ B Same as previous B. 

▪ C Same as previous C. 

▪ D This area contains three buttons. The Width and Height buttons display the di- 

mensions of the selected shape and the Angle button displays its angle of rotation; 

click any of the three buttons to open the Size & Position window. 

 

The right end of the status bar contains a variety of useful buttons and controls. 
 

 

▪ A Click the Presentation Mode button to view the active diagram in full-screen pre- 
sentation mode. 

▪ B Move the Zoom slider to zoom in or out. 

▪ C The Zoom Level button displays the current zoom percentage; click it to open the 

Zoom dialog box. 
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▪ D Click the Fit Page To Current Window button to resize the drawing page so the 
entire page is visible in the drawing window. 

▪ E Click the Switch Windows button to switch to another Visio window. 
TIP  Most other Office applications require the use of a button on the View tab of the 

ribbon to switch among multiple open windows. The Visio development team had 1  
the foresight to include the Switch Windows button (E) on the status bar where it is 

much more convenient. 

 

If you right-click anywhere in the status bar, the Customize Status Bar menu appears. You 

can click any of the options in the Customize Status Bar menu to toggle the display of a 

button  or control. 

 

 
 
 
 

Managing  the  Shapes window 
The upper part of the Shapes window contains a list of stencil titles and the lower part dis- 

plays the shapes from the currently selected stencil. 

 

In this exercise, you will learn various ways to manipulate the Shapes window so it appears 

in the most useful size and position when you are working on a drawing. 
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SET UP If Visio is already running, click File, and then click New. If Visio is not running, 

start it. On either the New or startup page, click Categories, click Maps and Floor Plans, 

and then double-click the Office Layout thumbnail. Save the new drawing as Exploring 

Visio   2013. 
 

 
 

1 Change the width of the Shapes window by dragging the window boundary left or 

right. The pointer changes to a double-headed arrow as the window border is dragged 

to a wider or narrower view. (In the following graphic, the pointer is located to the 

right of the Search tab.) 
 

 

 

IMPORTANT One of the user interface changes in Visio 2013 is that window boundaries have 

been designed to fade into the background so they don’t interfere visually with the content of 

the drawing. Consequently, the appearance of some parts of the Shapes window is less obvious 

than in previous versions of Visio. In particular, the boundary of the Shapes window is not 

visible. The only way to know where it is located is to move the pointer slowly across it until the 

pointer changes to a window resize tool. 
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2 Minimize the Shapes window by clicking the Minimize the Shapes window arrow 

shown in the preceding graphic. Even though the descriptions are now hidden, all of 

the masters in the stencil are still accessible when the Shapes window is minimized. 

Consequently, this view is useful when you need more space for the drawing window 

and the icons depicting the masters in the stencil are very recognizable. 1  

 

 

 

 

 

 

 
 
3 Return the Shapes window to its former size by clicking the Expand the Shapes 

window arrow highlighted in the preceding graphic. 

4 To hide the Shapes window entirely, on the View tab, in the Show group, click the 

Task Panes button, and then click Shapes. 

TIP The various subwindows that can be opened or closed within the Visio window 

are sometimes referred to as task panes. 
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TIP The Shapes window can be reopened by clicking the same button you used to 

close it. 

5 On the View tab, in the Show group, click Task Panes, and then click Shapes. If the 

window does not already show two columns of shapes, adjust the width so it does. 

The Walls, Doors and Windows title bar is highlighted, indicating that this is the ac- 

tive  stencil.  However,  the  Office  Layout  template  includes  several  additional stencils. 

6 In the Shapes window, click Office Furniture. 

TIP When you click the title bar of any stencil, the title bars remain stationary, and 

the stencil always opens in the same place, below all title bars. This is a significant 

improvement in behavior over versions of Visio prior to Visio 2010. 

 

 

You are not restricted to using just the stencils that open in a particular template, as 

you will discover in the following steps. 
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 1  
 

 

 

 

 

 

 

 

 

 

 

 

7 In the Shapes window, click More Shapes, and then point to General. (Do not click any 

stencils in the General group yet.) A fly-out menu containing stencil names appears. In 

the following graphic, the collection of stencils in the General group is visible. 
 

 

 

IMPORTANT  If there is a sufficient number of masters in a stencil to require scroll bars,  

the scroll bars are only visible if the pointer is inside the stencil portion of the Shapes 

window. The downside of this visual technique is that you don’t necessarily know there 

are more shapes available (refer to the following graphic on the leftw) unless you move 

the pointer into the stencil portion of the Shapes window (following graphic on the right). 
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8 With the cascading menus open from step 7, click Basic Shapes. Visio opens the 

Basic Shapes stencil. In a behavior change from Visio 2010, a check mark appears to 

the left of the stencil you selected, but the fly-out menus remain open, allowing  you      

to select additional stencils from the same or another stencil family. 

 

9 Click anywhere in the Visio window to close the cascading menus. 

Although it isn’t actually necessary in this exercise, it’s helpful to know how to close 

stencils you no longer need, so that’s what you will do in the remaining step. 

10 Right-click Basic Shapes, and then click Close. 

TIP Although you didn’t use it in this exercise, be sure to notice the Search tab at the 

top of the Shapes window. The enhanced shape search function in Visio 2013 yields 

more targeted results with fewer duplicate results. 

CLEAN UP Leave the Exploring Visio 2013 drawing open if you are continuing with 

the next exercise. If not, there is no need to save changes. 
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Panning and zooming in Visio 
As you work with more detailed Visio diagrams, you will find that you frequently need to 

zoom in and out and pan—move left-right and up-down—within the drawing window. 

Both can be accomplished using a variety of techniques, some of which rely on your mouse, 1 
some that use a special Pan & Zoom window, and others that use keyboard shortcuts. 

 
In this exercise, you will learn several techniques to pan and zoom your diagram, beginning 

with keyboard shortcuts and ending with the Pan & Zoom window. 

 

SET UP If the Exploring Visio 2013 drawing is still open from the preceding exercise, 

continue with this exercise. Otherwise, create a new drawing: on the File tab, click New, 
click Categories, click Maps and Floor Plans, and then double-click the Office Layout 
thumbnail. Save the new drawing as Exploring Visio 2013. 

 

1 Click Office Furniture if it is not already the active stencil, and then drag a Round 

table shape onto the drawing page. 

2 Drag a Chair shape onto a different part of the page. 

3 Drag a Corner table shape onto yet another part of the page. 

4 Drag a Stool and a Square table onto the page. Space the shapes so they occupy at 

least half of the drawing page. 

Your diagram might look something like the following graphic. 
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5 Hold down the Ctrl+Shift keys (the cursor will change to a magnifying glass with a 

plus sign), and then drag a rectangle around two of the shapes on the drawing page. 

 
 

 

 

IMPORTANT You must press Ctrl+Shift before you click for this zoom technique to 

work. 
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6 Release the mouse button and the keyboard keys. Visio sets the view in the drawing 

window to just the rectangle you outlined with the mouse. 

 

 

 1  

 

 

 

 

 

 

 

 
7 Press Ctrl+Shift+W to return to a view of the whole drawing page. 

TIP Ctrl+Shift+W is an incredibly useful keyboard shortcut to remember because you 

will frequently zoom in to part of a drawing and then want to return to full page view. 

To help remember this shortcut, just remember that W is the first letter of whole page. 
 

 

 

IMPORTANT In Visio 2007 and earlier, the keyboard shortcut to view the whole page 

was Ctrl+W. If you’ve upgraded from one of those versions of the software, it may take 

a bit of retraining to get accustomed to using Ctrl+Shift+W instead. To make matters 

worse, in Visio 2013, Ctrl+W closes the active document. (You will receive a warning if 

the document has unsaved changes.) 
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8 Hold down the Ctrl key and rotate the mouse wheel. Visio zooms in or out as you 

rotate the mouse wheel. 

 
 

TIP Sometimes you may want to zoom in on a specific shape. Visio provides an option 

setting that makes this very easy to do. On the File tab, click Options, and then click 

Advanced. In the Editing Options section of the Visio Options dialog box, click Center 

Selection On Zoom. Now when you select a shape and press the Ctrl key while rotating 

the mouse wheel, Visio automatically zooms in and out on the selected shape. 

9 Press Ctrl+Shift+W to return to a view of the whole drawing page. 

10 On the View tab, in the Show group, click the Task Panes button, and then click Pan 

& Zoom. The Pan & Zoom window opens. You can drag it to position it wherever 

you’d like. 

TIP You can also open the Pan & Zoom window by clicking the Pan & Zoom button 

on the right end of the status bar. (Refer to “Exploring the drawing window” earlier in 

this chapter for information about the Visio status bar.) 

 

 

 

IMPORTANT You can only perform this step if your mouse has a wheel. 
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11 Click in the Pan & Zoom window, and then drag the cursor to create a rectangle that 

surrounds any two of the shapes. A blue rectangle appears in the Pan & Zoom win- 

dow and the drawing window shows only the selected portion of the page. 

 

 1  
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12 In the Pan & Zoom window, click in the interior of the blue rectangle, and then drag 

into another part of the miniature drawing page. The drawing window now shows the 

newly selected area of the drawing page. 

 

With the Pan & Zoom window open, you can: 

▪ Continue to move the blue rectangle to reposition what appears in the drawing 
window. 

▪ Drag the edges or the corners of the blue rectangle to resize it and change the 
zoom level. 

▪ Drag the slider control on the right edge of the Pan & Zoom window to change 
the zoom level. 

For many drawings, the Pan & Zoom window isn’t necessary and may even be in the 

way. However, it is extremely helpful when your drawing page is very large, as it may 

be if you are working on diagrams such as engineering drawings, floor plans, or 

office layouts. 

CLEAN UP Close the Pan & Zoom window. Save changes and close the drawing. 



Key points 51  

TIP If you have a mouse with a wheel button, you can move the drawing page up and 

down in the drawing window by rotating the mouse wheel. You can reposition the drawing 

page to the left and right by holding down the Shift key while rotating the mouse wheel. 

 
You can also move the drawing page using the arrow keys on your keyboard. Be sure that 

no shapes are selected before pressing the arrow keys, however, or you will move the se- 1  
lected shape(s) instead of moving the page. 

 
 
 

Key points 
▪ Visio Professional contains templates, stencils, ribbon tabs, and functions that are not 

included in Visio Standard. A key focus for the additional features in Visio Professional 

is linking to data sources and then visualizing that data using text callouts and icons. 

Professional features also enhance diagram collaboration, and enable documenting 

and managing business processes. 

▪ Visio 2013 is the second version of Visio to employ the Office fluent user interface, 
commonly known as the ribbon. The Visio ribbon is well-designed and easy to use, 

in large part because the goal of the ribbon is to present sets of related functions 

visually, and Visio is a visual product. 

▪ Tool tab sets and add-in tabs provide unique features and are only visible when they 
are relevant and can be used. Most ribbon tabs are visible all of the time. 

▪ The Backstage view provides file management and option settings for Visio    2013. 

▪ The drawing window and the Shapes window are the primary windows you will use 
to create and manipulate Visio diagrams. 

▪ Visio provides a variety of keyboard shortcuts, mouse techniques, and specialized 
subwindows for panning and zooming within a diagram. 
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IN THIS CHAPTER, YOU WILL LEARN HOW  TO 

▪ Use basic shapes and the Dynamic Grid. 

▪ Select, copy, paste, and duplicate shapes. 

▪ Connect shapes with lines and dynamic connectors. 

▪ Identify one-dimensional shapes and types of glue. 

▪ Position shapes with rulers, guides, AutoConnect, and Quick Shapes. 

▪ Use AutoAdd and AutoDelete. 

▪ Replace shapes in a diagram. 

As you discovered in Chapter 1, “A visual orientation to a visual product,” Microsoft Visio 2013 

includes a variety of templates in either six (Standard edition) or eight (Professional edition) 

categories. One of the easiest ways to begin a new diagram is to start with one of the tem- 

plates. Some templates include stencils that contain very simple shapes; others contain 

stencils with very complex, intelligent shapes. 

 

In Chapter 4, “Creating flowcharts and organization charts” and Chapter 9, “Creating net- 

work and data center diagrams,” you will learn about templates in the latter category; you 

may even be surprised how sophisticated some of the shapes in those templates are. 

 

In this chapter, you will use a very basic template to explore some of the key features of 

Visio 2013 that make it so easy to create new drawings: the Dynamic Grid, AutoConnect, 

Quick Shapes, AutoAdd, and AutoDelete. In addition, you will learn techniques for copy- 

ing and pasting, connecting, resizing, and repositioning shapes. Finally, you will discover 

an exciting new feature that lets you replace a shape in a diagram with an entirely different 

shape. 

 
Creating a new diagram 
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PRACTICE FILES To complete the exercises in this chapter, you need the practice 

files contained in the Chapter02 practice file folder. For more information, refer to 

“Downloading the practice files” in this book’s Introduction. 
 

 

 
 

Using  basic  shapes and the Dynamic  Grid 
Visio 2013 provides an enhanced Dynamic Grid. The purpose of the Dynamic Grid is to help 

you position a shape with greater accuracy as you drop it on the page or when you relocate 

it, thereby eliminating much of the need to drag and nudge the shape into alignment after 

you’ve placed it. 

 

Though the Dynamic Grid was helpful in Visio 2010 and 2007, it’s even more useful in 

Visio 2013 because it reacts more quickly to pointer movement and shape locations, and 

because it provides a greater variety of visual feedback. In addition, the Dynamic Grid 

is more valuable for aligning shapes in Visio 2013 because the background page grid is 

turned off by  default. 

 

In this exercise, you will create a drawing from a stencil containing basic Visio shapes. In the 

process of doing so, you will use several types of Dynamic Grid feedback. You will also cre- 

ate several shapes using Visio’s drawing tools. 

 

SET UP If Visio is already running, click File, and then click New. If Visio is not running, 

start it. On either the New or startup page, double-click the Basic Diagram thumbnail. 

Save the drawing as Basic Shapes. 
 

1 Drag a Rectangle shape onto the drawing page and position it toward the upper-left 

corner of the page. 

2 Drag a Circle shape onto the drawing page and position it to the right of the rect- 

angle. Before you release the mouse button to drop the circle, move it up and down 

on the page. As you move the circle, a green, horizontal Dynamic Grid line appears 

when the circle is in certain positions relative to the rectangle. 

From left to right in the following graphics, the Dynamic Grid line indicates when the 

circle is aligned with the top, center, and bottom of the existing rectangle. 
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TROUBLESHOOTING If the Dynamic Grid lines don’t appear as you move shapes near 

others already on the page, it is probably because the feature is turned off for this 

drawing. To activate the Dynamic Grid, click the Dynamic Grid button in the Visual 

Aids group on the View tab. 2  
3 Use the Dynamic Grid to align the circle with the middle of the rectangle and drop it 

so the space between the shapes is approximately 1 inch (2.5 cm). 

TIP Use of the Dynamic Grid lines is not restricted to positioning new shapes as you 

drop them from the stencil. The Dynamic Grid lines also appear when you use the 

pointer to reposition existing shapes on the page. 

 

4 Click on the circle and drag it closer to the rectangle. The Dynamic Grid centerline 

appears, and if you’ve located the circle at a certain distance from the rectangle, a 

second Dynamic Grid element appears. When the distance between the two shapes 

matches the default spacing interval for this page, a double-headed arrow appears. 
 

 
 

TIP You can change the default inter-shape spacing interval for a page: on the Home 

tab, in the Arrange group, click Position, and then click Spacing Options. The Spacing 

Options dialog box that appears enables you to change the horizontal and vertical 

spacing intervals. 
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5 Press Ctrl+Z to undo the shape movement and position the circle back where you 

originally dropped it. 

6 Drag a Square shape onto the page and position it on the right side of the circle but 

don’t release the mouse button yet. 

7 Use the Dynamic Grid to align the square with the center of the circle and then move 

the square left and right until the green double-headed arrow appears. 

Notice that the double-headed arrow shown in the following graphic is longer than 

the double-headed arrow shown in the graphic after step 4 and that there are two of 

them, not one. In step 4, the double-headed arrow shows that the interval between 

your shapes matches the drawing’s default spacing. In this example, the pair of dou- 

ble-headed arrows indicates that your new shape is the same distance from the circle 

that the circle is from the rectangle. 
 

 
 

TIP To show you that the circle and square are the same height, Visio displays 

Dynamic Grid lines at the top, middle, and bottom of the pair of shapes. 

8 Release the left mouse button to drop the square. 

9 Continue to experiment with the Dynamic Grid by dragging an Octagon shape below 

the rectangle on the drawing page. As shown in the following graphic, the Dynamic 

Grid can provide guidance in two directions at once: the vertical lines indicate align- 

ment with the rectangle; the pair of longer double-headed arrows show horizontal 

spacing; the short double-headed arrow highlights vertical spacing. 
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10 Release the left mouse button to drop the shape. 

11 Drag a Triangle shape to the right of the octagon and below the circle. Once again, 

notice that the Dynamic Grid operates in two directions simultaneously. The Dynamic 

Grid also informs you that the triangle and circle are the same width (three vertical 

lines) but that the triangle and octagon are different heights (one horizontal line). 

 2  

 

 

 
Now that you’ve added five shapes to the page by using a Visio stencil, it’s time to 

create some shapes of your own using the Visio drawing tools. 

12 On the Home tab, in the Tools group, click the Rectangle Tool. Notice that the cursor 

changes to a plus sign with a rectangle to the lower right. 
 

 
 

13 Click anywhere on the drawing page and drag down and to the right to draw a 

rectangle. 

TIP You can constrain the Rectangle Tool so it only draws squares by holding down 

the Shift key while dragging the mouse. 

14 On the Home tab, in the Tools group, click the Ellipse Tool, and then drag to create 

an ellipse to the right of your rectangle. 

TIP You can constrain the Ellipse Tool so it draws only circles by holding down the 

Shift key while dragging the mouse. 

 

 

 

IMPORTANT The Rectangle Tool is one of six drawing tools that are located on a 

menu behind a button in the Tools group on the Home tab. The button is located to the 

right of the Pointer Tool and the image on the button and the accompanying tooltip 

text show the most recently used of the six tools. Each time you start Visio, however, the 

button function reverts to the Rectangle Tool. 
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TIP To return Visio to normal operating mode after using one of the drawing tools, 

click the Pointer Tool in the Tools group on the Home tab or use the keyboard 

shortcut Ctrl+1. 

CLEAN UP Save your changes to the Basic Shapes drawing and close it. 

Although you have used the Dynamic Grid in this exercise while working with simple, geo- 

metric shapes, it is also useful with more complex shapes. However, if at any time you prefer 

to work without the Dynamic Grid, you can turn it off: on the View tab, in the Visual Aids 

group, click the Dynamic Grid button. 

Selecting  shapes 
You can use several techniques for selecting shapes in Visio. The most obvious is that you 

can click once on a shape to select it. To select more than one shape using this method, 

hold down the Shift key or the Ctrl key while clicking additional shapes. You can remove 

shapes from an existing selection with the same method. 

A second common technique is to draw a bounding box around one or more shapes.  

You draw a bounding box by clicking anywhere on the page background and moving  

the mouse while holding down the mouse button. The bounding box appears as a gray 

rectangle. 

The default behavior in Visio is to select any shapes that are fully surrounded by a bound- 

ing box. For example, in the following graphic on the left, the rectangle and octagon will  

be selected when you release the mouse button. In the graphic on the right, no shapes  

will be selected. 
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Visio offers an alternative to a bounding box that lets you select shapes with a freeform 

lasso. To change from area select (another name for the bounding box technique) to lasso 

select, on the Home tab, in the Editing group, click the Select button, and then click Lasso 

Select. To create a lasso selection, click the left mouse button and drag a lasso around the 

shapes of interest, being certain to end at the same place you began. When you release the 

mouse button, the enclosed shapes will be selected. The lasso in the following graphic on 

the left produces the selection on the right. 

 2  

 

 

 

 

 
TIP To revert to using bounding boxes, on the Home tab, in the Editing group, click the 

Select button, and then click Area Select. 

 

You can change selection behavior in Visio so it will select shapes that are partially enclosed 

by a bounding box or lasso. On the File tab, click Options, and then click Advanced; select 

the Select Shapes Partially Within Area check box. 

 

Area/lasso selection and click selection are not mutually exclusive. You can select one or 

more shapes by clicking first, and then add additional shapes by holding down Shift or Ctrl 

while drawing a bounding box or lasso loop. The reverse works as well: you can start with a 

bounding box or lasso selection and add additional shapes by using the same keyboard and 

mouse combination. 

 

KEYBOARD SHORTCUT You can select all shapes on a page by pressing the standard 

Windows keyboard shortcut Ctrl+A. 
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Copying,  pasting,  and  duplicating shapes 
Pasting copied shapes works more logically in Visio 2013 and Visio 2010 than it did in 

previous versions of the product. If you copy one or more shapes from Page-1 and then 

paste them onto Page-2, Visio will paste them into the same position on Page-2 that they 

occupied on Page-1. Versions prior to Visio 2010 always pasted shapes into the center of 

the drawing window. Occasionally this was what you wanted, but as often as not, this place- 

ment required additional dragging and  nudging. 

 

In this exercise, you will use several techniques for copying and duplicating shapes in order 

to learn the differences in behavior among the techniques. 

 

SET UP You need the Basic ShapesA_start drawing located in the Chapter02 practice 

file folder to complete this exercise. Open the drawing in Visio and save it as Copy & 

Paste. 
 

1 Press Shift+click to select the Octagon and Circle shapes on Page-1, and press 

Ctrl+C to copy them. 

2 To the right of the Page-1 name tab (below the drawing page), click the Insert Page 

button. 

3 Press Ctrl+V to paste the shapes onto Page-2 (following graphic on the right). Notice 

that they are placed in the identical position on the page that they occupy on Page-1 

(following graphic on the left). 
 

 
 

4 Click the Page-1 name tab to return to that page. 

5 Select and copy the Triangle shape on the drawing page. 
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6 Drag the Square shape to the right and drop it beyond the right end of the drawing 

page. Visio automatically expands the page size to contain the new shape because 

Auto Size is on by default for this diagram type, 

SEE ALSO In Chapter 3, “Adding sophistication to your drawings,” you will learn more 

about the Auto Size function that automatically expands and contracts Visio pages. 
 

7 Scroll the drawing page to the left so that the only visible shape is the square. 
2 

 
8 Press Ctrl+V to paste a copy of the triangle onto the drawing page. Visio pastes the 

shape into the center of the drawing window. If the original triangle had still been 

visible, Visio would have pasted the new triangle next to the existing one. But because 

it was not, Visio chose the center of the drawing window. 

TIP The paste behavior in this step is different from what happens in Visio 2010. In 

that version of the software, using Ctrl+V always places the pasted shape next to the 

original shape (offset a small amount down and to the right), even if you scroll the 

original shape off the screen. Many people find this frustrating, because if your goal 

is to paste the copied shape in a distant location, Visio still scrolls back to the original 

shape. 

9 On the Home tab, in the Zoom group, click Fit to Window. 
 

 

In the next two steps, you will use a technique that enables you to control exactly 

where pasted shapes will be placed. 

10 Select and copy the Circle shape. 
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11 Right-click in the upper-right corner of the page and click Paste. Visio pastes the 

circle at the location where you right-clicked. 

 

Duplicating shapes is often faster and easier than copying and pasting, especially if 

you want to reproduce the same shape(s) multiple times. In the final step of this exer- 

cise, you will duplicate shapes. 

12 Draw a bounding box around the square and triangle shapes on the right side of the 

page to select them, and then press Ctrl+D twice to duplicate the shapes twice. 

KEYBOARD SHORTCUT You can also duplicate shapes by holding down the Ctrl key 

while dragging the shape(s) with the mouse. 

 

CLEAN UP Save your changes to the Copy & Paste drawing and close it. 

SEE ALSO Visio 2013 includes a new feature to duplicate an entire page. You will use that 

feature in Chapter 3. 
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Positioning  shapes  with rulers and guides 
In some of the preceding exercises, you have aligned shapes by using the Dynamic Grid 

feature of Visio 2013. However, the Dynamic Grid doesn’t always do what you need. For ex- 

ample, if there are other shapes between the two you are trying to align, the Dynamic Grid 

doesn’t help. Similarly, you may want to align shapes in ways that the Dynamic Grid doesn’t 

provide. 
2 In this exercise, you will align shapes by using other Visio features. 

 

SET UP Click the File tab, click New, and then double-click the Basic Diagram thumb- 

nail. Save the drawing as Shape Alignment. 
 

1 Drag a Rectangle shape onto the page and position it about one fourth of the way 

down the page. Drop it so the left end is at the left margin of the page. 

2 Use the resize handle on the right end of the rectangle shape to stretch the right 

edge to the right margin. 

TIP As you drag a shape near the edge of the page and it becomes aligned with the 

page margin, a green Dynamic Grid line appears. 

3 From the Basic Shapes stencil, drag a 5-Point Star shape onto the page and drop it 

above the left half of the rectangle. 
 

 

In the next step, you will try to align a second star with the one you just placed. 

4 Drag a 5-Point Star shape onto the page below the rectangle and observe that the 

Dynamic Grid does not help you align the two stars because of the intervening rect- 

angle. Drop the star onto the page. 
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To align the two stars, you could turn on the grid lines for the page (on the View tab, 

in the Show group, select Grid) and use them to maneuver the shapes into place. 

However, using a guide will make the task much easier. 

5 Position the cursor over the vertical ruler on the left side of the page and observe 

that the cursor changes to a double-headed arrow. Click the ruler and drag into the 

middle of the drawing page. The guide appears on the page as a vertical blue line, 

but be aware that guides do not appear in printed diagrams. 
 

 

6 Drag the top star toward and over the guide and observe that you can glue the edg- 

es and center of the star shape to the guide. 
 

 

7 Glue the center of the star to the guide. 

8 Drag the bottom star and glue its center to the guide. 

TIP Remember that if you hold the Shift key while dragging a shape, you restrict it to 

moving only horizontally or vertically, but not both. 
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The two stars are now precisely aligned, despite the intervening shape. 

Realize that the stars are actually glued to the guide just as lines were glued to shapes 

in previous exercises. If you move the guide, the stars will move also. However, if you 

don’t need to move the aligned shapes as a unit, you can delete the guide as you 

would any other shape: just click to select it, and then press the Delete key. 

TIP You can create more than one guide by dragging the ruler onto the page again. 

You can also create horizontal guides by dragging the ruler at the top of the page 

down. 

 

The rulers provide another means for aligning shapes, as you will discover in the 

remaining steps. 

9 Use the Zoom slider at the bottom of the drawing page to set the zoom level to 

100%. Then position the drawing page so the upper-left corner is visible. 

10 Drag an Octagon shape into the upper-left corner of the page; before releasing the 

mouse button, observe that there are dashed lines in both the horizontal and vertical 

rulers (the lines are highlighted in the following graphic). 

The lines on the top ruler mark the left, center, and right of the octagon; the lines on 

the side ruler denote the top, middle, and bottom of the shape. As you move a shape 

on the drawing page, there are times when it is convenient to place it based on the 

ruler marks. 
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11 Drop the Octagon shape onto the page. 

CLEAN UP Save your changes to the Shape Alignment drawing, and then close it. 

Resizing  and  repositioning shapes 
Once you’ve placed shapes onto the drawing page, you will probably need to move or re- 

size some of them. Visio provides a variety of techniques for doing so. You can alter shapes 

using your mouse or keyboard, or a combination of the two. You can also use the Size & 

Position window. 

Not all properties of all shapes can be modified through the user interface, and you may 

not know which attributes are locked until you attempt to make a change. You may even 

find that seemingly identical shapes have been designed with very different capabilities 

and, therefore, behave differently. Sometimes the locked attributes are very simple, like the 

examples that you will encounter in this exercise. Other times, shape attributes are locked 

in more complex ways. Regardless of which attributes are locked, the shape designer’s goal 

is typically the same: to ensure that shapes behave in particular ways for particular drawing 

types. 

In this exercise, you will change the characteristics of several shapes by using the mouse, the 

keyboard, and the Size & Position window. Note that the Visio grid lines have been turned 

on for this diagram to make the actions in some steps more apparent. 
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SET UP You need the Size and Position_start drawing located in the Chapter02 practice 

files folder to complete this exercise. Open the drawing in Visio and save it as Size and 

Position. 
 

1 Click once (don’t double-click) to select shape A. 

 

 2  

 
 

The white squares that appear on a selected shape are referred to as selection handles, 

resize handles, or just handles, and allow you to alter the shape in the following ways: 

▪ Dragging the square handles in the center of each edge alters the width or height 
of the shape. 

▪ Dragging the square handles on the corners adjusts the width and height 
proportionally. 

You will use both types of handles in the exercise steps that follow. 

2 Drag the middle handle on the right edge of shape A to the right to increase the 

width of shape A. When you first begin to drag to the right, notice that green, dou- ble-

headed arrows appear under shapes A and C. If fact, if you look at the lower part of 

the page, you’ll notice the same arrows under shapes D and E. Do not release the 

shape handle yet. 
 

 
 

 

 

IMPORTANT The green, double-headed arrows are an important new dynamic 

feedback feature in Visio 2013. They call attention to the fact that the width of the 

shape you are modifying matches the width of other shapes on the page. Although 

this example compares shape widths, the same feedback is provided when shape 

heights match. 
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3 Continue to drag the right handle of shape A further to the right until the Dynamic 

Grid feedback informs you that shape A is now the same width as shape B. 
 

 

4 Continue to drag the handle until shape A is wider than either B or C, and then 

release the resize handle. 
 

 

5 Drag the upper-right handle of shape A away from the shape to increase the size of 

the shape proportionally in both dimensions. 
 

 

6 Click once (don’t double-click) to select shape B, and then try to drag either of the 

height resize handles (top center and bottom center). You will not be able to adjust 

the height of the shape. 

7 With shape B still selected, drag the upper-right resize handle toward the upper 

right. Notice that the shape gets wider but the height doesn’t change. 
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You aren’t able to change the height of shape B because the designer of the shape 

chose to lock that shape property. You are allowed to adjust the width but not the 

height. 

TIP Previous versions of Visio displayed locked handles with a different color than 

unlocked handles. Visio 2013 does not make any visual distinction. 
 

8 With shape B still selected, point to the circular arrow above the shape. 
2 

 

 

 
The circular arrow is the rotation handle. When you point to it, the cursor changes to 

a curved arrow and an additional selection handle appears in the center of the shape 

(it’s on top of the letter B in the preceding graphic and is connected to the rotation 

handle by a thin, gray line). The new handle is the Center Of Rotation handle, com- 

monly referred to in Visio as the pin. 

TIP When you rotate a shape, it rotates around the pin. To envision the purpose of 

the pin, imagine that shape B is a piece of paper you’ve stuck on your wall with a pin. 

If you rotate the piece of paper, it will rotate around the pin. 

9 Drag the rotation handle clockwise approximately 90 degrees. 
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10 Click once to select shape C and then try to rotate it. 
 

 

You are not able to rotate it because that property has been locked for this shape. 

11 Select shape C and reposition it by dragging it up and down; it behaves quite nor- 

mally. Then try dragging it side to side and you’ll discover that you can’t do it, be- 

cause the horizontal position is locked. 

TIP A shape designer might lock a few simple attributes as you’ve observed in this 

exercise, or the designer might lock any of dozens of other attributes, in order to 

make shapes behave as required for a particular type of drawing. 

 

12 Click once to select shape D, which is a subprocess shape from the Basic Flowchart 

Shapes stencil. All of the usual handles are available, as shown on the left in the fol- 

lowing graphic, but there is a new style of control handle in the lower-left corner of 

the shape. Drag the yellow control handle to the right and you’ll create the variation 

shown in the right-hand image. As you drag the control handle in either direction, 

notice that the shape was designed with movement limits for the lines: you can only 

drag them a certain distance. 
 

 
 

In the subprocess shape, the yellow control handle moves the interior lines. If you drag 

the control handle far enough back to the left, the interior lines effectively disappear. 

Even though they aren’t visible, the continuing presence of the yellow square suggests 

that they still exist; if you drag the square back to the right, the lines will reappear. 
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TIP You will find yellow control handles on a variety of the shapes in Visio stencils. 

Whenever you select a shape and notice a yellow handle, it’s worth experimenting 

with it to learn how you can use it to alter the shape’s appearance. If you make a 

change that you don’t like, simply press Ctrl+Z to undo the modification. 

 

In the remaining steps of this exercise, you will learn to use the Size & Position win- 

dow as another method for altering shape appearance and location. 

13 Click once to select Shape E. Then on the View tab, in the Show group, click the Task 2  
Panes button, and then click Size & Position to open the Size & Position window. 

Position the new window to the left of Shape E. 

TIP Whenever you have selected one or more shapes, you can also open the Size & 

Position window by clicking Width, Height, or Angle in the status bar at the bottom 

of the Visio window. 

 

 

The Size & Position window displays current values for six shape attributes, but it also 

allows you to change those attributes. 
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14 Click in the Width cell, type 2, and then press Enter. The width of the cell changes to 

reflect the new value. Notice that you didn’t need to type a value for units, because     

Visio uses the units displayed in the cell as the default. By comparing the width of 

shape E with  the  ruler  shown  at  the  top  of  the  following  graphic,  you  can  confirm 

that the shape is, indeed, 2 inches wide. 
 

 

The X and Y cells in the Size & Position window reflect the location of the pin of the 

shape on the page with respect to the lower-left corner of the page. By comparing 

the values in the X and Y cells in the preceding graphic with the rulers at the edge of 

the drawing page, you can verify that the center of shape E is at X=7 inches and Y=3 

inches. 
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15 Click in the Y cell, type 4, and then press Enter. By changing the Y value from 3 inches 

to 4 inches, you have moved the shape higher on the page. You can confirm the new 

position of the shape on the page by looking at the ruler shown on the left side of  

the following graphic. 

 
 

 2  

 

 

 

 

 

 
16 Click in the Pin Pos cell, click Center-Left, and then press Enter. Changing this set- 

ting moves the pin for the selected shape. The following graphic shows the result of 

changing the pin to Center-Left. Notice two things: 

▪ The rotation handle is now on the left edge of the shape. 

▪ The shape has shifted to the right on the page. This is because the X and Y coordi- 
nates of the shape specify the location of the pin. Because you have moved the pin 

within the shape, the location of the shape on the page changes. 

TIP Using the Pin Pos menu, you can relocate the pin based on a fixed set of pin 

positions. You can also make freeform changes to the pin location by dragging the 

Center Of Rotation handle described in step 8. 
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17 Click in the Angle cell, type -90, and then press Enter. Typing -90 degrees is equiva- 

lent to dragging the rotation handle clockwise 90 degrees. The following graphic 

shows that shape E rotated around the new pin. 
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CLEAN UP Close the Size & Position drawing. It is not necessary to save changes 

unless you want to. 

TIP If you select more than one shape before dragging a resize handle or making changes 

in the Size & Position window, the changes you make will affect all selected shapes. 

In this exercise, you typed numbers into Size & Position window fields to change the physi- 

cal characteristics of a shape. However, you can also use the Size & Position window in the 2  
opposite way—you can move or alter a shape by dragging the control handles and then 

use the window to observe the new dimensions or position values. 

Connecting  shapes  with lines 
Visio shapes are either one-dimensional (1-D) or two-dimensional (2-D). 1-D shapes act like 

lines with endpoints that can be attached to other shapes. 2-D shapes behave like polygons 

with edges and an interior. However, appearances can be deceiving, because some shapes 

that appear to be two-dimensional may actually be 1-D shapes in Visio; there’s an example 

in the section titled, “Adding equipment to rack diagrams” in Chapter 9. The reverse can 

also be true. 

In previous exercises, you worked primarily with 2-D shapes. In this exercise, you will con- 

nect a variety of 1-D shapes to 2-D shapes. 

SET UP You need the Basic ShapesB_start drawing located in the Chapter02 practice 

file folder to complete this exercise. Open the drawing in Visio and save it as Connecting 

Shapes. 

1 On the Home tab, in the Tools group, click the Line Tool. Notice that the cursor 

changes to a plus sign with a diagonal line to the lower right. 

 

 

IMPORTANT The Line Tool is one of six tools located behind a button that is 

immediately to the right of the Pointer Tool. If the Line Tool is not visible, click the 

arrow next to whichever tool is displayed on the button, and then select the desired 

tool from the menu. 
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2 Point near any of the five shapes toward the top of the page. Notice that dark 

squares appear on the edges and in the center of the shapes. 
 

 

The dark squares are connection points. They appear whenever you move near them 

with a 1-D shape or a tool like the Line Tool. 

3 Move the cursor near a connection point and notice that a green square appears. The 

square indicates that you can click on it to glue one end of the line to the connection 

point. If you hold the pointer over the square without clicking, tooltip text will appear 

to confirm that you can glue to the connection point. 
 

 

4 Click the connection point on the right end of the rectangle, drag to the connection 

point on the left edge of the circle, and then release the mouse button. 
 

 

You have drawn a line that is glued to the edges of the two shapes. Notice that the 

handle on the originating end of the glued line shows a green circle and the handle 

on the destination end shows a white circle with a green dot. 
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5 Draw another line above the rectangle but do not glue either end to a shape. 
 

 

The line shows a white square on the originating end and a solid gray square on the 2  
destination end. 

TIP  The color distinction between the unglued line ends in this step and the glued 

line ends in the previous step is an important one in Visio. Although it’s quite obvious 

in these two examples whether the line ends are connected, in the next step, you’ll 

find an example in which the color of the line end is very helpful in determining 

connectedness. 

 

6 Use the Line Tool to draw a line from the connection point at the center of the 

octagon to the long rectangle below it. The long rectangle that you created with   

the drawing tool in a previous exercise does not contain any connection points. 

Consequently, you can only drop the end of the line onto the shape and can’t glue 

it. You  can confirm which ends are glued by comparing the color and pattern at each      

end of this line with the handles in the previous two examples. 
 

 

7 On the Home tab, in the Tools group, click the Pointer Tool. 

KEYBOARD SHORTCUT Press Ctrl+1 (the number one) to return to the Pointer Tool. 
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8 Drag the circle up a small distance, and then drag the long rectangle below the octa- 

gon down. The following two graphics show the before (left) and after (right). 
 

 
 

In the after image, the line that is glued to the rectangle and circle stays attached at 

the connection points. However, the line that touched, but wasn’t glued to, the rect- 

angle is no longer attached to that shape. 

9 On the Home tab, in the Tools group, click the Freeform Tool. Notice that the cursor 

changes to a plus sign with a squiggly line to the lower right. 

10 Click the connection point in the center of the circle and move the cursor randomly, 

eventually arriving at one of the connection points on the square. Notice that the line 

develops a bend each time you make a significant change in direction. 
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There are several important things to note about the line you’ve drawn: 

▪ If you glued both ends of the line to connection points, the curved line behaves 
just like the straight line: if you move the shapes, the line will follow. In the case of 

the freeform line, the line will also retain its unique set of curves. (Try moving the 

shapes attached to your squiggly line; the results are often quite interesting.) 

▪ There are blue circles at the key points of curvature along the line. These circles are 

actually control handles that you can drag to reshape the line. 2  
▪ The blue circles are only visible if you select the shape with one of the line tools 

(Line, Freeform, Arc, or Pencil). If you select it with the Pointer Tool or the Rectangle 

or Ellipse Tools, only the endpoints are visible, as shown in the following graphic. 

 

11 In a blank area of the drawing page, draw a freeform line, but be sure to end it at 

exactly the same point that you started. 

 

Notice the important difference from the line you drew in the previous step: as soon 

as you finish “closing the loop,” Visio applies a fill to your new shape and there are no 

square handles at the beginning and end of the line. By ending your line at the same 

place you began, you’ve actually drawn a 2-D shape, not a 1-D shape. 

CLEAN UP Save your changes to the Connecting Shapes drawing but leave it open if 

you are continuing with the next exercise. 

Though you didn’t use them in this exercise, you can experiment with the Arc and Pencil 

tools to learn about their unique characteristics. 
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In a previous exercise, you used the Size & Position window with a 2-D shape. If you open 

the Size & Position window for a 1-D shape, it contains fields that are appropriate to a line. 

In the following graphic, the coordinates of the beginning and ending points of the line, its 

length, its angle, and its height are visible. Note that the length is the absolute difference 

between the beginning and end of the line, and not the linear distance the line traverses. 

 

 
 
 

 

Connecting shapes with dynamic 
connectors 

In the previous exercise, you learned about four types of 1-D shapes that you can create 

with the Visio line tools. Although several of those line types can include curves or bends, 

those features are only present if you place them there. Visio also offers a line called a 

dynamic connector. When you use a dynamic connector, Visio automatically adds and re- 

moves bends in the line based on the relative positions of the shapes to which it’s glued. 

 

In this exercise, you will perform some of the same steps you completed in the previous ex- 

ercise, but you’ll use dynamic connectors in order to understand the differences in behavior. 

 

SET UP You need the Connecting Shapes drawing for this exercise. Either continue 

with the open copy from the previous exercise or open the Basic ShapesC_start draw- 
ing located in the Chapter02 practice file folder, and then save it as Connecting Shapes. 

Click the Page-2 tab at the bottom of the drawing page to move to Page-2. 
 

1 On the Home tab, in the Tools group, click the Connector button. Notice that the 

pointer changes to a black arrow and there is an arrow with two right-angle bends 

below it. 
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TIP Just as with the line tools you used in the preceding exercise, you’ll find that 

connection points appear on various shapes as you point near them with the 

Connector Tool. 

 

2 Drag from the connection point on the right center of the upper rectangle to the 

connection point on the left edge of the circle, and then release the mouse button, 

creating static glue between the two connection  points. 

 2  

 

 
Just as in the preceding exercise, the line you’ve drawn shows green handles at its 

endpoints. However, unlike the previous line, a dynamic connector has an arrowhead 

on its destination end by default. The arrowhead in this graphic is largely obscured 

by the green handle, but when the dynamic connector is deselected, as in the follow- 

ing graphic, the arrowhead is visible. 

3 Draw another dynamic connector above the rectangle but do not glue either end to  

a shape. Even if you try to draw the connector as a straight line, notice that it appears 

to have a mind of its own. This will turn out to be one of the most useful characteristics 

of a dynamic connector, as shown in subsequent steps in this exercise. 
 

 

4 Use the Connector Tool to draw a line from the connection point at the center of the 

octagon to the center of the long rectangle below  it. 

Something very different happens compared to the preceding exercise where you 

performed the same step with the line tool. Even though the long rectangle does not 

contain any connection points, you can still glue a dynamic connector to the shape. 

Visio provides two visual cues: pop-up text appears above the rectangle, as shown 

in the following graphic on the left, and the border of the shape is outlined in green. 

When you release the mouse button, the connector appears as shown in the graphic 

on the right. 
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You’ve just used something Visio calls dynamic glue to attach a connector to a shape 

without any connection points. As you will discover in the next step, you can do the 

same thing even if a shape has connection points, merely by pointing to a part of the 

shape where there aren’t any. 

5 Point to the interior of the octagon until the border of the selection rectangle lights 

up in red (the following graphic on the left shows the pointer inside the selection 

rectangle). Drag until the border of the triangle shape turns red and the words Glue 

to Shape appear, as shown on the right. Don’t release the mouse button yet. 
 

 
 

In the graphic on the right, even though the cursor (the plus sign) is above the center 

of the triangle, the dynamic connector once again seems to have a mind of its own 

and is connecting to the apex of the triangle. 

6 Release the mouse button and observe that the dynamic connector has glued itself 

to points on the edges of the two shapes. 
 

 

With a few final steps, you will discover the real value of a dynamic connector and 

learn the difference between static glue and dynamic glue. 

With a few final steps, you will discover the real value of a dynamic connector and 

learn the difference between static glue and dynamic glue.
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7 On the Home tab, in the Tools group, click the Pointer Tool. 

KEYBOARD SHORTCUT Press Ctrl+1 (the number one) to return to the Pointer Tool. 
 

8 Drag the circle up a small distance, drag the long rectangle below the octagon down 

and to the right until it overlaps the ellipse, and then drag the triangle down until it 

also overlaps the ellipse. 

The following graphics show the before (left) and after (right). 2  

 

Key observations after moving the three shapes: 

▪ The connector between the upper rectangle and the circle has right-angle bends 
but is still attached at exactly the same two connection points. This is an example 

of static glue: the connector remains attached to a fixed point on both shapes. 

▪ The connector between the octagon and the long rectangle now contains a right- 
angle bend. The tail of the arrow remains glued to the center connection point, 

another example of static glue, but there is also evidence of dynamic glue: the 

head of the arrow is still attached to the long rectangle, but it is connected at a 

different place along the edge of the shape. 

▪ The connector between the octagon and the triangle is glued dynamically at both 
ends. After moving the triangle down, the connector is still glued to both shapes, 

but the points of attachment have changed. 
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CLEAN UP Save your changes to the Basic shapes drawing, and then close it. 

By default, dynamic connectors use right-angle bends as you learned in the preceding exer- 

cise. You can change the appearance of a dynamic connector by right-clicking it and select- 

ing one of the upper three options shown in the following graphic. 

 

As you move shapes that are linked by dynamic connectors, Visio adjusts the connector 

segments. In addition, you can manually adjust individual connector segments by dragging 

the blue control handles that appear at each bend and in the middle of each line segment 

when you select a connector. 

 

If at any point, a dynamic connector has too many bends or becomes convoluted, you can 

right-click it and then click Reset Connector. Visio redraws the connector with the minimum 

number of bends and segments to fit in the required space. 

TIP Among the new features on the Visio 2013 Mini Toolbar is a single-use Connector Tool 

that is sometimes more convenient than the Connector Tool button in the Tools group on 

the Home tab. You can add a dynamic connector to your drawing simply by right-clicking 

either a shape or the drawing page, and then clicking the Connector Tool button shown in 

the following graphic. 
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Because you used the Connector Tool in successive steps in the preceding exercise, it made 

more sense to activate the Connector Tool on the Home tab and then select the Pointer 

Tool at the end. However, when you are creating your own diagrams and need to draw a 

single dynamic connector, remember that the Connector Tool is only a right-click away from 

wherever you are working on the page. 

 

Identifying 1-D  shapes and types  of glue 
2 

 
In the preceding sections, you learned about several types of 1-D shapes and two forms of 

glue. This section summarizes the behavior of 1-D shapes and identifies the visual cues Visio 

uses to differentiate glued and unglued endpoints of 1-D shapes. 

▪ A 1-D shape drawn with any of the line tools (Line, Freeform, Arc, or Pencil) retains its 
original form when the shapes at the ends are moved. 

▪ A 1-D shape created with the Connector Tool adds or removes bends in the line to 
accommodate shape movements. 

▪ A line or dynamic connector attached to a connection point forms static glue; the 1-D 
shape remains attached at that fixed point on the 2-D shape no matter how the 2-D 

shape is moved. 

▪ A dynamic connector attached to a shape but not to a connection point forms 
dynamic glue; as the 2-D shape moves, the point at which the dynamic connector at- 

taches to the shape moves. 

▪ A 1-D shape whose endpoints are not glued appears with square control handles that 
are white on the “from” end and are gray on the “to” end. 
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▪ A 1-D shape whose endpoints are glued appears with round control handles; the 
“from” end is a green circle and the “to” end shows a green dot inside a white circle. 

 

 
 

 
 
 

Using AutoConnect and Quick Shapes 
AutoConnect was introduced in Visio 2007 and provides a fast means to link shapes us- 

ing dynamic connectors. Quick Shapes were introduced in Visio 2010 and build on 

AutoConnect to let you create drawings even more quickly. 
 

In this exercise, you will create a new drawing using AutoConnect by itself in the first sec- 

tion, and AutoConnect with Quick Shapes in the second section. 

 

SET UP Click the File tab, and then click New. Click Categories, click Flowchart, and 

then double-click the Basic Flowchart thumbnail. Save the new drawing as Quick Draw. 
 

1 Drag a Start/End shape into the upper-left corner of the drawing page. 

2 Drag Process and Decision shapes onto the page to create a drawing like the one 

shown in the following graphic. Be sure you take advantage of the Dynamic Grid you 

learned about in Chapter 1 to make it easy to align and space the shapes. 
 

 

 

IMPORTANT In previous versions of Visio, the endpoints of 1-D shapes that were 

attached with static glue looked different than endpoints that were attached with 

dynamic glue. Visio 2013 no longer provides a visual distinction between the two. 
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Notice that when you point to any shape on the page, blue AutoConnect arrows 

appear on the sides that are not yet connected to another shape. 

TIP AutoConnect arrows are smarter in Visio 2013 than they were in previous 

versions of Visio. When you are working on a diagram, if you’ve used AutoConnect 

recently, the arrows appear much more quickly when you rest the pointer over a 

shape. However, if you haven’t used them recently, there is a delay before they 

appear so they don’t get in your way. 2  

 

TROUBLESHOOTING If the AutoConnect arrows don’t appear when you point to a 

shape, it’s probably because AutoConnect is turned off for this drawing. To activate 

AutoConnect, select the AutoConnect check box in the Visual Aids group on the 

View tab. 

 

3 Point to the AutoConnect arrow on the right side of the start/end shape. The Live 

Preview feature of Visio shows a dynamic connector linking the start/end to the pro- 

cess shape. A Mini Toolbar containing four shapes also appears; you will learn more 

about this toolbar later in this exercise. 
 

 

4 Click the AutoConnect arrow to connect the shapes. 

5 Continue clicking the appropriate AutoConnect arrows until the diagram looks like 

the following graphic. 
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It’s clear that AutoConnect makes short work of adding dynamic connectors to exist- 

ing shapes. Each AutoConnect arrow seeks out a neighboring shape in the direction 

that the arrow points. You can also use AutoConnect when the desired target shape 

is not directly in line with the AutoConnect arrow, as you’ll discover in the next step. 

6 Point to the Decision shape until the AutoConnect arrows appear, click the 

AutoConnect arrow on the right of the decision shape, and then drag it to the 

lower of the two rectangles on the right side of the page. As you drag, the screen 

will look like the following graphic on the left. When you release the mouse but- 

ton, the shapes are connected, as shown on the right. 
 

 
 

Now that you’ve used AutoConnect, you will work with a closely related feature to 

learn another way to create certain types of drawings quickly. 

Before moving to the next step, look back at the picture in step 3. In addition to the 

Live Preview image of a dynamic connector arrow, there are also four small shapes on 

a Mini Toolbar. These shapes are called Quick Shapes and you will use them to create 

a drawing that is similar to the one you just built. 

7 To the right of the Page-1 name tab below the drawing page, click the Insert Page 

button. Visio adds a new page called Page-2. 

8 Drag a Start/End shape into the upper-left corner of Page-2. 

9 Point to the AutoConnect arrow on the right side of the start/end shape. Live 

Preview shows two things in addition to the dynamic connector arrow: it displays 

a preview of the shape that is currently selected in the stencil, along with a Mini 

Toolbar containing four shapes. 
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 2  
 

If you want to add another start/end shape to the current drawing, a single click will 

accomplish that and the new shape will be automatically spaced at the default inter- 

val for this page. 

However, if you want to add a different shape, Quick Shapes provide an instant so- 

lution. Every open stencil in Visio 2013 includes a Quick Shapes section at the top 

of the stencil window pane, and most stencils include preselected Quick Shapes. If 

you look closely at the Basic Flowchart Shapes in the Shapes window, you’ll notice a 

fine gray line between the Document/Data shapes and the Database/External Data 

shapes. 

The shapes that appear in the Mini Toolbar are the first four shapes in the Quick 

Shapes section. If you want different shapes to appear in the Quick Shapes Mini 

Toolbar, simply drag them to be among the first four shapes in the Quick Shapes 

section of the stencil. 

TIP You can change the order of appearance of shapes in either the Quick Shapes 

section or the main part of a stencil merely by dragging them to a new location. 

10 Point to any of the shapes in the Quick Shapes Mini Toolbar and notice that the Live 

Preview image changes to reflect that  shape. 
 

 

11 Click the Process shape in the Mini Toolbar to drop it on the page 

12 Point to the process shape and use AutoConnect and the Quick Shapes Mini Toolbar 

to add a decision shape to its right. 
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13 Point to the decision shape on the page and drop a process shape below it. 
 

 

When you click a Quick Shape in the Mini Toolbar, Visio always adds a dynamic con- 

nector. Consequently, in order to place two unconnected shapes and finish reproduc- 

ing the pattern you created on Page-1, it is necessary to place the final two shapes 

manually. 

14 Drag a Process shape from the stencil and drop it to the right of the decision shape 

already on the page. Then drop another Process shape below it. Be sure to use the 

Dynamic Grid to ensure that spacing of the new shapes is consistent with the existing 

shapes. 
 

 

15 Right-click anywhere on the drawing page. On the Mini Toolbar, click the Connector 

Tool, and then use it to link the right end of the decision shape to the left end of the 

lower-right process shape. 

TIP You can also point to the Decision shape and drag a connector from the 

AutoConnect arrow to the Process shape as you did in step 6. 
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CLEAN UP Save your changes to the Quick Draw drawing but leave it open if you are 

continuing with the next exercise. 

SEE ALSO The “Visio Blog,” written by the Visio product team at Microsoft, contains two 

posts that were written for Visio 2010 but still apply to Visio 2013 and the exercise in this 

section: 

▪ blogs.office.com/b/visio/archive/2009/09/22/autoconnect-in-visio-2010.aspx 2  
▪ blogs.office.com/b/visio/archive/2010/12/08/flowcharts-in-under-a-minute.aspx 

TIP You can turn AutoConnect off for all drawings if you prefer to operate without it. On 

the File tab, click Options, and then click Advanced. In the Editing Options section, clear the 

Enable AutoConnect check box. 

Using  AutoAdd  and AutoDelete 
Visio 2013 offers enhanced ways to add and delete shapes in a drawing: 

▪ When you add a shape using AutoAdd, Visio rearranges the existing drawing to make 
the new shape fit. Sometimes the changes it makes are minor; other times they are 

more significant. 

▪ When you delete a shape that is linked to one other shape with a dynamic connector, 
AutoDelete automatically removes the now superfluous connector. In addition, if   you 

delete a shape that is between two other shapes, Visio will delete one dynamic con- 

nector and reconnect the remaining one to both shapes. 

TIP If you don’t like the results of an AutoAdd or AutoDelete operation, a single undo 

command will reset all changes made by the shape addition or deletion. 

In this exercise, you will alter a drawing by using AutoAdd and AutoDelete techniques. 
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SET UP You need the Quick Draw drawing for this exercise. Either continue with the 

open copy from the previous exercise or open the Quick Draw_start drawing located in 
the Chapter02 practice file folder, and then save it as Quick Draw. 

 

1 Navigate to Page-2 if you’re not already there. 

2 Drag a Subprocess shape from the stencil and position it on top of any existing 

dynamic connector. Both ends of the connector display large green squares that 

are visible through the semitransparent Subprocess shape. Don’t release the mouse 

button yet. 
 

 
 

3 Drop the Subprocess shape on the connector below the Decision shape. Visio 

pushes the Process shape down to make room for the new shape. 
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4 Drag a Subprocess shape from the stencil and drop it on the connector between the 

start/end shape and the first process box. Visio makes more significant changes in 

order to accommodate the new shape and avoid the unconnected Process shape in 

the upper right. 
 
 
 

 2  

 

 

 

 
 
5 Select the Process shape at the very bottom of the diagram, and then press the 

Delete key to remove the shape. Visio deletes the selected shape and also removes 

the dynamic connector that was linked to the Process shape. 
 

 



94 Chapter 2 Creating a new diagram 

6 Select the Subprocess shape between the Start/End shape and the first Process 

shape, and then press the Delete key. In addition to deleting the Subprocess shape, 

Visio removes one of the two dynamic connectors and reconnects the remaining one 

between the Start/End and the Process shapes. 

 

CLEAN UP Save your changes to the Quick Draw drawing, and then close it. 

TIP If you prefer not to have Visio automatically delete connectors when you delete shapes, 

you can turn this feature off. On the File tab, click Options, and then click Advanced. In the 

Editing options section, clear the Delete Connectors When Deleting Shapes check box. 

 

The power  of undo 
As you work on a diagram and make both small-scale and large-scale changes, one of 

your most powerful allies is the Undo feature in Visio. You can undo nearly any action 

in Visio. The program defaults to providing 20 undo levels, which means you can undo 

the most recent 20 actions in your diagram. You shouldn’t hesitate to try anything  

with Visio, because you will be able to undo it if you don’t like the result. 

 

If you prefer a larger or smaller number of undo levels, on the File tab, click Options, 

and then click Advanced, where you will find a setting for Maximum Number Of 

Undos (the maximum is 99). 
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Replacing  shapes 
The exercises up to this point in the chapter have shown you how to add shapes to a page, 

and then to position, align, resize, and connect them. 

In the first part of this exercise, you will create a diagram from a template you haven’t used 

yet. In the second part, you will use an important new Visio feature that enables you  to 

replace any shape with an entirely different shape, and yet retain all of the original shape’s 2 
key characteristics. 

 

SET UP Click the File tab, and then click New. Click Categories, click Maps and Floor 

Plans, and then double-click the Directional Map (not Directional Map 3D) thumbnail. 
Save the new drawing as Change Shapes. 

 

1 From the Road Shapes stencil, drag a 4-way shape and use the Dynamic Grid to drop 

it in the center of the drawing page. Leave the shape selected. 
 

 
 

TIP When you drag the first 2-D shape onto an empty drawing page, the Dynamic 

Grid provides both horizontal and vertical center lines, as shown in the preceding 

graphic. The center line feedback is not provided if the first shape is a 1-D shape, 

or if the page contains any other shapes. 
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2 With the 4-way shape still selected, on the Home tab, in the Shape Styles group, 

click Line, and then in the Standard Colors section of the color menu, click Red. The 

purpose of the red color is simply to make this shape more visible during the remain- 

der of this exercise. 

3 Drag a Road square shape onto the page and glue one end to the right end of the 

4-way shape. Then drag and glue a second Road square to the left end of the 4-way 

shape. 

You’ll notice that the road square shapes behave like the dynamic connectors and 

lines you’ve used in previous exercises in this chapter: the ends turn green when you 

attach them to the 4-way shape, indicating that they have been glued. 
 

 
 

4 Drag two additional Road square shapes onto the page and glue them to the top 

and bottom of the 4-way shape. 
 

 

5 Click the unglued end of the Road square shape attached to the top of the 4-way 

shape and drag it up and to the right until it is aligned vertically, and then do the 

same thing with the Road square shape attached to the bottom, but drag it down 

and to the right. 



Replacing shapes 97  

 
 
 
 
 
 

 

 2  

 

 
6 In the Shapes window, click the Landmark Shapes stencil header, and then drag a 

Barn shape into the upper-left quadrant of your roadmap. 

7 Drag a Gas station shape into the lower-right quadrant of your map. 
 

 

You’ve now created the basic diagram on which you’ll use the Change Shapes feature. 
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8 Click the Barn shape on the drawing page once to select it. 

9 On the Home tab, in the Editing group, click Change Shape, and then in the Change 

Shape menu, point to the Building 1 icon. Notice that Live Preview has replaced the 

Barn shape on the drawing page with the Building 1 shape. 
 

 
 

TIP You can also access the Change Shapes button on the right-click Mini Toolbar as 

shown in the following graphic. 
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10 Click the Building 1 icon. Visio has replaced the shape on the page with the one you 

selected. 

11 Right-click the 4-way shape on the drawing page to select it, and then on the Mini 

Toolbar click Change Shape. 

12 In the Change Shape menu, click the arrow to the right of Landmark Shapes to re- 

veal a list of the other open stencils. 

 2  

 

 

 

 

13 Click Road Shapes. The Change Shapes menu displays icons for the Road Shapes. 
 

 



100 Chapter 2 Creating a new diagram 

14 Click Cloverleaf interchange as shown in the preceding graphic. Visio replaces the 

simple four-way intersection with a cloverleaf shape. Notice that the newly inserted 

shape includes the altered color you applied to the 4-way shape. In addition, the 

Road square shapes that were glued to the 4-way shape are now glued to the 

Cloverleaf interchange. 

 

 

CLEAN UP Save your changes to the Change Shapes drawing, and then close it. 

The ability to replace one shape with another is a long-requested feature in Visio that is 

finally available in Visio 2013. In this exercise, you replaced one shape at a time, but if you 

select more than one shape, you can replace all of them at once. 

 

IMPORTANT In general, the shape on the drawing page after a change shape 

operation retains the formatting, text, and shape data of the original shape. (You will 

learn about shape data in Chapter 3. 
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Key points 
▪ The Visio 2013 Dynamic Grid facilitates aligning new and existing shapes on the 

drawing page and eliminates much of the need to drag and nudge shapes into align- 

ment after you’ve placed them on the page. You can also use the rulers on the edges 

of the drawing page, or drag guides onto the page, to assist with shape positioning. 

▪ Visio provides multiple shape selection techniques. Mouse-only techniques allow 2  
rectangular selection by bounding box or freeform selection using a lasso. Other 

techniques use a combination of keystrokes and mouse movements. 

▪ The Visio 2013 paste function is smarter than in previous versions of the product. 
When you copy shapes from one page to another, the shapes are now pasted into 

the exact position they occupied on the source page. You can also select a specific 

paste location or use Paste Special by right-clicking. 

▪ You can connect shapes by using either lines or dynamic connectors. Lines retain 
their shape characteristics when adjacent shapes are moved. Connectors, on the 

other hand, dynamically adjust their appearance by adding or removing elbow 

bends in order to accommodate new shape positions. 

▪ Lines and connectors  can  be  glued  either  to  a  specific  connection  point  on  a  shape 
or to the shape as a whole. The former is known as static glue; the latter is referred to 

as dynamic glue. When you reposition shapes that use dynamic glue, the attachment 

point of a line or connector can change. 

▪ Visio shapes are one of two types: 1-D shapes, which behave like lines; and 2-D 
shapes,  which  behave  like  filled  polygons. 

▪ The Visio 2013 AutoConnect and Quick Shapes features can significantly reduce the 
time it takes to create a drawing consisting of connected shapes. 

▪ With the Visio 2013 AutoAdd function, you can split dynamic connectors merely by 
dropping a new shape onto them. The reverse is also true: if you delete a shape that 

is linked by dynamic connectors, AutoDelete removes unneeded connectors. 

▪ Visio 2013 introduces the ability to substitute one shape for another in a diagram. 
The new shape retains most of the data, formatting, connections, and text of the 

original shape. 
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IN THIS CHAPTER, YOU WILL LEARN HOW  TO 

▪ Create and format text boxes. 

▪ Orient and group shapes. 

▪ Add, orient, and position shape text. 

▪ Add ScreenTips and comments. 

▪ Use shape data and insert fields. 

▪ Work with pictures, layers, borders, and background pages. 

▪ Manage pages and page setup. 

At this point in your Microsoft Visio 2013 journey, you know how to perform many basic 

tasks: create drawings from templates, add shapes from stencils, create your own shapes, 

and connect shapes by using lines and dynamic connectors. 

 

In this chapter, you’ll move beyond the basics and explore ways to add sophistication to 

your drawings. In addition to managing pages and page layouts, you will add text to shapes 

and manipulate shapes and text in new ways. You will also add fields, ScreenTips, and com- 

ments to shapes; insert pictures and other objects; learn about layers; and take the first steps 

in creating data-driven diagrams. (There’s more on that last subject in Chapter 6, “Entering, 

linking to, and reporting on data,” and Chapter 10, “Visualizing your data.”) 

 
 

PRACTICE FILES To complete the exercises in this chapter, you need the practice files 

contained in the Chapter03 practice file folder. For more information, see “Downloading 

the practice files” in this book’s Introduction. 
 

 

Adding sophistication 
to your drawings 
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Adding  text to shapes 
In some Visio diagrams, the shapes are self-explanatory. In many drawings, however, you 

need to label the shapes. 

In this exercise, you’ll add text to existing shapes, and you’ll change the font size to make 

the text more readable. 

SET UP You need the Text ExercisesA_start drawing located in the Chapter03 practice 

file folder to complete this exercise. Open the drawing in Visio and save it as Text Exer- 

cises. Then follow the steps. 

1 On the left side of the page, click once (don’t double-click) on the start/end shape, 

type Start, and then click  anywhere  on  the  page  background  to  finish  text  editing. 

Notice that Visio zooms the selected shape to the center of the screen when you start 

typing and returns it to its original shape and location when you finish. 

2 Press Ctrl+A to select all shapes. Then on the Home tab, in the Font group, in the 

Font Size list, click 14 pt. The text in your start/end shape is more legible. 

3 Double-click the process shape to the right of the start shape, type Prepare 

expense report, and then click anywhere on the background of the page. When 

you click outside of the shape, notice that the dimensions of the shape change— 

it grows taller. The process box is an example of a shape that expands automati- 

cally when the amount of text exceeds its size. 

4 Click once (don’t double-click) on the decision shape, press F2, type Amount > 

$1000, and then press F2 again. 

KEYBOARD SHORTCUT Press F2 to enter and exit text edit mode. 

 

CLEAN UP Save your changes to the Text Exercises drawing but leave it open if you 

are continuing to the next exercise. 
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TIP You added text to shapes in steps 1, 3, and 4 in this exercise. You may have noticed that 

you were instructed to use a different method each time. For most Visio shapes, the three 

methods of entering text edit mode—single-click and start typing; double-click; select the 

shape and press F2—are interchangeable. You will find exceptions to this rule, but most 

shapes behave as described in this exercise. 

 
 

Creating  and formatting text boxes 
Although a picture can be worth a thousand words, sometimes you still need a few words. 3 
In this exercise, you’ll use the Text Tool on the Home tab to create and format a text box to 

use as a page title. 

 

SET UP You need the Text Exercises drawing for this exercise. Either continue with the 

open copy from the previous exercise or open the Text ExercisesB_start drawing located 
in the Chapter03 practice file folder and save it as Text Exercises. Then follow the steps. 

 

1 On the Home tab, in the Tools group, click the Text button. The cursor changes to a 

plus sign with a page icon below it. 

TIP As an alternative, the Visio 2013 Mini Toolbar introduces a single use Text Tool: 

the pointer reverts to the Pointer Tool as soon as you draw one text box. To open the 

Mini Toolbar, right-click anywhere on the drawing page. 

 

 

2 Click in the upper-left corner of the drawing page and drag to create a text box that 

is approximately 6 inches (150 mm) long. Visio automatically zooms in so you can 

type in the text box. 
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3 Type Sample Flowchart for Expense Report Processing. 

4 On the Home tab, in the Tools group, click the Pointer Tool button. Visio closes the 

text box, returns to the previous zoom level, and leaves the text box selected. 

TIP If you want to continue working with the Text Tool to create another text box, you 

can close the current text box by pressing the Esc key or by clicking the drawing page. 

 

 

The text in the page title box is a bit small! 

5 On the Home tab, in the Font group, click the Font Size arrow. As you point to various 

font sizes, notice that Visio provides a live preview of the results on the drawing page. 

TIP You can also change font sizes by clicking the Grow Font and Shrink Font buttons 

located immediately to the right of the Font Size drop-down list box. 
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 3  

6 Select 24 pt. as the new font size. 

7 Because the text wraps inside the text box at this font size, drag the right resize 

handle to the right until the text no longer wraps. 

 

At this point, you can use all of the usual text manipulation tools in the Font and 

Paragraph groups on the Home tab to apply other fonts, colors, and text styles or to 

add bullets or numbers and reposition the text within the text box. 

CLEAN UP Save your changes to the Text Exercises drawing, and then close it. 

In this exercise, you created a page title text box manually, but Visio offers a number of pre- 

formatted page title boxes. An example appears in “Working with background pages and 

borders” later in this chapter. 
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TIP If you are a long-time Visio user and prefer to use the legacy text formatting dialog 

boxes, they are still available. Just click the dialog box launcher in either the Font or 

Paragraph groups on the Home tab. 

 

 

 
TIP To apply changes to all of the text in a text box, select the box by using the Pointer 

Tool before making changes. To change only part of the text, double-click the text box to 

enter edit mode, and then select the specific text you want to change. (As an alternative 

to double-clicking the text box, you can select the text box by using the Text Tool, which 

automatically enters edit mode.) 

 
 

Orienting  shapes  on  the page 
When you drop shapes onto the Visio drawing page, they are usually oriented the way you 

want them to be. However, there are times when you will want the shapes to appear at a 

different angle. Visio provides several ways to accomplish this. 

 

In this exercise, you will add several shapes to the Visio drawing page and rotate the shapes 

to different angles. 

 

TIP The font size for some of the graphics in this exercise has been increased for readability. 

The font in your shapes may be smaller. 

 

SET UP Click the File tab, and then click New. Click Categories, click General, and then 

double-click the Block Diagram thumbnail. To improve visibility of key diagram elements 
for this exercise, on the Design tab, in the Themes group, click the More button in the 
lower-right corner of the Themes gallery, and select No Themes. Save the drawing as 
Orient Shapes and Text. Then follow the steps. 

 

1 On the View tab, in the Zoom group, click the Page Width button, and then position 

the page so you can view the top edge. 
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2 Drag a Box shape from the Blocks stencil and drop it so the center is approximately 

8 inches (200 mm) up from the bottom and 3 inches (75 mm) in from the left side of 

the page. 

TIP Use the ruler on the left and top edges of the drawing page to guide shape 

placement. 

 
 
 
 

 3  
 

 

In addition to the regular selection handles surrounding the box, notice the rotation 

handle at the top center just above the box. 

When you point to the rotation handle, the cursor changes from an arrow to a circu- 

lar arrow. Notice also that a dot appears in the center of the rectangle. This dot shows 

the geometric center of the shape, that is, the point around which the shape will ro- 

tate when you drag the rotation handle. Though you won’t do it in this exercise, you 

can alter the rotation characteristics of the shape by dragging the center of rotation 

handle to a different location. 

 

IMPORTANT The shapes in the US Units version of the Block Diagram stencil contain 

the word text, whereas the same shapes in the Metric Units version of the stencil do not. 

Because the examples in this chapter were created using the US version, you will notice 

the word text. If you are using the Metric stencil, add the word text to each shape. 
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TIP If a rotation handle does not appear above a shape, it’s because the shape 

designer has turned off the rotation feature. 

3 Grab the rotation handle and rotate the shape 90 degrees to the left (counterclock- 

wise). Both the shape and the text rotate. 

TIP If you keep the cursor near the rotation handle as you drag it, the shape rotates in 

15-degree increments. However, if you move the cursor away from the rotation handle 

as you drag it, the shape rotates in 5-degree increments, giving more precise control. 

4 Drag the rotation handle counterclockwise another 90 degrees so the box is inverted. 

Notice that the text is also upside down—more about that in the next exercise. 
 

 

5 Return the box to its original upright position to continue with this exercise, thereby 

demonstrating that you can rotate the shape freely through 360 degrees of arc. 

6 Drag a Circle onto the page so its center is approximately 3 inches (75 mm) to the 

right of the center of the box, using the Dynamic Grid to align it with the box. 

7 Right-click the drawing page and select the Connector Tool from the Mini Toolbar. 

TIP The Visio 2013 Mini Toolbar introduces a single use Connector Tool: the pointer 

reverts to the Pointer Tool as soon as you draw one connector. 

8 Draw a connector from the right side of the box to the left side of the circle. 
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9 With the new connector still selected, type Demonstration Text and then press the 

Esc key. 

10 Draw a bounding box around all three shapes to select them. 

11 On the Home tab, in the Font group, in the Font Size list, click 14 pt. to make it easier 

to read the text in the steps that follow. 

TIP You can apply the same change to multiple shapes at one time. 
 

 3  

 
12 Draw a bounding box around all three shapes to select them, and then rotate the 

entire selection 90 degrees clockwise. Notice the difference in behavior between the 

text in the box or circle and the text on the connector. 

TIP You can rotate selections of shapes as easily as you can rotate individual shapes. 
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13 Rotate the selection another 90 degrees clockwise so the shapes are inverted. 

 

At this point, it’s quite obvious that the text in some shapes seems to behave 

better—or at least differently—than the text in other shapes when the shapes 

are rotated. The next exercise will make this even clearer and will show you how 

to change the text orientation. 

CLEAN UP Press Ctrl+Z twice to undo the last two rotations. Save your changes to 

the Orient Shapes and Text drawing but leave it open if you are continuing with the next 
exercise. 

Orienting  shape text 
As you observed in the preceding exercise, shape text does not always rotate as you rotate 

the containing shape. Whether it does depends on how the underlying shape was designed. 

In this exercise, you’ll discover additional examples of automatic text rotation, and you’ll 

rotate text manually and reposition text blocks on shapes. 

SET UP You need the Orient Shapes and Text drawing for this exercise. Either con- 

tinue with the open copy from the previous exercise or open the Orient Shapes and 

TextA_start drawing located in the Chapter03 practice file folder and save it as Orient 

Shapes and Text. Then follow the steps. 

1 Drag a 2-D single arrow shape from the Blocks stencil onto the drawing page and 

position it below the box shape from the preceding exercise. 

2 While the arrow is still selected, type ABC. 

3 In the Shapes window, click Blocks Raised, drag a Right arrow onto the page, and 

position it to the right of the arrow you placed in the previous step. 

4 While the arrow is still selected, type ABC. 
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5 Draw a bounding box around both arrows to select them, and change the font size 

to 14 pt. 
 

 

6 Select the arrow on the left and use the rotation handle to turn it 180 degrees, and 

then do the same thing with the right arrow. 

                                                                                                     3  

Although the two arrow shapes are similar in some respects, their designers made 

different choices for how text should be handled. In the left arrow, the text rotates 

along with the shape. In the right arrow, the text responds to gravity, or more cor- 

rectly, it responds to a mathematical function that sets the text angle based on the 

shape angle so that it appears to be responding to gravity. 

TIP For the technically inclined, if you look in the TxtAngle cell in the Text Transform 

section of the ShapeSheet for the right arrow, there is a function named GRAVITY(). 

You will learn the basics of the ShapeSheet in the Appendix. 

 

To get a better sense of how the gravity function works, rotate the right arrow in 

several steps from its current position to its original position. 
 

 
 

As shown, some shapes are designed so the text will be upright as the shape is ro- 

tated, but what do you do with shapes that aren’t designed that way? Enter the Text 

Block Tool. 

7 On the Home tab, in the Tools group, click the Text Block button. 

8 Click the left arrow one time and notice that the selection handles appear as usual. 
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9 Drag the selection handle clockwise. Notice that because you are using the Text 

Block Tool and not the Pointer Tool, only the text rotates. Stop when you have ro- 

tated the text 180 degrees. 

 

You can use the Text Block Tool to reorient the text in virtually any shape. However, 

be aware that a shape designer can lock the text in a shape so that the text can 

neither be altered nor repositioned. If you click with the Text Block Tool on a shape 

whose text is locked, the rotation handle will not appear, as shown in the following 

graphic. (If you zoom in on such a shape, you’ll notice that the resize handles include 

a dotted diagonal line.) 

 

CLEAN UP Save your changes to the Orient Shapes and Text drawing but leave it 

open if you are continuing with the next exercise. 

Positioning  shape text 
The text on a Visio shape is located in a text block. You can reposition the text within a text 

block with several buttons located on the Visio ribbon. You can also reposition the entire 

text block by using the Text Block Tool you learned about in the previous exercise. 

In this exercise, you’ll reposition text within a text block, and you’ll move the text block to a 

new location. 

SET UP You need the Orient Shapes and Text drawing for this exercise. Either continue 

with the open copy from the previous exercise or open the Orient Shapes and TextB_ 

start drawing located in the Chapter03 practice file folder and save it as Orient Shapes 

and Text. Then follow the steps. 
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1 Click once in the rectangle that contains the word text. 
 

 

TIP When you select a shape, the illuminated buttons in the Paragraph group show 

the current text alignment for that shape. For example, after clicking the rectangle, 3  
the Paragraph group should look like the following graphic, indicating that the text is 

centered both vertically and horizontally. 

 

 

2 On the Home tab, in the Paragraph group, click any of the buttons to observe the 

effect. For example, if you click the Align Top button and then the Align Left button, 

the shape will look like the following graphic. 
 

 

3 On the Home tab, in the Tools group, click the Text Block button, and then click 

once on the rectangle that contains the word text. 

4 Click anywhere on the edge of the text block and drag the text block up and to the 

left. When the Text Block Tool is active, the text block moves independently from 

the underlying shape. If you subsequently use the Pointer Tool to move the under- 

lying shape, the text block also moves and remains in the same position relative to 

the shape. 
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TIP If the shape designer has locked the text block in a shape, the rotation handle 

will not appear, and the resize handles will display a dotted diagonal line. You will 

not be able to move, resize, or rotate the text block. 

 

 

You can also resize the text block whenever the Text Block Tool is active by dragging 

any of the resize handles. Although moving the text block on this particular shape 

may not make a lot of sense, there are situations where knowing how to move and 

rotate text can be very helpful as the remaining steps in this exercise illustrate. 

5 Press Ctrl+1 to activate the Pointer Tool. 

6 In the Shapes window, click More Shapes, point to Network, and then click 

Computers and Monitors - 3D. After the Computers And Monitors - 3D stencil 

opens,  click  anywhere  on  the  drawing  page  to  close  the  fly-out menus. 

7 Drag an LCD monitor shape onto the page, drop it below the circle shape, and type 

Hello. Notice that this shape was designed so that the text block is located below the 

shape. 
 

 

8 On the Home tab, in the Tools group, click the Text Block button. 

9 Click the word Hello and then reposition and rotate the text block so the word Hello 

appears on the LCD screen at approximately the same angle as the screen itself. 
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TIP  Repositioning and rotating the text in the LCD monitor is an excellent situation 

in which to use the zoom feature in Visio. Zoom in to enlarge the shape before 

attempting to relocate and rotate the text. This will enable you to complete this step 

more easily and more precisely. 

 3  
CLEAN UP Save your changes to the Orient Shapes and Text drawing, and then 

close it. 

SEE ALSO For another perspective on text block positioning, go to www.visguy.com/ 

2007/11/07/text-to-the-bottom-of-the-shape/. 

Adding ScreenTips and comments 
In some drawings, you want to provide your reader with additional information that doesn’t 

need to be visible at all times. Visio provides two convenient options with very different 

characteristics: 

▪ ScreenTips display pop-up text when you point to a shape, but they are otherwise 
invisible. Indeed, there is no way to know that a ScreenTip exists unless you point 

to a shape containing one and a pop-up appears. 

 

▪ Comments provide a visible indication of their presence, but require you to click the 
indicator in order to view the text of the comment. Each comment stores and displays 

the name of the comment author and the date when it was created. New in Visio 2013, 

one comment shape can contain multiple comments from multiple authors; individ- 

ual entries are displayed in chronological order. You will learn more about comment- 

ing in Chapter 13, “Collaborating on and publishing diagrams.” 

 

IMPORTANT ScreenTips are part of a shape. Consequently, they move with a shape 

and are deleted when you delete a shape. 
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In general, use ScreenTips to provide useful but noncritical information about a shape. You 

should make the assumption that the reader may discover a ScreenTip, but also may not. 

Use comments when it is vital that the reader know that they exist and when it is important 

to know who created the comment and when. 

 

In this exercise, you’ll add a ScreenTip to a shape. You’ll also add and edit a comment. 

 

SET UP Click the File tab, and then click New. Click Categories, click Network, and 

then double-click the Basic Network Diagram thumbnail. Save the drawing as Text and 

Data on Shapes. Then follow the steps. 
 

1 In the Shapes window, click Computers and Monitors. The Computers And 

Monitors stencil opens. 

2 Drag a PC shape onto the page. 

3 On the Insert tab, in the Text group, click the ScreenTip button to open the Shape 

ScreenTip dialog box. 

4 Type I need a new PC in the dialog box, and then click OK. 
 

 

 

IMPORTANT If one shape is selected when you add a comment, the comment will be 

attached to that shape. If more than one shape is selected when you add a comment, 

the comment will be attached to the anchor shape (you will learn more about anchor 

shapes in Chapter 5, “Adding style, color, and themes”). If no shapes are selected, the 
comment will be attached to the drawing page. 
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5 Point to the PC and observe the pop-up text that you’ve created. 
 

 

6 Drag a Laptop shape from the Computers and Monitors stencil onto the page. 

7 With the laptop shape still selected, on the Review tab, in the Comments group, click 3  
the New Comment button. 

TIP Comments are part of the review feature set in Visio. Consequently, you will find 

comment buttons on the Review tab and not on the Insert tab where you found 

ScreenTips. 

 

Visio drops a comment indicator and an edit box for the comment body onto the 

page. The indicator is located in the upper-right corner of the shape and looks like a 

cartoon dialog balloon; the edit box appears above or near it. 
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8 Type This laptop contains Visio Professional 2013. 
 

 

9 Click anywhere on the background of the page to close the comment edit box. 
 

 

10 Point to the comment balloon but don’t click it, which causes Visio to display the 

word Comments but only for as long as you continue to point to the   indicator. 
 

 

11 Click once on the comment indicator to view the Visio display of the comment 

edit box. 
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12 Click in the Reply area of the edit box and type It also contains Office Professional 

2013. 

TIP If you click on the text of the previous comment, you can edit it instead of typing 

a reply. 

 
 
 
 

 

 3  

 

 
13 Click anywhere outside the comment balloon to close it and then click the balloon 

again to reopen the comment box. 
 

 

The comment feature in Visio 2013 is much more robust than in previous versions 

because it supports threaded conversations. Although both comments in the preced- 

ing graphic were entered by the same person, in Chapter 13 you’ll discover examples 

of coauthoring that feature comments from multiple people. 
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TIP If you prefer not to view pictures of the person who made a comment, click the 

blue triangle to the left of the person’s name to collapse the view. 

 

CLEAN UP Save your changes to the Text and Data on Shapes drawing, and then 

close it. 

TIP You can turn all comment indicators in your drawing on or off by clicking the lower 

part of the Comments pane button in the Comments group on the Review tab, and then 

clicking Reveal Tags. 

Using  shape data 
A significant part of what gives Visio diagrams uniqueness and value is the data that resides 

inside Visio shapes. Called shape data starting with Visio 2007, data fields were known as 

custom properties in previous versions of Visio. 

Many of the masters in the built-in Visio stencils already contain shape data fields. In this 

exercise, you’ll work with existing data fields. In Chapter 6, you’ll work with data in more de- 

tail, including creating new shape data fields. 

In this exercise, you’ll add and edit values in computer and network shapes. 
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SET UP Click the File tab, and then click New. Click Categories, click Network, and 

then double-click the Basic Network Diagram thumbnail. Save the drawing as Shape 

Data. Then follow the steps. 
 

1 In the Network and Peripherals stencil, drag a Server, a Printer, and a Fax shape 

onto the page, arranging them from top to bottom on the   page. 

2 Click once on the server shape to select it. 

3 On the View tab, in the Show group, click the Task Panes button, and then click 

Shape Data. The Shape Data window appears and displays the names and current 3 
values, if any, for data fields that are contained within the server  shape. 

 

 
 

TIP The Shape Data window can appear anywhere on the screen, but you can 

relocate it by dragging the window header. If you drag it toward any edge of the 

drawing window, it will attach itself there; if you drag it a bit further, it will dock 

outside the drawing window. You can also let the Shape Data window float over the 

drawing window as shown in the graphic. 
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4 Click in the Asset Number field, and type 6789-001. 

5 Click in the Serial Number field, and type 13579. 

6 Click in the Network Name field, and type FileServer-A32. 

 

TIP Note the scroll bar on the right side of the Shape Data window. This shape has 

additional data fields that are not visible in the graphic. 

7 Click once on the printer to select it. Notice that the Shape Data window now shows 

the fields that are defined for the     printer. 

8 Click in the Asset Number field, and type 6449-001. 

9 Click in the Network Name field, and type HR-Printer6. 

10 Click once on the fax to select it. Notice that there are fewer fields defined for the fax 

machine. 

11 Click in the Manufacturer field, and type Contoso. 

12 Click in the Product Number field, and type FX351. 

CLEAN UP Save your changes to the Shape Data drawing but leave it open if you are 

continuing with the next exercise. 
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Inserting fields: the basics 
Now that you have entered data into several shapes, wouldn’t it be nice if some of it 

appeared on the drawing? 

 

In this exercise, you’ll insert a field onto a shape and link the field to shape data. 

 

SET UP You need the Shape Data drawing for this exercise. Either continue with the 

open copy from the previous exercise or open the Shape Data_start drawing located in 

the Chapter03 practice file folder and save it as Shape Data. Then follow the steps. 3 
1 Click once on the server shape to select it. 

2 On the Insert tab, in the Text group, click the Field button. The Field dialog box 

opens and displays eight categories of field data that can be inserted into a shape. 

3 In the Category section of the Field dialog box, click Shape Data. The Shape Data 

fields for this shape appear in the Field name section. 
 

 

4 Scroll down in the Field name section, click Network Name, and then click OK. The 

field  you  inserted  appears  under  the server. 
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TIP For the server shape and the other shapes on this page, the default text position 

is centered below the shape. In previous sections in this chapter, you worked with 

shapes whose text appeared in the middle of a shape or somewhere else. You’ve also 

learned how to reposition shape text if you prefer a different location. 

5 Click once on the printer to select it, and then repeat steps 2–4 to display the net- 

work name for the printer. 

6 Click once on the fax to select it, and repeat steps 2 and 3, but this time, click the 

Product Number field to produce a diagram that looks like the following graphic. 

 

CLEAN UP Save your changes to the Shape Data drawing, and then close it. 

There is a lot more that you can do with fields than simply displaying the contents of one 

field. You will learn more about fields in the Appendix. 

Grouping shapes 
Most of the exercises you’ve done in this book so far have involved using or manipulat- 

ing individual shapes. Sometimes it’s more convenient to work with a set of shapes as a 

single unit. 

In this exercise, you’ll create and work with a group shape. 
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SET UP Click the File tab, and then click New. Click Categories, click Flowchart, and 

then double-click the Work Flow Diagram thumbnail. Save the drawing as Corporate 

Diagram. Then follow the steps. 
 

1 In the Shapes window, click the Department stencil if it is not already selected. 

2 Drag a Headquarters shape to the drawing page and use the Dynamic Grid to posi- 

tion it at the top center of the page. The two Dynamic Grid lines provide visual assur- 

ance that you are at the top center. 

 3  

 
3 On the status bar, click either the Width or Height button to open the Size & 

Position window. 

SEE ALSO For more information about the status bar and the Size & Position window, 

refer to Chapter 1, “A visual orientation to a visual product.” 

4 In the Size & Position window, double both the Width and Height to 2 inches for 

US units or 60 mm. for metric. The increased height of the shape has triggered the 

Auto Size feature and Visio has added a new page above the current page. 
 

 

5 Press the Down Arrow key until the resized shape is at the top margin of the 

original page. 

6 Drag the following shapes onto the page and position them around the headquarters 

icon: Customer Service, Management, Legal Department, Human Resources. 
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7 Draw a bounding box around all five   shapes. 
 

 

8 On the Home tab, in the Arrange group, click the Group Objects button, and then 

click Group. Notice that the blue selection rectangles around the individual shapes 

have disappeared, indicating that the group operation was successful. 

KEYBOARD SHORTCUT Press Ctrl+G to group selected shapes. 

 

 
 

TIP Like the individual shapes that comprise it, a group is also a shape. You can 

apply borders or fills, add fields and text, and add shape data—in short, you can 

do anything with a group shape that you can with any other shape. 

9 Drag the group to the upper-left corner of the page. All shapes that are part of the 

group move together. 

10 Click anywhere on the page background to deselect the group. 
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11 Click once on any shape in the group. Notice that the entire group is selected. 

12 With the group still selected, click once on the Legal Department shape. The selection 

rectangle around the group changes from a solid line with resize handles to a dashed 

line to indicate that the group no longer has the focus. The Legal Department shape, 

on the other hand, now displays resize handles and a rotation handle, because it is 

now the selected shape. 

The default behavior for grouped shapes is what you have observed in the preceding 

two steps: the first click selects the group; the second click selects a shape within the 

group. It is possible to change this behavior, but you won’t do that in this exercise. 3  

 

 

 

 

13 Click the dashed line surrounding the group to change the focus back to the group. 

14 Drag the lower-right resize handle to enlarge the group. Notice that all shapes within 

the group resize proportionally. 
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15 Drag a Bank shape from the Department stencil and drop it somewhere within the 

boundary of the group. 

16 Select and drag the group back to the center of the page. Dropping a shape onto a 

group does not add it to the group. 
 

 
 

TIP By default, shapes dropped on a group are not added to the group. However, if 

you run Visio in developer mode, you can change the behavior of a group so it will 

accept dropped shapes. You will learn about developer mode in the Appendix. 

 

17 Right-click any shape in the group, then on the context menu, click Group, and then 

click Ungroup. The shapes remain on the page, but Visio removes the group. Any 

styles, text, or data associated with the group are now gone as well. Once again, each 

shape now shows its own selection rectangle. 
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CLEAN UP Save your changes to the Corporate Diagram drawing, but leave it open if 

you are continuing with the next exercise. 

 3  

Inserting pictures 
As is true for Microsoft Word, PowerPoint, and many other programs, Visio lets you import 

pictures of various types into a drawing. You may want to add a picture of a specific object, 

a piece of clip art or a general background image—either way, you can import almost any 

type of image or picture into Visio. 

In this exercise, you’ll import several pictures to add value to and enhance the appearance 

of your drawing. 

SET UP You need the Corporate Diagram drawing for this exercise. Either continue 

with the open copy from the previous exercise or open the Corporate DiagramA_start 

drawing located in the Chapter03 practice file folder and save it as Corporate Diagram. 
You also need the International Office image from the same practice file folder. Then 
follow the steps. 

1 On the Insert tab, in the Illustrations group, click the Picture button. 

KEYBOARD SHORTCUT Press Alt+N and then press P to insert a picture. 

2 Navigate to the Chapter03 practice file folder, click International Office.jpg, and 

then click Open. (This image originated in the Microsoft Office Clip Art gallery.) 

3 Drag the inserted photo to the bottom center of the  page. 

 

IMPORTANT Ungrouping the shape in this step is perfectly safe. In general though, 

ungrouping a shape can be very destructive unless you know exactly what you’re doing. 

The reason is that to Visio, a group is just another shape, and it can have its own data 

and properties. Compounding the problem, the shapes in many groups derive some 

of their own behavior and data from the group. Consequently, when you ungroup the 

parent shape, you destroy the shape properties that were derived from the group. 
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4 Drag an International Division shape from the Department stencil and drop it on 

the right face of the building. 
 

 
 

5 On the Insert tab, in the Illustrations group, click the Online Pictures button to open 

the new Office 2013 Insert Pictures dialog box. 
 

 
 

6 In the Office.com Clip Art box, type EU flag and then press Enter. Several flag im- 

ages appear. 

7 Double-click one of the flag images to add it to your drawing. 
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8 Reduce  the  size  of  the  flag  image,  and  then  position  it  in  the  upper-left  corner  of 

the building image. Your drawing now includes an iconic representation of various 

headquarters’ functions at the top of the page, and images that represent the inter- 

national  division  office  at  the bottom. 

 3  

CLEAN UP Save your changes to the Corporate Diagram drawing, but leave it open if 

you are continuing with the next exercise. 

Once inserted into your drawing, an image becomes a shape, much like the group did in 

the preceding exercise. Consequently, you can use any of the various tools in Visio to alter 

or adjust the shape’s properties. You can also add data to the image shape by using a tech- 

nique you will learn in Chapter 6. 
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As you completed the steps in this exercise, you may have noticed that when you selected 

an image, the Picture Tools tool tab set appeared. You can use the buttons on the Format 

tool tab to alter the properties of an image. 

 

 

 
TIP Like most of the other applications in the Microsoft Office suite, you can insert more 

than just pictures into a Visio drawing. On the Insert tab, click Object, and you will find 

two dozen or more document and object types (the actual list varies from computer to 

computer depending which Office products you have installed). 

 
 

Understanding  and  using layers 
You can organize objects in a Visio drawing into layers and control various properties of 

all layer members at once. For example, you can control whether layer members will print, 

be visible on the drawing page, or be selectable. In a town map, for instance, you might 

put roads on one layer, sewer lines on a second, water pipes on a third, and buildings on a 

fourth. Organized this way, you can lock certain layers to prevent accidentally moving or 

selecting that collection of objects while working with shapes on other layers. Similarly, you 

could print a map showing roads and buildings, but not water pipes. 

 

SEE ALSO You can also use layers to select a subset of the shapes on a page, and you’ll learn 

this technique in “Setting glow, reflection and other effects” in Chapter 5. 

 

Layers offer considerable flexibility in managing the parts of a sophisticated drawing. 

However, working with layers requires some planning, because things can get complex: a 

drawing page can have multiple layers; each layer has multiple properties; and any shape 

can be on zero, one, or multiple layers. 

 

TIP  Every layer belongs to exactly one page. When you create a new layer, it is added 

to the current page. If you copy layer members to a different page, the layer is added to 

the destination page. (If a layer of the same name already exists on that page, the copied 

shapes are added to the existing layer.) 
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The Layer Properties dialog box that you will use in this exercise includes seven check boxes 

for setting layer properties. The y are described in the following paragraphs; default settings 

for each property are shown for the Flowchart layer in the graphic following step 7. 

▪ Visible Controls whether a layer’s shapes are visible on the drawing page. 

▪ Print Includes or excludes a layer’s members from printing. 

TIP Because the Visible and Print check boxes are separate, you can create a drawing 

in which members of a layer are visible in the drawing but do not print, and vice 

versa. 

▪ Active Causes all new shapes added to the page to be added to the layer. More than 
3 

one layer can be active at once, in which case new shapes are added to all active layers. 

▪ Lock Prevents you from selecting, moving, or editing any shapes on the layer. In ad- 
dition, you cannot add shapes to a locked layer. 

▪ Snap and Glue Allows and disallows snapping or gluing other shapes to the shapes 
on this layer. 

▪ Color Temporarily overrides the colors of all objects on a layer; clearing this option 
returns layer members to their original colors. When you select the Color property for 

a layer, the Layer Color and Transparency settings in the lower right of the dialog box 

are activated. 

 

In this exercise, you’ll create layers and assign shapes to them. You’ll also change layer prop- 

erties, which will show you the effects on the drawing. 

 

SET UP You need the Corporate Diagram drawing for this exercise. Either continue 

with the open copy from the previous exercise or open the Corporate DiagramB_start 

drawing located in the Chapter03 practice file folder and save it as Corporate Diagram. 

Then follow the steps. 
 

1 Click once on the photograph of the building at the bottom of the page to select it. 

2 On the Home tab, in the Editing group, click the Layers button, and then click Assign 

to Layer to open the Layer dialog box. When the Layer dialog box opens, notice that 

the Flowchart layer is already listed because the shapes that are used in the Work 

Flow Diagram template are pre-assigned to that layer. 
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3 Click the New button. 
 

 

4 In the New Layer dialog box, type Building Photo and then click OK. The Building 

Photo layer is added to the Layer dialog box, and the selected shape is added to the 

new layer. 
 

 

5 Click OK. 

6 On the Home tab, in the Editing group, click the Layers button, and then click the 

Layer Properties button. 
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7 In the Layer Properties dialog box, select the check box below Lock for the Building 

Photo layer. 
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8 Click OK. You have now created a new layer, added a shape to it, and locked the 

layer. 

9 Draw a bounding box around the International Division symbol, the EU flag, and the 

photograph of the building. Notice that you cannot select the building because it is 

on a locked layer. 
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10 On the Home tab, in the Editing group, click the Layer Properties button, and then 

click Assign to Layer to open the Layer dialog box. Notice that the Building Photo 

layer does not appear in the list, because you cannot assign shapes to a locked layer. 
 

 

11 Click the New button, type International, and then click OK. 
 

 

12 Click OK. The drawing doesn’t look any different at this point, but there is evidence of 

the new layer in subsequent steps. 
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13 On the Home tab, in the Editing group, click the Layers button, and then click Layer 

Properties. 
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14 In the Layer Properties dialog box, clear the check box below Visible, for the 

International layer, and then click Apply. 

TIP The Apply button provides a preview of the intended change without closing the 

Layer Properties dialog box. If you make a change in the Layer Properties dialog box 

and want that change to affect your drawing immediately, it is not necessary to click 

Apply—just click OK. 

 

In the graphic on the right, the two shapes on the International layer are no longer 

visible. Compare this graphic to the one following step 13. 
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15 Click OK to close the Layer Properties dialog box. 

CLEAN UP Save your changes to the Corporate Diagram drawing, and then close it. 

In this exercise, you saw that flowchart shapes are pre-assigned to a layer. The same thing is 

true for a number of other Visio templates. In addition, dynamic connectors are always on a 

layer, so dropping the first one onto any page creates a layer called Connector. 

TIP Although they both help you organize sets of shapes, groups and layers serve different 

purposes and have different behaviors. For example, you can select a group and then move 

it or resize it and the changes affect all of the shapes in the group; you can’t perform those 

actions with the shapes in a layer. On the other hand, you can lock, hide, and otherwise 

affect shapes in a layer in ways that you cannot with a group. Realize also that groups and 

layers are not mutually exclusive—you can use both in the same drawing. 

Managing pages and page setup 
A Visio drawing can contain any number of pages, and each page can have its own dimen- 

sions, measurement units, and other characteristics. In addition, the on-screen drawing 

page can have different dimensions from the physical printer page. 

Setting the drawing page size to be different from the physical page lets you do things like: 

▪ Compress a large drawing to fit on a smaller sheet of   paper. 

▪ Print a drawing on a very large sheet of paper. 

▪ Print a drawing across multiple sheets of paper. 

Indeed, Visio gives you remarkable flexibility in setting page attributes that are useful for 

virtually any diagram type and any form of printed or electronic  output. 

Visio drawings also support two types of drawing pages: 

▪ Foreground pages contain the active drawing content and are typically the pages that 
are printed or published in some form. 

▪ Background pages contain page elements that can appear on one or more pages but 
cannot be selected unless you are viewing the background page. 
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By associating a background page with a foreground page, all text and graphics on the 

background page appear on the foreground page. One common use for background pages 

is to add consistent borders or titles to a set of foreground pages. Another is to include the 

company logo, a legal notice, or any other graphic or text on multiple pages. 

 

In this exercise, you’ll add, delete, and reorder pages, as well as change various page set- 

tings. You’ll also use the new Visio 2013 duplicate page feature. You will work with back- 

ground pages in the next exercise. 

 

SET UP Click the File tab, and then click New. Click Categories, click General, and then 

double-click the Basic Diagram thumbnail to create a new drawing. Save the drawing as 3 
Pages and Page Setup. Then follow the steps. 

 

1 On the Insert tab, in the Pages group, click the lower part of the New Page button, 

and then click the Blank Page button. Visio adds a page called Page-2. 

2 Notice that you can also add a background page or duplicate the current page from 

the same drop-down menu. 

TIP Clicking the Blank Page button is equivalent to clicking the Insert Page button 

that you learned about in Chapter 2, “Creating a new diagram” (it’s the button to the 

right of Page-2 in the following graphic). 

 

 

Next you’ll change some of the attributes of Page-2 using convenient new features of 

Visio 2013. 

3 On the Design tab, in the Page Setup group, click the Orientation button, and then 

click Portrait. Clicking this button changes the orientation of both the drawing page 

and the printer page. 

4 Drag a Square from the Basic Shapes stencil onto the top edge of the page so that 

part of it is on the page and part is on the canvas. Because the Visio 2013 Auto Size 

feature is on by default in this template, as it is in many others, Visio added a page 

for you. The dashed line is the boundary between tiles, each of which represents the 

portion of the drawing page that will print on a single physical page. 
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5 Drag the square down so it is below the dashed line. Visio removes the added page 

because it is no longer needed. 
 

 

You can turn off the Auto Size feature if you want to use the drawing canvas to store 

shapes temporarily that you don’t want to be on the drawing page. 

6 On the Design tab, in the Page Setup group, click the Auto Size button, which 

removes the illumination from the Auto Size button. 

TIP The Auto Size option is applied per page. Consequently, changing the setting for 

the current page does not affect other pages. 

7 In the Shapes window, click Arrow Shapes, and then drag a Simple Arrow onto the 

canvas just above the page. The arrow remains on the canvas and Visio does not ex- 

pand the drawing page. 

TIP  Items on the drawing canvas but not on the drawing page do not print. 

 

 

8 Click the Insert Page button below the drawing window to add a new page. 
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You’ve now used several buttons in the Orientation group on the Design tab that 

simplify some page-related functions. There are times, however, when you need to 

make more sophisticated changes to page attributes. The Page Setup dialog box, 

which will be familiar to users of previous Visio versions, is still available for that 3  
purpose. 

9 On the Design tab, in the Page Setup group, click the Auto Size button. This action 

turns Auto Size behavior back on for this page. 

10 Right-click the page name tab for Page-3, and click Page Setup. The Page Setup 

dialog box opens to the Page Properties tab. 
 

 

In addition to selecting the page type and changing the page name, you can assign a 

background page (refer to the next exercise) and select from a large number of mea- 

surement units. Be sure to notice the scroll bar in the Measurement units menu—you 

have a total of 20 choices. If you change the measurement units, the result is visible in 

the rulers on the top and left of the drawing page. 

 

IMPORTANT When you added a page in step 1, the new page had landscape orien- 

tation; however, this time the new page has portrait orientation. The difference demon- 

strates an important point: when you add a page, Visio copies all of the characteristics 

of the active page. Consequently, if the pages in your drawing have different attributes, 

be sure to activate a page with the desired attributes before adding a new page. 
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11 In the Page Setup dialog box, click the Print Setup tab. 
 

 

You use the options on the Print Setup tab primarily to affect the size and layout of 

the physical page, although the zoom settings on this tab also affect the drawing 

page size. 

The Print Setup tab contains three configuration sections on the left and a preview 

pane on the right. The preview pane changes dynamically to reflect your current 

print settings and displays them in both visual and text form: 

▪ Printer paper Choose the paper size for your desired printer. Most US Units 
templates default to letter-sized paper as shown in the previous graphic. Metric 

templates typically default to A4. Regardless of the default, there is a long list of 

alternate, predefined paper sizes available in the list at the top of this section. You 

can also select Portrait or Landscape orientation. 

The Setup button opens the printer setup dialog box for the current printer. 

▪ Print zoom Adjust to 100% is the default zoom for many templates, but you can 
select a different zoom level if you want your drawing to print larger or smaller 

than normal. Choosing a zoom setting greater than 100% causes your drawing to 

be split across multiple sheets of paper; choosing a setting less than 100% scales 

your drawing down to fit onto a portion of the printer page. 
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▪ Fit To Provides an alternate way to scale your drawing for printing. 

▪ Print The single setting in this section includes or excludes gridlines from printed 
output. The default in most templates is to exclude gridlines. 

12 In the Printer paper section, click Landscape. The preview section reflects your 

choice. 

13 In the Page Setup dialog box, click the Page Size tab. 
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You use the Page Size tab to change attributes of the drawing page; changes you 

make on this tab do not directly affect the printed page. 

The Page Size tab includes two configuration sections plus a preview pane: 

▪ Page size The first option in this section enables the dynamic Auto Size behav- 
ior you used in steps 3 through 5. As an alternative, the second and third options 

let you set a fixed page size, either from a list of preset sizes or by typing specific 

dimensions. 

▪ Page orientation The options in this section are only active if you choose Pre- 

defined size or Custom size in the Page size section. You can use these options 

to set a different orientation for the physical page than the one that is set for the 

drawing page. 
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14 Click OK. The dialog box closes and Page-3 now has landscape orientation. 

15 Double-click the page name tab for Page-2 (not Page-3), type Portrait with Square, 

and then press Enter. 
 

 

As you saw in step 10, you can change the page name on the Page Properties tab in 

the Page Setup dialog box, but double-clicking the page name tab is usually more 

convenient. 

In addition to changing page names, you can also change the sequence of pages in a 

drawing. 

16 Drag the page name tab for Page-3 to before Page-1. 

As you drag the page name tab, the cursor displays a page icon, and a black down 

arrow points to the junctions between pages. 
 

 

When you release the mouse button, the page tabs reflect the new page sequence. 
 

 
 

TIP Dragging page name tabs is an easy way to resequence pages when the des- 

tination tab location for your page is visible. However, if your diagram has a lot of 

pages and the destination tab is not visible, there is a simple alternative: right-click 

any page name tab and select Reorder Pages. In the Reorder Pages dialog box that 

opens (shown in the following graphic), use the Move Up or Move Down buttons. 
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17 Right-click the Portrait with Square page name tab and then click Duplicate. 

Visio creates a new page that is an exact copy of the source page. 

TIP Duplicating a page and all of its contents is a long-desired feature that is new in 

Visio 2013. 

 

CLEAN UP Save your changes to the Pages and Page Setup drawing, and then 

close it. 

KEYBOARD SHORTCUT Visio provides two convenient shortcuts for navigating back and 

forth among the foreground pages in your drawing: Ctrl+Page Up and Ctrl+Page Down. 
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Working with background pages and 
borders 

You can create background pages manually and assign them to selected foreground 

pages. You can also take advantage of several Visio features that automatically create 

and assign background pages. 

 

In this exercise, you’ll create background pages manually and assign them to selected fore- 

ground pages 

 

TIP In the previous section, you adjusted the sizes and attributes of foreground pages. You 

can use the same techniques to resize and adjust attributes of background pages. 

 

SET UP You need the Starfish image and the Background Exercises_start drawing lo- 

cated in the Chapter03 practice files folder to complete this exercise. Open the drawing 
in Visio and save it as Background Exercises. Then follow the steps. 

 

1 The drawing you just opened contains four pages, each of which contains a collection 

of shapes, and each page has a different theme applied to it. In addition, each page 

name reflects the contents of the page. The shapes and themes on each page exist so      

you can quickly tell one page from another as you complete the steps in this exercise. 

Notice, also, that the drawing for this exercise was created using the metric template. 

2 On the Insert tab, in the Pages group, click the New Page arrow (not the button), 

and then click Background Page. The same Page Setup dialog box that you saw in 

the previous exercise opens to the Page Properties tab, however, in this case the 

Type is preset to Background and the default page name is Background-1. 
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3 Click OK. Visio creates the background page. 

TIP If the tab for the new page doesn’t show the entire name Background-1, click any 

other page name tab, and then click back to the background tab. 

 

 
 

TIP Remember that the attributes of the active page determine the attributes of 

each new page. If your drawing contains pages with different orientations or settings, 

activate the page that is like, or most like, your desired background page before 

creating the new page. 
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4 On the Insert tab, in the Illustrations group, click the Picture button, navigate to 

the Starfish.jpg in the Chapter03 practice files folder, and then click Open. Visio 

inserts the picture into the center of the drawing window. You will use this picture 

as a stand-in for a company logo. 

5 Drag the starfish picture to the upper-right corner of the page, and then resize it so it           

is approximately 25 mm (1 inch) wide. 

TIP Remember that when you have selected a shape, its current width and height are 

displayed in the status bar at the bottom of the Visio window. As you drag the corner 

resize handle, the status bar updates dynamically to show the current size. 

 

 
 

TIP You can include “Company Confidential” or other text on the pages in your 

diagram by adding a text box to the background page. 

 

Now that you’ve created a background page, you can apply it to one or more fore- 

ground pages. 

6 Right-click on the Squares page name tab, and then click Page Setup. The Page 

Setup dialog box opens to the Page Properties tab. 

7 Use the Background list, select the name of the background page, Background-1, 

and then click OK. The Squares page now includes the “logo” and any other objects 

or text you might have placed on that page. Three important notes: 

▪ Because the starfish is on a background page, you cannot select, change, or relo- 
cate it on this page. You must go to the background page to make changes. 

▪ Applying background pages is done per page. When you navigate to the Circles 
or Triangles pages, they do not show the background. 
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▪ If you create a new page from an active page that includes a background page, 
the new page will also include the background page. 
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8 Go to the Circles page. Notice that the background was not applied to this page. 

9 On the Design tab, in the Background group, click the Borders & Titles button to 

open the Borders & Titles gallery. As you point to any thumbnail in the gallery, its 

name is displayed as pop-up text. Be sure to notice that there is a scroll bar at the 

right giving you access to additional selections. 
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10 Click the Tiles thumbnail, which should be toward the upper left. Visio creates a back- 

ground page containing the title shapes and applies it to the Circles page. Most of 

the title box that appears across the top of the page is reserved for the document 

title, but the right portion contains today’s date. There is also a page number in the 

lower-right corner. 

TIP The page number will be updated dynamically if you add, delete, or reorder 

pages. 

 

 
 

TIP The automatically generated background page is called VBackground-1. Visio 

includes the letter V to distinguish the background page it created from the one you 

created manually. 

 

 

11 Go to VBackground-1, click in the Title text box, and then type Tailspin Toys. 
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12 Go to Circles. The Circles foreground page reflects the change you made on the 

background page. 
 

 

13 Go to the Triangles page. 

14 On the Design tab, in the Background group, click the Backgrounds button to view 3  
a gallery of available backgrounds. Each thumbnail displays the colors and effects 

of the theme applied to this page. The name is viewable when you point to any 

background. 

15 Scroll down in the background gallery and click once on the Verve background. Visio 

creates a new background page called VBackground-2, and applies it to Triangles. 
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16 Go to the Arrows page. Note that it does not include any of the backgrounds you’ve 

created for other pages in the drawing. 

17 Right-click the Arrows page name tab, and then select Page Setup. 

18 In the Background list, select Background-1, and then click OK. 

You have now assigned the same background page to both Triangles and Squares. 

CLEAN UP Save your changes to the Background Exercises drawing, and then close it. 

Five final thoughts about background pages: 

▪ Changes you make to a background page appear on all pages using that back- 
ground page. 

▪ If you have foreground pages with different orientations or sizes, you are likely to 
need multiple background pages with attributes that match the foreground pages. 

▪ Background pages can have background pages. It is possible, therefore, to build a set 
of foreground pages that all display shapes from a common background page. (Think 
of it as the “deep background” page.) Those same foreground pages can also display 

the contents of other background pages that are unique to an individual page or to a 

group of pages. 

▪ The page name tabs for background pages always appear to the right of all fore- 
ground pages and they cannot be reordered. 

▪ Background page names are italicized. 
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Key points 
▪ You can add text to almost any Visio shape. In addition, you can create “text only” 

shapes to add titles, labels, and other information to a drawing. 

▪ Visio provides a set of tools for changing the size, position, and orientation of shapes 
on a page. There is a complementary set of tools for altering the size, position, and 

orientation of the text displayed on a shape. 

▪ ScreenTips and comments are two different ways to add text annotations to a draw- 

ing. Each behaves differently and is suited for a different purpose. 3  
▪ Many Visio shapes contain one or more data fields. Shape data can turn a drawing 

into far more than just a “pretty picture”—the drawing can become the single source 

for viewing structure, content, form, and function. 

▪ One way to display shape data on a drawing page is to insert a field into a shape and 

link that field to shape data. 

▪ You can insert photographs, clip art, or other images onto foreground pages; you can 
also insert them onto background pages so they can appear on multiple foreground 

pages. 

▪ The Visio 2013 duplicate page function replicates all attributes of a page including its 
dimensions, contents, and background page, if any. 

▪ Visio provides several ways to organize collections of shapes. You can use groups 
to tie a set of shapes together so you can move, resize, and work with them as a 

unit. You can use layers to hide, print, recolor, or lock a set of shapes, while allow- 

ing each shape to retain its individuality in ways that aren’t true in a group. In 

Chapter 11, “Adding structure to your diagrams,” you’ll learn about another option 

called a container. 
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IN THIS CHAPTER, YOU WILL LEARN HOW  TO 

▪ Select a flowchart type. 

▪ Create flowcharts and add flowchart labels. 

▪ Understand and create swimlane diagrams. 

▪ Understand and build organization charts. 

▪ Use the Organization Chart Wizard with existing or new data. 

▪ Alter org chart layout and appearance. 

▪ Add photos and change styles in org charts. 

In the first three chapters, you learned many of the basic capabilities of Microsoft Visio 2013. 

In this chapter, you’ll apply that knowledge to creating real-world diagrams. There is no 

better place to start than with the humble flowchart, because creating flowcharts is one of 

the most common tasks for which people use Visio. In fact, according to Microsoft, more 

than one-third of all Visio diagrams are based on templates from the flowchart category. 

 

Whether the end goal is to diagram the logic of a current or future software module, or to 

document the way that a work procedure is, or could be, performed, Visio flowcharts are 

the standard. Also, Visio is frequently used to create an alternative type of flowchart called 

a cross-functional  flowchart  or a swimlane    diagram. 

Creating flowcharts and 
organization charts 
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Another common application for Visio is to create organization charts, often known as org 

charts. You can create org charts manually by dragging the intelligent organization chart 

shapes from the Visio stencil onto the drawing page, or you can run the Organization Chart 

Wizard to automate the work of creating your drawing. As you’ll discover later in this chap- 

ter, the Visio 2013 org chart add-in has been totally redesigned to let you create more at- 

tractive, modern, dynamic charts—even ones that include photographs. 

 

In this chapter, you’ll learn about different types of flowcharts and will create both conven- 

tional flowcharts and swimlane diagrams. You’ll also learn how to add text to Visio flowchart 

shapes. Finally, you’ll learn how to build an organization chart by hand as well as by using 

the wizard, and how to enhance organization charts with pictures. 

 
 

PRACTICE FILES To complete the exercises in this chapter, you need the practice 

files contained in the Chapter04 practice file folder. For more information, refer to 

“Downloading the practice files” in this book’s Introduction. 
 

 

 
 

Selecting a flowchart  type 
Visio provides different flowchart templates, depending on the edition that you use. 

 

 

Visio Standard 
Microsoft Visio Standard 2013 includes four flowchart templates, as shown in the following 

graphic. You will work with the Basic Flowchart and Cross-Functional Flowchart templates in 

this chapter. The Work Flow Diagram template is a brand new, theme-capable template for 

creating workflow diagrams. The corresponding template from previous versions of Visio 

was retained in Visio 2013 and is now called Work Flow Diagram - 3D. 
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Visio Professional 

Visio Professional 2013 includes the same four templates as the Standard edition, but also 

includes five additional flowchart templates: Business Process Model and Notation (BPMN), 

IDEF0, Specification and Description Language (SDL) Diagram, and two variations of 

Microsoft SharePoint Workflow, one for SharePoint 2010 and one for SharePoint 2013. 
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You’ll learn more about the BPMN and SharePoint Workflow templates in Chapter 12, 

“Creating and validating process diagrams.” 

 

SEE ALSO For additional information about IDEF0, go to en.wikipedia.org/ 

wiki/IDEF0. For additional information about SDL, go to en.wikipedia.org/wiki/ 

Specification_and_Description_Language. 
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Creating flowcharts 
In this exercise, you’ll create a new flowchart for a simple human resources recruiting 

process. The flowchart will have seven process steps and one decision. 

 

SET UP Click the File tab, and then click New. Click Categories, click Flowchart, and 

then double-click the Basic Flowchart thumbnail. Save the new drawing as HR Recruiting 

Flowchart. Then follow the steps. 
 

1 Drag a Start/End shape from the Basic Flowchart Shapes stencil onto the 

drawing page. 
 

 
 

2 Point to the start shape you added to the drawing page, click the right-facing blue 

triangle that appears, and then click the Process shape from the Quick Shapes menu. 

SEE ALSO For a refresher on using Quick Shapes, refer to “Using AutoConnect and 

quick shapes” in Chapter 2, “Creating a new diagram.” 

Vertical or horizontal? 
Should you draw your flowcharts with vertical (portrait) or horizontal (landscape) orien- 

tation? Vertical flowcharts, with tasks arranged from top to bottom, are probably more 

common, but there have always been advocates for the left-to-right, horizontal view. 

 

One interesting note if you have created flowcharts with previous versions of Visio: the 

Visio 2013 and Visio 2010 Basic Flowchart templates default to horizontal orientation, 

whereas previous versions presented a vertical view by default. Although this may 

frustrate people with a long-standing preference for the portrait view, there is some 

logic to this choice, because computer screens have grown wider over the years. 
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3 Use the same technique to add three more Process shapes to the page. 
 

 

4 Drag a Process shape onto the drawing page. Then use the Dynamic Grid to position 

the new process shape below the leftmost process shape. 

SEE ALSO For more information about the Dynamic Grid in Visio, refer to “Using basic 

shapes and the Dynamic Grid” in Chapter 2. 

 

 

5 From the Quick Shapes menu, add the following four shapes: 

▪ Another Process shape to the right of the one from step 4. 

▪ A Decision diamond to the right of the previous process shape. 

▪ Another Process shape to the right of the decision diamond. 

▪ A Start/End shape to the right of the final process shape. 
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At this point, the flowchart is nearly complete with the exception of two connectors: 

one that links the end of the first row to the beginning of the second row, and one 

that links the decision diamond back to a previous step in the flowchart. 

6 Right-click anywhere on the drawing page, select the Connector Tool from the Mini 

Toolbar, and then move the cursor near the last shape in the first row. 

TIP The Visio 2013 Mini Toolbar introduces a single use Connector Tool: the pointer 

reverts to the Pointer Tool as soon as you draw one connector. 

7 Click the connection point on the right of the top-right process shape, and then drag 

to the leftmost connection point on the first process shape in the second row. 
 

 

8 Click the blue AutoConnect arrow under the decision shape and drag it to the con- 

nection point on the bottom of the leftmost process shape in the same row. 
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9 Drag a Document shape to just below the last process shape in the top row. 

 

10 Drag a bounding box around all of the shapes in the bottom row. Then hold down 

the Shift key while you drag that row down to make more room. Once again, Visio 

will reposition the connector line to accommodate the new location of the bottom row. 

TIP Holding down the Shift key constrains Visio to moving the selected shapes only 

vertically or horizontally, whichever is the first direction you move the cursor. 

11 Click the blue AutoConnect arrow under the upper-right process shape to connect it 

to the document shape. The layout of your flowchart is now complete. 

 

 

IMPORTANT Do not drop the document shape on a connector line or else Visio will 

break the connector in two and connect your document shape to both lines. This feature 

is called AutoAdd and is described in Chapter 2. 
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CLEAN UP Save your changes to the HR Recruiting Flowchart drawing, but leave it 

open if you are continuing with the next exercise. 

Adding  labels  to flowcharts 
In the preceding exercise, you learned the mechanics of creating a flowchart, but your 

diagram isn’t very useful yet because your shapes have no labels, data, or identifying 

information. 

SEE ALSO For information about adding data to your shapes, refer to Chapter 6, “Entering, 

linking to, and reporting on data.” 
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In this exercise, you’ll add text labels to your flowchart shapes. 

SET UP You need the HR Recruiting Flowchart drawing for this exercise. Either contin- 

ue with the open copy from the previous exercise or open the HR Recruiting Flowchart_ 

start drawing located in the Chapter04 practice file folder and save it as HR Recruiting 

Flowchart. Then follow the steps. 

1 Click the Start/End shape in the upper-left of your diagram, and then type Hiring 

need reported. 

2 Click the first Process shape in your flowchart, type Log hiring request, and then 

continue from left to right across the top row to add the following labels to the re- 

maining shapes: 

▪ Prepare job description and screening questions 

▪ Advertise open job 

▪ Interview candidates 

3 Click and type the following text into the five shapes in the bottom row, from left to 

right: 

▪ Select a candidate 

▪ Make job offer 

▪ Candidate accepts? 

▪ Hire candidate 

▪ End 
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4 Click the connector between the Candidate accepts? shape and the Hire candidate 

shape and type Yes. 

5 Click the connector between the Candidate accepts? shape and the Select a candidate 

shape and type No. 

6 Add a text box to the top of the page, type Human Resources Recruiting Process as 

a title for the flowchart, and then set the font to 24 pt. and bold. Your finished flow- 

chart should look something like the following graphic. 

 

CLEAN UP Save your changes and close the HR Recruiting Flowchart drawing. 

Understanding  swimlane diagrams 
Swimlane diagrams are a popular variation on flowcharts, because they correct one signifi- 

cant failing of flowcharts: very few flowcharts show who is responsible for each of the steps 

or who makes the key decisions. 

A swimlane diagram, on the other hand, is specifically organized by role, function, or de- 

partment. Each process step is placed into a specific lane based on who does the work or 

who has the responsibility for that process step. For example, a swimlane diagram with a 

focus on roles might include lanes marked Accounts Payable Clerk, Accounting Supervisor, 

and Chief Financial Officer. Similarly, a department-focused swimlane drawing might show 

lanes labeled Sales, Marketing, Order Processing, and  Manufacturing. 

A swimlane diagram is also known as a cross-functional flowchart (CFF), because it shows 

work steps as they cross the functional boundaries in an organization. In this context, indi- 

vidual swimlanes are usually referred to as functional bands. 
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Regardless of the terminology, swimlane diagrams can be laid out with horizontal or vertical 

lanes. Using Visio, you can choose the orientation you prefer, as described in the exercise in 

the following section. 

TIP Some Visio templates employ additional software, outside of Visio itself, to perform 

their functions. The cross-functional flowchart diagram is an example of this type of Visio 

add-in. And, like many add-ins, cross-functional flowcharts present a custom tab on the 

ribbon, as shown in the following graphic. 

                         4
 

Creating  swimlane diagrams 
In the preceding exercises, you created a flowchart of a human resources recruiting process. 

However, the flowchart does not indicate who is responsible for each task. 

In this exercise, you’ll create a swimlane diagram of the same process. In doing so, you’ll 

organize the work steps into role-based lanes to make responsibilities clear. 

 

SET UP Click the File tab, and then click New. Click Flowchart in the Suggested 

Searches list. Then follow the steps. 
 

1 Double-click the Cross-functional Flowchart thumbnail. The orientation selection 

dialog box opens. 
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TIP If you have previously selected a default orientation, this dialog box will not 

appear again. However, you can still change both the orientation of a single diagram 

and the default for future diagrams. On the Cross-Functional Flowchart tab, in the 

Arrange group, click the Orientation button and make your selection. 

 

 

2 Click OK to accept the Horizontal layout option. The CFF add-in places a title band 

and two swimlanes onto the drawing page. 

3 On the Cross-Functional Flowchart tab, in the Insert group, click the Swimlane but- 

ton to add another lane to your diagram. 

TIP There are three other ways to add swimlanes, each of which is useful at various 

times: 

▪ Right-click the header of an existing lane, and Visio offers you a choice of adding a 
new swimlane above or below the one you’ve selected. 

▪ Drag a Swimlane shape from the stencil and drop it on top of an existing lane. 

▪ Point to the boundary between lanes, with the cursor just outside the swimlane 
structure, and click the blue insertion triangle. (You will learn about this method 

in the exercise titled, “Finding containers and lists in Visio” in Chapter 11, “Adding 

structure to your diagrams.”) 

4 Click the Title bar and type Human Resources Recruiting Swimlane Diagram. 

5 Click the Function title bar for the top swimlane and type Recruiter. 

6 Type HR Admin as the title for the second swimlane, and Candidate for the third 

swimlane. 

TIP You’ve probably already figured this out, but swimlane diagrams are so named 

because they resemble a swimming pool viewed from above. 
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7 Drag a Swimlane from the Cross-Functional Flowchart stencil but before you drop 

it onto the page, pause briefly over the boundary between the HR Admin and 

Candidate swimlanes. An orange insertion bar appears indicating that the lane you 

drop will be inserted between the two existing lanes. 

SEE ALSO Visio 2013 swimlanes are built from a combination of containers and lists. 

You will learn more about both in Chapter 11. 

 

 

 

IMPORTANT The remaining screen shots for this exercise were captured using a black 

and white theme to improve legibility in the print edition of this book. Your swimlane 

diagram will continue to show the default theme colors, as seen in the preceding graphic, 

unless you have changed themes. 
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8 Drop the swimlane onto the page, and while it is still selected, type Hiring Manager. 
 

 

9 On the Home tab, in the Tools group, click the Connector button. 

 
 

10 Drag a Start/End shape from the Basic Flowchart Shapes stencil onto the draw- 

ing page, and use the Dynamic Grid to position it toward the left end of the Hiring 

Manager lane. 
 

 

11 With the Start/End shape still selected, type Hiring need reported. 

 

IMPORTANT If you select a shape with the Connector Tool and then drag another 

shape onto the page, Visio automatically adds a connector from the first shape to     

the second. In this exercise, you accomplish this by leaving each shape selected after 

dragging it onto the page and typing text into it. 

 
You can stop the automatic addition of connectors by deselecting a shape before 

dragging the next one onto the page. Alternatively, you can select a different shape 

at any time to change which shapes will be connected automatically. 
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TIP It is not necessary to exit text edit mode before continuing to the next step. 

 

12 Drag a Process shape into the HR Admin lane, dropping it above and to the right of 

the Start/End shape, and then type Log hiring request. 

TIP To fit the shapes for this exercise onto a single page, ensure that the left edge of 

each new shape you add to the page overlaps horizontally with the preceding shape 

as shown in the two graphics that follow. 

 

13 Draw a connector from the top of the Hiring need reported shape to the left side of 

the Log hiring request shape. 
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14 Drag a Process shape into the Hiring Manager lane, and then type Prepare job 

description  and  screening questions. 

15 Use the Connector Tool to link the previous process step to your new task. 
 

 

16 Continue adding flowchart shapes to  your  diagram  using  the  information  in  rows 4-

10 of the following table. (Rows 1-3 represent the shapes you’ve already added.) 
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 Shape Swimlane Shapetext 

1 Start/End Hiring Manager Hiring need reported 

2 Process HR Admin Log hiring request 

3 Process Hiring Manager Prepare job description and 
screening questions 

4 Process HR Admin Advertise open job 

5 Process Recruiter Interview candidates 

6 Process Hiring Manager Select a candidate 

7 Process Recruiter Make job offer 

8 Decision Candidate Candidate accepts? 

9 Process Recruiter Hire candidate 

10 Start/End Hiring Manager End 
 

17 Add a connector from the Candidate accepts? shape to the bottom of the Select a 

candidate shape, and then type No. 

18 Click the connector from the Candidate accepts? shape to the Hire candidate shape 

and type Yes. 

Your swimlane diagram should look something like the following graphic. It’s unlikely 

that your drawing will look exactly like this one, because you probably made differ- 

ent decisions about placing shapes. However, after the general placement and con- 

nectivity are correct, you can adjust and tweak your diagram to make it look the  

way you’d like. 

If you think your diagram is too crowded, realize that the cross-functional flowchart 

template used the default paper size for your region. If you need more space, you 

can increase the drawing page size as described in Chapter 3, “Adding sophistication 

to your drawings.” 
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 4  

CLEAN UP Save the drawing as HR Recruiting Swimlane, and then close it. 

One final note about the Visio 2013 take on cross-functional flowcharts: although the end 

result looks very much as it has in previous versions of Visio, the underlying structure is very 

different. In fact, structure is the operative word in the previous sentence. In Visio 2013, 

each swimlane is a container, and the overall framework is a list. Containers and lists are key 

components of Visio 2013 structured diagrams and are described in Chapter 11. 

Understanding  organization  charts 
An organization chart is typically used to reflect the structure of an organization by show- 

ing who reports to whom. The Visio organization chart solution is based on a hierarchical 

model in which each employee has one boss. Consequently, it doesn’t lend itself to organi- 

zations that use a matrix or other nonhierarchical structures. However, it is well-suited for 

most organizations. 

The Visio org chart template that has been part of the product since its earliest days has 

been totally revamped for Visio 2013 and includes exciting new capabilities based on the 

concept of styles. Each style, accompanied by six brand-new intelligent shapes, provides a 

totally new look to Visio organization charts. You can switch between styles with one click 

in order to try out new looks until you find one you  like. 
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You can further customize Visio 2013 charts with a few additional clicks, because the new 

org chart shapes take advantage of the enhanced themes and embellishments available in 

Visio 2013. Visio 2013 organization charts also include a long-requested feature: the ability 

to import photographs, either one shape at a time or in bulk. 

 

The Visio org chart template is assisted by add-in software that is packaged with Visio. The 

combination of the two simplifies the creation of org charts by handling nearly all of the 

sizing and spacing chores when you do things like drop an employee shape on top of a 

manager shape. In addition, the add-in software includes a wizard that you can use to im- 

port organization data from Microsoft Excel or other data sources. 

 

The org chart add-in displays an add-in tab on the Visio ribbon whenever an org chart is 

the active drawing. 

 

SEE ALSO For more information about add-in tabs, refer to “Understanding tool tabs and 

add-in tabs” in Chapter 1, “A visual orientation to a visual product.” 

 

 
 

The Visio 2013 Org Chart tab includes many more buttons that in previous Visio versions, 

making it easier than ever to modify the layout, style, and spacing of your charts. You also 

have easy access to import and export features, including the ability to import pictures. 

 

At the screen resolution used for the preceding graphic, all 10 new org chart styles aren’t 

visible without clicking the More button highlighted at the lower right of the Styles pane. 

With a wide-screen monitor, all 10 styles appear, as shown in the following graphic. 

 

 
 

In the sections that follow, you’ll create a simple org chart manually and a more complex 

org chart by importing data from an Excel workbook. You’ll also import several dozen 

photographs and learn how to export org chart data to Excel. 
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Building  organization  charts  by hand 
Although you will use the Organization Chart Wizard in subsequent exercises, it’s helpful to 

understand first how easy it is to create org charts by hand. 

 

When you look in the Business template category, you’ll find two org chart templates called 

Organization  Chart  and Organization  Chart  Wizard. The only difference between them is  

that the latter automatically starts a wizard when you create a new document. If you should 

ever select the Organization Chart Wizard template by mistake, just cancel the wizard and 

continue. If you happen to select the template without the wizard and then decide you  

want to use it, click the Import button in the Organization Data group on the Org Chart  tab. 

In this exercise, you’ll create a new org chart by dragging shapes onto the page and using 4 
the org chart template’s auto-positioning features. You’ll also enter data for each shape in 

the chart. 

 

SET UP Click the File tab and then click New. Click Categories, click Business, and then 

double-click the Organization Chart thumbnail. Save the new drawing as Org Chart by 

Hand. Then follow the steps. 
 

1 Drag the Executive shape from the Belt – Organization Chart Shapes stencil to the 

top center of the drawing page. 

TIP  The title of the Organization Chart Shapes stencil in Visio 2013 is preceded by 

the name of the currently selected org chart style. When you start a new drawing, it 

defaults to the Belt style; consequently, Belt – Organization Chart Shapes is displayed 

in the title bar. 

2 With the shape still selected, type President, click the word Name, and then type 

Magnus Hedlund. 

TIP Just as the title of the Organization Chart Shapes stencil includes the name of the 

currently selected org chart style, certain master names in the stencil also include the 

style name. For example, if you are using the Belt style, the masters include Executive 

Belt, Manager Belt, and others with similar names. 
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3 Drag a Manager shape onto the Magnus Hedlund shape. Then type Vice 

President, click the word Name, and then type Magdalena Karwat. Notice 

that the org chart software automatically positions the new shape below the 

Hedlund shape. 
 

 
 

4 Repeat step 3 and notice that the org chart add-in has positioned the second man- 

ager shape to the side of the first one. With the new shape still selected, type Vice 

President, click the word Name, and then type Allison Brown. 

5 Drag one more Manager shape onto the Hedlund shape. Type Vice President, click 

the word Name, and then type Giorgio Veronesi. 
 

 
 

6 Drag a Position shape onto the Giorgio Veronesi shape, open the Shape Data win- 

dow, and then type Janet Schorr into the Name field. 

SEE ALSO Refer to Chapter 3 for information about opening and using the Shape 

Data window. 

7 Drag a Position shape onto the Giorgio Veronesi shape, and type Reina Cabatana 

into the Name field in the Shape Data window. 
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8 Drag the Three positions shape onto the Magdalena Karwat shape, and use the 

Shape Data window to enter the following names from top to bottom: Filip Rehorik, 

April Reagan, and Scott Rockfeld. 

TIP The Three Positions shape makes it very easy to add three people to the chart at 

once. Note that there is also a stencil shape called Multiple Shapes. When you drop it 

onto an existing org chart shape, it prompts you to select a shape type and to specify 

how many of them you’d like to add to the chart. 

9 Drag a Consultant shape onto the Allison Brown shape and enter Sandeep Kaliyath. 

TIP Notice that the Belt org chart style does not provide any visual differentiation 

between Consultant and Position shapes. However, the appearance of the Consultant 

shape is different in other styles as you’ll discover later in this exercise. 
 

10 Drag a Vacancy shape onto the Allison Brown shape and type Open as the name. 

Notice that vacancy shapes do not include a photo placeholder. 
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11 Drag an Assistant shape onto each of the Vice President shapes and type the follow- 

ing names: 

 
 

1 

2 

3 

 

12 Drag an Assistant shape onto the Magnus Hedlund shape and type Cassie Hicks as 

the name. The org chart add-in has rearranged your drawing to position all of your 

 Shape Shapetext 

 Giorgio Veronesi Yan Li 

 Magdalena  Karwat Gabe Frost 

 Allison Brown Erik Rucker 
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shapes. Notice that Assistant shapes are automatically positioned differently than 

other subordinate shapes. 

At this point, you’ve built a reasonably sophisticated organization chart by doing little 

more that dragging shapes and typing text. 

 4  

CLEAN UP Save your changes to the Org Chart by Hand drawing, and then close it. 

TIP Later in this chapter you’ll learn how to insert images into the picture placeholders that 

are included in all of the new org chart styles. However, if you do not plan to include any 

photos, select all the shapes on the page and then click the Show/Hide button in the Picture 

group on the Org Chart tab. 

As you work with the org chart add-in, you’ll find that Visio usually moves existing shapes 

to accommodate new shapes as you add them to the page. On occasion, however, shapes 

may overlap. You can resolve the problem by clicking the Re-Layout button in the Layout 

group on the Org Chart tab. You can also initiate page layout by right-clicking anywhere on 

the background of an org chart page and then selecting Re-layout from the context menu. 
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Using the Organization Chart Wizard 
with existing data 

What if you already have your organization data available in electronic form? For example, 

you might have: 

▪ An Excel workbook that already contains names and reporting information. 

▪ A human resources or Enterprise Resource Planning (ERP) system that can generate 
an Excel file or a text   file. 

▪ Organization data in a Microsoft Exchange Server directory. 

▪ Organization data in a Microsoft Access, dBase, or other database. 

In all of those situations, the org chart wizard can help you create your chart. 
 

In this exercise, you’ll use data in an Excel workbook to build an organization chart. 

 

SET UP You need the Org Chart Data_start workbook located in the Chapter04 prac- 

tice file folder to complete this exercise. Then follow the steps. 
 

1 Start Excel and open the Org Chart Data_start workbook so you can look at the data 

that will be used in this exercise. In particular, notice that there are columns for Name, 

Title, Reports To, Employee Number, and Extension. 
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2 Close Excel, and then start Visio. 

3 On the New page, click Categories, click Business, and then double-click the 

Organization Chart Wizard thumbnail. The first page of the wizard appears. 

TIP If the wizard doesn’t appear, simply click the Import button in the Organization 

Data group on the Org Chart tab. 
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4 Click Next. The data source type page appears. 
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5 Click A text, Org Plus (*.txt), or Excel file, and then click Next. The file selection page 

appears. 

6 Click the Browse button on the file selection page, and then, in the resulting file    

open dialog box, navigate to the Org Chart Data_start workbook that you viewed 

in step 1. After selecting the correct file, click the Open button, which causes the file 

name you selected to appear in the Locate the file that contains your organization 

information box. 
 

 

7 Click Next. There is a slight pause as Visio opens and reads the data in your 

spreadsheet. 

The Organization Chart Wizard uses the column names, if any, in your spreadsheet 

to determine which columns hold the name and reporting structure information. It 

displays the column names that seem to be the best match in the next wizard page. 
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Because the Org Chart Data workbook contains columns called Name and Reports   

To, the assumptions made by Visio are correct as shown. If the assumptions are not 

correct, click the arrows to the right of Name and Reports To in order to select the 

correct columns. Notice you can specify that a separate column contains employees’ 

first names, if that is the case. 

8 Click Next to display a page where you can indicate which employee data will be dis- 

played on each shape in the chart. The wizard assumes that you want to display the 

name and title fields, so those fields are preselected on the right side of the page. 
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9 In the Data file columns section of the page, click Employee Number, and then click 

the Add button to move it to the Displayed fields section. Finally, click Next. 

On the wizard page that appears, you determine which spreadsheet data, if any, 

should be stored in each organization chart shape. This is a separate and unrelated 

decision from the one on the previous page. You can still display data on the org 

chart shapes even if you don’t store data in the shapes. 

TIP The primary reason to store data in org chart shapes is so you can run reports or 

use the data in other ways without the need to revert to your original data source. 

 

 

10 Hold down the Shift key while clicking Extension, which selects everything in the 

Data file columns section, click Add, and then click Next. 

TIP You can use the standard Windows conventions for selecting multiple items in 

the Data File Columns section: 

▪ Hold down the Shift key and click to select everything from the current selection 
up to and including the item you click. 

▪ Hold down the Ctrl key and click to select noncontiguous items. 

11 On the picture import page that appears, click Next. You will not import pictures in 

this exercise, but you will in the one that follows. 
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 4  

12 On the final wizard page, you can choose among some of the Organization Chart 

Wizard’s powerful layout options. 
 

 
 

Accepting the default selection of I Want The Wizard To Automatically Break My 

Organization Chart Across Pages lets the wizard figure out how much to fit on each 

Visio page. The <Top Executive> option tells Visio to select the person who doesn’t 

report to anyone else as the top shape on the first page of the org chart. If you pre- 

fer to select a specific person, such as a department head, you can click the arrow to 

choose anyone in your list. 

Clicking I Want To Specify How Much Of My Organization To Display On Each Page 

takes you to a wizard page not shown here, and allows you to more directly control 

how much to fit on each org chart page. 
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The Hyperlink Employee Shapes Across Pages check box specifies whether the wizard 

should add hyperlinks when org charts consist of multiple pages. For example, if a 

manager’s direct reports don’t fit on the page with the manager, the wizard will leave 

the Manager shape on the original page and also place it on a subsequent page, 

along with that manager’s direct reports. A check mark in this option tells Visio to 

add links in both Manager shapes, making page-to-page navigation simpler. 

The Synchronize Employee Shapes Across Pages check box also applies to the sce- 

nario described in the preceding paragraph. A check mark in this option tells Visio to 

update the second shape if you change the data in the first one. 

13 Click Finish. The completed organization chart appears in the Visio drawing window, 

however, the default style and layout that were applied are not very practical for this 

particular organization chart. In the exercise that follows, you’ll reformat the organi- 

zation chart using alternate styles and layouts. 

TIP Notice that the Belt org chart style uses different shades of color to indicate 

different position levels in the organizational hierarchy. 

 

CLEAN UP Save your drawing as Org Chart using Wizard and then close it. 
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TIP  The org chart wizard correctly connects each group of people to its respective boss, 

but you cannot control where the wizard places people on the page. You can use the 

buttons in the Arrange group on the Org Chart tab to relocate people and groups after the 

wizard has created the diagram. However, you can’t control how the wizard does the initial 

placement. 

 
 

Altering org chart layout and    appearance 
Whether you create an organization chart manually or automatically using the wizard, you 

might want to modify the appearance and attributes of the org chart shapes after they’re 

on the page. Previous versions of Visio allowed you to resize org chart rectangles, adjust 4  
spacing, and use more than a dozen alternate layouts. 

 
You can still do all of those things with Visio 2013, but you also have the ability to create 

radically different looking organization charts if you choose. Visio 2013 includes 10 highly 

varied org chart styles and more than one hundred new theme-compatible shapes. In addi- 

tion, the Org Chart tab on the Visio ribbon has been redesigned so that many features that 

were difficult to find in previous versions are now much more accessible. 

 

 

Layout 
You can change the layout of an org chart by using more than a dozen predefined layouts, 

each of which varies the spacing and connections between shapes. On the Org Chart tab, in 

the Layout group, click Layout to select from a variety of options. 
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TIP When the Apply Automatic Layouts to Shape Styles option at the bottom of the layout 

options list is selected, Visio will re-layout your org chart every time you apply a style. You 

can retain your current layout when you change styles by clearing the option first. 

 

As an alternative, right-click any shape with subordinates, and then click Arrange 

Subordinates. Visio opens a dialog box showing all of the built-in layouts. 

 

 

 
TIP If you don’t like the results of any re-layout operation—no matter how radical the 

changes—you can restore the previous layout with a single undo. Simply type Ctrl+Z or 

click the Undo button on the Quick Access Toolbar. 

If you’ve made manual adjustments to shape position or size, the Re-Layout button, also in 

the Layout group, will move required shapes to ensure correct positions. 

 

The Best Fit To Page button relocates the entire org chart to better fit on the current page. 
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Arrange 
You rearrange an organization chart by increasing or decreasing the vertical spacing be- 

tween shapes or groups of shapes using the Spacing buttons in the Arrange group. Also in 

the Arrange group, the left and right Move arrows change the horizontal spacing. 

If you want to hide some sections of your org chart, select an Executive or Manager shape, 

and then click Show/Hide Subordinates (you can accomplish the same thing by right-click- 

ing a shape and then clicking Show Subordinates or Hide Subordinates). A Manager shape 

with hidden subordinates displays an icon in the lower–right corner of the shape to indicate 

their presence. 

 4  

 

 

 
Shapes 

The Shapes group contains the Org Chart style gallery that you can use to change the ap- 

pearance of your chart. From top to bottom, the following graphic shows three of the 10 

org chart styles: Belt, Bound, and Stone. 
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The Shapes group contains buttons that let you adjust the height and width of some or 

all of the shapes in the org chart; you can select specific shapes to adjust them or click the 

buttons with no shapes selected to affect all shapes on the page. The final button in the 

Shapes group lets you convert a shape to a different type of shape, for example, to change 

a Manager to a Position, or a Vacancy to a Consultant. 

 

 

Picture 
In the following exercise, you’ll import photographs during the process of creating a new 

organization chart. However, that technique is not the only way to manage org chart pho- 

tos. The Insert button in the Picture group lets you add one or multiple pictures to an ex- 

isting organization chart. Additional buttons allow you to change, delete, or show/hide an 4  
existing picture. All of these functions can also be performed by right-clicking an org chart 

shape. 
 

 

Themes 
Though themes are located on the Design tab and not the Org Chart tab, don’t forget that 

all Visio 2013 org chart shapes were designed to accept theme settings. You can apply any 

range of colors, effects, and embellishments to create exactly the look you want. The three 

examples in the following graphic use, from top to bottom, the Bound style and the Whisp 

theme; the Pip style and the Bubble theme; the Coin style and the Organic theme. 
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SEE ALSO For more information about Visio themes, refer to “Applying themes to your 

diagrams” in Chapter 5, “Adding style, color, and themes.” 
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Adding photos and changing styles 
in org charts 

Previous versions of Visio allowed you to insert photographs into organization chart 

shapes—but only one shape at a time! Visio 2013 allows you to import multiple pho- 

tographs at once, either into an existing org chart, or as you create one from externally 

stored data. In the latter case, you can import photos from a folder on your computer  

or a server. In addition, if you import organization data from Microsoft Exchange Server, 

you can import the same photos that people use in their Microsoft Outlook profiles. 

 

In this exercise, you’ll create an org chart using data from Excel and will import photographs 

at the same time. You will also use styles to change the appearance and layout of your org 4 
chart. 

 

SET UP You need the Org Chart Data_start workbook located in the Chapter04 practice 

file folder to complete this exercise. You also need the Photos folder contained within the 
Chapter04 practice file folder. Start Visio if it’s not already running. Then follow the steps. 

 

 
 

1 Repeat steps 3 through 10 from the preceding exercise. 

2 On the Picture Import page, click the Locate the folder that contains your organi- 

zation pictures radio button and then use the Browse button to navigate to and se- 

lect the Photos folder. After clicking Open, the folder name appears in the text box. 

 

IMPORTANT  Some of the steps in this exercise are based on the specific placement of shapes  

using the US Units version of the Org Chart template. If you are using the Metric version of the 

template, you may need to make small adjustments in the exercise steps. 
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3 Use the arrow to the right of Match pictures based on to select Name, click Next, 

and then click Finish on the final wizard page. The new org chart will look very 

similar to the one you created in the previous exercise, but this one will contain 

photographs. 

TIP The image files in the Photos folder are named as described at the bottom of the 

wizard page in the preceding graphic: each file name includes “FirstnameLastname” 

and an image file extension (“Firstname Lastname” is also acceptable) and matches a 

person listed in the Excel data file. 
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4 On the Org Chart tab, in the Shapes group, click Shapetacular style in the shapes 

gallery. 

TIP Notice that the Shapetacular org chart style uses both color shades and the 

geometry of the shape containing the photograph to indicate different position 

levels in the organizational hierarchy. Each style uses various combinations of shape 

geometry, fill color, fill gradients, line style, and ornamentation to differentiate 

position levels. 
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The Shapetacular style highlights the photographs you’ve imported, but the layout 

doesn’t show very much of the chart. 

5 On the Org Chart tab, in the Layout group, click Single Top. Notice that Visio has 

added new pages automatically to accommodate the new layout. 

6 Press Ctrl+Shift+W to show the whole page. 
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7 Select the Art Helmers shape at the top of the page and hold down the Shift key 

while dragging it to the left. (Holding Shift while dragging a Visio shape constrains 

motion to a single direction, either horizontal or vertical.) Position it anywhere near 

the dashed tile boundary line separating the two upper-leftmost pages. Notice that 

Visio removes pages that are no longer required. 

TIP Moving an Executive shape also moves all subordinate shapes. The same is true if 

you relocate a Manager shape. 

8 On the Org Chart tab, in the Arrange group, click Best Fit to Page. Visio centers the 

entire organization chart on the pages. 

TIP You may want to press Ctrl+Shift+W again to center the set of pages in the 

drawing window. 

 

 

At this point, the organization chart looks reasonably good, but it will require four 

sheets of paper to print. In the remaining steps of this exercise, you’ll use several ad- 

ditional org chart features to position and size the chart to fit the fewest number of 

sheets. You’ll begin with buttons that allow you to reduce either the horizontal or 

vertical space required for each shape (refer to the following graphic). 
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9 Ensure that no shapes are selected, and then on the Org Chart tab, in the Shapes 

group, click Decrease the Height button twice. 

10 Select and drag the Art Helmers shape upward so the top edge of his photo is at the 

top margin of the page. 

11 On the Org Chart tab, in the Layout group, click Re-Layout. The organization chart 

now  fits  comfortably  on  two  printer pages. 

12 To  finalize your organization chart, drag the Title/Date shape from the stencil into   

the upper-left portion of the drawing page. Double-click the Company Name text 

box and replace Company Name with Trey Research. The resulting organization chart 

should look like the following graphic. 
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CLEAN UP Save your drawing as Org Chart using Wizard-Photos and then close it. 

Depending on the size and position of peoples’ heads in the photographs you import into 

your org chart, you’ll find that most are positioned reasonably well within the photo frame 

provided by the various Visio org chart styles. However, there may be cases where you’ll 

want to reposition the photo. You can do so by selecting the photo, and then on the green 

Picture Tools Format tab, in the Arrange group, click Crop Tool. A preview of the entire im- 

age is displayed and the portions that are outside the photo frame will be grayed out. 
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Simply drag the picture to position it the way you want it, and then click outside the picture 

to complete your changes. 

 

Using the Organization Chart Wizard 
with new data 

If your organization data is not in a format that Visio can read, and you would like to type it 

into a spreadsheet but don’t want to start from scratch, the Organization Chart Wizard can 

create a preformatted spreadsheet for you. 

In this exercise, you’ll use the Organization Chart Wizard to create an Excel workbook into 

which you’ll enter your organization data. 
 

SET UP Click the File tab, and then click New. Click Categories, click Business, and 

then double-click the Organization Chart thumbnail. Then follow the steps. 

1 On the first page of the Organization Chart Wizard, click Information that I enter 

using the wizard. The description text for this option confirms that you will be creat- 

ing a new data source. 

2 Click Next. The File Type selection page appears. 

3 On the File Type selection page, click Excel, and then click the Browse button. In the 

resulting dialog box, select a folder in which to save the file, type Org Chart Data via 

Wizard in the File name box, and then click the Save button. The selected file name 

appears in the New file name  box. 
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4 Click Next. Visio instructs you to type your data over the sample data provided in the 

Excel workbook it has created. 
 

 

5 Click OK. Excel opens to display the formatted workbook. As shown in the following 

graphic, each column heading includes a comment with instructions for entering data 

in that column. 
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6 Ordinarily, you would type your data into the worksheet at this point; however, for 

this exercise you’ll use the sample data, so just close Excel. 

 

After Excel closes, Windows returns the focus to Visio and the photo import page of 

the Organization Chart Wizard. 

7 Click Next and then click Finish to display your org chart. 

 

CLEAN UP Save the sample file if you want to keep it. 

In the preceding exercise, you created an org chart by typing data into Excel. What if you 

prefer to start by dragging and dropping shapes, yet you still want to work with an external 

data source? Consider using an approach that combines things you’ve learned in this and 

the preceding sections of this chapter: 

▪ Drag and drop org chart shapes as you did in “Building organization charts by hand.” 

▪ Export the data to Excel as you did in the exercise in this section. 

▪ Add and edit the data in your Excel workbook to fill out your organization’s details. 

 

IMPORTANT Closing the worksheet isn’t sufficient; you must close the Excel 

application. 
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▪ Create a new org chart from the data in Excel as you did in “Using the Organization 
Chart Wizard with existing data.” 

▪ Repeat as needed. 
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Key points 
▪ Creating flowcharts is one of the most common uses for Visio. The built-in templates 

make it very easy for you to create both conventional flowcharts and swimlane dia- 

grams. 

▪ Swimlane diagrams, also known as cross-functional flowcharts, offer one key advan- 
tage over regular flowcharts: each process step resides in a swimlane that  identifies 

which role, department, or function is responsible for that step. 

▪ You can create organization charts manually by dragging shapes from the org chart 
stencil onto the drawing page. 

▪ The Organization Chart Wizard automates most of the creation of org charts by let- 
ting you import data from Excel spreadsheets, text files, and databases. In   addition, 

the wizard can provide you with a preformatted spreadsheet that you can use to 

enter your organization’s data prior to running the wizard. 

▪ Visio 2013 lets you import photographs while building an org chart. You can also 
import either a single photo or a folder full of photos into an existing chart. 

An unconventional  use  for  organization charts 
Occasionally, you find a use for a Visio template that its designers might not have en- 

visioned. The author of this book and another Visio expert did exactly that with the 

Organization Chart Wizard by using it to display the folder structure on a Windows 

computer. After all, groups of people and folders on a disk drive are both organized 

hierarchically, so it seemed like a logical thing to do. 

 
SEE ALSO To read an article about viewing the Windows disk drive as an “organization 

chart,”  go  to www.experts-exchange.com/viewArticle.jsp?articleID=2802. 
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