
LESSON SKILL MATRIX

KEY TERMS
• Blank Forms

• hierarchical form

• main form

• Multiple Items tool

• Navigation form

• split form

• subform

Advanced Forms

Skill Exam Objective Objective Number

Creating Advanced Forms

Using Application Parts to Create Blank Forms Use Blank Forms. 1.3.1

Creating a Navigation Form Create Navigation forms. 3.1.4
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241Advanced Forms

As a regional manager for Contoso Pharmaceuticals, you are in charge of overseeing the 

sales reps in your division. The salespeople you supervise call on doctors to promote 

Contoso medications and to leave samples. You use Access to put the sales information 

together and pull data from a variety of sources. In this lesson, you learn how to create 

a multi-item form, a split form, and a subform.
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SOFTWARE ORIENTATION

The Templates Group and the Forms Group

The Application Parts button in the Templates group and the Navigation and More Forms 
buttons in the Forms group, all located on the Create tab, contain menus with commands 
for creating all types of forms—some of which you have already learned about. Figures 10-1, 
10-2, and 10-3 show the menus and commands you use to create advanced forms. Use these 
fi gures as references throughout this lesson as well as the rest of this book.

Figure 10-1

Application Parts button 
and menu

Blank Forms 
category on 
Application 
Parts menu

Figure 10-2

Navigation button and menu

Navigation 
menu

Figure 10-3

More Forms button and menu

More 
Forms 
menu
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 242 Lesson 10

  The Contoso fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.

CREATING ADVANCED FORMS
Access provides tools to help you create forms quickly—including advanced forms with features 
that can improve the usability of your database. The Multiple Items tool creates a customiz-
able form that displays multiple records. A split form gives you two views of your data at the 
same time—in both Form View and Datasheet View. A subform is a form that is inserted into 
another form.

Creating a Multi-Item Form
When you create a simple form by using the Form tool, Access creates a form that displays a 
single record at a time. To create a form that displays multiple records but that is more customiz-
able than a datasheet, you can use the Multiple Items tool. In this exercise, you create a Multi-
Item form using the Multiple Items tool.

When you use the Multiple Items tool, the form that Access creates resembles a datasheet. The 
data is arranged in rows and columns, and you see more than one record at a time. However, a 
Multiple Items form gives you more customization options than a datasheet, such as the ability 
to add graphical elements, buttons, and other controls.

STEP BY STEP Create a Multi-Item Form

GET READY. Before you begin these steps, be sure to LAUNCH Microsoft Access.

 1. OPEN the Contoso database from the data fi les for this lesson.

 2. SAVE the database as Contoso XXX (where XXX is your initials).

 3. In the Navigation pane, double-click the Doctors table to open it.

 4. On the Create tab, in the Forms group, click the More Forms button. On the menu that 
appears, click the Multiple Items button. Access creates the form and displays it in 
Layout View, as shown in Figure 10-4.

The Bottom Line

WileyPLUS Extra! features an 
online tutorial of this task.

Figure 10-4

Multiple Items form in 
Layout View

In Lesson 5, you learned how to use some of the commands in the Forms group to create 
several basic forms.

Ref
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243Advanced Forms

 5. Scroll down and to the right to view the multiple records on the form.

 6. Click the File tab and click Save.

 7. In the Save As dialog box, key Doctors Multiple and click OK.

 8. Click the Close button on Doctors Multiple to close the form.

 9. Click the Close button on Doctors to close the table.

 10. LEAVE the database open.

PAUSE. LEAVE Access open to use in the next exercise.

  You learned about using controls to format your forms in Lesson 7.  

Creating a Split Form
Creating a split form allows you to see two views of your data at the same time—in Form View 
and in Datasheet View. The two views are connected to the same data source and are completely 
synchronized with each other. In this exercise, you create a split form.

Working with split forms gives you the benefi ts of both types of forms in a single form. Select-
ing a fi eld in the datasheet part of the form selects the same fi eld in the form part of the form. 
When you add, edit, or delete data in the datasheet part, the change is refl ected in the form part.

STEP BY STEP Create a Split Form

USE the database that is open from the previous exercise.

 1. In the Navigation pane, double-click the Sales Reps table to open it.

 2. On the Create tab, in the Forms group, click the More Forms button. On the menu that 
appears, click the Split Form button. Access creates the form and displays it in Form 
View and Datasheet View at the same time, as shown in Figure 10-5.

Ref

Form View

Datasheet View

Next Record button 

Figure 10-5

Split form
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 244 Lesson 10

 3. Click the Next Record navigation button to display the next record in Form View.

 4. In the datasheet part on the bottom, place the insertion point in the Mobile Phone fi eld 
for Nancy Buchanan. Notice that the same fi eld is selected in the form part at the top.

 5. Change the number for Nancy Buchanan in the Mobile Phone fi eld to 806-555-4489.

 6. Click anywhere on the form part above the datasheet and notice that the mobile phone 
number has been changed there as well, as shown in Figure 10-6.

 7. On the Home tab, in the Views group, click the View button and click Design View.

 8. Press F4 to display the Property Sheet.

 9. Click Form in the drop-down list at the top of the Property Sheet and click the Format 
tab, if necessary, as shown in Figure 10-7.

Changes made 
to the datasheet 
will also be 
reflected on the 
form

Figure 10-6

Editing a split form
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 10. Scroll down to the Split Form Orientation property, click the down arrow, and click 
Datasheet on Top, as shown in Figure 10-8.

Press F4 to 
display the 
Property Sheet

Figure 10-7

Property Sheet

Datasheet on 
Top property 
selected

Figure 10-8 

Changing a property

If all text for the properties is not visible, click the left border of the Property Sheet and drag to 
widen it.

 11. Click the Close button to close the Property Sheet.

 12. On the Home tab, in the Views group, click the View button and click Layout View. The 
split form is displayed with the datasheet on top, as shown in Figure 10-9.

Take Note
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 13. Click the File tab and click Save.

 14. In the Save As dialog box, key Sales Reps Split and click OK.

 15. Click the Close button on Sales Reps Split to close the form.

 16. Click the Close button on Sales Reps to close the table.

 17. LEAVE the database open.

PAUSE. LEAVE the database open to use in the next exercise.

Table 10-1 lists some of the properties related to split forms that you can set on the Property 
Sheet to fi ne-tune your form. To change form properties, switch to Design View, press F4 to 
display the Property Sheet, select Form from the drop-down list at the top of the Property Sheet, 
and click the Format tab.

  You learned how to set properties using the Property Sheet in Lesson 4.  Ref

Change the 
Split Form 
Orientation 
property to 
display the 
datasheet 
on top

Figure 10-9 

Split form with datasheet 
on top

Table 10-1

Properties Related to Split Forms

 View(s) in which you 

Property can set the property Description

Split Form Orientation Design View  Allows you to defi ne whether the datasheet appears above, below, to the left, 

or to the right of the form.

Split Form Datasheet Design View or If set to Allow Edits (and the form’s record source is updateable), Access 

 Layout View   allows edits to be made on the datasheet. If set to Read Only, Access prevents 

edits from being made on the datasheet.

Split Form Splitter Bar Design View  If set to Yes, Access allows you to resize the form and datasheet by moving the 

splitter bar that separates the two parts. If set to No, the splitter bar is hidden, 

and the form and datasheet cannot be resized.

Save Splitter Bar Position Design View  If set to Yes, the form opens with the splitter bar in the same position in which 

you last left it. If set to No, the form and datasheet cannot be resized, and the 

splitter bar is hidden.

Split Form Size Design View or Allows you to specify an exact height or width (depending on whether the 

 Layout View   form is split vertically or horizontally) for the form part of the split form. For 

example, key 1” to set the form to a height or width of 1 inch. Key Auto to set 

the dimension by other means, such as dragging the splitter bar in Layout View.

Split Form Printing Design View or Allows you to defi ne which portion of the form is printed when you print the 

 Layout View   form. If set to Form Only, only the form portion is printed. If set to Datasheet 

Only, only the datasheet portion is printed.
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Creating a Subform
A subform is a convenient tool that allows you to view data from more than one table or query 
on the same form. A subform is a form that is inserted into another form. The primary form is 
called the main form, and the form within the form is called the subform. A form/subform 
combination is sometimes referred to as a hierarchical form, a master/detail form, or a parent/
child form. You can use the Form Wizard to help you create subforms quickly. For best results, 
all relationships should be established fi rst. This enables Access to automatically create the links 
between subforms and main forms. In this exercise, you create a subform.

When working with a relational database, you often need to view data from more than one table 
or query on the same form. For example, you want to see customer data, but you also want to 
see information about the customer’s orders at the same time. Subforms are a convenient tool 
for doing this.

Subforms are especially effective when you want to show data from tables or queries that have 
a one-to-many relationship—the main form shows data from the “one” side of the relationship 
and the subform shows the data from the “many” side of the relationship.

STEP BY STEP Create a Subform

USE the database that is open from the previous exercise.

 1. On the Create tab, in the Forms group, click Form Wizard.

 2. In the fi rst screen on the Form Wizard, click the down arrow in the Tables/Queries box 
and click Table: Samples Given.

 3. In the Available Fields box, double-click the Week Name, Sales Rep, Product, and 
Quantity fi elds to move them to the Selected Fields box.

 4. Click the down arrow in the Tables/Queries box and click Table: Doctors.

 5. In the Available Fields box, double-click the Last Name, First Name, Specialty, and 
Hospital fi elds to move them to the Selected Fields box. The screen should look like 
Figure 10-10.

Figure 10-10 

Form Wizard, screen 1

 6. Click the Next > button.

 7. In the How do you want to view your data? box, click by Doctors. The Form with 
subform(s) radio button should be selected, and the Form Wizard should look like 
Figure 10-11.
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 8. Click the Next > button.

 9. Click the Tabular radio button to select that as the layout for your subform, as shown 
in Figure 10-12.

 10. Click the Next > button. Access has suggested titles for the forms, as shown in 
Figure 10-13. Keep the default selection to open the form.

 11. Click the Finish button to create the forms. The Doctors form appears with the Samples 
Given subform, as shown in Figure 10-14.

Figure 10-11 

Form Wizard, screen 2

Figure 10-12 

Form Wizard, screen 3

Figure 10-13 

Form Wizard, screen 4
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 12. In the Navigation pane, double-click the Samples Given subform to open it, as shown 
in Figure 10-15.

 13. Scroll down and to the right, if necessary, to see the data contained in the records and 
then click the Close button on the Samples Given subform to close the subform.

 14. Click the Close button on the Doctors form to close the form.

 15. LEAVE the database open.

PAUSE. LEAVE the database open to use in the next exercise.

Subform

Main form

Figure 10-14 

Doctors form with subform

Figure 10-15 

Samples Given subform
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USING APPLICATION PARTS TO CREATE BLANK FORMS
As you learned in Lesson 2, the Application Parts gallery consists of two categories, Blank Forms
and Quick Start. The Blank Forms category contains a collection of 10 form parts that allow you 
to add predefi ned forms to a database. In this exercise, you create an Application Parts Blank Form 
and populate the form with bound controls using the Field List.

Application Parts Blank Forms are created as unbound forms and provide a prearranged control 
layout. They can also provide unbound command button controls, depending on what type of 
Blank Form you choose. These forms can also be easily populated with bound controls by using 
the Field List.

Application Parts Blank Forms differ from adding a form using the Blank Forms tool since you 
can add forms that automatically include command buttons that provide additional functional-
ity such as saving a record or closing a form. Using Application Parts Blank Forms, you can also 
easily add forms that do more than just display data from a record source. Unbound forms can 
be created to display messages to a user, or to provide dialog boxes that prompt the user for an 
action. These unbound forms can be referenced through code using Visual Basic for Applica-
tions (VBA) to help provide a more functional database.

STEP BY STEP Use Application Parts to Create Blank Forms

USE the database that is open from the previous exercise.

 1. On the Create tab, in the Templates group, click the Application Parts button and in the 
Blank Forms category, hover your mouse over the 1 Right button. A Tooltip appears 
informing you of the form’s layout.

 2. Click the 1 Right button and a new form object named SingleOneColumnRightLabels 
appears in the Navigation Pane in the Unrelated Objects category, as shown in 
Figure 10-16.

The Bottom Line

NEW
to Offi ce 2010

Figure 10-16 

New Blank Form object in 
Navigation pane

New 
Blank 
Form

 3. Open the SingleOneColumnRightLabels form. The form displays in Form View, as 
shown in Figure 10-17.
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 4. Switch to Layout View and shift-click each label control placeholder titled Field1, 
Field2, Field3, and Field4 to select them all. Press the Delete key on the keyboard to 
delete the label controls. Also delete the label control placeholder that contains the red 
asterisk, which could be used to denote an important fi eld, like a key fi eld.

 5. Click the Add Existing Fields button in the Tools group. The Field List pane appears. If 
necessary, click the Show all tables link. Your screen should resemble Figure 10-18.

 6. In the Field List pane, expand the Doctors table.

 7. In the Field List pane, click and drag each Last Name, First Name, Specialty, and 
Hospital fi eld to the form and to the right placeholder of the original locations of the 
Field1, Field2, Field3, and Field4 label controls that you just deleted. You screen should 
resemble Figure 10-19.

Figure 10-17 

Blank Form in Form View

Figure 10-18 

Blank Form in Layout View and 
Field List pane
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 252 Lesson 10

 8. Resize the label and fi eld controls that you just added until your screen resembles 
Figure 10-20.

 9. Click the Form Title label, and delete Form Title. Key Doctors.

 10. Switch to Form View and cycle through the records. Click the Save & Close button on 
the form to close the form.

 11. Rename the form Doctors Blank Form.

 12. LEAVE the database open.

PAUSE. LEAVE the database open to use in the next exercise.

Fields dragged 
to placeholders 
on right-side of
previously 
deleted labels

Figure 10-19 

Form with fi elds from Field 
List pane

Figure 10-20 

Form with resized label and 
fi eld control

1.3.1

How do you use Application 
Parts to create Blank Forms?
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CREATING A NAVIGATION FORM
The ability to create Navigation forms is a new feature in Access 2010. A Navigation form 
includes a set of navigation tabs that you can click to display forms and reports. In this exercise 
you create a Navigation form.

As you learned in Lesson 2, you can create databases based on templates. When a database is 
created using a web database template, a navigation form is used as the main interface within 
the database since the Navigation pane cannot be viewed from within a web browser. However, 
Navigation forms can also be used from within the Access application window to simplify your 
interaction with database objects. For example, you can easily click a tab on a Navigation form to 
view a form to add, view, or edit data. Similarly, you can simply click a button on the Navigation 
form to work with reports. Navigation forms are created by clicking the Navigation button in 
the Forms group on the Create tab. There are six Navigation form layouts to choose from. Each 
layout includes a specifi c arrangement of tabs that can then be modifi ed in Layout or  Design 
View to access forms and reports. In Layout View, form and report objects can be clicked and 
dragged from the Navigation pane to tabs to quickly add functionality to the Navigation form. 
You can also type a form or report’s name as the tab’s label and Access will automatically bind the 
associated form or report to that label. You can also work with Navigation forms using Design 
View to have the most control over design options, but you lose the ability to quickly add form 
and report objects just by clicking and dragging them to the tabs, or modifying the labels.

You can also add fi elds from multiple tables using the Field List pane to your Navigation form 
in both Design and Layout Views to allow for even greater customization.

STEP BY STEP Create a Navigation Form

USE the database that is open from the previous exercise.

 1. On the Create tab, in the Forms group, click the Navigation button to display a menu 
that contains six form layouts.

 2. Click the Horizontal Tabs button and a new Navigation form appears in Layout View, as 
shown in Figure 10-21.

Take Note

The Bottom Line

NEW
to Offi ce 2010

Figure 10-21 

Navigation form in Layout View
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 3. Click and drag the Doctors form object from the Navigation pane to the [Add New] tab 
near the top of the form. The form tab has been renamed Doctors and all the Doctors 
form’s controls appear. A new [Add New] tab appears next to the Doctors tab. Your 
screen should resemble Figure 10-22.

 4. Click and drag the Doctors report object from the Navigation pane to the [Add New] 
tab near the top of the form. The form tab has been renamed Doctors Report and all 
the Doctors report controls appear. A new [Add New] tab appears next to the Doctors 
tab. Your screen should resemble Figure 10-23.

Figure 10-22 

Navigation form displaying 
Doctors form

Figure 10-23 

Navigation form displaying 
Doctors report
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 5. Double-click the Doctors tab and key Doctors Form to rename the tab.

 6. Switch to Form View and use the form’s tabs to switch between the form and report.

 7. Click the File tab and click Save.

 8. In the Save As dialog box, key Doctors Navigation Form and click OK.

 9. Click the Close button to close the Doctors Navigation Form.

STOP. CLOSE the database.

3.1.4

How do you create 
Navigation forms?

SKILL SUMMARY

In This Lesson  Objective 
You Learned How To: Exam Objective Number

Create Advanced Forms

Use Application Parts to 
 Create Blank Forms Use Blank forms. 1.3.1

Create a Navigation Form Create Navigation forms. 3.1.4

Knowledge Assessment

Fill in the Blank

Complete the following sentences by writing the correct word or words in the blanks provided.

1. The Forms group, located on the  tab, contains commands for 
creating all types of forms.

2. When Access creates a Multiple Items form, it is displayed in  View.

3. Creating a(n)  form allows you to see two views of your data at the 
same time.

4. To set properties for a split form, fi rst switch to  View.

5. For best results, all  should be established before creating a subform.

6. When creating a subform, the primary form is called the  form.

 7. To create a Navigation form, fi rst select the Navigation button in the  
group.

8. A(n)  form resembles a datasheet, but it gives you more 
customization options.

 9. The views in a split form are connected to the same data  and are 
completely synchronized with each other.

 10. Subforms are especially effective when you want to show data from tables or queries 
that have a(n)  relationship.

Multiple Choice

Select the best response for the following statements or questions.

1. Which tool creates a customizable form that displays multiple records?

a. PivotTable

b. Subform

c. Split Form

d. Multiple Items
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2. When you use the Multiple Items tool, the form that Access creates resembles a

a. Control

b. Datasheet

c. Filter

d. Query

3. A split form shows your data in which views?

a. Form View and Datasheet View

b. Layout View and Design View

c. Form View and Design View

d. Layout View and Datasheet View

4. Which split form property allows you to defi ne whether the datasheet appears above, 
below, to the left, or to the right of the form?

a. Split Form Orientation

b. Split Form Datasheet

c. Split Form Splitter Bar

d. Split Form Size

5. Which type of form allows you to view data from more than one table or query on the 
same form?

a. Multi-item form

b. Split form

c. Subform

d. Navigation form

 6. Which tool would you use to create a subform?

a. Form Design

b. Blank Form

c. Form

d. Form Wizard

 7. A form/subform combination is sometimes referred to as a

a. Hierarchical form

b. Master/detail form

c. Parent/child form

d. All of the above

 8. Which type of form already has a predefi ned layout and can automatically contain 
command buttons?

a. Multi-item form

b. Split form

c. Subform

d. Application Parts Blank form

 9. What type of form can be added to a database to simplify your interaction with objects 
preventing the need to use the Navigation pane?

a. Subform

b. Blank form

c. Split form

d. Navigation form

 10. Unbound forms can be easily created that display messages to users using

a. Application Parts Blank forms

b. Navigation forms

c. Split forms

d. None of the above
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Competency Assessment

Project 10-1: Create a Multi-Item Form
In your job as a travel agent at Margie’s Travel, you want to create a form that displays multiple 
database records but that is more customizable than a datasheet. You use the Multiple Items tool to 
create the form.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN the Margie’s Events database from the data fi les for this lesson.

 2. SAVE the database as Margie’s Events XXX (where XXX is your initials).

 3. In the Navigation pane, double-click the Events table to open it.

 4. On the Create tab, in the Forms group, click the More Forms button and then click the 
Multiple Items button on the menu that appears.

 5. Scroll down and to the right to view the multiple records on the form.

 6. Click the File tab and click Save.

 7. In the Save As dialog box, key Events Multiple and click OK.

 8. Click the Close button to close the Events Multiple form.

 9. Click the Close button to close the Events table.

 10. CLOSE the database.

LEAVE Access open for the next project.

Project 10-2: Create a Split Form
Your brother, who owns Wingtip Toys, wants to be able to see two views of his inventory data at the 
same time—in Form View and in Datasheet View. He asks you to help him create a split form and to 
modify it so that the datasheet is on top.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN Toy Stock from the data fi les for this lesson.

 2. SAVE the database as Toy Stock XXX (where XXX is your initials).

 3. In the Navigation pane, double-click the Inventory table to open it.

 4. On the Create tab, in the Forms group, click the More Forms button and then click the 
Split Form button on the menu that appears to create the form and display it in Form 
View and Datasheet View at the same time.

 5. On the Home tab, in the Views group, click the View button and click Design View.

 6. Press F4 to display the Property Sheet.

 7. Click Form in the drop-down list at the top and click the Format tab, if necessary.

 8. Scroll down to the Split Form Orientation property, click the down arrow, and click 
Datasheet on Top.

 9. Click the Close button to close the Property Sheet.

 10. On the Home tab, in the Views group, click the View button and click Layout View to 
display the split form with the datasheet on top.

 11. Click the File tab and click Save.

 12. In the Save As dialog box, key Inventory Split and click OK.

 13. Click the Close button to close the Inventory Split form.

 14. Click the Close button to close the Inventory table.

 15. CLOSE the database.

LEAVE Access open for the next project.

          The Margie’s 
Events fi le for this lesson 
is available on the book 
companion website or in 
WileyPLUS.

          The Toy Stock fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.
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Profi ciency Assessment

Project 10-3: Create Forms for the Wine Club Database
Information about each selection for the Coho Vineyard monthly wine club is stored in an Access 
database. As purchasing manager, you use the database frequently and need to have several types of 
forms available to work with the data. Create a multi-item form and a split form.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN Wines from the data fi les for this lesson.

 2. SAVE the database as Wines XXX (where XXX is your initials).

 3. Create a multi-item form for the red wine table.

 4. Name the form Red Wines Multi and close it.

 5. Create a multi-item form for the white wine table.

 6. Name the form White Wines Multi and close it.

 7. Create a split form for the red wine table.

 8. Name the form Red Wines Split and close it.

 9. Create a split form for the white wine table.

 10. Name the form White Wines Split and close it.

 11. LEAVE the database open for the next project.

LEAVE Access open for the next project.

Project 10-4: Create a Subform
As purchasing manager for Coho Winery, it would be helpful to view data about wines by distributor. 
Create a subform that shows the red wines in the monthly club by distributor.

GET READY. LAUNCH Access if it is not already running.

 1. On the Create tab, in the Forms group, click Form Wizard.

 2. In the fi rst screen on the Form Wizard, select Table: Red Wines in the Tables/Queries 
box.

 3. Move the Bottled, Label, and Type fi elds to the Selected Fields box.

 4. Select Table: Distributors in the Tables/Queries box.

 5. Move the Company fi eld to the Selected Fields box.

 6. In the second screen of the Form Wizard, choose to view your data by distributors.

 7. In the third screen of the Form Wizard, choose to view your data in tabular layout.

 8. In the fi nal screen of the Form Wizard, accept the default form names and click Finish.

 9. Navigate to the third record to see which red wines in your monthly club are 
distributed by Northwind Traders.

 10. Close the form.

 11. CLOSE the database.

LEAVE Access open for the next project.

          The Wines fi le for 
this lesson is available 
on the book companion 
website or in WileyPLUS.
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Mastery Assessment

Project 10-5: Modify a Split Form
As the manager at Southridge Video, you created a split form to work with the used game information 
in the Access database. However, when you open the form, it appears that someone has made changes 
because the datasheet is on the right and the splitter bar is not visible. Change the form properties back 
to the way you want them.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN Used Games from the data fi les for this lesson.

 2. SAVE the database as Used Games XXX (where XXX is your initials).

 3. Open the split form Games.

 4. Switch to Design View and open the form properties.

 5. Change the property to make the datasheet appear on the top.

 6. Change the property to make the splitter bar visible, thus allowing the form and 
datasheet to be resized.

 7. Change the form property so the form will open with the splitter bar in the same 
position in which you last left it.

 8. Change the property to allow edits to be made on the datasheet.

 9. Change the property to print only the datasheet portion of the form.

 10. Switch to Layout View.

 11. Close the form and save the changes to the design when prompted.

 12. CLOSE the database.

LEAVE Access open for the next project.

Project 10-6: Create a Navigation Form
Your son plays on a recreational league basketball team, and you have volunteered to manage the 
team’s database of games, players, and statistics by tracking and updating data. In order to be able to 
quickly and effi ciently update data, you decide to create a Navigation form.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN Stats from the data fi les for this lesson.

 2. SAVE the database as Stats XXX (where XXX is your initials).

 3. Use the Stats: Table and the skills you have learned in this lesson to create a 
Navigation form using the Vertical Tabs, Left layout.

 4. Save the form as Games, Player, Stats Navigation Form and close it.

 5. CLOSE the database.

CLOSE Access.

          The Used Games 
fi le for this lesson is 
available on the book 
companion website or in 
WileyPLUS.

          The Stats fi le for 
this lesson is available 
on the book companion 
website or in WileyPLUS.
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users. When fi nished, click the Access training on Offi ce.com 
link in the Resources for all Access 2010 users category. On 
the Training courses page, shown in Figure 10-24, you can 
fi nd links to several articles to help you improve your skills, 
as well as training courses to help you practice your skills. 
Online resources don’t have to be dull. These training courses 
also contain audio and slideshows to help you learn visually.

INTERNET READY
Get help learning Access or other Microsoft 

Offi ce applications with self-paced training courses and more. 
Using your browser, go to offi ce.microsoft.com and conduct 
a search for Resources for learning Access 2010. Explore 
the page that contains several helpful links to Access 2010 
 resources arranged in categories for different types of Access 

Figure 10-24

Training courses page
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Circling Back 2

Woodgrove Real Estate is growing and adding more listings. Your offi ce has added another real 
estate agent and has begun listing commercial properties as well as residential ones. The database 
you created has been a great way to keep track of all the listings and other relevant information. 
As you learn more about Access, you begin using it for a wider variety of tasks.

Project 1: Create and Format a Report
You want to create a report to display data about each agent’s listings. Use the Report Wizard 
and then switch to Design View to make changes to the format and add a control.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN the Real Estate database from the data fi les for this lesson.

 2. SAVE the database as Real Estate XXX (where XXX is your initials).

 3. On the Create tab, in the Reports group, click the Report Wizard button.

 4. In the Tables/Queries menu, choose Table: Listings.

 5. Click the >> button to move all the fi elds into the Selected Fields list.

 6.  Click the ID fi eld to select it and click the < button to move it back to the Available 
Fields list.

 7. Click the Next > button.

 8.  Click the Listing Agent fi eld to select it and click the > button to add it as a 
grouping level.

 9. Click the Next > button.

 10.  Select Price from the fi elds menu to sort in ascending order and click the Next > button.

 11.  In the Layout section, click the Outline button. In the Orientation section, click the 
Landscape button. Click Next.

 12. Key Listings Report as the title of the report.

 13. Click Finish to display the Listings Report.

 14.  On the Print Preview tab, in the Close Preview group, click the Close button on Print 
Preview to display the report in Design View.

 15.  In the Listing Agent Header section, click and drag the right border of the Listing 
Agent fi eld to make it smaller.

 16.  Continue clicking and dragging the borders of the remaining report fi elds to size them 
so your report looks similar to the report displayed in Report View, as shown in Figure 1.

 The Real Estate fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.

Figure 1

Listings report
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 17.  Click the Close button on the Listings Report to close the report and save the changes 
when prompted.

PAUSE. LEAVE the database open to use in the next project.

Project 2: Create and Modify Queries
You want to query the database to fi nd all the house sales that closed in June. Create a query 
using the Query Wizard and then add criteria to get the information you need.

USE the database that is open from the previous project.

 1.  On the Create tab, in the Other group, click the Query Wizard button to display the 
New Query dialog box.

 2. Click Simple Query Wizard and then click OK to display the Simple Query Wizard.

 3. In the Tables/Queries drop-down list, click Table: Houses Sold.

 4.  Under Available Fields, double-click Listing Agent, Address, Selling Price, and Closing 
Date to move them to the Selected Fields box.

 5. Click the Next > button to display the next screen. Detail query should be selected.

 6. Click the Next > button to display the fi nal screen.

 7. Click the Finish button to display the query.

 8. On the Home tab, in the Views group, click the View button and click Design View.

 9.  In the Criteria row of the Closing Date fi eld, key Between #6/1/2011# And 
#6/30/2012#.

 10.  On the Design tab, in the Results group, click the View button and click Datasheet 
View to display the query results of all records for houses that closed in June.

 11.  Right-click the Closing Date fi eld header and choose Sort Oldest to Newest on the 
menu. Your query should look similar to Figure 2.

Figure 2

Query results  12.  Click the Close button on the Houses Sold Query to close the query. When prompted 
to save, click Yes.

PAUSE. LEAVE the database open for the next project.
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Project 3: Sum Table Data
You want to know the total value of the current listings. Open the table and add a Totals row to 
get this information.

USE the database that is open from the previous project.

 1. Open the Listings table.

 2.  On the Home tab, in the Records group, click the Totals button. The Totals row appears 
below the asterisk (*) row.

 3.  Click the down arrow in the Price column of the Totals row. Select Sum from the 
menu. Your screen should look similar to Figure 3.

Figure 3

Totals row  4. On the Home tab, in the Records group, click the Totals button to hide the Totals row.

 5.  On the Home tab, in the Records group, click the Totals button again. The Totals 
row reappears.

 6. Save and close the table.

PAUSE. LEAVE the database open for the next project.

Project 4: Create a Subform
You want to see the real estate agent’s contact information along with the listings. Use the Form 
Wizard to create a subform that will show all the data in the same place.

USE the database that is open from the previous project.

 1. On the Create tab, in the Forms group, click Form Wizard.

 2.  In the fi rst screen on the Form Wizard, click the Tables/Queries box down arrow and 
click Table: Agents.

 3.  In the Available Fields box, double-click the Last Name, First Name, and Mobile Phone 
fi elds to move them to the Selected Fields box.

 4. Click the Tables/Queries box down arrow and click Table: Listings.

 5.  In the Available Fields box, double-click the Address, Square Feet, and Price fi elds to 
move them to the Selected Fields box.

 6. Click Next >.
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 7.  In the How do you want to view your data? box, click by Agents. The Form with 
subform(s) radio button should be selected.

 8. Click Next >.

 9. Click the Tabular radio button to select that as the layout for your subform.

 10. Click Next >.

 11.  Click the Finish button to create the Agents form with the Listings subform. Your form 
should look similar to Figure 4.

 12. In the Navigation pane, double-click the Listings subform to open it.

 13.  Scroll down to see the data contained in the records and then click the Close button 
on the Listings subform to close the subform.

 14. Click the Close button on the Agents table to close it.

STOP. CLOSE the database.

Figure 4

Subform
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Skill Exam Objective Objective Number

Defi ning Groups Add calculated controls. 5.2.2

Creating Aggregate Fields Add calculated controls. 5.2.2

Creating the Print Layout Change page size. 5.5.1
 Change page orientation. 5.5.2

Using the Label Wizard

LESSON SKILL MATRIX

KEY TERMS
• aggregate fi elds

• group

• group footer

• group header

• grouping fi elds

• grouping intervals

• grouping levels

• Label Wizard

• Print Preview
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Consolidated Messenger is a New York City—based company that provides quick 

and reliable pickup and delivery services to area businesses. The company provides 

courier service by foot, bike, or truck. The company has a sales force that negoti-

ates contracts with some of its larger corporate clients. As sales manager, you 

have created a database with tables and reports to keep track of this data. In this 

lesson, you generate reports that group data, create aggregate fi elds to total data 

in reports, use Print Preview to adjust reports before printing, and use the Label 

Wizard to create labels for customer mailings.

DEFINING GROUPS
A group is a collection of records separated visually with any introductory or summary infor-
mation displayed with it. Reports can be grouped on fi elds or expressions. A grouping fi eld 
is a fi eld by which data is grouped. Grouping levels are the nested arrangement of the groups 
in a report. Access creates indented levels to show the groups from highest to lowest priority. 
You can change a group’s level in the Report Wizard by using the priority up and down arrows. 
Access allows you to specify as many as 10 groups in a report. Groups can be nested so that that 
you can easily see the group structure.

When data is arranged in groups, it is often easier to comprehend and it becomes more mean-
ingful. For example, if you want to see the sales performance for each region, it is easier to review 
this data if each region’s sales are grouped together. You can go a step further and specify another 
group level, such as salesperson. This allows you to group a report by region and by salesperson 
within each region.

You can specify grouping intervals by using the Grouping Options button. Grouping intervals 
establish the way that records are grouped together. They can be very useful in arranging a large 
number of records in a group. You can group on the fi rst character of a text fi eld so that all of 
the records are visually separated alphabetically. You can specify a group interval of a day, week, 
month, or quarter on a date fi eld. This is useful if you want to view the sales for each week in a 
report. You can also specify a custom interval.

Using the Report Wizard
You can easily specify groups with the Report Wizard when creating a new report. This is an 
easy and fast way to create a report with groups. The Report Wizard lets you specify how you 
would like data to be grouped as you create the report. You can also add grouping to an existing 
report using the Group, Sort, and Total pane. Grouping options let you further specify how you 
want the groups to appear in your report. In this exercise, you use the Report Wizard to specify 
grouping levels and create a report.

STEP BY STEP Use the Report Wizard

GET READY. Before you begin these steps, be sure to turn on and/or log on to your 
computer and start Access.

 1. OPEN Messenger from the data fi les for this lesson.

 2. SAVE the database as Messenger XXX (where XXX is your initials).

 3. Open the Corporate Sales table.

 4.  On the Create tab, in the Reports group, click the Report Wizard button. The fi rst 
Report Wizard dialog box appears.

 5.  Select the Region (Borough) fi eld and click the > button to move the fi eld to the 
Selected Fields list.

The Bottom Line

WileyPLUS Extra! features an 
online tutorial of this task.

 The Messenger fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.
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 6.  Using the same method, move the Sales Person Last Name, Company Name, and 
Contract Amount fi elds from the Available Fields list to the Selected Fields list, as 
shown in Figure 11-1.

Figure 11-1

Report Wizard, screen 1

 7. Click the Next > button. The second Report Wizard screen appears.

 8.  Select the Region (Borough) fi eld and click the > button to move it to the grouping 
levels box.

 9.  Select the Contract Amount fi eld and click the > button to move it to the grouping 
levels box.

 10.  Select the Sales Person Last Name fi eld and click the > button to move it to the 
grouping levels box.

 11.  Notice that the Sales Person Last Name fi eld is the active fi eld in bold type. Click the 
Priority up arrow to move the Sales Person Last Name fi eld to the second level of 
grouping. Your screen should look similar to Figure 11-2.

Figure 11-2

Report Wizard, screen 2

 12.  Click the Grouping Options button at the bottom of the dialog box. The Grouping 
Intervals dialog box appears, as shown in Figure 11-3.

Figure 11-3

Grouping Intervals dialog box
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 13.  Click the down arrow on the fi rst Grouping intervals menu to see the choices available. 
Select Normal from the menu and click OK.

 14.  Click the Next > button. The third Report Wizard screen appears. You can sort in either 
ascending or descending order, and by up to four fi elds.

 15.  Click the down arrow on the Sort menu and select Company Name, as shown in 
Figure 11-4. You will sort in ascending order by Company Name.

Figure 11-4

Report Wizard, screen 3

 16.  Click the Next > button. The fourth Report Wizard screen appears. You can choose from 
three different layouts for your report as well as two different orientations.

 17.  In the Layout section, click the Block radio button, as shown in Figure 11-5. Keep the 
default orientation as Portrait and keep the selection so all fi elds fi t on one page.

 18.  Click the Next > button. The fi fth Report Wizard screen appears, as shown in 
Figure 11-6.

Figure 11-5

Report Wizard, screen 4

Figure 11-6

Report Wizard, screen 5
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 19.  Click the Finish button to accept the settings. The Report Wizard creates the report, 
shown in Figure 11-7, with the groups you specifi ed.

 20. Close the report and close the table.

PAUSE. LEAVE the database open to use in the next exercise.

Adding Group Headers and Footers
You can add group headers and footers to a report using the Group, Sort, and Total pane. When 
you select a fi eld from the Group On menu, the group header is added to the report. In this 
exercise, you add group headers using the Group, Sort, and Total pane.

As you may remember from Lesson 6, a report is organized into sections. You can view sections 
of a report in Design View. The group header is the section of a report where the name of a 
grouped fi eld is displayed and printed. Group headers take on the name of the group, so instead 
of seeing a group header named Group Header you will see [Fieldname] Header.

A group footer is the section of the report where the data in the group is summarized. It is 
optional. If you do not have any summary data, such as a total, you don’t need a group footer.

STEP BY STEP Use the Group, Sort, and Total Pane

USE the database open from the previous exercise.

 1. Open the Sales by Region report. Notice that the report is not arranged by groups.

 2. Switch to Layout View and close the Field List pane if it opens.

 3.  On the Design tab, in the Grouping & Totals group, click the Group & Sort button. 
The Group, Sort, and Total pane appears at the bottom of the screen, as shown in 
Figure 11-8.

Figure 11-7

Corporate Sales report

5.2.2

How do you group report 
records?
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 4.  Click the Add a group button. Select Region (Borough) from the Group On menu, as 
shown in Figure 11-9. The report is now grouped on the Region (Borough) fi eld.

Group, Sort, and Total paneFigure 11-8

Group, Sort, and Total Pane

Figure 11-9

Group On menu

Group 
On menu

 5.  Click the Add a group button on the Group, Sort, and Total pane. Select Sales Person 
Last Name from the Group On menu. The report is now also grouped on the Sales 
Person Last Name fi eld.

 6.  Switch to Design View. Your screen should look similar to Figure 11-10. Notice that 
there is a Region (Borough) Header for that group and a Sales Person Last Name 
header for that group. The Company Name and Contract Amount fi elds are arranged 
in the Detail section.

 Another Way
You can also right-

click a fi eld header in Layout 
View and select Group on Field 
name from the shortcut menu 
to defi ne a group header.
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 7. Save the report.

PAUSE. LEAVE the database open to use in the next exercise.

Changing Grouping Options
After grouping data, Access gives you options for displaying grouped data. To display the group-
ing options in the Group, Sort, and Total pane, click More on the group level that you want to 
change. If you want to hide the grouping options, click Less. In this exercise, you use the Group, 
Sort, and Total Pane to change group options.

Grouping options include:

•  Sort order: Choose ascending or descending

•  Group interval: Change the way records are grouped together

•  Totals: Add totals to fi elds

•  Title: Change the label of a column heading or summary fi eld

•  With/without header: Add or remove the header section

•  With/without footer: Add or remove footer section

•  Keep group together: Decide how or if you want to keep grouped data together on the 
same page

•  Do not keep group together on one page: Groups can be broken up by page breaks

•  Keep whole group together on one page: Minimizes the number of page breaks in 
a group

•  Keep header and fi rst record together on one page: Makes sure a group header is not 
printed by itself at the bottom of a page

You can also click the Move up and Move down arrows at the end of the Group On row to 
change the priority of grouping levels. To delete a grouping level, click the Delete button at 
the end of its Group On row and Access will move the data to the Detail section of the report. 
However, if other controls are in the header, Access will warn you that these could be deleted.

The Hide Details command is a toggle button that hides data in the Details section of the 
report. Click it again to display the data.

Group 
headers

Detail 
section

Group 
On rows

Figure 11-10

Group headers in Design View
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 4.  Switch to Design View. Note that the Sales Person Last Name Header has 
been deleted.

 5. Switch to Layout View.

 6.  Click the down arrow beside the without a header section (if the without a header 
section option doesn’t appear, click the More button) and select with a header section 
from the drop-down menu.

 7.  Click the Move up arrow at the end of the Group On Sales Person Last Name row. 
Notice that the Sales Person Last Name group is now the top level group in the report.

 8.  Click the Add a group button and select Company Name from the menu. A new group 
level is added to the report.

 9.  On the Design tab, in the Grouping & Totals group, click the Hide Details button. The 
data in the Contract Amount fi eld is hidden.

 10.  On the Design tab, in the Grouping & Totals group, click the Hide Details button. The 
data in the Contract Amount fi eld is displayed.

 11. Click the More button in the Group, Sort, and Total pane.

 12.  Click the with A on top down arrow on the Group On Company Name row in the 
Group, Sort, and Total Pane and select with Z on top from the drop-down menu. The 
sort order is changed from ascending to descending order.

 13. Click the with Z on top down arrow and select with A on top.

 14.  Click the Delete button on the right side of the Group On Company Name row in the 
Group, Sort, and Total pane. The row is deleted, as is the Company Name header 
section.

 15. Switch to Report View to see the report. Your screen should resemble Figure 11-12.

STEP BY STEP Change Grouping Options

USE the database and report open from the previous exercise.

 1. Switch to Layout View.

 2.  Click the Group On Sales Person Last Name row in the Group, Sort, and Total Pane and 
then click the More button to view the available grouping options.

 3.  Click the down arrow beside with a header section and select without a header 
section from the drop-down menu, as shown in Figure 11-11.

Move down

Delete

Move up

Figure 11-11

Group On Sales Person Last 
Name row
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 16. Save the report.

PAUSE. LEAVE the database open to use in the next exercise.

CREATING AGGREGATE FIELDS
Report data often contains numbers, such as sales fi gures, that need to be totaled. A report that 
lists sales for each month in a quarter but does not total all the sales for the quarter is incom-
plete. Aggregate fi elds use functions to provide summary information of such data. You can 
create an aggregate fi eld by using aggregate functions to calculate data in a fi eld. The aggregate 
functions you can use are Sum, Average, Count Records, Count Values, Max, Min, Standard 
Deviation, or Variance.

Access 2010 provides a Totals command that lets you create an aggregate fi eld that provides not 
only grand totals, but totals for groups in a report as well. You can also use the Group, Sort, and 
Total pane to add aggregate functions to fi elds.

The Totals command is located on the Format tab, in the Grouping & Totals group, but you 
can also access it on the shortcut menu. In Layout View, just right-click the fi eld you want to 
total and select Totals from the shortcut menu. The Totals command adds a calculated control 
in the report footer where it displays the grand total. If you don’t already have group footers 
in your report, the Totals command adds group footers and calculated controls to calculate the 
totals for each group.

For more information about aggregate functions, see Lesson 9.

Creating Aggregate Fields
You have a few more options when using the Group, Sort, and Total pane to create an aggregate 
fi eld in a report. The Totals menu gives you options for choosing the fi eld and type of function 
as well as options on how you want to display totals. You can display a grand total or a group 
 total as a percentage of the grand total. You can also choose to show the totals in the group header 
or footer. In this exercise, you use the Group, Sort, and Total pane to create aggregate fi elds.

Ref

Figure 11-12

Sales by Region report

The Bottom Line
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STEP BY STEP Create Aggregate Fields

USE the database and report open from the previous exercise.

 1. Switch to Layout View.

 2. Click the Group On Sales Person Last Name row and click More.

 3. Click the With No Totals down arrow. The Totals menu appears, as shown in Figure 11-13.

With no totals down arrow

Figure 11-13

Totals menu

 4. Click the Total On menu down arrow and select Contract Amount.

 5. Click the Type menu down arrow and select Sum if it isn’t selected already.

 6.  Click the Show Grand Total box. The menu disappears and the grand total appears in 
the Contract Amount column at the bottom of the report.

 7.  Click the Group On Sales Person Last Name row again and click More, then click the 
with Contract Amount totaled down arrow.

 8.  Click the Total On menu down arrow and select Contract Amount, then click the Show 
subtotal in Group Footer box. The settings are applied, and the subtotals are now 
shown in each group’s footer.

 9. Select the Sales Person Last Name fi eld header on the report.

 10.  On the Design tab, in the Grouping & Totals group, click the Totals button and select 
Count Records from the menu.

 11.  Switch to Report View. The total number of records appears at the bottom of the 
report.

 12. Save the report and close it.

PAUSE. LEAVE the database open to use in the next exercise.

 Another Way
You can also right-

click a fi eld in Layout View and 
select Total from the shortcut 
menu to apply an aggregate 
function to a fi eld.

5.2.2

How do you total report 
records?
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CREATING THE PRINT LAYOUT
Reports are often created so that they can be printed and displayed or shared with colleagues. 
You can print a report from any view: Report, Layout, Design, or Print Preview. Print Preview
displays a report as it will look when printed. It is helpful to preview a report before printing it. 
This allows you to make adjustments to the layout before clicking the Print button so that you 
can make sure the report prints the way that you want. The settings that you choose will be saved 
with the report, so you won’t have to select the same settings each time you print.

When you are confi dent your report will print correctly, you can click the Print button. The 
Print dialog box lets you select the printer, choose the number of copies you want to print, and 
specify which pages you want to print. If you don’t need to preview a report, you can skip Print 
Preview and select Print or Quick Print on the File tab’s Print menu. The Print command dis-
plays the Print dialog box, but the Quick Print command sends the report directly to the printer.

You can even print a report from the Navigation pane. But before you print a report, you should 
check settings such as margins and page orientation to make sure the report will print correctly.

Using Print Preview to Create a Print Layout
The Print Preview tab has commands for printing, changing the page layout, and zooming in 
or out to view the pages. When you are fi nished previewing a report, you can click the Close 
Print Preview button to leave the view. In this exercise you use Print Preview to create the print 
layout of a report.

STEP BY STEP Create the Print Layout

USE the database open from the previous exercise.

 1.  Right-click the Sales by Region report in the Navigation pane and select Rename from 
the menu.

Take Note

SOFTWARE ORIENTATION

Print Preview Tab

The Print Preview tab (Figure 11-14) has commands for viewing a report in a variety of ways 
and for adjusting its layout. You can display the Print Preview tab by choosing the Print 
Preview option on the File tab’s Print menu. Use the Print Preview tab to view and adjust 
page layout before printing.

Figure 11-14

Print Preview tab

Suppresses the printing 
of labels on a report

Displays 
a menu of 
page sizes

Displays the 
page vertically

Displays the Page 
Setup dialog box

Displays 1, 2, or 
more pages at a time

Displays margin 
size menu

Displays the Columns 
tab of the Page Setup 

dialog box

Displays a menu 
of zoom levels

Displays the page 
horizontally

The Bottom Line
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 5.  On the Print Preview tab, in the Zoom group, click the Two Pages button. Both pages 
of the report are displayed on the screen.

 6.  On the Print Preview tab, in the Page Layout group, click the Landscape button. The 
report is displayed in landscape orientation.

 7.  On the Print Preview tab, in the Page Layout group, click the Portrait button. The report 
is displayed in portrait orientation again. The margins need adjustment.

 8. Click the Margins button and select Narrow from the menu.

 9.  On the Print Preview tab, in the Page Layout group, click the Page Setup button. The 
Page Setup dialog box appears, as shown in Figure 11-16. Notice it has many of the 
same options that are available in the Page Layout group, but more options and 
details to choose from.

 2. Key Sales by Sales Person.

 3.  Open the report in Design View and click the Report title. Select Region and key Sales 
Person, because the report no longer shows sales by region, but sales by salesperson.

 4.  On the Home tab, in the Views group, click the View button and select Print Preview 
from the menu. The report is displayed in Print Preview, as shown in Figure 11-15.

Figure 11-15

Report in Print Preview

Figure 11-16

Page Setup dialog box

 10.  Click the Page tab. Click the Size box down arrow and select Legal from the menu to 
see if all data will fi t on one page.
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 11. Click OK.

 12.  On the Print Preview tab, in the Zoom group, click the Zoom button and select 50% 
from the menu. Notice that all data does not fi t on one page.

 13.  On the Print Preview tab, in the Page Layout group, click the Size button and select 
Letter (8 1/2 � 11 in) from the menu. Notice that the group at the bottom of the fi rst 
page is split and continues on the second page.

 14.  Click the Close button on Print Preview.

 15. Switch to Layout View.

 16.  On the Group, Sort, and Total pane, on the Group On Sales Person Last Name row, 
click the More button. Click the Do Not Keep Group Together On One Page down arrow 
and select Keep whole group together on one page from the menu.

 17. Save the report design.

 18.  Right-click in a blank area of the report and select Print Preview from the shortcut menu, 
as shown in Figure 11-17. Notice that the group is no longer split across two pages.

Figure 11-17

Shortcut menu

5.5.1

How do you change the 
page size of a report?

5.5.2

How do you change the page 
orientation of a report?

 19.  Click the Print button. The Print dialog box appears. Click OK to print or click Cancel to 
close the dialog box.

 20. Close Print Preview and close the report.

PAUSE. LEAVE the database open to use in the next exercise.

You can add the Print Preview and/or the Quick Print command to the Quick Access Toolbar by 
clicking the Customize Quick Access Toolbar down arrow at the end of the toolbar and selecting 
Print Preview or Quick Print from the menu.

USING THE LABEL WIZARD
You can create labels for mailing, or other purposes, using the data in your Access databases. The 
Label Wizard helps you create a label-sized report that you can use to print labels. The Label 
Wizard asks you a series of questions about the labels you want and then creates the labels based 
on your answers. You can choose from a wide variety of sizes, including sizes to fi t label sheets 
that you purchase at the offi ce supply store or custom-created labels.

Creating Labels Using the Label Wizard
You can create mailing labels or other types of labels from an Access table or query. Access allows 
you to choose the font name, font size, font weight, and text color for your labels. You can also 
choose to underline or italicize text in the label. The Sample box displays the choices you make. 
In this exercise, you use the label wizard to create labels.

Take Note

The Bottom Line

 Another Way
Right-click the 

report you want to preview in the 
Navigation pane and select Print 
Preview from the shortcut menu.

c11AdvancedReports.indd Page 277  8/12/11  9:00 PM user-f463c11AdvancedReports.indd Page 277  8/12/11  9:00 PM user-f463 Volume/202/es/JWCL558Volume/202/es/JWCL558



 278 Lesson 11

You can select predefi ned label sizes that match popular manufacturer’s label sheets. These are 
listed by Product Number in the fi rst Label Wizard screen. If you don’t know the manufacturer 
of your label sheets, you can choose a sheet with similar dimensions and with the correct num-
ber of labels across the sheet. If you don’t see the size you need, you can customize the size and 
create a new label using the Customize button.

As you add fi elds to the Prototype label, remember to use the Spacebar to add a space between 
fi elds and press Enter to move to the next line. You can also key text directly in the Prototype 
label that you want to appear on each label.

You can sort the labels by one or more fi elds, such as zip code for bulk mailings. On the last 
Label Wizard screen, you can choose to See the labels as they will look when printed and they 
will be displayed in Print Preview. Choose Modify the label design to view the label report in 
Design View.

STEP BY STEP Use the Label Wizard

USE the database open from the previous exercise.

 1. Select the Clients table in the Navigation pane.

 2.  On the Create tab, in the Reports group, click the Labels button. The fi rst Label Wizard 
screen appears, as shown in Figure 11-18.

Figure 11-18

Label Wizard, screen 1

 3.  Scroll down in the Product number box and select Avery USA 5160 and click the 
Next > button. The second Label Wizard screen appears, as shown in Figure 11-19.

Figure 11-19

Label Wizard, screen 2
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 4.  Click the Font name drop-down arrow and scroll down to select Times New Roman. 
Notice the preview sample displays the new font.

 5. Click the Font size menu and select 9.

 6. Click the Font weight menu and select Normal.

 7.  In the Text color section, click the Ellipses button to display the Color menu. Notice the 
options available, then click Cancel to close it.

 8.  Click the Next > button. The third Label Wizard screen appears, as shown in 
Figure 11-20.

Figure 11-20

Label Wizard, screen 3

 9.  Select the Company Name fi eld in the Available fi elds list and click the > button to 
place it on the Prototype label.

 10. Press Enter.

 11. Key ATTN: and press the Spacebar.

 12. Select the Contact First Name fi eld and click the > button.

 13. Press the Spacebar to insert a blank space between fi elds.

 14. Select the Contact Last Name fi eld and click the > button.

 15. Press Enter.

 16. Select the Address fi eld and click the > button. Press Enter.

 17. Select the City fi eld and click the > button. Key a comma and press the Spacebar.

 18. Select the State fi eld and click the > button. Press the Spacebar.

 19.  Select the Zip fi eld and click the > button. Your screen should look similar to 
Figure 11-21.

Figure 11-21

Completed Prototype label

 20. Click Next >. The fourth Label Wizard screen appears, as shown in Figure 11-22.
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 21. Select the Zip fi eld and click the > button.

 22. Click Next >. The fi fth Label Wizard screen appears, as shown in Figure 11-23.

Figure 11-22

Label Wizard, screen 4

Figure 11-23

Label Wizard, screen 5

 23.  Click the Modify the label design radio button and click Finish. Your screen should look 
similar to Figure 11-24.

Figure 11-24

Label report
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24.  On the Home tab, in the Views group, click the View menu and select Print Preview 
from the menu. Your screen should look similar to Figure 11-25.

Figure 11-25

Report in Print Preview
 25.  Click the Print button. The Print dialog box appears. Click OK to print or click Cancel to 

close the dialog box.

 26. Close Print Preview and close the report.

CLOSE the database.

Troubleshooting  If Access displays a message warning you that some of your data may not be displayed, 
this means the controls on the label are too wide for the allotted space. If this happens, try 
reducing the size of the controls in Design View so that they fi t in the space available for a 
single label or try reducing the page margins using Page Setup.

As an alternative to printing labels, you can print addresses directly on envelopes. To do this, 
you will need to create a custom label instead of a predefi ned label and set the Label Type setting 
to Sheet Feed.

Take Note

SKILL SUMMARY

In This Lesson   Objective
You Learned How To: Exam Objective Number

Defi ne Groups Add calculated controls. 5.2.2

Create Aggregate Fields Add calculated controls. 5.2.2

Create the Print Layout Change page size. 5.5.1
 Change page orientation. 5.5.2

Use the Label Wizard
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Knowledge Assessment

Matching

Match the term in Column 1 to its description in Column 2.

Column 1 Column 2

 1. group a.  asks you questions about the labels and data you want to 
display and then creates labels based on your answers

 2. group header b. fi eld that contains an aggregate function to calculate data

 3. group footer c. a fi eld by which data is grouped

 4. Hide Details command d. the nested arrangement of the groups in a report

 5. grouping fi eld e.  a collection of records separated visually with any 
introductory or summary information displayed with it

 6. aggregate fi eld f.  the section of a report where the name of a grouped fi eld 
is displayed and printed

 7. Print Preview g.  the sample in the Label Wizard where you create the 
label design

 8. grouping levels h. hides the data in the Details section of a report

 9. Label Wizard i.  the section of a report where the data in a group is 
summarized

 10. Prototype label j. displays a report as it will look when printed

True/False

Circle T if the statement is true or F if the statement is false.

T  F 1. Grouping intervals establish the way that records are grouped together.

T  F 2. You cannot group data in the Report Wizard.

T  F 3. Group headers take on the name of the group.

T  F 4. Group footers are optional in a report.

T  F 5. The arrows at the end of a Group On row determine sort order.

T  F 6. Average is an aggregate function.

T  F 7. The Totals command adds group footers and calculated controls for you.

T  F 8. You must preview a report before you can print.

T  F 9. You can modify labels in Design View.

T  F 10. Labels are small reports.

Competency Assessment

Project 11-1: Create Address Labels for Authors
You need to send out confi dential contract information to the authors in the Business Books division. 
Create labels for the authors using the Author Contact Information table.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN the Lucerne database.

 2. SAVE the database as Lucerne XXX (where XXX is your initials).

 3. Select the Author Contact Information table in the Navigation pane.

 4. On the Create tab, in the Reports group, click the Labels button.

 5. Select the C2242 label in the Product number box and click Next.

 6. Select Arial from the Font name menu and select 9 from the Font size menu.

          The Lucerne fi le for 
this lesson is available 
on the book companion 
website or in WileyPLUS.
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 7. Click the Italic button and click Next.

 8. Key CONFIDENTIAL in all caps and press Enter.

 9. Key For Addressee Only and press Enter.

 10. Select the Author First Name fi eld and click the > button. Press the Spacebar.

 11. Select the Author Last Name fi eld and click the > button. Press Enter.

 12. Select the Author Address fi eld and click the > button. Press Enter.

 13.  Select the Author City fi eld and click the > button. Key a comma and press 
the Spacebar.

 14. Select the Author State fi eld and click the > button. Press the Spacebar.

 15. Select the Author Zip fi eld and click the > button.

 16. Click Finish.

 17. Close the report.

LEAVE the database open for the next project.

Project 11-2: Total and Preview the Book Sales Report
Finish the Book Sales report to show totals for Domestic and International Sales. You also need to 
make some adjustments in Print Preview before printing.

USE the database open from the previous project.

 1. Open the Book Sales report.

 2. In Layout View, select the Domestic Sales fi eld header.

 3.  On the Design tab, in the Grouping & Totals group, click the Totals button and select 
Sum from the menu.

 4. Select the International Sales fi eld header.

 5.  On the Design tab, in the Grouping & Totals group, click the Totals button and select 
Sum from the menu.

 6. Select the Book Title fi eld header.

 7.  On the Design tab, in the Grouping & Totals group, click the Totals button and select 
Count Records from the menu.

 8.  On the Design tab, in the Views group, click the View menu and select Print Preview 
from the menu.

 9.  On the Print Preview tab, in the Page Size group, click the Margins button and select 
Wide from the menu.

 10.  On the Print Preview tab, in the Zoom group, click the Zoom button and select Fit 
to Window.

 11. Save the report.

 12. On the Print Preview tab, in the Print group, click the Print button. Click OK.

 13. Close the report.

CLOSE the database.

Profi ciency Assessment

Project 11-3: Create a Grouped Report with Aggregate Fields
Your supervisor asks you to create a report using the Monthly Sales by Store table that shows 
monthly sales by store.

GET READY. LAUNCH  Access if it is not already running.

 1. OPEN Fourth Coffee from the data fi les for this lesson.

 2. SAVE the database as Fourth Coffee XXX (where XXX is your initials).

 3. Select the Monthly Sales by Store table.

          The Fourth Coffee 
fi le for this lesson is 
available on the book 
companion website or in 
WileyPLUS.

c11AdvancedReports.indd Page 283  8/12/11  9:00 PM user-f463c11AdvancedReports.indd Page 283  8/12/11  9:00 PM user-f463 Volume/202/es/JWCL558Volume/202/es/JWCL558



 284 Lesson 11

 4. Use the Report Wizard to create a report that includes the Mon, Store, and Sales fi elds.

 5. Group by Store and create a Stepped layout.

 6.  Close Print Preview and switch to Layout View to decrease the width of the Mon and 
Sales columns.

 7. Click the Group & Sort button to open the Group, Sort, and Total pane.

 8.  Click the Add a Sort button and select Sales from the menu. Sort from smallest to largest.

 9. Select the Sales column.

 10. Click the Totals button and select Sum from the menu.

 11. Save the report.

LEAVE the report open for use in the next project.

Project 11-4: Preview and Print the Monthly Sales Report
You need to print the Monthly Sales by Store report. View the report in Print Preview to make sure 
the report is centered on the page before printing.

USE the Fourth Coffee XXX database that you saved in a previous exercise.

 1. Switch to Print Preview.

 2. Click the Zoom button and select Fit to Window.

 3. Click the Margins button and select Wide from the menu.

 4. Click the Landscape button.

 5. Click the Page Setup button.

 6.  Click the Print Options tab. In the Margins section, key 1 in the Top box and key 1 in 
the Bottom box.

 7. Key 1.5 in the left box and key 1.5 in the right box.

 8. Click OK.

 9.  Click the Print button and click OK to print the report or click Cancel to close the 
dialog box.

 10. Save the report.

 11. Click the Close button on Print Preview.

 12. Close the report.

CLOSE the database.

Mastery Assessment

Project 11-5: Group and Total the Inventory Report
As marketing manager at Wingtip Toys, you review Inventory information regularly with other employees.
Add groups and totals to the Inventory report before your meeting with the production manager.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN Wingtip from the data fi les for this lesson.

 2. SAVE the database as Wingtip XXX (where XXX is your initials).

 3. Open the Inventory report.

 4. Switch to Layout View and open the Group, Sort, and Total pane.

 5. Group the report by the In Stock fi eld.

 6. Sort the Description column from A to Z.

 7. Sum the Price fi eld. Show a grand total and totals in the group footers.

 8. Save and close the report.

CLOSE the database.

          The Wingtip fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.
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Project 11-6: Create Labels for Alpine Ski House Customers
In your position as Administrative Assistant for Alpine Ski House, you are involved in a variety of 
projects. The owners want to send a special thank you letter and promotion to previous customers. 
Create labels for the mailing.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN Alpine from the data fi les for this lesson.

 2. SAVE the database as Alpine XXX (where XXX is your initials).

 3. Open the Customers table.

 4. Use the Label Wizard to create address labels for all the customers in the table.

 5. Select the C2160 labels.

 6.  Arrange the customers’ last name, fi rst name, address, city, state, and zip code fi elds 
appropriately on the mailing label.

 7. Name the labels Customers Labels.

 8. Save, print and close the report.

 9. CLOSE the database.

CLOSE Access.

          The Alpine fi le for 
this lesson is available 
on the book companion 
website or in WileyPLUS.

information such as services offered and prices charged for 
common services such as overnight delivery or two-day 
service. Create a database table and report that displays the 
data grouped by company with group totals for like services. 
Preview your report, make sure it looks attractive on the 
page, and then print it.

INTERNET READY
Delivery service companies are used extensively 

in business. As a result, comparing service and prices can 
be very important for a company to make sure it is using a 
 reliable and economical delivery service. Search the Internet 
for three companies that pick up and deliver packages. Gather
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LESSON SKILL MATRIX

KEY TERMS
• action query

• aggregate function

• append query

• calculated fi eld

• cross join

• crosstab query

• delete query

• inner join

• join

• left outer join

• make table query

• outer join

• right outer join

• SELECT statement

• subquery

• unequal join

• update query

Advanced Queries

Skill Exam Objective Objective Number

Creating Crosstab Queries Create a Crosstab query. 4.1.4

Creating a Subquery Add fi eld. 4.3.1
 Remove fi eld. 4.3.2
 Rearrange fi elds. 4.3.3
 Use the Zoom box. 4.5.2

Saving a Filter as a Query

Creating Action Queries Create an Append query. 4.1.3
 Create a Make Table query. 4.1.2

Understanding Advanced Query Modifi cation Create ad hoc relationships. 4.2.3
 Use Expression Builder. 4.5.3
 Perform calculations. 4.5.1
 Use Group By. 4.4.2
 Use the Total row. 4.4.1

286

12
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World Wide Importers is a car dealership that specializes in imported luxury 

cars. The company has recently opened a used car division that sells vehicles 

acquired in trade and expands the buyer’s purchasing options. As the of-

fi ce manager for the new division, you have started using Access to track 

inventory and sales. In this lesson, you learn how to create an action query, 

a crosstab query, a subquery, and how to save fi lters as a query. You also 

learn how to create joins, include calculated fi elds in a query, and create 

aggregated queries.

WW

cc

a

fi

CREATING CROSSTAB QUERIES
Queries are powerful tools that can be used to retrieve exactly the data you need from your da-
tabase, showing only the relevant records. Depending on the information you want to display, 
these advanced queries can help refi ne the results of your search or perform the actions you 
want. A crosstab query calculates a sum, average, count, or other type of total on records 
and then groups the results by two types of information: one down the left side of the datasheet 
and the other across the top. When you summarize data using a crosstab query, you select values 
from specifi ed fi elds or expressions as column headings so you can view data in a more compact 
format than with a select query.

In Lesson 7, you learned how to create and modify several types of queries.

Creating Crosstab Queries
A crosstab query is a special type of query that displays its results in a grid similar to an Excel 
worksheet. Crosstab queries summarize your values and then group them by two sets of facts—a 
set of row headers down the side and a set of column headers across the top. A crosstab query 
typically includes data from more than one table and always includes three types of data: the 
data used as row headings, the data used as column headings, and the values that you want to 
sum or otherwise compute. A crosstab query does not always populate all the fi elds in the result 
set because the tables that you use in the query do not always contain values for every possible 
data point. In this exercise, you create a crosstab query.

The easiest way to create a crosstab query is to use the Crosstab Query Wizard. To run a crosstab 
query, double-click it in the Navigation pane, or click it and then press Enter. When you run a 
crosstab query, the results are displayed in Datasheet View.

STEP BY STEP Create Crosstab Queries

GET READY. Before you begin these steps, be sure to launch Microsoft Access.

1. OPEN the Importers database from the data fi les for this lesson.

2. SAVE the database as Importers XXX (where XXX is your initials).

 3.  On the Create tab, in the Queries group, click the Query Wizard button to display the 
New Query dialog box, shown in Figure 12-1.

Ref

WileyPLUS Extra! features an 
online tutorial of this task.

 The Importers fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.

The Bottom Line
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4.  Click Crosstab Query Wizard and click OK to display the Crosstab Query Wizard, 
shown in Figure 12-2.

Figure 12-1

New Query dialog box

5.  Click Table: Used Cars Sold and then click Next > to display the next screen, shown 
in Figure 12-3.

Figure 12-2

Crosstab Query Wizard, 
screen 1

Figure 12-3

Crosstab Query Wizard, 
screen 2
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6.  In the Available Fields box, double-click Sold By to move it to the Selected Fields box 
and then click Next >. The next screen appears, as shown in Figure 12-4.

7. Click Date Sold and then click Next > to display the next screen, shown in Figure 12-5.

Figure 12-5

Crosstab Query Wizard, 
screen 4

8. Click Month and then click Next > to display the next screen, shown in Figure 12-6.

Figure 12-6

Crosstab Query Wizard, 
screen 5

Figure 12-4

Crosstab Query Wizard, 
screen 3
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9.  In the Fields box, click Sales Price, and in the Functions box, click Sum. Click Next > to 
display the fi nal screen, as shown in Figure 12-7.

10. Click Finish to display the results of the crosstab query, as shown in Figure 12-8.

Figure 12-7

Crosstab Query Wizard, 
fi nal screen

Figure 12-8

Crosstab query results

A crosstab query does not always populate all the fields 
in the result set because the tables used do not always 

contain values for every possible data point.

11. Click the Close button to close the Used Cars Sold Crosstab query.

PAUSE. LEAVE the database open to use in the next exercise.

4.1.4

How do you create crosstab 
queries?
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CREATING A SUBQUERY
You can use a subquery to limit the amount of data returned by a query. A subquery is a 
 SELECT statement that is inside another select or action query. A SELECT statement is a 
SQL command that instructs the Microsoft Access database engine to return information from 
the database as a set of records.

At a minimum, the syntax for a SELECT statement is:

SELECT fi elds FROM table

An asterisk (*) can be used to select all the fi elds in a table. The following example selects all the 
fi elds in the Inventory table:

SELECT * FROM Inventory

Clauses such as WHERE and ORDER BY can be used in a SELECT statement to restrict and 
organize your returned data. Table 12-1 shows some SELECT statements and the results that 
are returned.

Table 12-1

Select Statements with 
Returned Results

SELECT Statement Result

SELECT [FirstName], [LastName]  Displays the values in the FirstName and 

FROM [Employees] WHERE LastName fi elds for employees whose last name is 

[LastName] � “Cooper”; Cooper.

SELECT [ProductID], fi elds [ProductName]  Displays the values for ProductID and ProductName

FROM [Products] WHERE [CategoryID] �  in the Products table for records in which the 

Forms! [New Products]![CategoryID];  CategoryID value matches the CategoryID value 

specifi ed in an open New Products form.

SELECT Avg([ExtendedPrice]) AS  Displays in a fi eld named Average Extended Price the

[Average Extended Price] FROM the average extended price of orders for which the value

[Order Details Extended] WHERE  in ExtendedPrice fi eld is more than 1,000.

[ExtendedPrice] > 1000;

SELECT [CategoryID], Count([ProductID])  Displays in a fi eld named CountOfProductID the total

AS [CountOfProductID] FROM [Products]  number of products for categories with more than

GROUP BY [CategoryID] HAVING  10 products.

Count([ProductID]) > 10

A SELECT statement can be entered in a fi eld or criteria cell in Design View. If you need more 
space in which to enter the SELECT statement in a fi eld or criteria cell, press Shift�F2 and 
enter the statement in the Zoom box. You can see the entire SQL statement by switching to 
SQL View.

In a subquery, you use a SELECT statement to provide a set of one or more specifi c values to 
evaluate in the WHERE or HAVING clause expression. A subquery has three parts:

•  Comparison: An expression and a comparison operator that compares the expression with 
the results of the subquery

• Expression: An expression for which the result set of the subquery is searched
•  Sqlstatement: A SELECT statement, following the same format and rules as any other 

SELECT statement. It must be enclosed in parentheses

The Bottom Line
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Creating a Subquery
In this exercise, you create a subquery that returns results that select only the records from the 
Inventory table whose asking price is equal to or greater than the average asking price. You also 
add, remove, and reposition fi elds while working within the query design grid.

Subqueries are created in Design View. You fi rst need to add the table window with the pertinent 
fi elds to the query design grid by using the Show Table dialog box. You can easily add fi elds from 
the table window either by double-clicking the fi eld name, or by clicking and dragging it to the 
design grid. You can remove fi elds from the query design grid by moving the mouse pointer 
above the fi eld name you want to remove until the pointer changes to a bold down arrow, then 
press delete on the keyboard, or the Delete Columns button in the Query Setup group on the 
Design tab. You can rearrange fi elds on the grid by moving the mouse pointer above the fi eld 
you want to move until the pointer changes to a bold down arrow, then click and drag the fi eld 
to any position on the grid using the vertical placeholder bar that appears as a guide.

STEP BY STEP Create a Subquery

USE the database that is open from the previous exercise.

 1.  On the Create tab, in the Queries group, click Query Design. The query designer opens, 
and the Show Table dialog box appears, as shown in Figure 12-9.

 2.  In the Tables tab, click Inventory, click Add, and then click Close. The table appears as a 
window in the upper section of the query design grid, as shown in Figure 12-10.

Figure 12-9

Show Table dialog box
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To quickly add all the fi elds in a table, double-click the asterisk (*) at the top of the list of table 
fi elds.

3.  In the list of table fi elds, double-click Year, Make, Model, Trim, and AskingPrice to add 
those fi elds to the design grid, as shown in Figure 12-11.

Take Note

Figure 12-10

Query design grid

Table 
field 
list

Double-click a 
field name to add 
it to the query 
design grid below.

Figure 12-11

Fields added to design grid
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4.  Move the insertion point above the Trim fi eld on the design grid until it turns into a bold 
down arrow. Click to highlight and select the Trim column, as shown in Figure 12-12.

5.  Press the Delete key on the keyboard and the Trim column is deleted. The AskingPrice 
fi eld replaces the Trim column.

6.  Move the insertion point above the Model fi eld on the design grid until it turns into a 
bold down arrow. Click to highlight and select the Model column.

7.  On the Design tab, in the Query Setup group, click the Delete Columns button. 
The Model column is deleted.

8.  In the table fi eld list in the Inventory table window, double-click the Model fi eld to add 
it back to the query design grid as the last column.

9.  Move the insertion point above the Model fi eld on the design grid until it turns into 
a bold down arrow. Click to highlight and select the Model column. Click and hold 
the mouse button down and drag the Model fi eld to the left until the black vertical 
placeholder bar is positioned between the Make and AskingPrice fi elds. Your screen 
should resemble Figure 12-13.

Column selected 

Figure 12-12

Column highlighted on 
design grid

Figure 12-13

Query design grid
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 10.  Place the insertion point in the Criteria row of the AskingPrice fi eld and press Shift�F2 
to display the Zoom dialog box.

11. Key the following expression in the Zoom dialog box, as shown in Figure 12-14:

  >�(SELECT Avg(AskingPrice) FROM Inventory WHERE Make � Inventory.Make)

12. Click OK to insert the expression in the Criteria row of the Asking Price fi eld.

13.  On the Design tab, in the Results group, click the View tab, and click SQL View to see 
the entire expression, as shown in Figure 12-15.

Figure 12-14

Zoom dialog box with 
expression

Figure 12-15

SQL View

Subquery WHERE clause in SQL View

14.  On the Design tab, in the Results group, click Run. The query results are displayed, as 
shown in Figure 12-16.
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15. Click the File tab and click Save.

16. In the Save As dialog box, key Subquery as the query name and click OK.

17. Click the Close button to close the Subquery query.

PAUSE. LEAVE the database open to use in the next exercise.

SAVING A FILTER AS A QUERY
A fi lter can be saved as a query so it can be run again anytime you want. If you often work with 
certain fi lters, you might want to save these fi lters so that you are not wasting time defi ning them 
each time. You cannot save more than one fi lter for each table, query, or form—but, you can 
save a fi lter as a query and then apply the query as a fi lter when and where you want.

Saving a Filter as a Query
In this exercise, you create a simple select query, fi lter it, and then save it.

Create a fi lter by form and apply it to the query. On the Home tab, in the Sort & Filter group, 
click the Advanced button and click Advanced Filter/Sort. The new query appears in the Da-
tabase window. It automatically includes all the fi elds from the underlying view. On the Home 
tab, in the Sort & Filter group, click the Advanced button and click Save As Query. Key a name 
for the query and click OK.

To apply the query as a fi lter, click the Advanced button, and click Load from Query to display 
the Applicable Filter dialog box, shown in Figure 12-17.

Figure 12-16

Subquery results

4.3.1

How do you add a fi eld to a 
query?

4.3.2

How do you remove a fi eld 
from a query?

4.3.3

How do you rearrange 
query fi elds?

4.5.2

How do you use the 
Zoom box?

The Bottom Line

Figure 12-17

Applicable Filter dialog box
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Only select queries that are based on the same underlying table or query as the form or datasheet 
will appear in the dialog box. Select the fi lter, click OK, and then apply the fi lter.

STEP BY STEP Save a Filter as a Query

USE the database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click the Query Wizard button.

2. In the New Query dialog box, click Simple Query Wizard and click OK.

3. In the Tables/Queries drop-down list, click Table: Used Cars Sold.

4.  Click the >> button to move all the fi elds from the Available Fields to the Selected 
Fields box and then click Next >.

5. Click Next > again and then click Finish to display a simple select query.

6.  On the Home tab, in the Sort & Filter group, click the Advanced button and then click 
Filter by Form.

7.  In the Filter by Form dialog box, click the Year fi eld down arrow and click 2010, as 
shown in Figure 12-18.

8.  On the Home tab, in the Sort & Filter group, click the Toggle Filter button to apply the 
fi lter. The results are displayed, as shown in Figure 12-19.

Click the down arrow to select criteria by which to filter a field

Figure 12-18

Filter by Form

Results filtered to show only 2010 cars

Figure 12-19

Filter by Form results
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9.  On the Home tab, in the Sort & Filter group, click the Advanced button and then click 
Advanced Filter/Sort to display the new query design grid, shown in Figure 12-20.

Figure 12-21

Design grid

Figure 12-20

New query design grid

New query filter tab

10.  On the Home tab, in the Sort & Filter group, click the Advanced button and then click 
Save As Query. The Save As Query dialog box appears, as shown in Figure 12-21.

11.  Key Filter Query in the Query Name box and click OK.

12. Click the Close button to close the Used Cars Sold Queryfi lter1 query.

13.  On the Home tab, in the Sort & Filter group, click the Toggle Filter button to remove 
the fi lter.

14.  Click the Close button to close the Used Cars Sold Query and save the changes when 
prompted. If another dialog box appears informing you that another user may have 
changed the data, click Yes.

PAUSE. LEAVE the database open to use in the next exercise.

CREATING ACTION QUERIES
An action query changes the data in its datasource or creates a new table. There are four 
types of action queries—append, delete, update, and make table—and except for the make table 
query, action queries make changes to the data in the tables on which they are based.

The Bottom Line
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As their name suggests, action queries make changes to the data in the tables they are based on 
(except for make table queries, which creates new tables). There are four types of action queries:

• Append query: Adds the records in the query’s result set to the end of an existing table

•  Delete query: Removes rows matching the criteria that you specify from one or more 
tables

• Update query: Changes a set of records according to criteria that you specify

•  Make table query: Creates a new table and then creates records in it by copying records 
from an existing table

Changes made by action queries cannot be easily undone, so if you later decide you didn’t want 
to make those changes, usually you will have to restore the data from a backup copy. For this 
reason, you should always make sure you have a current backup of the underlying data before 
running an action query.

To minimize the risk involved in running an action query, you can fi rst preview the data that 
will be acted upon by viewing the action query in Datasheet View before running it. When you 
are ready to run an action query, double-click it in the Navigation pane or click it and then press 
Enter. Or, on the Design tab, in the Results group, click Run.

Creating an Append Query
An append query adds a set of records from one or more source tables (or queries) to one or 
more destination tables. Typically, the source and destination tables reside in the same database, 
but they don’t have to. For example, suppose you acquire some new customers and a database 
that contains a table of information about those customers. To avoid entering that new data 
manually, you can append it to the appropriate table in your database. In this exercise, you 
practice creating an append query.

You can also use append queries to append fi elds that are based on criteria. For example, you 
might want to append only the names and addresses of customers who have outstanding orders. 
Or you can use append queries to append records when some of the fi elds in one table don’t exist 
in the other table. For example, suppose that your Customers table has 10 fi elds, and the fi elds 
in the Clients table in another database match 8 of your 10 fi elds. You can use an append query 
to add only the data in the matching fi elds and ignore the others.

You cannot use append queries to change the data in individual fi elds in existing records. To 
do that type of task, you use an update query—you can only use append queries to add rows 
of data.

STEP BY STEP Create an Append Query

USE the database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click the Query Design button.

2.  In the Show Table dialog box, double-click Inventory to add it to the upper section of 
the query design grid.

3. Click Close to close the Show Table dialog box.

4.  In the list of table fi elds, double-click Year, Make, Model, and Asking Price to add those 
fi elds to the design grid. Your screen should look similar to Figure 12-22.
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5.  On the Design tab, in the Results group, click Run. Verify that the query returned the 
records that you want to append, as shown in Figure 12-23.

Figure 12-22

Design grid

Figure 12-23

Records to be appended

If you need to add or remove fi elds from the query, switch back to Design View and double-
click to add fi elds or select the fi elds that you don’t want and press Delete to remove them from 
the query.

6.  Right-click the document tab for the open query and click Design View on the shortcut 
menu.

7.  On the Design tab, in the Query Type group, click Append. The Append dialog box 
appears, as shown in Figure 12-24.

Take Note
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8.  In the Table Name box, click the down arrow and click Used Cars Sold. This is the table 
you want to append to. The Current Database radio button should be selected.

9.  Click OK. Access automatically adds the names of the destination fi elds that match the 
source fi eld names to the Append To row in the design grid. Because the Asking Price 
fi eld doesn’t have a match, Access leaves that fi eld blank.

10.  Click the blank fi eld in the Append To row under the Asking Price cell and select Sales 
Price as the destination fi eld, as shown in Figure 12-25.

Figure 12-24

Append dialog box

Click the down arrow to 
manually choose SalesPrice 
as the destination field for 
the AskingPrice source field

Figure 12-25

Source and destination 
fi elds matched

11.  Right-click the document tab for the query, and then click Datasheet View to preview 
your changes.

12. Right-click the document tab for the query, and then click Design View.

13.  On the Design tab, in the Results group, click Run. An alert message appears, as 
shown in Figure 12-26.

Figure 12-26

Append alert message

14. Click Yes.

15.  Open the Used Cars Sold table and scroll down to see that the records from the 
Inventory table have been appended to the end, as shown in Figure 12-27.
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16. Click the Close button to close the Used Cars Sold table.

17. Click the File tab and click Save.

18. In the Save As dialog box, key Append Query as the query name and click OK.

19. Click the Close button on Append Query to close the query.

PAUSE. LEAVE Access open to use in the next exercise.

Creating a Make Table Query
A make table query is an action query that creates a new table and then creates records in it 
by copying records from an existing table. You use a make table query when you need to copy 
the data in a table or to archive data. In this exercise, you practice creating a make table query.

STEP BY STEP Create a Make Table Query

USE the database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click the Query Wizard button.

2. In the New Query dialog box, click Simple Query Wizard and click OK.

3. In the Tables/Queries drop-down list, click Table: Sales Team.

4.  Click the >> button to move all the fi elds from the Available Fields to the Selected 
Fields box and then click Next >.

5. Click Finish to display a simple select query.

6.  Right-click the Sales Team Query document tab and click Design View to display the 
query in Design View, as shown in Figure 12-28.

Original records

Appended 
records

Figure 12-27

Results of append query

4.1.3

How do you create append 
queries?
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7.  On the Design tab, in the Query Type group, click Make Table. The Make Table dialog 
box appears, as shown in Figure 12-29.

Figure 12-28

Query in Design View

Figure 12-29

Make Table dialog box

8.  In the Table Name box, key Sales Team Backup. If it isn’t already selected, click 
Current Database, and then click OK.

9.  On the Design tab, in the Results group, click Run. An alert message appears, as 
shown in Figure 12-30.

Figure 12-30

Make table alert message

10. Click Yes. A new table appears in the Navigation pane.

11.  Double-click Sales Team Backup: Table in the Navigation pane to open the new table, 
as shown in Figure 12-31.
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 12. Click the Close button to close the Sales Team Backup table.

 13.  Click the Close button to close the Sales Team query. Save the changes when 
prompted.

 14. LEAVE the database open.

PAUSE. LEAVE Access open to use in the next exercise.

Creating an Update Query
An update query is an action query that changes a set of records according to specifi ed criteria. 
Use an update query when you need to add, change, or delete the data in one or more existing 
records. You can think of update queries as a powerful form of the Find and Replace dialog box. 
In this exercise, you practice making an Update Query.

When making an update query, you enter a select criterion and an update criterion. Unlike the 
Find and Replace dialog box, update queries can accept multiple criteria. You can use them to 
update a large number of records in one pass and to change records in more than one table at 
one time. You can also update the data in one table with data from another—as long as the data 
types for the source and destination fi elds match or are compatible.

To create an update query, fi rst create or open a select query. On the Design tab, in the Query 
Type group, click Update. Access adds the Update to row in the query design grid. Locate the 
fi eld that contains the data you want to change, and type your change criteria in the Update to 
row for that fi eld.

You can use any valid expression in the Update to row. Table 12-2 shows some example expres-
sions and explains how they change data.

New table now 
available in the 
Navigation pane

Figure 12-31

New table

4.1.2

How do you create make 
table queries?
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STEP BY STEP Create an Update Query

USE the database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click the Query Wizard button.

2. In the New Query dialog box, click Simple Query Wizard and click OK.

3. In the Tables/Queries drop-down list, click Table: Inventory.

4.  Click the >> button to move all the fi elds from the Available Fields to the Selected 
Fields box.

5.  Click Trim and then the < button to move it back to the Selected Fields box. Click Color 
and then the < button to move it back to the Selected Fields box. Click Next >.

6.  Click Next > again and then click Finish to display a simple select query in Datasheet 
View, as shown in Figure 12-32.

Expression Result

“Chicago” In a Text fi eld, changes a text value to Chicago.

#9/25/11# In a Date/Time fi eld, changes a date value to 25-Sept-11.

Yes In a Yes/No fi eld, changes a No value to Yes.

“PN” & [PartNumber] Adds “PN” to the beginning of each specifi ed part number.

[UnitPrice] * [Quantity] Multiplies the values in fi elds named UnitPrice and Quantity.

[Shipping] * 1.5 Increases the values in a fi eld named Shipping by 50 percent.

DSum(“[Quantity] * 

[UnitPrice]”, “Order Details”, 

“[ProductID] =”& [ProductID])

Where the ProductID values in the current table match the ProductID 

values in table named Order Details, this expression updates sales 

totals by multiplying the values in a fi eld named Quantity by the values 

in a fi eld named UnitPrice. The expression uses the DSum function 

because it can operate against more than one table and table fi eld.

Right([PostalCode], 5) Removes the leftmost characters in a text or numeric string and 

leaves the 5 rightmost characters.

IIf(IsNull([SalesPrice]), 0, 

[SalesPrice])

Changes a null (unknown or undefi ned) value to a zero (0) value in a 

fi eld named SalesPrice.

Table 12-2

Expressions and How They 
Change Data

Figure 12-32

Select query in Datasheet View
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7.  Right-click the Inventory Query document tab and click Design View to display the 
query in Design View, as shown in Figure 12-33.

8. Key 2012 in the Criteria row of the Year fi eld.

9.  On the Design tab, in the Query Type group, click Update. Access adds the Update To 
row in the query design grid.

10.  In the Update To row of the AskingPrice fi eld, key [AskingPrice] � 500. The design grid 
should look similar to Figure 12-34.

Figure 12-33

Select query in Design View

Update criteria

Figure 12-34

Select and update criterion

11.  On the Design tab, in the Results group, click Run. An alert message appears, as 
shown in Figure 12-35.

Figure 12-35

Update alert message
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12. Click Yes.

13.  Right-click the Inventory Query document tab and click Datasheet View to display the 
update query results, as shown in Figure 12-36.

When you run the query, you will notice that some fi elds are missing from your result set. If the 
query contains fi elds that you don’t update, Access does not display those fi elds in the results.

14. Click the Close button to close the Inventory query. Save the changes when prompted.

15.  Double-click Inventory: Table in the Navigation pane to open it. Notice that the asking 
price for all 2012 cars has been increased by $500.

16.  Click the Close button to close the Inventory table.

17. LEAVE the database open.

PAUSE. LEAVE Access open to use in the next exercise.

Creating a Delete Query
A delete query is an action query that removes rows matching the criteria that you specify 
from one or more tables. A delete query is used to delete entire records from a table, along with 
the key value that makes a record unique. Typically, delete queries are used only when you need 
to change or remove large amounts of data quickly. To remove a small number of records, open 
the table in Datasheet View, select the fi elds or rows that you want to delete, and press Delete.

To create a delete query, fi rst create or open a select query and add criteria to return the records 
you want to delete. On the Design tab, in the Query Type group, click Delete. Access changes 
the select query to a delete query, hides the Show row in the lower section of the design grid, and 
adds the Delete row. The word Where should appear in any columns that you use for criteria.

When you click Run, Access prompts you to confi rm the deletion. Click Yes to delete the data 
and then open the table to see that the records have been deleted.

STEP BY STEP Create a Delete Query

USE the database that is open from the previous exercise.

 1. On the Create tab, in the Queries group, click Query Wizard.

 2. In the New Query dialog box, click Simple Query Wizard and click OK.

Take Note

The query contains fields 
that you don’t update, so 
Access does not display 
those fields in the results

Figure 12-36

Update query results
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3. In the Tables/Queries drop-down list, click Table: Used Cars Sold.

4.  Click the >> button to move all the fi elds from the Available Fields to the Selected 
Fields box and then click Next >.

5. Click Next > again.

6. Key Delete Query as the title and then click Finish displaying a simple select query.

7.  Right-click the Delete Query document tab and click Design View to display the query 
in Design View.

8. Key <#3/31/2012# in the Criteria row of the Date Sold fi eld, as shown in Figure 12-37.

Figure 12-37

Date Sold criteria

9.  On the Design tab, in the Results group, click Run to display the records to be deleted, 
as shown in Figure 12-38.

Figure 12-38

Records to be deleted

10.  Right-click the Delete Query document tab and click Design View to display the query 
in Design View.

11.  On the Design tab, in the Query Type group, click Delete. Access hides the Show 
row in the lower section of the design grid and adds the Delete row, as shown in 
Figure 12-39.
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12.  On the Design tab, in the Results group, click Run. An alert message appears, as 
shown in Figure 12-40.

Delete 
row 
added

Figure 12-39

Delete row in design grid

Figure 12-40

Delete alert message

 13. Click Yes.

14.  Double-click Used Cars Sold: Table in the Navigation pane to open it. Notice that all 
the records for cars sold before March 31, 2012 have been deleted, as shown 
in Figure 12-41.

All the records 
for cars sold 
before March 
31, 2012 have 
been deleted

Figure 12-41

Table with records deleted
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15. Click the Close button on Used Cars Sold to close the table.

16.  Click the Close button on Delete Query to close the query. Save the changes when 
prompted.

17. LEAVE the database open.

PAUSE. LEAVE Access open to use in the next exercise.

UNDERSTANDING ADVANCED QUERY MODIFICATION
After a query has been created, you can modify it in various ways to suit your purposes—by 
creating a join, creating calculated fi elds, or using aggregated functions.

Creating a Join
Relational databases consist of tables that have logical relationships to each other. You use rela-
tionships to connect tables on fi elds that they have in common. A relationship between identical 
fi elds in different tables is represented by a join in Design View. When you include multiple 
tables in a query, you use joins to help you get the results you want. A join helps a query return 
only the records from each table you want to see, based on how those tables are related to other 
tables in the query. When you add tables to a query, Access creates joins that are based on rela-
tionships that have been defi ned between the tables. You can manually create joins known as ad 
hoc relationships in queries, even if they do not represent relationships that have already been 
defi ned. In this exercise, you create a join between tables.

If the relationship is one-to-many, Access displays a “1” above the join line to show which table 
is on the “one” side and an infi nity symbol (�) to show which table is on the “many” side.

The four basic types of joins are inner joins, outer joins, cross joins, and unequal joins. An 
inner join includes rows in the query only when the joined fi eld matches records in both 
tables. Inner joins are the most common type of join. Most of the time, you don’t need to do 
anything to use an inner join. Access automatically creates inner joins if you add two tables to 
a query and those tables each have a fi eld with the same or compatible data type and one of the 
join fi elds is a primary key.

An outer join includes all of the rows from one table in the query results and only those rows 
from the other table that match the join fi eld in the fi rst table. You create outer joins by modify-
ing inner joins.

To create an outer join, double-click the line joining the tables to display the Join Properties 
dialog box. In the Join Properties dialog box, Option 1 represents an inner join. Option 2 
is a left outer join, where the query includes all of the rows from the fi rst table and only 
those records from the second table that match the join fi eld in the fi rst table. Option 3 is a 
right outer join, where the query includes all of the rows from the second table and only 
those rows from the fi rst table that match the join fi eld in the second table.

To tell which table is the left table or the right table in a given join, double-click the join to view 
the Join Properties dialog box.

Because some of the rows on one side of an outer join will not have corresponding rows from the 
other table, some of the fi elds returned in the query results from that other table will be empty 
when the rows do not correspond.

In a cross join, each row from one table is combined with each row from another table. Any 
time you run a query that has tables that are not explicitly joined, a cross join is produced. Cross 
joins are usually unintentional, but there are cases where they can be useful. A cross join can be 
used if you want to examine every possible combination of rows between two tables or queries.

If you want to combine the rows of two sources of data based on fi eld values that are not equal, 
you use an unequal join. Typically, unequal joins are based on either the greater than (>), less 
than (<), greater than or equal to (>=), or less than or equal to (<=) comparison operators. Unequal 
joins are not supported in Design View. If you wish to use them, you must do so in SQL View.

Take Note

Take Note

The Bottom Line
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Troubleshooting If you create a join by mistake, for example, a join between two fi elds that have dissimilar 
data types, you can delete it. In the query design grid, click the join you want to remove 
and press Delete.

STEP BY STEP Create a Join

USE the database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click Query Design.

2.  In the Show Table dialog box, double-click Sales Team and Used Cars Sold to add 
them to the design grid.

3. Click Close.

4. In the Sales Team fi eld list, double-click E-mail Address.

 5.  In the Used Cars Sold fi eld list, double-click Year, Make, Model, and Sales Price. Your 
screen should look similar to Figure 12-42.

Double-click join line to open 
the Join Properties dialog box

Inner join 
option

Right outer 
join option

Left outer 
join option

Figure 12-42

New query

6.  Double-click the join line between the tables, indicating which fi elds are joined. The 
Join Properties dialog box opens, as shown in Figure 12-43.

Figure 12-43

Join properties dialog box
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7. Click the radio button for option 2: and then click OK to create a left outer join.

8. On the Design tab, in the Results group, click Run.

9. The results of the query are displayed, as shown in Figure 12-44.

4.2.3

How do you create ad hoc 
relationships between tables?

Results include all of the rows from the first table and only those records 
from the second table that match the join field in the first table.

Figure 12-44

Left outer join

10. Save the query as Join Query and close.

11. LEAVE the database open.

PAUSE. LEAVE Access open to use in the next exercise.

Creating a Calculated Query Field
You can create a new fi eld that displays the results of a calculation you defi ne with an expression 
or that manipulates fi eld values. A calculated fi eld is a column in a query that results from 
an expression. For example, you can calculate a value; combine text values, such as fi rst and last 
names; or format a portion of a date. In this exercise you use the Expression Builder to create a 
calculated query by subtracting two fi elds to determine a markup price.

You can use expressions that perform arithmetic operations in calculated fi elds to add, subtract, 
multiply, and divide the values in two or more fi elds. You can also perform arithmetic operations 
on dates or use expressions that manipulate text. Table 12-3 shows examples of expressions that 
can be used in calculated fi elds.
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A well-designed database does not store simple calculated values in tables. For example, a table 
might store an employee’s hire date, but not how long she has worked for the company. If you 
know both today’s date and the employee’s date of hire, you can always calculate her employ-
ment length, so there is no need to store that in the table. Instead, you create a query that calcu-
lates and displays the pertinent value. The calculations are made every time you run the query, 
so if the underlying data changes, so do your calculated results.

To create a calculated fi eld, fi rst open or create a query and switch to Design View. In the Field 
row of the fi rst blank column in the design grid, key the expression. You can use the Zoom box 
to access a larger screen area to help you enter the expression or, as you learned in Lesson 8, you 
can use the Expression Builder to easily select the elements of the expression (fi elds, operators, 
and built-in functions) from menus. To name the fi eld, key a name followed by a colon before 
the expression. If you do not supply a name, Access will use a generic name for the fi eld, for 
example, EXPR1. The string following the colon is the expression that supplies the values for 
each record. To see the SQL code, you can switch to SQL View.

STEP BY STEP Create a Calculated Query Field

USE the database that is open from the previous exercise.

1. On the Create tab, in the Queries group, click Query Design.

2.  In the Show Table dialog box, double-click Inventory to add the table to the 
design grid.

3. Click Close.

4.  In the Inventory fi eld list, double-click Year, Make, Model, AskingPrice, and 
TradeInValue.

5.  Click the Field cell in the fi rst blank column (to the right of the TradeInValue fi eld) 
and click the Builder button in the Query Setup group to open the Expression Builder 
dialog box.

 6. In the blank area of the dialog box, key the following:

  Markup: [AskingPrice]

 7.  In the Expression Elements category, click Operators. The dialog box should resemble 
Figure 12-45.

Expression Description

PrimeShip: [Ship] * 1.1 Creates a fi eld called PrimeShip, and then displays shipping charges 

plus 10 percent in the fi eld.

OrderAmount: [Quantity] * 

[Price]

Creates a fi eld called OrderAmount, and then displays the product of 

the values in the Quantity and Price fi elds.

LeadTime: [RequiredDate] – 

[ShippedDate]

Creates a fi eld called LeadTime, and then displays the difference 

between the values in the RequiredDate and ShippedDate fi elds.

TotalInventory: [UnitsInStock] � 

[UnitsOnOrder]

Creates a fi eld called TotalInventory, and then displays the sum of the 

values in the UnitsInStock and UnitsOnOrder fi elds.

FullName: [FirstName] & “ “ & 

[LastName]

Creates a fi eld called FullName that displays the values in the 

FirstName and LastName fi elds, separated by a space.

Address2: [City] & “ “ & 

[Region] & “ “ & [PostalCode]

Creates a fi eld called Address2 that displays the values in the City, 

Region, and PostalCode fi elds, separated by spaces.

Table 12-3

Expressions that Can Be Used 
in Calculated Fields
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8.  In the Expression Values category, double-click the minus sign (�). The minus sign 
should appear in the expression and next to the AskingPrice fi eld.

9.  In the Expression Elements category, click the expand button next to Importers.accdb. 
Tables, Queries, Forms, and Reports should appear under Importers.accdb.

10.  In the Expression Elements category, click the expand button next to Tables to expand 
it. The available table names appear. Click Inventory. The available fi eld from the 
Inventory table should appear in the Expression Categories box. Your screen should 
resemble Figure 12-46.

Expression

Operators

Expression Categories 
and Values appear once 
Operators button is clicked.

Expand button for 
Importers.accdb

Figure 12-45

Expression Builder

Importers.accdb
expanded

Tables expanded

Inventory 
table selected

Available fields 
from Inventory table

11.  In the Expression Categories box, double-click TradeInValue; [Inventory]!TradeInValue 
should appear in the expression and next to the minus sign (�).

The part of the expression that reads [Inventory]!TradeInValue specifi es that the TradeInValue
fi eld originates from the Inventory table; however, even though Access automatically formats 
it this way, this expression format is not required since you’re already referencing the Inventory 
table in the Table row of the design grid.

12. Click OK.

13.  On the Design tab, in the Results group, click Run. The query with the new calculated 
Markup fi eld is displayed, as shown in Figure 12-47.

Take Note

Figure 12-46

Expression Builder with 
Expression Elements 

expanded
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14. Save the query as Calculated Query and close.

15. LEAVE the database open.

PAUSE. LEAVE Access open to use in the next exercise.

Creating Aggregated Queries
An aggregate function performs a calculation on a set of values and then returns a single 
value. You can add, count, or calculate other aggregate values, and display them in a special 
row, called the Total row, which appears below the asterisk (*) row in Datasheet View. You can 
use a different aggregate function for each column and you can also choose not to summarize 
a column. You can use aggregated functions to count the data returned by a query; calculate 
average values; and fi nd the smallest, largest, earliest, and latest values using a feature called the 
Total row, which doesn’t alter the design of your query. You can work with the Total row in both 
query Design and query Datasheet Views. In this exercise, you create an aggregated query using 
the Total row in both query Design and query Datasheet Views.

You can also apply aggregated functions in Design View where you also have the ability to use 
the Group By function in the Totals row on the design grid. The Group By function can be used 
in combination with other fi elds and aggregated functions. For example, if you’re managing a 
human resource database, you can group by employees’ gender and display the average salary 
per group.

The following aggregated functions are available in both Datasheet View and Design View:

• Count: Counts the number of items in a fi eld (column of values)

• Sum: Sums a column of numbers

• Average: Averages a column of numbers

• Maximum: Finds the highest value in a fi eld

• Minimum: Finds the lowest value in a fi eld

•  Standard Deviation: Measures how widely values are dispersed from an average value 
(a mean)

• Variance: Measures the statistical variance of all values in the column

The following additional aggregated functions are available in Design View:

• First: Finds the fi rst value in a fi eld

• Last: Finds the last value in a fi eld

New field 
with results 
of calculated 
expression

Figure 12-47

Calculated fi eld query results

4.5.1

How do you create a 
calculated query fi eld?

4.5.3

How do you use Expression 
Builder to create a calculated 

query fi eld?
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• Expression: Groups data based on an expression you can specify

• Where: Groups data based on criteria you can specify

Many of the aggregated functions work only on data fi elds set to specifi c data types. For 
example, if you are in a column that only displays text values, some functions—such as Sum 
or Average—are not relevant, and are therefore not available.

STEP BY STEP Create an Aggregated Query

USE the database that is open from the previous exercise.

 1. On the Create tab, in the Queries group, click Query Design.

 2.  In the Show Table dialog box, double-click Inventory to add the table to the 
design grid.

 3. Click Close.

 4.  In the Inventory fi eld list, double-click Year, Make, Model, Mileage, AskingPrice, and 
TradeInValue to add them to the design grid.

 5. On the Design tab, in the Results group, click Run.

 6.  On the Home tab, in the Records group, click the Totals button. Scroll down, if 
necessary, to see the Totals row at the bottom of the result set.

 7.  In the Totals cell of the Year fi eld, click the down arrow to display the menu and click 
Count, as shown in Figure 12-48.

Take Note

Click the down 
arrow in the 
Totals row to 
see aggregate 
function options.

Figure 12-48

Totals row menu options
8. Click the down arrow in the Totals cell of the Mileage fi eld and click Average.

9. Click the down arrow in the Totals cell of the AskingPrice fi eld and click Maximum.

10.  Click the down arrow in the Totals cell of the TradeInValue fi eld and click Sum. Your 
Totals row should appear similar to Figure 12-49.
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11.  Switch to Design View and remove the Model, Mileage, AskingPrice, and TradeInValue 
from the design grid. The Year and Make fi elds should be the only ones remaining on 
the grid.

 12.  On the Design tab, in the Show/Hide group, click the Totals button. A new Totals row 
should appear below the Table row on the design grid.

 13.  Click the Group By cell below the Make fi eld cell and click the down arrow to display 
the aggregate function menu.

 14. Click the Count aggregate function to select it from the menu, as shown in Figure 12-50.

Count Average Maximum Sum

Figure 12-49

Aggregate function results

Aggregate function menu in Total row

Figure 12-50

Aggregate function menu in 
Design View
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15.  Switch to Datasheet View. Your screen should resemble Figure 12-51. Notice the 
records in the Make fi eld are grouped by Year and counted with the results appearing 
in a new column named CountOfMake. Also notice the Year fi eld is grouped and each 
year remains counted as applied from the aggregate function we created previously in 
Datasheet View.

Figure 12-51

Aggregate function results

 16. Save the query as Aggregated Query and close.

17. CLOSE the database.

PAUSE. LEAVE Access running to use in the next exercise.

4.4.1

How do you use the Total row 
to calculate totals in queries?

4.4.2

How do you use Group By to 
calculate totals in queries?

In This Lesson  Objective
You Learned How To: Exam Objective Number

Create Crosstab Queries Create a Crosstab query. 4.1.4

Create a subquery Add fi elds. 4.3.1
 Remove fi elds. 4.3.2
 Rearrange fi elds. 4.3.3
 Use the Zoom box. 4.5.2

Save a Filter as a Query

Create Action Queries Create an Append query. 4.1.3
 Create a Make Table query. 4.1.2

Understand Advanced Query Create ad hoc relationships. 4.2.3
 Modifi cation Use Expression Builder. 4.5.3
 Perform calculations. 4.5.1
 Use Group By. 4.4.2
 Use the Total row. 4.4.1

SKILL SUMMARY
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Knowledge Assessment

Fill in the Blank

Complete the following sentences by writing the correct word or words in the blanks provided.

 1. A(n)  is a SELECT statement that is inside another select or action 
query.

 2. A(n)  removes rows matching on the criteria that you specify from 
one or more tables.

 3. To minimize the risk of running an action query, you can fi rst preview the data that will 
be acted upon by viewing the action query in  View before running it.

 4. A(n)  includes all of the rows from one table in the query results and 
only those rows from the other table that match the join fi eld in the fi rst table.

 5. A(n)  is a column in a query that results from an expression.

 6. You can use the Group By function in the  row on the design grid in 
query Design View.

 7. A(n)  performs a calculation on a set of values and then returns a 
single value.

 8. A(n)  query always includes three types of data: the data used as row 
headings, the data used as column headings, and the values that you want to sum or 
otherwise compute.

 9. To quickly add all the fi elds in a table to the design grid in Design View, double-click 
the  at the top of the list of table fi elds.

 10. To be able to apply a fi lter when and where you want, save the fi lter as 
a(n) .

Multiple Choice

Select the best response for the following statements or questions.

 1. What type of query displays its results in a grid similar to an Excel worksheet?

a. Crosstab

b. Append

c. Aggregated

d. Subquery

 2.  What can you use for a more intuitive interface in which to enter criteria or an 
expression in a fi eld or criteria cell?

a. Zoom box

b. Field list pane

c. Control label

d. Expression Builder

 3. Which action query does not make changes to the data in the tables that it is based on?

a. Append

b. Make table

c. Update

d. Delete

 4.  Which type of query can be thought of as a powerful version of the Search and 
Replace dialog box?

a. Filter

b. Calculated fi eld

c. Update

d. Crosstab
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 5. Which of the following is not a type of join?

a. Inner join

b. Exterior join

c. Cross join

d. Unequal join

 6. Which of the following is not an aggregated function?

a. Lowest

b. Sum

c. Average

d. Count

 7.  Which of the following SELECT statement selects all the fi elds from the Inventory 
table?

a. SELECT all fi elds FROM Inventory

b. SELECT [ALL] from [INVENTORY]

c. SELECT from INVENTORY {all fi elds}

d. SELECT * FROM Inventory

 8.  For more space in which to enter the SELECT statement in a fi eld or criteria cell, what 
do you press to display the Zoom box?

a. Shift�F2

b. Ctrl�2

c. Shift�Enter

d. Ctrl�Spacebar

 9. To undo the changes made by an action query,

a. Click the Undo button

b. Restore the data from a backup copy

c. Switch to Datasheet View

d. Run the query again

 10.  Which type of query adds the records in the query’s result set to the end of an existing 
table?

a. Append

b. Make table

c. Update

d. Delete

Project 12-1: Create a Calculated Query Field
In your job as a travel agent at Margie’s Travel, you are frequently asked the length of various trips. 
So that you don’t have to calculate it mentally, create a calculated fi eld that will give you this 
 information.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN the M Travel database from the data fi les for this lesson.

 2. SAVE the database as M Travel XXX (where XXX is your initials).

 3. On the Create tab, in the Queries group, click Query Design.

 4. In the Show Table dialog box, double-click Events to add the table to the design grid.

Competency Assessment

           The M Travel fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.
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 5. Click Close.

 6.  In the Inventory fi eld list, double-click Event, StartTime, and EndTime to add them to 
the design grid.

 7.  Click the Field cell in the fi rst blank column and press Shift�F2 to open the Zoom 
dialog box.

 8. In the Zoom dialog box, key the following expression:

  TripLength: [EndTime] � [StartTime]

 9. Click OK.

 10.  On the Design tab, in the Results group, click Run. The query is displayed, with a new 
TripLength fi eld calculating the number of days of the trip.

 11. Save the query as Calculated Query and close.

 12. CLOSE the database.

LEAVE Access running for the next project.

Project 12-2: Save a Filter as a Query
As purchasing manager for the Coho Vineyard monthly wine, you frequently run the same fi lters on 
the database. Now that you have learned to save a fi lter as a query, you can save yourself some time.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN Wine Coho from the data fi les for this lesson.

 2. SAVE the database as Wine Coho XXX (where XXX is your initials).

 3. On the Create tab, in the Queries group, click the Query Wizard button.

 4. In the New Query dialog box, click Simple Query Wizard and click OK.

 5. In the Tables/Queries drop-down list, click Table: Red Wines.

 6.  Click the >> button to move all the fi elds from the Available Fields to the Selected 
Fields box and then click Next >.

 7. Click Next > again and then click Finish to display a simple select query.

 8.  On the Home tab, in the Sort & Filter group, click the Advanced button and then 
click Filter by Form.

 9. In the Filter by Form, click the down arrow in the Country fi eld and click Italy.

 10.  On the Home tab, in the Sort & Filter group, click the Toggle Filter button to apply the 
fi lter. The results are displayed.

 11.  On the Home tab, in the Sort & Filter group, click the Advanced button and then click 
Advanced Filter/Sort to display the new query design grid.

 12.  On the Home tab, in the Sort & Filter group, click the Advanced button and then click 
Save As Query. The Save As Query dialog box appears.

 13. Key Filter Query in the Query Name box and click OK.

 14. Click the Close button to close the Red Wines QueryFilter1 query.

 15.  On the Home tab, in the Sort & Filter group, click the Toggle Filter button to remove 
the fi lter.

 16.  Click the Close button to close the Red Wines query and save the changes when 
prompted.

 17. LEAVE the database open.

LEAVE Access open for the next project.

          The Wine Coho fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.
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Profi ciency Assessment

Project 12-3: Create a Subquery
You are interested in extracting specifi c information about the wine prices from the database. Create 
a subquery to determine which white wines have a purchase price that is above average.

USE the database that is open from the previous project.

 1. On the Create tab, in the Queries group, click Query Design.

 2.  Use the Show Table dialog box to add the White Wines table to the upper section of 
the query design grid and then close it.

 3. Add the Bottled, Label, Type, and PurchasePrice fi elds to the design grid.

 4.  Place the insertion point in the Criteria row of PurchasePrice fi eld and display the 
Expression Builder.

 5.  Key the following expression in the Expression Builder, using the available categories 
and menus:

  > (SELECT AVG([PurchasePrice]) FROM [White Wines])

 6. Click OK.

 7. On the Design tab, in the Results group, click Run to display the query results.

 8. Save the query as Subquery and close.

 9. CLOSE the database.

LEAVE Access open for the next project.

Project 12-4: Create a Make Table Query
As the manager at Southridge Video, you want to archive the current table with information about 
used games. Use the make table action query to create a backup table.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN Games Southridge from the data fi les for this lesson.

 2. SAVE the database as Games Southridge XXX (where XXX is your initials).

 3.  Create a simple select query named Games Query using all the fi elds in the 
Games: Table.

 4. Display the query in Design View if it is not already.

 5.  On the Design tab, in the Query Type group, click Make Table to display the Make Table 
dialog box.

 6.  In the Table Name box, key Games Backup. If it is not already selected, click Current 
Database, and then click OK.

 7. On the Design tab, in the Results group, click Run. An alert message appears.

 8. Click Yes. A new table appears in the Navigation Pane.

 9. Close the Games Query and save the changes when prompted.

 10. CLOSE the database.

LEAVE Access open for the next project.

          The Games 
Southridge fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.
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4. LEAVE the database open for the next project.

LEAVE Access open for the next project.

Project 12-6: Create an Update Query
The name of one of the hospitals in your region has recently been changed. You need to create an 
update query to change the name in the database.

USE the database that is open from the previous project.

1.  Create a select query named Update Query that includes all the fi elds in the 
Doctors: Table.

 2. Switch to Design View.

 3.  Use criteria to select only the records that have Community Medical Center in the 
Hospital fi eld.

 4.  Use the skills you have learned in this lesson to create an update query that will 
change the name of Community Medical Center to Community Regional Hospital.

 5.  Open the Doctors: Table to verify that the hospital name has been changed. Then, 
close the table and the query.

 6. CLOSE the database.

CLOSE Access.

Mastery Assessment

Project 12-5: Create a Crosstab Query
As a regional manager for Contoso Pharmaceuticals, you are in charge of overseeing the sales reps in 
your division. To determine the total samples given by each rep in the fi rst two weeks of the quarter, 
you decide to create a crosstab query.

GET READY. LAUNCH Access if it is not already running.

1. OPEN Contoso Data from the data fi les for this lesson.

2. SAVE the database as Contoso Data XXX (where XXX is initials).

 3.  Use the Samples Given: Table and the skills you have learned in this lesson to create 
the crosstab query named Samples Given_Crosstab shown in Figure 12-52.

          The Contoso Data 
fi le for this lesson is 
available on the book 
companion website or in 
WileyPLUS.

Figure 12-52

Crosstab query
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INTERNET READY
At this point in the book, you have learned a 

lot about using Access. If you want to learn even more about 
Access from a programming and coding perspective, you can 
explore the Microsoft Developers Network (MSDN) web-
site. The URL for this site is http://msdn.microsoft.com. 

Here you can ask and answer questions in forums related to 
Access 2010 and all Microsoft applications and technologies, 
stay connected with the MSDN community to explore new 
innovations and technologies, and read articles about techni-
cal trends. The MSDN home page is shown in Figure 12-53.

CREATING MAILING LABELS IN ACCESS
Keeping track of sales data and contacts is vital to the success of any business.  Access provides 
the tools you need to not only keep these records available and secure, but also to generate sales 
and provide customer service. Whether you need to mail a single sales brochure or do a mass 
mailing of two hundred, you can use Access to create the labels using the records you maintain 
in your Access databases.

Imagine you are a partner in a start-up software fi rm named Proseware, Inc., that has developed 
specialized software for colleges and universities. You have created an Access database with tables 
that include information for customers as well as sales leads for professors to whom you are 
marketing the product.

Using the Label Wizard in Access, you can create mailing labels and sort them by zip code for 
bulk mailing. You can create a parameter query that uses one or more criteria to select only cer-
tain records for labels. You can specify a label size that matches a brand of label sheets you can 
purchase at the offi ce supply store, or you can choose to create a custom-sized sheet of labels. 
With Access, you can produce professional, high-quality mailings to your targeted audience 
quickly and effi ciently.

WorkplaceReady

Figure 12-53

MSDN home page
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