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 108 Lesson 5

You are the owner of the Graphic Art Institute, a small fi ne-arts gallery dedicated 

to presenting challenging and contemporary visual arts and educational pro-

grams. The current exhibition is successfully under way; you are now calling for 

submissions for the next exhibition—a juried art show featuring photographic 

work from the local region. The competition is open to all regional artists who 

use photographic processes in their work. This particular event will be open to 

digital submissions. As each submission is received, you will enter the artist 

and image information into an Access database for easy retrieval. In this 

lesson, you learn how to create forms using a variety of methods; how to apply 

a Theme to a form; and how to sort and fi lter data within a form.
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SOFTWARE ORIENTATION

Forms Group

The Forms group (Figure 5-1) is located on the Create tab in the Ribbon and can be used 
to create a variety of forms.

Use this fi gure as a reference throughout this lesson as well as the rest of this book.

 Figure 5-1 

Forms group

Create a simple form Create a new blank form in Layout View

Create a new blank form in Design View

Create a new 
form using the 
Form Wizard

The Bottom Line

CREATING FORMS
A form is a database object that you can use to enter, edit, or display data from a table or query. 
Forms can be used to control access to data by limiting which fi elds or rows of data are displayed 
to users. For example, certain users might need to see only certain fi elds in a table. Providing 
those users with a form that contains just those fi elds makes it easier for them to use the data-
base. Think of forms as windows through which people see and reach your database in a more 
visually attractive and effi cient way.

You can create forms in several different ways, depending on how much control you want 
over the form’s design. Forms that include all fi elds in a table can be quickly created through a 
single mouse-click by using the Form tool, or you can control the number of fi elds you’d like 
to include on the form as well as the layout of the form by using the Form Wizard. You have 
the most fl exibility with the amount and placement of fi elds on the form by using Layout 
or Design View, with Design View giving you the greatest control over fi eld placement and 
properties. Finally, you can quickly apply a chosen theme to the form to modify its color and 
font scheme using the Themes command. In this section, you practice creating forms using a 
variety of these skills.
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109Create Forms

Creating a Simple Form
You can use the Form tool to create a form with a single mouse-click. When you use this tool, 
all the fi elds from the underlying data source are placed on the form. Access creates the form and 
displays it in Layout View. You can begin using the new form immediately, or you can modify 
it in Layout View or Design View to better suit your needs. In this exercise, you create a simple 
form by using the Form tool.

To use the Form tool to create a simple form, fi rst click in the Navigation Pane on the table that 
contains the data you want to see on the form. On the Create tab, in the Forms group, click Form.

To save your form design, click the File tab and click Save. Key a name in the Form Name box 
and click OK. After you save your form design, you can run the form as often as you want. The 
design stays the same, but you see current data every time you view the form. If your needs 
change, you can modify the form design or create a new form that is based on the original.

STEP BY STEP Create a Simple Form

GET READY. Before you begin these steps, be sure to LAUNCH Microsoft Access.

1. OPEN the Graphic Art database from the data fi les for this lesson.

2. SAVE the database as Graphic Art XXX (where XXX is your initials).

3. In the Navigation Pane, click the Photo Exhibit table. This is the table for which you will
create a form.

4. On the Create tab, in the Forms group, click the Form button. Access creates the form and
displays it in Layout View, as shown in Figure 5-2. Your form may be slightly different.

 The Graphic Art fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.

Close 
‘Photo 
Exhibit’ 
button

Figure 5-2

Simple form 5. Click the File tab and click Save. The Save As dialog box appears, as shown in
Figure 5-3.

Figure 5-3

Save As dialog box

c05CreateForms.indd Page 109  8/11/11  8:20 PM user-f462c05CreateForms.indd Page 109  8/11/11  8:20 PM user-f462 volumes/202/JWCL558volumes/202/JWCL558



 110 Lesson 5

You can use the record navigation buttons at the bottom of a form to navigate among the form’s 
records, just as you used them to navigate among records in a table in Lesson 3.

6. Click OK to accept the Photo Exhibit form name suggested by Access. The form name
appears in the Navigation Pane.

7. Click the Close button on Photo Exhibit to close the form.

8. LEAVE the database open.

PAUSE. LEAVE Access open to use in the next exercise.

Creating a Form in Design View
When you click the Form Design button, a new blank form is created in Design View. 
Design View gives you a more detailed view of the structure of your form than Layout View. 
The form is not actually running when it is shown in Design View, so you cannot see the 
underlying data while you are making design changes. In this exercise, you create a new blank 
form in Design View and manually add fi elds to it.

You can fi ne-tune your form’s design by working in Design View. To switch to Design View, 
right-click the form name in the Navigation Pane and then click Design View. You can also 
use the View button on the Home tab on the Ribbon. You can add new controls—used to 
enter, edit, and fi nd information—and fi elds to the form by adding them to the design grid. 
Plus, the property sheet gives you access to a large number of properties that you can set to 
customize your form.

STEP BY STEP Create a Form in Design View

USE the database that is open from the previous exercise.

1. On the Create tab, in the Forms group, click the Form Design button. A new blank form
is created in Design View, as shown in Figure 5-4.

Take Note

Figure 5-4

New blank form in Design View
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111Create Forms

 2. On the Form Design Tools Design contextual tab, in the Tools group, click the 
Add Existing Fields button. The Field List pane appears, as shown in Figure 5-5.

 3. Click the Show all tables link, then the expand button to the left of the table name, 
as shown in Figure 5-6. The available fi elds display from the Photo Exhibit table, as 
shown in Figure 5-7.

 4. In the list of fi elds, double-click Artist to add it to the form.

 5. Double-click Image Title to add it to the form.

Figure 5-5 

Field List pane

Field List pane 

Figure 5-6 

Field List pane with Show all 
tables link and expand button

Table

name

Expand button

Figure 5-7 

Field List pane with 
available fi elds

Field List pane with 
available fields

 Another Way
You can also 

display the Field List pane by 
clicking Alt+F8.
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 112 Lesson 5

7. Click the File tab and click Save.

8. In the Save As dialog box, key Photo Label, and click OK.

9. On the Design menu, in the Views group, click the lower half of the View button and
click Form View to display the form in Form View, as shown in Figure 5-9.

 10. Click the Close button on Photo Label to close the form.

11. LEAVE the database open.

PAUSE. LEAVE the database open to use in the next exercise.

Figure 5-8

Fields inserted in Design View

Fields 
added 
to form

Figure 5-9

Form View 

 Another Way
You can also click 

the fi eld name and drag it onto 
the form to add a fi eld.

3.1.3

How do you use form 
design tools?

6. Double-click Price to add it to the form. Your form should look similar to Figure 5-8.
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113Create Forms

You learn how to use the commands in the Controls group and a greater variety of form 
design tools in Lessons 7 and 10.

Creating a Form in Layout View
If other form-building tools do not fi t your needs, you can use the Blank Form tool to create a 
form. The Blank Form tool creates a new form in Layout View. This can be a very quick way 
to build a form, especially if you plan to put only a few fi elds on your form. Click the Blank 
Form button to quickly create a new blank form in Layout View; you can make design changes 
to the form while viewing the underlying data. In this exercise, you use the Blank Form tool to 
create a form in Layout View.

On the Create tab, in the Forms group, click the Blank Form button. Access opens a blank 
form in Layout View and displays the Field List pane. To add a fi eld to the form, double-click 
it or drag it onto the form. In Layout View, you can make design changes to the form while it 
is displaying data.

STEP BY STEP Create a Form in Layout View

USE the database that is open from the previous exercise.

 1. On the Create tab, in the Forms group, click the Blank Form button. A new blank form 
is created in Layout View, with the Field List displayed, as shown in Figure 5-10.

Ref

 2. In the list of fi elds, double-click Image Title to add it to the form.

 3. Double-click Dimensions to add it to the form.

 4. Double-click Media to add it to the form. Your form should look similar to Figure 5-11.

Figure 5-10

New blank form in Layout View

Double-click a 
field to add it 
to the form
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 114 Lesson 5

 5. Click the File tab and click Save.

 6. In the Save As dialog box, key Image Info, and click OK.

 7. Click the Close button to close the Field List.

 8. Click the Close button on Image Info to close the form.

 9. LEAVE the database open.

PAUSE. LEAVE the database open to use in the next exercise.

To add more than one fi eld at a time, press Ctrl and click several fi elds; then, drag them all onto 
the form at once.

Using the Form Wizard
Another method of building a form is to use the Form Wizard tool. The Form Wizard allows 
you to select the fi elds that will appear on the form, choose the form layout (which determines 
the positioning of controls, objects, and data on a form), and also choose a predefi ned style, if 
desired. In this exercise, you use the Form Wizard to create a datasheet form. A datasheet form 
looks very similar to the table upon which it is based and provides a way to enter data using 
columns and rows.

STEP BY STEP Use the Form Wizard

USE the database that is open from the previous exercise.

 1. On the Create tab, in the Forms group, click the Form Wizard button, shown in 
Figure 5-12.

Take Note

Figure 5-11

Fields inserted in Layout View

3.1.2

How do you use the Blank 
Form tool to create a form?

Figure 5-12

Form Wizard button in 
Forms group

Form Wizard button
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 2. The Form Wizard displays, as shown in Figure 5-13.

 3. Click the >> button to move all the fi elds from the Available Fields box to the Selected 
Fields box.

 4. Click the Next > button to move to the next screen in the Form Wizard, shown in Figure 5-14.

 5. Click Datasheet as the layout for the form. Form layouts help determine the 
positioning of controls, objects, and data on a form.

 6. Click the Next > button to move to the fi nal screen in the Form Wizard, as shown in 
Figure 5-15.

Figure 5-13

Form Wizard

Click to 
move all 
fields

Click to move selected field

Figure 5-14

Form Wizard, next screen

Figure 5-15

Form Wizard, fi nal screen
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7. Key Photo Details as the title of the form.

8. Click the Finish button. A datasheet form appears, as shown in Figure 5-16.

9. Click the Close button on Photo Details to close the form.

PAUSE. LEAVE the database open to use in the next exercise.

To include fi elds from more than one table on your form, do not click Next or Finish after you 
select the fi elds from the fi rst table on the fi rst screen of the Form Wizard. Instead, repeat the 
steps to select another table, and click any additional fi elds that you want to include on the form 
before continuing.

Applying a Theme
The Themes command applies a predefi ned color and font scheme to a form or report. A 
theme modifi es a form by controlling the color and fonts of its text. In this exercise, you apply 
a Theme to a form.

To apply a theme, fi rst switch to Layout View. On the Form Layout Tools Design contextual tab, 
in the Themes group, click the Themes button to view a gallery of theme styles from which to 
choose. You can point to each option to see the name of that format and a live preview before 
it’s applied to the form.

STEP BY STEP Apply a Theme

USE the database that is open from the previous exercise.

1. Double-click the Image Info form in the Navigation Pane to open it.

2. On the Home tab, in the Views group, click the lower half of the View button, and click
Layout View on the View menu.

Take Note

Blank Database paneFigure 5-16

Datasheet form

3.1.1

How do you use the Form 
Wizard to create a form with a 
predefi ned layout and style?
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117Create Forms

4. A gallery of themes appears, as shown in Figure 5-18.

5. Click the Couture theme (fourth row, fi rst column) to apply it to the form. Notice how
the form’s text has changed, shown in Figure 5-19.

6. Click the Close button on Image Info to close the form.

PAUSE. LEAVE the database open to use in the next exercise.

Figure 5-17

Themes button

Themes button
accesses Themes gallery

Figure 5-18

Themes gallery

Figure 5-19

Form in Layout View with 
Couture theme applied

Theme modified 
labels and record data

3.2.1

How do you apply a 
theme to a form?

3. On the Form Layout Tools Design contextual tab, in the Themes group, click the
Themes button, shown in Figure 5-17.
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SORTING AND FILTERING DATA WITHIN A FORM
Sorting data in a form can help make it much more effective and easy to use. Sorting helps users 
review and locate the records they want without having to browse the data. To fi nd one or more 
specifi c records in a form, you can use a fi lter. A fi lter limits a view of data to specifi c records 
without requiring you to alter the design of the form. You also can use a tool called fi lter by form 
to fi lter on several fi elds in a form or to fi nd a specifi c record.

Sorting Data within a Form
Data can be sorted in the Form View of a form. The order that is chosen when a form is designed 
becomes that object’s default sort order. But when viewing the form, users can sort the records 
in whatever way is most useful. You can sort the records in a form on one or more fi elds. In this 
exercise, you sort data in a form in ascending order.

STEP BY STEP Sort Data within a Form

USE the database that is open from the previous exercise.

1. Double-click the Photo Label form in the Navigation Pane to open it in Form View.

2. Right-click the Price fi eld to display the shortcut menu shown in Figure 5-20.

3. Click Sort Smallest to Largest. The form is sorted by price from smallest to largest. The
record with the smallest price is displayed fi rst, as shown in Figure 5-21.

4. Click the Next record button on the record navigator at the bottom of the form.
Continue clicking through all the records to see the records in order according to price.

5. On the Home tab, in the Sort & Filter group, click the Remove Sort button.

6. Click the Close button on Photo Label to close the form.

PAUSE. LEAVE the database open to use in the next exercise.

The Bottom Line

Figure 5-20

Price fi eld shortcut menu

Right-click 
to display 
shortcut menu

 Another Way
You can also sort 

on a fi eld by selecting it and 
clicking the Ascending or De-
scending button on the Home 
tab in the Sort & Filter group.
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You cannot sort on a fi eld that contains attachments. When sorting on a fi eld with the Yes/No 
data type, a value of “Yes,” “True,” or “On” is considered “Selected”; a value of “No,” “False,” or 
“Off” is considered “Cleared.”

You must identify the fi elds on which you want to sort. To sort on two or more fi elds, identify the 
fi elds that will act as the innermost and outermost sort fi elds. Right-click anywhere in the column 
corresponding to the innermost fi eld, and click one of the sort commands. The commands vary 
based on the type of data that is in the selected fi eld. Repeat the process for each sort fi eld, 
ending with the outermost sort fi eld. The records are rearranged to match the sort order.

You already learned how to sort data within a table in Lesson 3. Sorting in a form is very similar.

The last-applied sort order is automatically saved with the form. If you want it automatically 
applied the next time you open the form, make sure the Order By On Load property of the form 
is set to Yes. Remember that you cannot remove a sort order from just a single fi eld. To remove 
sorting from all sort fi elds, on the Home tab, in the Sort & Filter group, click Remove Sort.

Filtering Data within a Form
Common fi lters are built into every view that displays data. The fi lters available depend on 
the type and values of the fi eld. When you apply the fi lter, only records that contain the values 
that you are interested in are included in the view. The rest are hidden until you remove the 
fi lter. In this exercise, you fi lter form data using common fi lters.

Filters are easy to apply and remove. Filter settings remain in effect until you close the form, even 
if you switch to another view. If you save the form while the fi lter is applied, it will be available 
the next time you open the form. To permanently remove a fi lter, on the Home tab, in the Sort 
& Filter group, click the Advanced button and click Clear All Filters.

Take Note

Ref

Figure 5-21 

Form sorted by price
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STEP BY STEP Filter Data with Common Filters

USE the database that is open from the previous exercise.

 1. Double-click the Photo Exhibit form in the Navigation Pane to open it in Form View.

 2. Right-click the Media fi eld to display the shortcut menu and click Text Filters, as shown 
in Figure 5-22.

 3. Click Contains . . . to display the Custom Filter dialog box, as shown in Figure 5-23.

 4. In the Media contains box, key print, and click OK.

 5. Click the Next record button on the record navigator at the bottom of the form. 
Continue clicking to see the fi ve records that contain the word “print” in the 
Media fi eld.

 6. Right-click the Price fi eld to display the shortcut menu and click Number Filters, as 
shown in Figure 5-24.

Figure 5-23

Custom Filter dialog box

Figure 5-22

Media fi eld text fi lters

Common filters for a text field
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7. Click Less Than . . . to display the Custom Filter dialog box shown in Figure 5-25.

8. In the Price is less than or equal to box, key 500, and click OK.

9. Click the Next record button on the record navigator at the bottom of the form.
Continue clicking to see the three photos that use print media and are less than $500.

 10. On the Home tab, in the Sort & Filter group, click the Advanced Filter Options button
to display the menu shown in Figure 5-26.

11. Click Clear All Filters.

PAUSE. LEAVE the database open to use in the next exercise.

You already learned how to fi lter data within a table in Lesson 3. Filtering in a form using 
common fi lters is very similar.Ref

Figure 5-24

Price fi eld number fi lters

Common filters for a number field

Figure 5-25

Custom Filter dialog box

Figure 5-26

Advanced Filter Options 
button menu
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Using Filter by Form
Although only a single fi lter can be in effect for any one fi eld at any one time, you can specify a dif-
ferent fi lter for each fi eld that is present in the view. In addition to the ready-to-use fi lters for each 
data type, you can also fi lter a form by completing an action called fi lter by form. Filter by form 
is useful when you want to fi lter several fi elds in a form or if you are trying to fi nd a specifi c record. 
Access creates a blank form that is similar to the original form, you then complete as many of the 
fi elds as you want. When you are done, Access fi nds the records that contain the specifi ed values. In 
this exercise, you fi lter by form.

To use fi lter by form, open the form in Form View and make sure the view is not already fi ltered 
by verifying that either the Unfi ltered or the dimmed No Filter icon is present on the record 
selector bar. On the Home tab, in the Sort & Filter group, click Advanced, and then click Filter 
by Form. Click the down arrow in a fi eld to display the available values.

Enter the fi rst set of values on the Look for tab, then click the Or tab and enter the next set of 
values. Each time you click the Or tab, Access creates another Or tab so you can continue to add 
additional fi lter values. Click the Toggle Filter button to apply the fi lter. The fi lter returns any 
record that contains all of the values specifi ed on the Look for tab, or all of the values specifi ed 
on the fi rst Or tab, or all of the values specifi ed on the second Or tab, and so on.

STEP BY STEP Use Filter by Form

USE the database that is open from the previous exercise.

1. On the Home tab, in the Sort & Filter group, click the Advanced Filter Options button
and click Filter by Form. A form fi lter appears, as shown in Figure 5-27.

Figure 5-27

Form fi lter

Click or tab to add additional filter values
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3. Click 30 � 40.

4. Click the Or tab at the bottom of the form.

5. Place the insertion point in the Dimensions box, click the down arrow, and then click
12 � 28.

6. On the Home tab, in the Sort & Filter group, click the Toggle Filter button to apply the
fi lter. The records containing either the dimensions 30 � 40 or 12 � 28 are displayed,
as shown in Figure 5-29.

2. Place the insertion point in the Dimensions box and click the down arrow on the right
to display the list of options shown in Figure 5-28.

Figure 5-28

Form fi lter fi eld options

Figure 5-29

Form fi lter results

Click to see 
available 
field values

Indicates the form is filtered

c05CreateForms.indd Page 123  8/11/11  8:20 PM user-f462c05CreateForms.indd Page 123  8/11/11  8:20 PM user-f462 volumes/202/JWCL558volumes/202/JWCL558



 124 Lesson 5

7. Click the Next record button on the record navigator at the bottom of the form to see
the second record in the form fi lter results.

8. On the Home tab, in the Sort & Filter group, click the Toggle Filter button again to
remove the fi lter.

9. On the Home tab, in the Sort & Filter group, click the Advanced button and click Clear
All Filters.

 10. Click the File tab and click Close Database.

STOP. LEAVE Access open for use in the projects.

Take Note If you want a fi eld value to operate as a fi lter that is independent of other fi eld values, you must 
enter that value on the Look for tab and each Or tab. In other words, the Look for tab and each 
Or tab represents an alternate set of fi lter values.

Knowledge Assessment

Matching

Match the term in Column 1 to its description in Column 2.

Column 1 Column 2

1. Form Wizard a.  useful when you want to fi lter on several fi elds in
a form or if you are trying to fi nd a specifi c record

2. Form Design button b. creates a simple form with a single mouse-click

3. Theme command c.  applies a predefi ned combination of colors and
fonts that you select for a form or report

4. Blank Form button d. quickly creates a new blank form in Design View

5. form e.  allows you to select fi elds for the form, choose the form
layout, and also choose a predefi ned style

6. fi lter by form f.  limits a view of data to specifi c records without
requiring you to alter the design of the form

7. sorting g. built into every view that displays data

8. Form tool h.  database object that you can use to enter, edit, or
display data from a table or a query

9. common fi lters i.  helps users review and locate records without
having to browse the data

10. fi lter j. quickly creates a new blank form in Layout View
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True/False

Circle T if the statement is true or F if the statement is false.

T F 1. The Forms group is located on the Home tab in the Ribbon.

T F 2.  Forms can be used to control access to data, such as which fi elds or rows of
data are displayed.

T F 3. After you save your form design, you can run the form as often as you want.

T F 4.  Layout View gives you a more detailed view of the structure of your form than
Design View.

T F 5.  Using the Blank Form tool is a very quick way to build a form, especially if you
plan to put only a few fi elds on your form.

T F 6. To access the Theme options, fi rst switch to Form View.

T F 7. You cannot remove a sort order from just a single fi eld.

T F 8. The fi lters available depend on the fi eld’s data type and values.

T F 9. To fi lter by form, fi rst switch to Design View.

T F 10. When using the Form Wizard, you can only include fi elds from one table.

Competency Assessment

Project 5-1: Form Wizard
As a travel agent at Erin’s Travel, you need an easy way to input data about events into the database. 
You decide to use the Form Wizard to create a datasheet form that has a preformatted style.

GET READY. LAUNCH Access if it is not already running.

1. OPEN Travel Events from the data fi les for this lesson.

2. SAVE the database as Travel Events XXX (where XXX is your initials).

3. On the Create tab, in the Forms group, click the Form Wizard button.

4. Click the >> button to move all the fi elds from the Available Fields box to the Selected
Fields box.

5. Click the Next > button to move to the next page in the Form Wizard.

6. Click Datasheet as the layout for the form.

7. Click the Next > button to move to the fi nal page in the Form Wizard.

8. Key Event Details as the title of the form.

9. Click the Finish button to create a datasheet form.

 10. On the Home tab, in the Views group, click the lower half of the View button, and click
Form View.

11. Click the Close button on Event Details to close the form.

 12. CLOSE the database.

LEAVE Access open for the next project.

Project 5-2: Used Games Forms
You are the manager at Southridge Video. To expand the store, you have recently started taking used 
games in trade. You store information about each title in an Access database. You decide to create 
some forms to help you use the database more effi ciently.

GET READY. LAUNCH Access if it is not already running.

1. OPEN Games inventory from the data fi les for this lesson.

2. SAVE the database as Games inventory XXX (where XXX is your initials).

3. In the Navigation Pane, double-click Games: Table to open the table.

4. On the Create tab, in the Forms group, click the Form button to create a simple form
and display it in Layout View.

           The Travel Events fi le 
for this lesson is available on 
the book companion website 
or in WileyPLUS.

           The Games 
inventory fi le for this 
lesson is available on the 
book companion website or 
in WileyPLUS.
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 5. Click the File tab and click Save.

 6. In the Save As dialog box, click OK to accept the Games form name suggested by Access.

 7. Click the Close button for Games to close the form.

 8. On the Create tab, in the Forms group, click the Form Design button to create a new 
blank form in Design View.

 9. On the Form Design Tools Design contextual tab, in the Tools group, click the Add 
Existing Fields button to display the Field List pane.

 10. Click the Show all tables link in the Field List pane.

 11. Click the + next to Games to list the available fi elds.

 12. Double-click Title to add it to the form.

 13. Double-click Rating to add it to the form.

 14. Double-click Platform to add it to the form.

 15. Click the File tab and click Save.

 16. In the Save As dialog box, key Game Rating, and click OK.

 17. Click the Close button to close the Field List.

 18. On the Design contextual tab, in the Views group, click the lower half of the View 
button and click Form View to display form in Form View.

 19. Click the Close button for Game Rating to close the form.

 20. LEAVE the database open for the next project.

LEAVE Access open for the next project.

Profi ciency Assessment

Project 5-3: Sort and Filter Games
A customer comes into Southridge Video and asks about game publishers and the availability of a 
particular game. Sort and fi lter data in the forms you created to get the information that you need.

USE the database that is open from the previous project.

 1. In the Navigation Pane, double-click the Games form to open it.

 2. Right-click the Publisher fi eld to display the shortcut menu.

 3. Click Sort A to Z to sort the form by publisher name in alphabetic order.

 4. Navigate to record 3, titled Marvel: Ultimate Alliance.

 5. Right-click the Title fi eld and click Contains “Marvel: Ultimate Alliance.”

 6. Click the Next record button on the record navigator at the bottom of the form to see 
all the versions of the game with that name.

 7. On the Home tab, in the Sort & Filter group, click the Remove Sort button.

 8. CLOSE the database.

LEAVE Access open for the next project.

Project 5-4: Toy Inventory
Your brother owns Wingtip Toys and recently started keeping a list of the store inventory in an Access 
database. He wants to add a form to the database and asks for your help. Add a simple form and then 
show him how to sort and apply fi lters.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN Toy inventory from the data fi les for this lesson.

 2. Save the database as Toy inventory XXX (where XXX is your initials).

 3. Open Inventory: Table.

           The Toy Inventory 
fi le for this lesson is available 
on the book companion 
website or in WileyPLUS.
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 4. Use the Form tool to create a simple form.

 5. Format it using the Trek theme option (last row, fi rst column).

 6. Save the form as Inventory.

 7. Sort the form’s In Stock fi eld from Largest to Smallest.

 8. Sort the Description fi eld from A to Z.

 9. Run a fi lter that fi nds all the records where the Price fi eld is between $50 and $100.

 10. Clear all sorts and fi lters.

 11. Create a fi lter by form to fi nd all the records that have two items in stock.

 12. Close the form and CLOSE the database.

LEAVE Access open for the next project.

Mastery Assessment

Project 5-5: Red Wines
The Coho Vineyard has started a monthly wine club. Each month features a red wine hand picked 
for its unique label and diverse style. Information about the monthly club selections is stored in an 
Access database; you will create forms so that you can retrieve the data in a useful way.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN the Red Wine database from the data fi les for this lesson.

 2. Save the database as Red Wine XXX (where XXX is your initials).

 3. Create a simple form that contains all the fi elds in the Club Selections table and name 
it Club Wines.

 4. Use the Form Design button to create a form named Wine Details that looks like the 
one shown in Figure 5-30 when displayed in Form View.

           The Red Wine fi le for 
this lesson is available on the 
book companion website or in 
WileyPLUS.

Figure 5-30

Wine Details form

 5. CLOSE the database.

LEAVE Access open for the next project.
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Project 5-6: Personal Contacts
Your address book is becoming outdated, and you decide to transfer all the current information 
about friends and family to an Access database. Input the data and then create forms to manage 
it effi ciently.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN Personal Contacts from the data fi les for this lesson.

 2. SAVE the database as Personal Contacts XXX (where XXX is your initials).

 3. Input as much contact information as you have about at least fi ve friends or 
family members.

 4. Create a simple form named Friends/Family using the Form tool. Apply the 
Black Tie theme.

 5. Create a form named Birthday Contacts using the Form Wizard. Include the following 
fi elds: First Name, Last Name, E-mail Address, Home Phone, Mobile Phone, and 
Birthday. Use the Columnar layout. Keep all other default settings.

 6. CLOSE the database.

STOP. CLOSE Access.

           The Personal 
Contacts fi le for this lesson 
is available on the book 
companion website or 
in WileyPLUS.

tools, and information tailored to small and midsized 
businesses. Search the Microsoft site for Small & Midsize 
Companies, shown in Figure 5-31. Explore the resources 
offered on the site. In the Latest Editions section, choose a 
topic about which you would like to know more, and read an 
article that interests you.

INTERNET READY
Microsoft has numerous online resources avail-

able to provide solutions, services, and support for whatever 
business needs you may have. If you are a small or midsized 
business, a helpful site is the Microsoft Business for Small 
& Midsize Companies. Here, you can fi nd advice, products, 

Figure 5-31

Microsoft Business for Small & 
Midsize Companies
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Circling Back 1

You are a real estate agent and have recently opened your own offi ce—Woodgrove Real 
Estate—with several other licensed agents. Because you are the one who is most knowledgeable 
about computers, you will be responsible for keeping track of the listings and other relevant 
information. You will use Access to begin developing the database that will be used by everyone 
in the offi ce.

Project 1: Create a Database and Tables
After sketching out a plan on paper, you are ready to begin creating the database and tables.

GET READY. LAUNCH Access if it is not already running.

1.  In the Available Templates section, click the blank database icon if it’s not already
selected.

2. In the File Name box, key Woodgrove XXX (where XXX is your initials).

3. Click the folder icon and browse to the location where you want to store the fi le.

4. Click the Create button to create a new blank database.

5. Click Click to Add and click Text on the shortcut menu.

6. Key Address as the column name and press Enter.

7. Add new Text columns named Bedrooms, Bathrooms, Square Feet, and Price.

8. Click the File tab and click Save.

9. In the Save As dialog box, key Listings as the table name and click OK.

10.  On the Create tab, in the Templates group, click the Application Parts button, and click
Contacts to create a new table. Click OK, if necessary, to close and save the Listings
table, then click Cancel in the Create Relationship dialog box that appears.

11.  Open the Contacts table.

12.  Right-click the Company fi eld header and click Delete Field on the shortcut menu. Click
OK if you receive a dialog box warning you about the deletion.

 13.  Delete the Job Title, Business Phone, Fax Number, Address, City, State/Province, ZIP/
Postal Code, Country/Region, Web Page, Notes, and Attachment columns. (If you get a
message asking if you want to delete all indexes for the ZIP column, click Yes.)

14. Save the table as Agents.

 15. Delete all the objects in your database except the Agents and Listings tables.

PAUSE. LEAVE the database open to use in the next project.

Project 2: Modify Tables and Fields
Now that you have created the tables for your database, you need to modify them to suit your 
needs.

USE the database that is open from the previous project. The Agents table should 
be displayed.

1. On the Home tab, in the Views group, click Design View.

2.  On the Table Tools Design contextual tab, in the Show/Hide group, click Property
Sheet.

3. In the Property Sheet’s Description property box, key Agent contact information.

4. Click Close to close the property sheet.
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5.  In the upper portion of the table design grid, click the E-mail Address fi eld. In the fi eld
properties on the bottom, click in the Required property box and set it to Yes.

6. Save the table and switch back to Datasheet View.

7. Open the Listings table. Place the insertion point in the Price column.

8.  On the Table Tools Fields contextual tab, in the Formatting group, click the down arrow
in the Data Type box and click Number.

9. In the Format box, click the down arrow and choose Currency.

10.  Change the data type/format on the Bedrooms, Bathrooms, and Square Feet fi elds to
Number/General Number.

11.  Click the Click to Add column. Choose Attachment as the data type to create an
attachment column.

 12.  Save the table.

PAUSE. LEAVE the database open for the next project.

Project 3: Create Forms and Enter Data
Now it is time to enter data into your database. First you create a form to make this task easier.

USE the database that is open from the previous project. The Listings table should be 
displayed.

1. On the Create tab, in the Forms group, click the More Forms button.

2. Click Datasheet to create a datasheet form.

3. Click the File tab and click Save.

4. In the Save As dialog box, key Listings as the form name and click OK.

5. Use the form to enter data into the Listings table, as shown in Figure 1.

Figure 1

Listings data
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10. Click the Next record button on the record navigator.

11. Enter the data shown in Figure 3 as the second record.

Figure 2

Agents data, record 1

Figure 3

Agents data, record 2

6. Display the Agents table.

7. On the Create tab, in the Forms group, click the Form button.

8. Save the form as Agents.

9. Switch to Form View and use the form to enter the data shown in Figure 2.
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13. Close the Agents form and the Listings form.

PAUSE. LEAVE the database open for the next project.

Project 4: Add Attachments and Create a Lookup Field
You have begun to use the database and realize it would be helpful for the Listings table to 
include the listing agent. Create a lookup fi eld with this information and attach photos for some 
of the houses.

USE the database that is open from the previous project.

1. I n the Listings table, double-click the Attachment fi eld for the fourth record (677 West 
Avenue).

2. In the Attachments dialog box, click Add.

3. Navigate to the data fi les for this lesson, select 677_West_Avenue, and click Open.

4. In the Attachments dialog box, click OK.

5. Attach the photo named 2002_Sundown_Lane to the sixth record.

6. Close the Listings form.

7.  Display the Listings table and place the insertion point in the cell under the Click to 
Add column.

 8.  On the Table Tools Fields contextual tab in the Add & Delete group, click the More 
Fields button. Click the Lookup & Relationship command.

 9. Click Next > twice.

 10. Click Last Name and then click the > button to move it to the Selected Fields box.

 11. Click Next > three times.

 12. Key Listing Agent as the title for your lookup column.

 13. Click Finish.

 14. Save the Listings table.

PAUSE. LEAVE the database open for the next project.

 12. Enter the data shown in Figure 4 as the third record.

Figure 4

Agents data, record 3

 The 677_West_
Avenue fi le is available 
for download on the 
companion website.

 The 2002_
Sundown_Lane fi le is 
available for download 
on the companion 
website.
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Project 5: Modify a Form
Now that you have a lookup fi eld, you want to add it to your form and use it to enter additional 
information.

USE the database that is open from the previous project.

1. Display the Listings form and switch to Design View.

2. Click the Field1 fi eld on the design grid and press Delete.

3. On the Form Design Tools contextual tab, in the Tools group, click Add Existing Fields.

4.  In the Fields available for this view box, click Listing Agent and drag it to the form
below the Price fi eld.

5. Close the Field List and switch to Datasheet View.

6.  In the Listing Agent column click the down arrow and select the last name for each
record, as shown in Figure 5.

Figure 5

Listing agents

7. Close the form.

STOP. CLOSE the database.
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Alpine Ski House is a small mountain lodge that features cross-country skiing in the 

winter and hiking in the summer. As an administrative assistant for Alpine Ski House, 

you take care of many of the administrative duties for the innkeepers, including 

reservations, billing, and recordkeeping. You have recently started using Access to 

keep track of customers and reservations at the lodge. In this lesson, you learn three 

different ways to create reports for the lodge, how to apply auto formats to reports, 

and how to sort and fi lter report data.

SOFTWARE ORIENTATION

Reports Group

The Reports group (Figure 6-1) is located on the Create tab in the Ribbon. Use the Reports 
group of commands to create reports.

Report Design button used to create 
a blank report in Design View

Report button creates a simple report

Report Wizard button starts 
the Report Wizard

Figure 6-1

Reports group

CREATING REPORTS
A report is a database object that is used to organize and display data pulled from tables and 
queries. You can create a report using the Report button, the Report Wizard, or Design View, 
depending on the amount of customization desired. After creating a report, you can instantly 
apply a Theme to create a professional look. You can also sort and fi lter data in a report to display 
the records to suit your needs.

Creating a Simple Report
You can use Access 2010 to create simple or complex reports. When creating a complex report, 
you might spend quite a bit of time choosing which fi elds you want to include from various 
tables or queries. That is fi ne when you need such a report, but when you need a simple display 
of all the fi elds in a table or query, you can use the Report button to create a simple report. In 
this exercise, you use the Report button to create a simple report.

Reports are commonly used as formatted hard copies of table or query data. You can modify a 
report’s design, but you cannot add or edit data in a report. The purpose of a report is to allow 
users to view data, not edit it. For example, a supervisor might ask you to create a sales report 
that is fi ltered to show only one region’s sales. The supervisor does not need to edit the data, 
just view it.

The Bottom Line
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A report’s record source is the table or query that provides the data used to generate a report. 
Before you can create a report, you need to defi ne the record source by clicking in the Naviga-
tion Pane on the table or query on which you want to base the report. Then, click the Report 
button and a report is generated based on the table or query you selected.

You can modify a report’s design, print, or save and close a report. You should save a report’s 
design if you are likely to use it again. To save a report, click the Save button on the File tab or 
in the Quick Access Toolbar. If you click the Close button without saving, Access will display a 
dialog box asking if you want to save it. Once it is saved, the report is listed in the Navigation 
Pane. You can open it and modify it in the future or create a new report based on the original. 
The next time you run the report, the design will be the same, but the data will be different if 
the data in the table or query has been updated.

STEP BY STEP Create a Report

GET READY. Before you begin these steps, be sure to turn on and/or log on to your 
computer and start Access.

1. OPEN Alpine Ski House from the data fi les for this lesson.

2. Save the database as Alpine Ski House XXX (where XXX is your initials).

3. In the Navigation Pane, click the Rooms table to select it. This is your record source.

4.  On the Create tab, in the Reports group, click the Report button. The report appears
in Layout View, as shown in Figure 6-2. Notice the Report Layout tools that appear in
the Ribbon.

 The Alpine Ski 
House fi le for this lesson 
is available on the book 
companion website or in 
WileyPLUS.

WileyPLUS Extra! features an 
online tutorial of this task.

Figure 6-2

Simple report

5.  Click the Room ID header to select it. Position the pointer over the right border until
you see a double-sided arrow. Click and drag to the left, resizing the column to remove
excess white space.
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7.  Click the Save button on the Quick Access Toolbar. The Save As dialog box appears 
with Rooms in the Report Name box. Click OK. Notice that the Rooms report is listed in 
the Navigation Pane.

8. Click the Close button to close the Rooms report.

PAUSE. LEAVE the database open to use in the next exercise.

Using the Report Wizard
You are probably already familiar with the way a “wizard” works. The Report Wizard displays a 
series of questions about the report you want and then it creates the report for you based on your 
answers. The Report Wizard knows what makes a good report, so the questions are designed to 
help you create a professional report with little effort. The Report Wizard is usually the easiest way 
to create a report when you want to choose which fi elds to include. It guides you through a series 
of questions and then generates a report based on your answers. If you want to skip steps such as 
Sorting or Grouping in the Report Wizard, click the Next button to go to the next screen. You 
can click the Finish button anytime it is available to create the report with the choices you have 
specifi ed. In this exercise, you use the Report Wizard to create a report based on the Rooms table.

The Report Wizard allows you to include fi elds from more than one table or query. You can 
click the double right arrow button (>>) to include all the fi elds in the report or click the single 
right arrow button (>) to move them one at a time. Likewise, you can click the double left arrow 
button (<<) to move all the fi elds out of the report or the single left arrow button (<) to move 
them one at a time.

You can specify group levels, such as grouping all of the fi rst-fl oor rooms together and all of the 
second-fl oor rooms together if creating a room report. You can also choose up to four fi elds on 
which to sort data in ascending or descending order. On the layout screen, you can choose from 
various layouts such as stepped, block, or outline, all of which indent fi elds and records in differ-
ent ways to make the report clearer to read. You can also choose to display the report in portrait or 
landscape orientation. Access provides a wide variety of design styles from which to choose. On 
the last screen, you can key a name for the report and choose to preview or modify the report.

  You learn more about grouping in Lesson 11.  Ref

Figure 6-3

Report with resized columns

6. Resize the other columns until your screen looks similar to Figure 6-3.
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STEP BY STEP Use the Report Wizard

USE the database you used in the previous exercise.

1.  On the Create tab, in the Reports group, click the Report Wizard button. The fi rst 
screen of the Report Wizard appears.

2. Make sure the Rooms table is selected in the Tables/Queries menu.

3. Click the >> button to move all the fi elds into the Selected Fields list.

4.  Click the Room ID fi eld to select it and click the < button to move it back to the 
Available Fields list, as shown in Figure 6-4. Click the Next > button.

5.  Click the Location fi eld to select it and click the > button to add it as a grouping level, 
as shown in Figure 6-5.

Figure 6-4

The Report Wizard Fields screen

Figure 6-5

The Report Wizard 
Grouping screen

6. Click the Next > button.

7.  Select Room Name from the fi elds menu to sort in ascending order, as shown in 
Figure 6-6, and click the Next > button.
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8.  In the Layout section, click the Outline button. In the Orientation section, click the 
Landscape button, as shown in Figure 6-7. Click Next >.

Figure 6-6

The Report Wizard Sort screen

Figure 6-7

The Report Wizard 
Layout screen

 9. Key Rooms Wizard as the title of the report, as shown in Figure 6-8.

Figure 6-8

The Report Wizard Title screen
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11. Close the report. Notice that the new report is listed in the Navigation Pane.

PAUSE. LEAVE the database open to use in the next exercise.

Creating a Report in Design View
When you want a customized report, you can create it in Design View, which offers you many 
options for creating the report exactly the way you want it. Design View gives you the most 
options for creating a report, because it shows you the underlying structure of the report. It 
also provides you with more design tools and capabilities. In this exercise, you create a report 
in Design View by adding and moving fi elds.

In the previous exercise, you created a very basic report in Design View. In Lesson 8, you will 
learn how to add more functionality to a report.

In Design View, a report is displayed on a design grid with sections. Table 6-1 lists the sections.

Figure 6-9

The Report Wizard report

5.1.3

How do you use the Report 
Wizard to create a report?

Table 6-1

Design View Sections
Section Name Description

Report header  This section is printed once at the beginning of every report. This is a good 

place to include a logo, a date, or information that might normally appear on 

a cover page.

Page header  This section is printed at the top of every page of a report, so it would be 

good place to include the report title.

Group header  This section is printed at the beginning of a group. It is a good place to include 

the group name.

Detail  This section includes the body of the report. It is printed once for every row 

in a record source.

Group footer  This section is printed at the end of a group. It may include summary 

information for the group.

Page footer  This section is printed at the bottom of every page of a report, so it would 

be a good place to include information such as a page number.

Report footer  This section is printed once at the end of every report. This is a good place 

for report totals.

 10. Click Finish. The Rooms Wizard report appears on the screen, as shown in Figure 6-9.
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To add fi elds to the report design, you can display the Field List pane by clicking the Add Exist-
ing Fields button. Double-click a fi eld in the Field List to add it to the design grid, or you can 
drag the fi eld to a location on the grid. If you need to move a fi eld on the grid, click the fi eld to 
select it and then position the pointer on the border until you see a four-sided arrow. Then, drag 
to the new location. To change the size of a fi eld, click and drag a selection handle.

To see what your report will look like, click the View button on the Views group and select 
Report from the menu.

STEP BY STEP Create a Report in Design View

USE the database you used in the previous exercise.

1. If necessary, click the Rooms table in the Navigation Pane to select it.

2.  On the Create tab, in the Reports group, click the Report Design button. A new blank
report is displayed in Design View, as shown in Figure 6-10.

View button Page header section

Detail 
section

Add Existing Fields button

Figure 6-10

New blank report in 
Design View 3.  If the Fields List is not already displayed, on the Design tab, in the Tools group, click

the Add Existing Fields button. The Show all tables link appears.

4.  Click the Show all tables link then the plus (�) box beside Rooms to display the fi elds
in the table, as shown in Figure 6-11.

c06CreateReports.indd Page 141  8/11/11  8:53 PM user-f462c06CreateReports.indd Page 141  8/11/11  8:53 PM user-f462 volumes/202/JWCL558volumes/202/JWCL558



 142 Lesson 6

5. Double-click Room ID. The fi eld is inserted onto the design grid.

6. Double-click Room Name, Bed Size, and Rate.

7. Click the Close button on the Field List pane.

8.  Click the Bed Size label. The border around the label changes to orange, indicating it is 
selected. Position the insertion point over the top of the border, as shown in 
Figure 6-12, until the pointer changes to a four-sided arrow. 

Figure 6-11

Fields List pane

Label

Field

Selection 
handle

Figure 6-12

Bed Size label selected
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9.  Click and drag the label to position it about one-half inch to the right of the Room ID 
fi eld and release the mouse button. The fi eld is moved along with the label.

 10.  In the same manner, move the Rate label and fi eld to position it below the Bed Size 
fi eld, as shown in Figure 6-13.

Figure 6-13

Moved fi elds

11.  Click the Room ID fi eld to select it. Position the mouse pointer on the square handle in 
the middle of the right-side border. Click and drag the fi eld to the left to decrease the 
size by about one-quarter inch.

 12.  On the Ribbon, in the Views group, click the bottom-half of the View button and select 
Report View from the menu. The report is shown in Report View. Scroll down to see 
all the records.

 13. Click the Save button on the Quick Access Toolbar.

 14. Key Report Design in the Report Name box and click OK.

15. Close the report.

PAUSE. LEAVE the table open to use in the next exercise.

You can add more than one fi eld to a report design at once. Hold down the Ctrl key and click 
the fi elds you want, and then drag the selected fi elds onto the report.

  In Lesson 8, you learn how to add controls to reports in Design View. 

APPLYING A THEME
A theme applies a set of predefi ned fonts, colors, and design to a report. You can apply a theme 
to any report in Layout View. The Themes gallery displays a variety of designs. After you click 
the design you want, it is applied to the report. This instant formatting can quickly give your 
report the professional look you want.

Applying a Theme
To apply a theme, on the Report Layout Tools Design contextual tab, in the Themes group, click 
the Themes button to display the Themes gallery. You can select a design from the list displayed, 
or browse for saved themes. You can also customize and then save a theme based on the current 
report. You can click the Colors button and choose a color scheme from the menu to update 
the currently applied theme’s colors, and even create new theme colors. You can also click the 

Take Note

Ref

5.1.2

How do you create a report 
in Design View?

The Bottom Line
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Fonts button and choose a font scheme to update the currently applied theme’s fonts and create 
new theme fonts. In this exercise, you apply a theme to the Rooms report, and modify the fonts.

STEP BY STEP Apply a Theme

USE the database open from the previous exercise.

1. Open the Rooms report.

2.  On the Ribbon, in the Views group, click the bottom-half of the View button. Select
Layout View from the menu.

3.  On the Report Layout Tools Design contextual tab, in the Themes group, click the
Themes button. The Themes gallery of predefi ned report themes appears.

4.  In the sixth row, fourth column, click the Metro design, as shown in Figure 6-14. The
format is applied to the report.

5.  In the Themes group, click the Fonts button. Select Newsprint from the menu, as
shown in Figure 6-15, and click OK. The new Font theme is applied.

Metro theme chosen

Figure 6-14

Themes gallery with Metro 
theme chosen

Figure 6-15

Fonts menu with Newsprint 
font chosen

Newsprint font chosen
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6. SAVE the report.

PAUSE. LEAVE the report open to use in the next exercise.

WORKING WITH REPORTS
Reports help group and summarize data in different ways. However, after a report is created, you 
can use Layout View as well as Report View to help locate data. For example, you can use Layout 
View to easily sort fi eld data one at a time, or perform more complex sorts using the Group, Sort, 
and Total pane. You can also use Layout View to fi lter data and view only those records based on 
the criteria you specify, and use Report or Layout View to fi nd data based on any term you specify.

Sorting Data within a Report
Sorting organizes data into a particular sequence, such as alphabetic order or from smallest to 
largest numbers. For example, you can sort a customer list in alphabetic order by last name or by 
customer ID number. You can sort data by clicking the buttons on the Ribbon, right-clicking 
and choosing commands from the shortcut menu, or by using the Group, Sort, and Total pane. 
In this exercise, you sort data within a report by using the Ribbon, shortcut menu, and the 
Group, Sort, and Total pane.

Sorting data in a report is similar to sorting in a table. In Layout View, select the fi eld you want 
to sort and click the Ascending or Descending button on the Home tab, in the Sort & Filter 
group. Click the Remove Sort button to remove the sort orders. You can sort as many fi elds as 
you like one at a time.

  Lesson 3 has more information about sorting in a table.  

You can also easily sort data by right-clicking in a fi eld and choosing the type of sort you want 
from the shortcut menu. The sort commands in the shortcut menu vary depending on the type 
of data in the fi eld. For text, you will choose Sort A to Z or Sort Z to A; for numbers, you will 
choose Sort Smallest to Largest or Sort Largest to Smallest; and for dates, you will choose Sort 
Oldest to Newest or Sort Newest to Oldest.

  Lesson 5 has more information about sorting in a form.  

The Group, Sort, and Total pane gives you more sorting options. You can use the pane to specify 
the sort order or to view the results of sorting using the shortcut menu. To specify a sort, click 
the Add a Sort button and select a fi eld from the pop-up menu. Click the drop-down menu to 
specify the type of sort you want. Click the More Options button to display additional com-
mands for creating detailed sorts. Click the Less Options button to return to the basic sorting 
options.

To delete a sort in the Group, Sort, and Total pane, click the Delete button at the end of the 
sort line.

  Lesson 7 has more information about sorting in a query.  

STEP BY STEP Sort Data within a Report

USE the report open from the previous exercise.

1.  On the Home tab in the Views group, click the bottom-half of the View button. Select 
Layout View from the menu.

2. Click the Room Name header.

 3.  On the Home tab, in the Sort & Filter group, click the Ascending button. The column is 
sorted in ascending alphabetic order.

4.  On the Home tab, in the Sort & Filter group, click the Remove Sort button. The Sort is 
removed.

Ref

Ref

Ref

5.2.1

How do you apply a theme to 
a report?

The Bottom Line
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5. Right-click the Room Name header. The shortcut menu appears.

6. Select Sort Z to A, as shown in Figure 6-16. The column is sorted.

Figure 6-16

Shortcut menu

Click Sort Z to A to sort 
in descending order

Figure 6-17

Group, Sort, and Total pane

Group, Sort, and Total pane

7.  On the Home tab, in the Sort & Filter group, click the Remove Sort button. The Sort is 
cleared.

8.  On the Report Layout Tools Design contextual tab, in the Grouping & Totals group, 
click the Group & Sort button. The Group, Sort, and Total pane appears at the bottom 
of the screen, as shown in Figure 6-17.
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12.  Click the More Options button in the Sort line. Notice the options available for 
customizing a sort.

 13. Click the Delete button. The sort is cleared.

 14.  On the Formatting tab, in the Grouping & Totals group, click the Group & Sort button. 
The Group, Total, and Sort pane is removed.

 15. SAVE the report.

PAUSE. LEAVE the database open to use in the next exercise.

Filtering Data within a Report
A fi lter displays only data that meet the criteria you have specifi ed and hides the rest. It does 
not modify the table data or the design of the report. After you remove a fi lter, all the records 
are displayed again. Filtering data in Layout View of a report is very similar to fi ltering data in 
a table. You can apply common fi lters using the commands on the Sort & Filter group or by 
right-clicking a fi eld and choosing a fi lter from the shortcut menu. The fi lters available on the 
shortcut menu vary depending on the type of data in the fi eld. Only one fi lter can be applied to 
a fi eld at a time. However, you can specify a different fi lter for each fi eld. In this exercise, you 
fi lter a report using a custom fi lter, and fi lter by selection.

You can toggle between fi ltered and unfi ltered views using the Toggle Filter button. To remove 
a fi lter from a fi eld, right-click in the fi eld and select the Clear fi lter from fi eld name command. 
To remove all fi lters permanently, select the Clear All Filters command on the Advanced menu 
in the Sort & Filter group.

If you save a report (or other object) while a fi lter is applied, it will be available the next time you 
open the report. If you want to open the report and see the fi lter already applied, set the Filter 
On Load property setting to Yes.

Take Note

Figure 6-18

Sort displayed in the Group, 
Sort, and Total pane

Field 
Name 
menu

Sort order menu More Options button Delete buttonSort line

9. Click the Add a Sort button in the Group, Sort, and Total pane.

10.  Click the Room Name fi eld in the fi elds list. Notice that the fi eld was sorted in 
ascending order by default and a line was added describing the sort.

 11.  Click the down arrow beside with A on top and select with Z on top from the menu, as 
shown in Figure 6-18. The fi eld is sorted in descending order.

5.6.2

How do you sort data within 
a report?
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You can also fi lter by selection in a report. If you want to view only the reservations for 12/13/11, 
select that date in the Check-in fi eld and click the Selection button. That date will appear in the 
menu, so that you can choose Equals 12/13/11, Does Not Equal 12/13/11, and so on. You can 
also access these commands on the shortcut menu by right-clicking the value.

If you need to apply a fi lter that is not in the common fi lters list, you can write an advanced 
fi lter using the Advanced Filter/Sort command on the Advanced menu. You need to be familiar 
with writing expressions, which are similar to formulas, and be familiar with the criteria that you 
specify when designing a query.

  Lesson 3 has more information about fi ltering records in a table.  

  Lesson 5 has more information about fi ltering data within a form.  

  Lesson 7 has more information about fi ltering data within a query.  

STEP BY STEP Filter Data within a Report

USE the database you used in the previous exercise.

1. Click the Location header to select it.

2. On the Home tab, in the Sort & Filter group, click the Filter button. A menu appears.

3.  Point to Text Filters. A second menu appears. Select Begins with . . . as shown in 
Figure 6-19. The Custom Filter box appears.

Take Note

Ref

Ref

Ref

Figure 6-19

Text Filters menu

4.  Key 1 into the Custom Filter box and click OK. The data is fi ltered to show only the 
rooms on the fi rst fl oor.

5.  Click the Remove Filter button. The report returns to its unfi ltered state.

 6. In the Bed Size fi eld, click King in the second row.

 7.  On the Home tab, in the Sort & Filter group, click the Selection button. Select Equals 
“King” from the menu. The data is fi ltered to show only the rooms with 
King-sized beds.
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8.  Right-click the Bed Size header. A shortcut menu appears. Notice that the Equals 
“King” fi lter and the other fi lters from the Selection menu are also available in the 
shortcut menu, shown in Figure 6-20.

Figure 6-20

Shortcut menu

9. Select Clear fi lter from Bed Size from the menu. The fi lter is cleared.

10. SAVE and close the table.

PAUSE. LEAVE the database open to use in the next exercise.

Finding Data within a Report
When you want to quickly locate records in a report, you can use the Find command, which 
searches all the records of the report for any term you specify. Sometimes you may need to 
quickly fi nd records within a report while in Report View or Report Layout View. To accomplish 
this, you can use the Find command in the Find group on the Home tab. In this exercise, you 
locate data in Report View by using the Find command.

  Lesson 3 has more information about the Find command.  

The Find command was overviewed for tables in Lesson 3, Like the Find command in table 
Datasheet View, once clicked, the Find dialog box appears where you can enter search criteria, 
set options for where you’d like Access to look for the data, and set data matching and other 
search options. You can quickly locate records that match your search term and view multiple 
occurrences; however, remember that you cannot modify record data from within a report, so 
you cannot replace the record data that is found.

You cannot use the Find command when you’re in Report Design View.

You can also use the Find command in tables, forms, and queries.

STEP BY STEP Find Data within a Report

USE the database open from the previous exercise.

1. Open the Rooms report.

 2.  On the Ribbon, in the Views group, click the bottom-half of the View button. Select 
Report View from the menu.

Ref

Take Note

Take Note

5.6.3

How do you fi lter data within 
a report?

5.6.4

How do you apply and remove 
fi lters?

 Another Way
You can also access 

the Find command by pressing 
Ctrl�F on the keyboard.
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Figure 6-21

Find dialog box

3.  On the Home tab, in the Find group, click the Find button. The Find dialog box appears,
as shown in Figure 6-21.

4.  Key King in the Find What drop-down box and select Current document in the Look In
drop-down box.

5.  Click the Find Next button. Access highlights the fi rst occurrence of ‘King’ in the
report. Continue clicking the Find Next button until Access reports that it has fi nished
searching the records.

6. Close the table. CLOSE the database.

 STOP. CLOSE Access.

5.6.1

How do you use the Find 
command?

Knowledge Assessment

Matching

Match the term in Column 1 to its description in Column 2.

Column 1 Column 2

1. report a. organizes data in a particular order

2. record source b.  displays data that meets the criteria you have specifi ed and
hides the rest

3. Report Wizard c. a list of available fi elds for adding to a report

4. Field List pane d.  a database object that is used to organize and display data from
tables and queries

5. Detail e. locates data in an open object like a table, query, or report

6. theme f.  the table or query that provides the data used to generate a report

7. Sort g. the way a report is displayed in Design View

8. Filter h.  guides you through a series of questions and then generates a
report based on your answers

9. design grid i.  the section of a report that includes the body of the report

 10. Find command j.  a predefi ned format that you can apply to any
report in Layout View
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True/False

Circle T if the statement is true or F if the statement is false.

T F 1. A simple report contains all the records in a table or query.

T F 2. You can edit the data in a report.

T F 3. Click the Report button to defi ne a record source.

T F 4. In the Report Wizard, you can skip steps such as Sorting or Grouping by
clicking the Next button.

T F 5.  You can drag a fi eld from the Field List pane to the design grid to add it to
the report.

T F 6.  Layout View gives you the most options for creating a report, because it
shows you the underlying structure of the report.

T F 7. Templates resize column widths for you.

T F 8. You can save a fi lter with a report.

T F 9.  You can use the Group, Sort, and Total pane to specify sort order or view the
results of sorting using the shortcut menu.

T F 10. The Toggle Filter button removes a fi lter permanently.

Competency Assessment

Project 6-1: Soccer Team Report
You need a copy of the soccer team’s roster that you can print and take with you to work. Create a 
simple report and apply a theme.

GET READY. LAUNCH Access if it is not already running.

1. OPEN the SoccerTeam database.

2. Save the database as SoccerTeamXXX (where XXX is your initials).

3. Click the Roster table to select it.

4.  On the Create tab, in the Reports group, click the Report button. A new report is
created.

5. Resize each fi eld so that all fi elds fi t on one page.

6.  On the Report Layout Tools Design contextual tab, in the Themes group, click the
Themes button.

7.  Select the purple format in the seventh row, third column named Opulent.

8.  Click the Save button on the Quick Access Toolbar. The Save As dialog box appears
with the name Roster in it. Click OK to accept that name for the report.

9. Close the report.

 10. CLOSE the database.

LEAVE Access open for the next project.

Project 6-2: Fourth Coffee Inventory Report
In your job at Fourth Coffee, you are responsible for maintaining the coffee inventory. Create a report 
to view the inventory and prepare for the next order.

GET READY. LAUNCH Access if it is not already running.

1. OPEN Coffee from the data fi les for this lesson.

2. SAVE the database as CoffeeXXX (where XXX is your initials).

3. Click the Coffee Inventory Table in the Navigation Pane to select it.

          The SoccerTeam 
fi le for this lesson is 
available on the book 
companion website or in 
WileyPLUS.

          The Coffee fi le for 
this lesson is available 
on the book companion 
website or in WileyPLUS.
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4.  On the Create tab, in the Reports group, click the Report Wizard button. The fi rst Report
Wizard screen appears.

5.  Click the double arrow >> to move all the fi elds to the Selected Fields list and click
Next.

6.  On the grouping screen, click the Scheduled Order Date fi eld, click the >, and click
Next.

7.  On the sorting screen, click the active down arrow on the menu, select Pounds, and
click Next.

8. Keep the defaults as is on the layout screen and click Next.

9. Click Finish. The report is created.

10. Close the report.

11. CLOSE the database.

LEAVE Access open for the next project.

Profi ciency Assessment

Project 6-3: Alpine Ski House Reservations Report
Every week is different at the Alpine Ski House. Sometimes the lodge is full of guests, and sometimes 
only a few rooms are occupied. Create a report to show the innkeepers what to expect in the coming 
weeks.

GET READY. LAUNCH Access if it is not already running.

1. OPEN the Alpine House database.

2. SAVE it as Alpine House XXX (where XXX is your initials).

3.  Use the Report Wizard to create a report using the Room, Check-in Date, and Check-out
Date fi elds.

4. Group the report by Room and sort it in ascending order by Check-in Date.

5. Use stepped layout and portrait orientation.

6. Name the report December Reservations and fi nish the wizard.

7. Switch to Layout View and increase the width of the Room fi eld.

8. Apply the Foundry theme.

9. Save and close the table.

 10. CLOSE the database.

LEAVE Access open for the next project.

Project 6-4: Wingtip Toys Design View Report
The manufacturing department at Wingtip Toys needs summary information about each toy in inventory. 
Create a report in Design View that will display the requested information.

GET READY. LAUNCH Access if it is not already running.

1. OPEN Wingtip Toys and save it as Wingtip Toys XXX (where XXX is your initials).

2. Click the Inventory table in the Navigation Pane to select it.

3. On the Create tab, in the Reports group, click the Report Design button.

4.  On the Design tab, in the Tools group, click the Add Existing Fields button. The Field
List pane appears.

          The Wingtip Toys 
fi le for this lesson is 
available on the book 
companion website or in 
WileyPLUS.

          The Alpine House 
fi le for this lesson is 
available on the book 
companion website or in 
WileyPLUS.
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5.  Position the fi elds from the Inventory table onto the design grid, as shown in
Figure 6-22. Adjust fi eld widths as shown.

Figure 6-22

Wingtip Toys report in 
Design View

6. Save the report as Toy Summary.

7. Close the report.

LEAVE the database open for the next project.

Mastery Assessment

Project 6-5: Filter, Sort, and Find Records in a Wingtip Toys Report
A large order was recently fi lled, and now the inventory at Wingtip Toys is quite low on some items. 
Create a report that displays this information.

The Wingtip Toys XXX database should be open.

GET READY. LAUNCH Access if it is not already running.

1. Defi ne the Inventory table as the record source for a new report.

2. Create a simple report.

3. Apply the Equity theme to the new report.

4. Sort the report in ascending order by the Description fi eld.

5. Click the fi rst row of the In Stock fi eld, which contains the number 10.

6. Filter by selection to display the toys with 10 or fewer items in stock.

7. Click the In Stock fi eld header and sort the fi eld in ascending order.

8. Clear all sorts.

9. Clear all fi lters.

 10. Find and cycle through all occurrences of the word Car.

11. Save the report as Inventory.

 12. Close the report.

 13. CLOSE the database.

LEAVE Access open for the next project.
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Project 6-6: Angel Project Report
The school Angel Project has begun. Information for the boy angels needs to be distributed to the 
boys in the kindergarten classes, and the girl angels’ information needs to be distributed to the girls. 
Create a report with fi lters that displays the boy and girl information separately.

GET READY. LAUNCH Access if it is not already running.

1. OPEN the Angel Project database.

2. Save the database as Angel Project XXX (where XXX is your initials).

3. Defi ne the List table as the record source for a new report.

4. Use the Report Wizard to create a report with all the fi elds.

5. Skip the grouping and sorting screens, and choose a tabular, portrait layout.

6. Name the report Angel Needs and Wants.

7.  Switch to Layout View and adjust fi eld widths as necessary so that all data fi ts on the
screen and on one page, and apply the Trek theme.

8. Display the Group, Sort, and Total pane.

9. Sort the report in ascending order by Age.

10. Create a fi lter to show only the information for the males.

11. Toggle the fi lter and create a new fi lter to show only the information for the females.

12. Save and close the report.

13. CLOSE the database.

CLOSE Access.

          The Angel Project 
fi le for this lesson is 
available on the book 
companion website or in 
WileyPLUS.

hotel’s location, name, cost, and favorite amenities or activi-
ties. After creating the table, use the Report Wizard to create 
a professional-looking report that displays your data.

INTERNET READY
Search the Internet for at least fi ve dream va-

cation packages and create a database table that lists each 
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KEY TERMS
• bound control

• calculated control

• conditional formatting

• control

• control layouts

• control tab order

• Control Wizard

• Expression Builder

• stacked layout

• tabular layout

• unbound control

Use Controls in Reports 
and Forms8

183
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Wingtip Toys is a mom-and-pop operation with fewer than 25 employees, many of 

whom craft the heirloom-style wooden toys that the company has sold success-

fully for more than 20 years. As the newly hired marketing coordinator, you are 

learning every aspect of the business in order to market its products effectively. 

In this lesson, you learn to add, format, and arrange controls on forms and 

reports that you can use to evaluate sales and inventory for the company.
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SOFTWARE ORIENTATION

Controls and Header/Footer Groups in Reports and Forms

When you view a report in Design View, the Report Design Tools are displayed in the Rib-
bon. The Controls and Header/Footer groups are located on the Design tab. When you 
position the mouse pointer over a tool, Access will display the tool’s name in a ScreenTip. 
Use the Controls and Header/Footer groups on the Design tab (Figure 8-1) to add controls 
to a report.

Controls group

Header/Footer group

Launches the Field List paneFigure 8-1

Controls and Header/Footer 
groups on the Report Design 

Tools tab

Controls group

Header/Footer group

Launches the Field List pane
Figure 8-2

Controls and Header/Footer 
groups on the Form Design 

Tools tab

The Controls group located on the Design tab in the Form Design Tools on the Ribbon, 
shown in Figure 8-2, is very similar to the one for reports. The procedure for adding con-
trols to a form and a report are similar as well. Use the Controls and Header/Footer groups 
on a form’s Design tab to add controls to a form.

The Bottom Line

ADDING BOUND AND UNBOUND CONTROLS
A control is an object that displays data, performs actions, and lets you improve the look and 
usability of a form or report. Access uses three different types of controls: bound, unbound, and 
calculated.

Controls add functionality to a report or form. For example, you can add a logo control to a 
report to enhance the look of the report or a list box control to allow users to choose from a 
list of items. You can insert bound, unbound, and calculated controls using the tools on the 
Controls and Header/Footer groups. The Control Wizard, located on the Controls group, is 
helpful when creating some of the more complicated controls.
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Adding Unbound Controls
An unbound control does not have a data source; it displays information such as lines, shapes, 
or pictures. Unbound controls are not connected to a fi eld, but they display information that 
is important for reports and forms, some of which will appear in report and form header and 
footer sections, such as titles, dates, and page numbers. You can add both bound and unbound 
controls using the tools on the Controls group, or add unbound controls to the header and 
footer sections of reports and forms by using the Header/Footer group. In this exercise, you use 
the tools on the Header/Footer group to add unbound controls to the Report Header section.

STEP BY STEP Add Unbound Controls

GET READY. Before you begin these steps, be sure to turn on and/or log on to your 
computer and LAUNCH Access.

1. OPEN WingtipInventory from the data fi les for this lesson.

2. Save the database as WingtipInventoryXXX (where XXX is your initials).

3. Double-click the Toy Summary report in the Navigation pane.

4.  On the Home tab, in the Views group, click the View button and select Design View
from the menu.

5.  On the Design tab, in the Header/Footer group, click the Logo button. The Insert Picture
dialog box appears.

6.  Navigate to the student data fi les for this lesson and select Chrysanthemum.jpg and
click OK. The picture is inserted in the Report Header section.

7.  On the Design tab, in the Header/Footer group, click the Title button. The title control
with the title Toy Summary is inserted in the Report Header section. The text in the title
is selected.

8. Key Inventory Summary by Toy and press the Enter key.

9.  On the Design tab, in the Header/Footer group, click the Date and Time button. The
Date and Time dialog box appears, as shown in Figure 8-3.

WileyPLUS Extra! features an 
online tutorial of this task.

 The WingtipInventory 
fi le for this lesson is 
available on the book 
companion website or in 
WileyPLUS.

 The Chrysanthemum 
fi le for this lesson is 
available on the book 
companion website or in 
WileyPLUS.

Figure 8-3

Date and Time dialog box

 10.  Click OK to accept the default date and time formats. The Date and Time controls are
inserted in the Report Header section of the report, as shown in Figure 8-4.
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 11.  On the Design tab, in the Header/Footer group, click the Page Numbers button. The 
Page Numbers dialog box appears, as shown in Figure 8-5.

Figure 8-4

Report Header shown in 
Design View

Figure 8-5

Page Numbers dialog box

 12.  In the Position section of the Page Numbers dialog box, select the Bottom of Page 
[Footer] option then click OK. If necessary, scroll to the bottom of the report window. 
The page number is inserted in the Page Footer section near the bottom of the report, 
as shown in Figure 8-6.

Figure 8-6

Report shown in Design View

3.2.3

How do you apply form 
design options by formatting 

a header and footer?

5.2.4

How do you apply report 
design options to a header 
and footer by inserting a 

page number?
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 13. Click the Save button on the Quick Access Toolbar.

PAUSE. LEAVE the report open to use in the next exercise.

Adding Bound Controls
A bound control uses a fi eld in a table or query as the data source. Bound controls, such as 
text boxes, display information such as text, dates, numbers, pictures, or graphs from a fi eld in 
a table or query.

You can bind a control to a fi eld by moving it from the Field List pane or by using the Property 
Sheet. In this exercise, you practice adding a bound control to a report by using the Field List 
pane, and adding a bound control and unbound controls to a report by using the Controls 
group.

When you bind a control to a fi eld, you connect it to that fi eld. The easiest way to create a 
bound control is to double-click or drag a fi eld from the Field List pane to the report. Ac-
cess creates the appropriate control, binds the control to the fi eld, and creates a label for the 
control.

You can display the Field List pane by clicking the Add Existing Fields button on the Tools 
group.

Another way to bind a control to a fi eld is to fi rst add an unbound text box to a report or 
form using the Controls group. Then, open its Property Sheet either by right-clicking and 
choosing Properties from the shortcut menu or by clicking the Property Sheet button on 
the Tools group in the Design tab. On the Property Sheet, in the Data tab, click the down 
arrow beside the Control Source property and select the fi eld you want to display in the 
control.

The process for adding a control to a form and a report is the same. Once shown how to add a 
control to a report, you can add a similar control to a form in the same manner.

When you click any button on the Controls group (except the Hyperlink and Insert Image but-
tons) the pointer changes to the move pointer with a plus sign (�). Click where you want the 
upper-left portion of the control to start. Remember that a label will also be inserted, so leave 
enough space for the label. Click once to create a default-sized control, or click the tool and then 
drag it into the design grid to create the size you want.

When you click the Hyperlink and Insert Image buttons on the Controls group, a dialog box 
appears requesting additional information before these unbound controls are created. For 
example, the insert Hyperlink dialog box asks what fi le or location you’d like to link to, and the 
corresponding hyperlink text to display on the form or report; the Insert Image button displays 
a submenu with two selections, one of which allows you to browse your computer for images 
to add to the report or form, and the other allows you to view a gallery of images you’ve already 
included on your report or form so you may easily add them again.

You can use the Controls group to add other unbound controls like lines and page breaks 
to forms and reports. For example, you may want to use the line control to visually separate 
controls on a form to help it look more aesthetically pleasing, or the Insert Page Break con-
trol to create a report’s title page by separating controls in the Report Header from the rest 
of the report.

To delete a control from the grid, select it, display the shortcut menu, and choose Delete.

Take Note

5.2.4

How do you apply report 
design options to a header 

and footer by inserting a logo?

 Another Way
You can also 

display the Field List pane by 
pressing Alt�F8.

 Another Way
You can also 

display the property sheet by 
clicking control and pressing F4.
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2. Click the ID fi eld and drag it to the right of the Price fi eld, as shown in Figure 8-8.

3. Drag the In Production fi eld to the design grid below the ID fi eld.

4. Click Close on the Field List pane.

5.  Click the ID fi eld control until you see the orange border with selection handles on the
borders and corners.

6. Right-click in the control to display the shortcut menu.

ID field
dragged
here

Figure 8-8

Bound control dragged from 
the Field List pane

STEP BY STEP Add a Bound Control to a Report

USE the database open from the previous exercise.

1.  On the Design tab, in the Tools group, click the Add Existing Fields button. The Field
List pane appears. Click the Show all tables link. The fi elds for the Inventory table
appear, as shown in Figure 8-7.

Fields in Field List pane
Figure 8-7

Field List pane

c08UseControlsinReportsandForms.indd Page 188  8/12/11  9:38 PM user-f463c08UseControlsinReportsandForms.indd Page 188  8/12/11  9:38 PM user-f463 Volume/202/es/JWCL558Volume/202/es/JWCL558



189Use Controls in Reports and Forms

 8.  Select the In Production control, right-click and select Delete from the menu. If 
necessary, right-click the check box control that may still appear and select Delete 
from the menu.

 9.  On the Design tab, in the Controls group, click the Text Box button. The mouse pointer 
changes to a move pointer.

 10.  Position the pointer at approximately the same location as the deleted ID fi eld control 
and click to create the text box control as shown in Figure 8-10. Notice that the word 
Unbound is shown in the control and the word Text and a number (depending on the 
number of controls you have created in this session) appear in the label.

Figure 8-9

Shortcut menu

 7.  Select Delete from the menu, as shown in Figure 8-9. The control and label are 
removed from the design grid.

Figure 8-10

Unbound control
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 11. Select the control if it isn’t selected already.

 12.  On the Design tab, in the Tools group, click the Property Sheet button. The Property 
Sheet appears.

 13.  In the Data tab, click the down arrow on the Control Source row, and click the ID fi eld, 
as shown in Figure 8-11. Notice the control now displays the fi eld name ID, which 
means that it is now bound to the control.

 14. Click Close on the Property Sheet.

 15. Click the ID control label on the design grid and select the text in the label.

 16. Key ID and then press Enter. Your screen should look similar to Figure 8-12.

Figure 8-12

Bound control

Figure 8-11

Property Sheet
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 18.  Key Wingtip Toys Website in the Text to display box and www.wingtiptoys.com in the 
Address box, then click OK. Your screen should look similar to Figure 8-14.

Figure 8-13

Insert Hyperlink dialog box

Hyperlink 
control for 
Wingtip Toys 
website

Figure 8-14

Hyperlink control for Wingtip 
Toys website

 17.  On the Design tab, in the Controls group, click the Hyperlink button The Insert 
Hyperlink dialog box appears, as shown in Figure 8-13.

 19.  Click the Wingtip Toys website control until you see the orange border with selection 
handles on the borders and corners.

 20.  Position the pointer on the orange border until you see a four-sided arrow. Then, 
drag the control to the Report Header section and release it over the lower half of the 
Inventory Summary by Toy control. The Wingtip Toys website control should appear 
below the Inventory Summary by Toy control, as shown in Figure 8-15. You have just 
created a hyperlink to the Wingtip Toys website that is active in Report View.

3.2.2

How do you add a bound text 
box control to a form?

5.2.3

How do you add an unbound 
hyperlink to a report?

c08UseControlsinReportsandForms.indd Page 191  8/12/11  9:38 PM user-f463c08UseControlsinReportsandForms.indd Page 191  8/12/11  9:38 PM user-f463 Volume/202/es/JWCL558Volume/202/es/JWCL558



 192 Lesson 8

 21.  Switch to Report View to test the hyperlink. When fi nished, switch back to Report 
Design View.

 22. Click the Save button on the Quick Access Toolbar.

PAUSE. LEAVE the report open to use in the next exercise.

Adding Calculated Controls
A calculated control is a control that displays the result of a calculation or expression. 
Calculated controls can display calculations that are vital to the usefulness of a report or form. 
For example, when your company needs to know the amount of sales dollars generated by 
each toy in a product line, you can multiply the number of toys sold by the price and display 
the value in a report or form. Text boxes are the most popular choice for a calculated 
control because they can display so many different types of data. However, any control that has a 
Control Source property can be used as a calculated control. In this exercise, you use the Expres-
sion Builder to add a calculated control to a report.

An expression is like a formula in Excel. An expression consists of the following elements used 
alone or in combination:

• Identifi ers: The names or properties of fi elds or controls
• Operators: Such as � (plus), – (minus), or * (multiply)
• Functions: Such as SUM or AVG
• Constants: Values that do not change, such as numbers that are not calculated

To create a calculated control, you can either key an expression in the Control Source property 
box or use the Expression Builder, which is a feature that provides names of the fi elds and 
controls in a database, lists the operators available, and has built-in functions to help you create 
an expression. New to Access 2010 is a more intuitive Expression Builder, which reorganizes the 
layout of its dialog box and includes IntelliSense, which presents you with a drop-down box of 
potential values as you’re typing an identifi er or function name to create your expression.

STEP BY STEP Add a Calculated Control

USE the database open from the previous exercise.

 1. On the Design tab, in the Controls group, click the Text Box button.

 2.  Position the mouse pointer on the design grid and drag down and to the right to 
create a control the size of the one shown in Figure 8-16.

Figure 8-15

Wingtip Toys website control in 
Report Header section

5.2.3

How do you add a bound text 
box control to a report?

5.4.1

How do you rename a label in 
a report?

3.2.5

How do you view a control’s 
property sheet?

NEW
to Offi ce 2010
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193Use Controls in Reports and Forms

 3. With the control selected, right-click to display the shortcut menu.

 4. Select Properties from the menu. The Property Sheet appears.

 5.  On the Data tab, in the Control Source row, click the Build button. The Expression 
Builder dialog box appears.

 6.  In the Expression Categories list, scroll down and double-click In Stock, as shown in 
Figure 8-17. All the list items in the Expression Categories on your screen may not 
match exactly to the fi gure. The In Stock fi eld is inserted in the expression box.

Figure 8-17

Expression Builder

 7.  In the Expression Elements box, click the Operators item then double-click the 
* asterisk item in the Expression Values box to select the multiplication operator.

 8.  In the Expression Elements box, click the Toy Summary item, then fi nd and double-
click the Price fi eld in the list that appears in the same box below.

Figure 8-16

Text box control
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 10. Click Close on the Properties Sheet.

11. Select the text in the label and key Investment.

 12. Switch to Report View and scroll through the records to view the calculated totals.

 13. Click the Save button on the Quick Access Toolbar.

 14. Close the report.

PAUSE. LEAVE the database open to use in the next exercise.

It is often easiest to add and arrange all the bound controls fi rst, and then add the unbound and 
calculated controls to complete the design of the report.

Adding Controls Using a Wizard
It could take quite a bit of time to fi gure out how to set all the properties necessary to create 
option groups and combo and list boxes for a report or form. To speed up this task, Access 
2010 includes wizards that help you create some of the more complicated controls, such as 
option groups and combo and list boxes. A Control Wizard can help you create controls such 
as command buttons, list boxes, combo boxes, and option groups. In this exercise, you add a 
combo box to a form using the Control Wizard.

Like other wizards you have used, a Control Wizard asks you questions about how you want the 
control to look and operate, and then it creates the control based on your answers. The Control 
Wizard’s button is a toggle button that you can click to activate and deactivate wizards on 
controls that use them.

STEP BY STEP Use the Control Wizard

USE the database open from the previous exercise.

1. Click the Inventory table in the Navigation pane to select it.

2.  On the Create tab, in the Forms group, click the Form Design button. A new, blank
form is created, and the Field List pane is displayed. (If it isn’t, click the Add Existing
Fields button.)

3. Double-click the Description fi eld to add it to the form.

4. Double-click the In Stock fi eld to add it to the form.

5. Double-click the Price fi eld to add it to the form.

6. Double-click the In Production fi eld to add it to the form.

7.  On the Design tab, in the Controls group, locate the Use Control Wizards command
and make sure it is turned on. The image next to the command should be displayed
in orange.

8. On the Design tab, in the Controls group, click the Combo box button.

Take Note

Expression 
in Control 
Source row 
of Property 
Sheet 

Figure 8-18

Controls group on the Design 
tab for forms

5.2.2

How do you add a calculated 
control to a report?

9.  Click OK. The expression appears in the Control Source row of the Property Sheet,
as shown in Figure 8-18. Notice that Access added the equal sign (=) that starts an
expression.
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 10.  When you release the mouse button, the Combo Box Wizard appears. Click the button 
beside I will type in the values that I want and click Next. In the empty cell below the 
Col1 header, key Yes. Continue keying values in the column as shown in Figure 8-20.

Figure 8-19

Drag to draw a custom control

Draw rectangle 
here to create 
custom control

Combo box button

Figure 8-20

Combo Box Wizard

 11. Click Next >.

 12.  Click the button beside Store that value in this fi eld and click the down arrow to 
display the menu. Select In Production from the menu, as shown in Figure 8-21.

Figure 8-21

Combo Box Wizard store 
values screen

 9. Position the mouse pointer and drag to draw a rectangle, as shown in Figure 8-19.

 13. Click Next >.
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 15. Click Finish. Your screen should look similar to Figure 8-23.

Figure 8-22

Combo Box Wizard 
caption screen

Figure 8-23

Form with combo box control

Combo box 
added to form

A combo box is also known as a drop-down control, because it is a combination of a text box 
with a list box that is hidden until you select the arrow next to the text box and it drops down.

 16.  Delete the fi rst In Production control and label you added to the form since the combo 
box you added is a better control format to keep track of inventory.

 17.  Switch to Form View, scroll through the records, and modify the In Production fi eld 
based on the items in the combo box.

 18. Click the Save button on the Quick Access Toolbar and save the form as Inventory.

PAUSE. LEAVE the form open to use in the next exercise.

Adding Button Controls Using the Wizard
You can also use Control Wizards to add Button controls to forms. Button controls can be 
created by using the Command Button wizard and assigned certain tasks created by macros. 
Macros are useful since they add additional functionality to a database by automating a series 
of tasks to create an action. For example, Button controls can be created on a form to perform 
many different actions, including moving to the next or previous record, or even to display the 

Take Note

5.2.3

How do you add a bound 
drop-down control to a report?

3.2.2

How do you add a bound 
drop-down control to a form?

3.2.6

How do you add existing 
fi elds to a report?

 14. Key In Production in the text box, as shown in Figure 8-22.
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Print dialog box or close the form. The code that enables this functionality is automatically 
created as a macro by the Command Button wizard. In this exercise, you create a Button control 
using the Command Button wizard and use the View Code button to open the Visual Basic for 
Applications program.

You can further customize the function of database controls and even objects by viewing and 
modifying their code using a programming language called Visual Basic for Applications (VBA). 
You can click the View code button in the Tools group of the Form Design Tools contextual 
tab to open the VBA program. The VBA program is built into Access and provides you with an 
interface to write and modify code associated with database controls and objects. You can really 
harness the power of Access 2010 by directly interacting with controls and objects via VBA.

STEP BY STEP Use the Control Wizard to Add Button Controls

USE the form open from the previous exercise.

 1. Switch to Design View, if necessary.

 2. On the Design tab, in the Controls group, click the Button button.

 3.  Position the mouse pointer on the design grid and drag down and to the right to 
create a control the size of the one shown in Figure 8-24.

Figure 8-24

Button control

Draw rectangle 
here to create 
Button control

 4.  When you release the mouse button, the Command Button Wizard appears. In the 
Categories list box, click Form Operations and in the Actions list box click Close Form, 
as shown in Figure 8-25.

Figure 8-25

Command Button 
Wizard, screen 1
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5. Click Next >.

6.  On the next screen, keep the default settings to have the button contain the Exit
Doorway picture displayed in the dialog box, as shown in Figure 8-26.

Figure 8-26

Command Button 
Wizard, screen 2

Figure 8-27

Command Button Wizard, 
fi nal screen

7. Click Next >.

8.  On the fi nal screen, key Exit_Inventory_Form as the default button name, as shown
in Figure 8-27, and click Finish. (The button name indicated on your screen may differ
depending on how many controls you’ve previously attempted to include.)

9.  Notice that the image on the Button control on the form has changed to the Exit
Doorway picture.

 10.  Click the Button control on the form, on the Design tab, in the Tools group, click the
View Code button, as shown in Figure 8-28. The Microsoft Visual Basic for Applications
window appears, as shown in Figure 8-29.

Figure 8-28

View Code button in 
Tools group

View Code button
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Figure 8-29

Microsoft Visual Basic for 
Applications window

3.2.4

How do you use the View 
Code button?

The Bottom Line

11. Click the Close button on the Visual Basic for Applications window to return to Access.

 12. Save and close the form.

PAUSE. LEAVE the database open to use in the next exercise.

DEFINING CONTROL TAB ORDER
When you are in Form or Report View, pressing the Tab key moves the selection, or focus, to the 
next fi eld. Control tab order refers to the order in which the selection, or focus, moves from 
fi eld to fi eld in a form or report. When entering data in a form, it is helpful to set the control tab 
order to a sequence that matches the order of the data you are entering. It’s also helpful to set the 
tab order of a report to a logical fi eld sequence when reviewing report records. In this way, you 
can effi ciently concentrate on meaningful data as you use the change of focus as a guide. In this 
exercise you defi ne report control tab order.

You can change the tab order using the Tab Order dialog box, which is located in the Tools 
group of the Report Design Tools Design contextual tab. The Tab Order dialog box lists each 
section of the report or form and the tab order of the fi elds in each section. Click the selection 
button to the left of each row in the Custom Order list to select the row. You can drag the rows 
into the tab order you want, from top to bottom. The AutoOrder button places the fi elds in the 
order that they appear on the form or report, from top to bottom, left to right.

STEP BY STEP Defi ne Control Tab Order

USE the database you used in the previous exercise.

1. Open the Toys By Quantity In Stock report in Report View.

2.  Press the Tab key several times to see the order in which the controls are selected each
time you press it. Notice that the tab order begins in the Report Header section with
the Print Report control, and moves to the In Stock control (grouping fi eld) then moves
to the ID, Description, and Price controls. The tab order then continues in sequence
through the controls in the In Stock grouping level, skipping the In Stock fi eld until it
reaches the next group.

 Another Way
You can also right-

click the design grid in Design 
View to access the Tab Order 
dialog box.
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 3. Switch to Design View.

 4.  On the Design tab, in the Tools group, click the Tab Order button. The Tab Order dialog 
box appears. Click the Detail option in the Section list, as shown in Figure 8-30, 
displaying the tab order in the Custom Order list.

Figure 8-30

Tab Order dialog box

Row selector

 5.  Click the Auto Order button. Nothing changed. The order of the fi elds already has been 
automatically set based on the order that they appear on the form or report.

 6.  Click the row selector to the left of the Price fi eld to select it.

 7.  Click and hold the row selector. The mouse pointer changes to a move pointer with an 
empty rectangle. Drag up a row and notice the black horizontal line moves with you. 
Drag up until the black horizontal line is in place at the bottom of the ID fi eld; release 
the mouse button. The Price fi eld should be second, right below the ID fi eld, as shown 
in Figure 8-31.

Figure 8-31

New order on the Tab Order 
dialog box

 8. Click OK.

 9. Save the report design.

 10. Switch to Report View.

 11. Press the Tab key several times to see the new tab order.

 12. Close the report.

PAUSE. LEAVE the database open to use in the next exercise.

5.2.5

How do you defi ne control 
tab order in a report?
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SOFTWARE ORIENTATION

Report Design Tools Format Tab

When you are working with reports, the Format tab is located in the Report Design Tools 
and contains groups of commands used to format reports, as shown in Figure 8-32. Refer to 
this fi gure in the following section and throughout the book.

Align Text Left

Font 
Menu

Font Size menu

Align Text Right
Center Text

Font Color
Change

Shape button
Fill/Back Color Background

Image button

Conditional Formatting button
Quick Styles button

Format painter

Figure 8-32

Format tab in Report 
Design Tools

When you are working with forms, the Format tab contains the same groups of commands 
and is available in the Form Layout Tools. Use these common formatting commands to 
change the display of controls and their labels in forms and reports.

FORMATTING CONTROLS
Formatting professional-looking reports and forms not only projects a high-quality image, but 
it also improves the form or report’s readability. Display formatting allows you to refi ne the look 
of your reports and forms. You can change the font, font size, font color, alignment, and other 
attributes of text and numbers in controls and their associated labels. You can also change the 
background images of your reports and forms, as well as change the shapes of certain controls. 
You can even apply Quick Styles to controls to quickly change their appearance, or use condi-
tional formatting to change the look of data when certain conditions are met.

Formatting Controls
To format the display of a control, you can use many of the formatting tools that you have prob-
ably used before to format text, numbers, and objects in other Offi ce programs, such as Word. 
In this exercise, you format the display of controls on a report and increase the amount of space 
in the Report Header section to include an Insert Page Break unbound control.

You can resize controls and their labels by clicking the resize handles, which are tiny squares 
located on the borders and corners of a selected control or label. Position the mouse pointer 
over a handle to get a two-sided arrow, then drag to increase or decrease the width or height of a 
label. To move a control and its label, select the control and position the mouse pointer over the 
selection until you see a four-sided arrow, then drag to the new position.

As you remember from previous lessons, forms and reports are divided into sections, including 
the Report Header, Page Header, Detail, Page Footer, and Report Footer. You can change the 
amount of space between sections to eliminate extra space and to accommodate the controls in 
the report or form. To increase or decrease the height of the section, position the mouse pointer 
over the top edge of the section border until you see a double-sided resizing arrow and drag up 
or down.

The Bottom Line
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Double-click a section bar or any blank space within a section to display the Property Sheet for 
that section.

Controls on forms and reports display the format applied to the source table. However, you can 
change the display formatting for each control and label on a form or report. Your changes will 
only affect each control and the way the data appears. It does not change how users enter data 
or how data is stored.

You cannot apply visual formats to controls bound to Attachment and OLE Object fi elds. How-
ever, you can change the format of the label associated with the control.

You can format a control in Design View or Layout View using the commands in the Font 
group. You can change the font as well as the size, color, alignment, and background color of 
text. You can also add bold, underline, and italics. The Format Painter button copies formats so 
that you can easily apply the same formatting to another control.

You can also format controls using the commands in the Control Formatting group. You can 
apply Quick Styles, change the shape, and apply shape effects to quickly change the appearance 
of certain controls like button controls, or change the fi ll and outline color of controls. You can 
even use conditional formatting to change the look of the data that appears in a control when 
certain conditions are met.

By default, text does not automatically wrap when it reaches the edge of a fi eld or box. It remains 
on a single line and extends beyond the edges of the control. To enable text wrapping in a form 
or report, set the height to a nondefault size and change the CanGrow and CanShrink properties 
for the control to Yes.

STEP BY STEP Format Controls on a Report

USE the database open from the previous exercise.

 1. Open the Toy Summary report and switch to Design View.

 2.  Click the In Stock control. Position the mouse pointer over the resize handle on the 
right border. The mouse pointer changes to a double-sided arrow. Drag to the left to 
resize the control. 

 3. In the same manner, reduce the size of the Price and ID controls.

 4. Click the Description control to select it.

 5.  On the Format tab, in the Font group, click the Bold button. The Description control 
displays bold.

 6.  Click the arrow on the Font Size menu and select 12 from the menu. The point size 
becomes 12.

 7. Click the In Stock control to select it.

 8.  On the Design tab, in the Font group, click the Left Align button. The In Stock text 
aligns to the left of the control box. Your report should look similar to Figure 8-33.

Take Note

Take Note

Take Note
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 9.  Position the mouse pointer over the top edge of the Page Header section border until you 
see a double-sided resizing arrow and drag down to increase the height of the Report 
Header section by approximately one-quarter of an inch, as shown in Figure 8-34.

Figure 8-33

Report with display 
formatting applied

Figure 8-34

Resize Report Header section

Report 
Header 
section 
increased 
by ¼”
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 10. On the Design tab, in the Controls group, click the Insert Page Break button.

 11.  Position the mouse pointer on the design grid and under the Wingtip Toys Website 
Hyperlink control, drag down and to the right to create an Insert Page Break control, 
as shown in Figure 8-35. This will divide the Report Header section from the rest of the 
Report when printed, essentially creating a title page.

Figure 8-35

Insert Page Break control 
added to Report Header section

Insert Page 
Break control in 
Report Header 
section

 12. Save the report.

 13.  Switch to Print Preview to see the changes you’ve made. Notice the Report Header 
section is on the fi rst page by itself.

 14. Open the Toys By Quantity In Stock report in Design View.

 15. In the Report Header section, click the Print Report Button control to select it.

 16.  On the Format tab, in the Control Formatting group, click the Change Shape button to 
display the menu. Click the Oval option. The Button control’s style changes to an oval.

 17. Save and close the report.

PAUSE. LEAVE the database open to use in the next exercise.

Formatting Controls on a Form
In this exercise, you learn how to format the display of controls on a form and include a back-
ground image.

STEP BY STEP Format Controls on a Form

USE the database open from the previous exercise.

 1. Open the Inventory Form if it’s not open already, and switch to Design View.

 2.  Click the Button control on the form. On the Format tab, in the Control Formatting 
group, click the Quick Styles button to display the Quick Styles gallery. Click the 
Colored Outline – Aqua, Accent 5 Quick Style, as shown in Figure 8-36. The Button 
control’s style changes to the chosen Quick Style.

5.2.3

How do you insert a page 
break into a report?

5.4.3

How do you change the shape 
of a control in a report?
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 3. Click the Description label to select it.

 4.  On the Format tab, in the Font group, click the Font Color button and click Black from 
the Font Color menu. The Description label displays in black. Change the font color 
to black for the In Stock, Price, and In Production labels. Your screen should resemble 
Figure 8-37.

Figure 8-36

Quick Styles gallery

Quick Styles button and gallery

Button 
control 
selected

Figure 8-37

Color of labels changed 
to black

Label colors 
changed to 
black

 5.  On the Format tab, in the Background group, click the Background Image button 
and select the Chrysanthemum thumbnail that displays in the gallery. (If the 
Chrysanthemum image doesn’t appear, then use the Browse command under the 
gallery to access the data fi les for this lesson.) Notice the form’s background image 
is now that of the chrysanthemum, as shown in Figure 8-38.
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 6. Switch to Form View to see the changes you made.

 7. Save and close the form.

PAUSE. LEAVE the database open to use in the next exercise.

Creating Conditional Formatting on Controls
Sometimes employees need a little help recognizing when inventory is low or when sales are 
high. Conditional formatting in forms and reports helps alert users to text or numbers that need 
attention so that important data is not overlooked. Conditional formatting changes the 
appearance of a control or the value in a control when certain conditions are met. You can 
change the color of text or numbers in the control or the background color. In this exercise, you 
create conditional formatting for a report fi eld.

You can create conditional formatting based on a value or expression. For example, when the 
number of products in an inventory falls below 10 for a single product, you can set the condi-
tional formatting so that Access will display that number in red or with a red background so that 
you and others will notice the low inventory number.

The easiest way to add conditional formatting to a form or report is by using the Conditional 
Formatting Rules Manager dialog box, which displays a list of the existing formatting rules, if 
any. Here you can add new rules, and edit or delete existing rules.

STEP BY STEP Create Conditional Formatting

USE the database you used in the previous exercise.

 1. Open the Toy Summary report, if necessary, and switch to Design View.

 2. Click the In Stock control to select it.

Figure 8-38

Form background image

3.4.2

How do you apply a 
background image to a form?

5.4.2

How do you apply a 
background image to a report?

3.4.1

How do you reformat a font 
in a form?

3.4.3

How do you apply Quick Styles 
to controls in forms?
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 3.  On the Format tab, in the Control Formatting group, click the Conditional Formatting 
button. The Conditional Formatting Rules Manager dialog box appears.

 4.  Click the New Rule button. The New Formatting Rule dialog box appears. You will 
create a new rule based on criteria you will enter.

 5.  In the Edit the rule description section, keep the Field Value Is in the fi rst menu. Click 
the drop-down arrow next to between and scroll to the bottom of the list to select less 
than or equal to. Click in the empty text box and key 10.

 6. Click the Bold button in the Preview section.

 7.  Click the down arrow on the Background Color button. A menu of colors appears. Click 
Red, as shown in Figure 8-39.

Figure 8-39

Fill Color menu on New 
Formatting Rule dialog box

 8.  Click the OK button. A formatting rule for the In Stock fi eld is added to the dialog box, 
as shown in Figure 8-40. Now, when the report is viewed in Report View, the value for 
the In Stock fi eld will appear bold and the control background color will appear red if 
the formatting rule applies.

Figure 8-40

Formatting rule for the 
In Stock fi eld

 9. Click OK.

 10. Save the report.

 11.  Switch to Report View and scroll through the records to see the conditional formatting 
at work.

 12. Close the report.

PAUSE. LEAVE the database open to use in the next exercise.

3.4.4

How do you apply conditional 
formatting to form controls?

5.4.4

How do you apply conditional 
formatting to report controls?
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SOFTWARE ORIENTATION

Arrange Tab

The Arrange tab, shown in Figure 8-41, is located in the Report Layout Tools as well as 
the Report Design Tools area of the Ribbon. It contains groups of commands for arranging the 
layout, alignment, size, and position of controls on a report. Use the commands in the 
Arrange tab to arrange controls on a report.

Figure 8-41

Arrange tab in the Report 
Design Tools Ribbon in 

Layout View

Select Column
Split

Vertically

Merge
Button

Control 
  Margins button

Move
Down

Move
Up

Select Row Select Layout

Gridlines 
button

Stacked Layout Tabular Layout

Insert
Row

Above

Insert Row Below

Split 
Horizontally

Control Padding 
button

Insert Column Left

Insert 
Column

Right

Similar to a report, the Arrange tab is displayed in both the Form Layout Tools and Form 
Design Tools area of the Ribbon. The buttons and commands on the Arrange tab are the 
same as the Arrange tab for reports, except for the Anchoring button located in the Position 
group. The Position group, shown in Figure 8-42, contains an Anchoring button that helps 
position controls on a form when the containing window is resized. Use the commands in 
the Arrange tab to arrange controls on a form.

Figure 8-42

Position group on Arrange tab 
in the Form Design Tools 

Ribbon in Layout View

ARRANGING CONTROL LAYOUT
After you have created a form or report, you can arrange the controls on it to fi t the data or to 
best display the data. Access provides commands for arranging the layout, alignment, position, 
and size of controls. Control layouts align your controls horizontally and vertically to give 
your report or form a uniform appearance. The two types of control layouts are tabular and 
stacked. Controls are arranged vertically in a stacked layout, with a label on the left and the 
control on the right. Stacked layouts are contained in one report or form section. In a tabular 
layout, the controls are arranged in rows and columns like a spreadsheet, with labels across the 
top. Tabular layouts use two sections of a report or form. The labels are displayed in one section 
and the fi elds are arranged in the section below. In this exercise, you arrange controls on a form 
using control layouts.

You can have more than one layout on a report. For example, you could have a tabular layout 
to create a row of data for each record, then a stacked layout underneath with more information 
about the same record.

The Bottom Line
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209Use Controls in Reports and Forms

Access automatically creates tabular control layouts when you create a new report using the 
Report button or the Blank Report button in the Create tab. When you create a new form using 
the Form button or the Blank Form button, Access creates stacked control layouts.

On an existing blank report, you can create a new control layout by holding down the Shift key 
and selecting the fi elds you want to include in the form or report from the Field List pane. On 
the Arrange tab, in the Table group, click the Tabular button or the Stacked button.

You can switch the entire layout of a report or form to the other by selecting all the cells in the 
layout and then clicking the layout button you want, either Stacked or Tabular.

You can split a control layout into two different layouts. Hold down the Shift key and click the 
controls you want to move to the new control layout and click the Tabular or Stacked button.

STEP BY STEP Arrange Control Layout

USE the database open from the previous exercise.

 1. Click the Inventory table in the Navigation pane to select it.

 2.  On the Create tab, in the Reports group, click the Blank Report button. A new, blank 
report is created and the Field List pane is displayed.

 3.  Close the Field List pane, and close the Blank Report. Notice Access didn’t ask us if 
we wanted to save the report since we didn’t add any fi elds to it. We want to create an 
interface to interact with the Inventory table to input, modify, and delete records, so a 
form would be necessary.

 4.  On the Create tab, in the Forms group, click the Form Design button. A new, blank 
form is created, and the Field List pane is displayed. (If it isn’t, click the Add Existing 
Fields button.)

 5. Double-click the Description fi eld to add it to the form.

 6. Double-click the In Stock fi eld to add it to the form.

 7. Double-click the Price fi eld to add it to the form.

 8. Press and hold the Shift key and click each of the three controls to select them all.

 9.  On the Arrange tab, in the Table group, click the Stacked button. The controls and 
labels are arranged in a stacked layout, as shown in Figure 8-43.

Figure 8-43

Stacked control layout

 10.  On the Arrange tab, in the Table group, click the Tabular button. The controls and labels 
are arranged in a tabular layout, as shown in Figure 8-44.
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 11.  On the Arrange tab, in the Table group, click the Stacked button to switch it back to a 
stacked layout.

 12. Save the form as Stacked Form and leave it open for use in the next exercise.

PAUSE. LEAVE the database open to use in the next exercise.

You can adjust the location of information displayed in a control with the Control Margins 
button in the Position group. You can choose None, Narrow, Medium, or Wide settings in the 
Control Margins menu.

The Control Padding button adjusts the amount of space between a control and the gridlines 
of a layout. The Control Padding menu contains choices for None, Narrow, Medium, or Wide 
padding.

The Position group also contains the Anchoring button and menu, which ties a control to other 
controls so that they resize with the parent. The Anchoring button only appears in the Form 
Design Tools Arrange contextual tab in the Position group since the anchoring option is only 
available for forms and not reports. Anchoring is helpful when you want to control the position 
of the controls on a form when the form window is resized. For example, you can anchor the 
Description fi eld control (the parent) to stretch down and to the right so you can see more text 
within the fi eld control as the form becomes larger. The anchoring of the surrounding controls 
is set automatically based on the parent. You can only anchor one control in each control layout. 
You have nine anchoring options to choose from.

By using the new tools in the Rows & Columns group, Merge/Split group, and Move group on 
the Arrange tab, Access 2010 gives you even greater fl exibility over arranging and controlling 
the cells in control layouts.

By using the tools in the Rows & Columns group, you can add new rows and columns of cells 
above and below existing cell rows and to the left and right of existing cell columns. By using the 
tools in the Merge/Split group, you can merge two cells into one, as well as split them vertically 
and horizontally. Finally, the tools in the Move group can be used to reorganize cells by moving 
them up or down.

Adding, Moving, and Removing a Control
When you want to add a new fi eld from the Field List to an existing control layout, just drag 
the fi eld from the Field List pane to the grid. To add it to the layout, select all the controls in 
the layout and the new control, and click the Stacked or Tabular button. Removing a control 
from a control layout allows you to place it anywhere on the report or form without affecting 
the positioning of any other controls. Click the control you want to remove and click Remove 
Layout from the Table group. The Remove Layout button is only available in the Table group 
in report or form Design View. In this exercise, you add and move controls within a layout and 
remove a control from a layout.

NEW
to Offi ce 2010

Figure 8-44

Tabular control layout

5.1.1

How do you create a 
blank report?
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STEP BY STEP Add, Move, and Remove a Control from a Layout

USE the database open from the previous exercise.

 1. Select all three controls, if they aren’t selected already.

 2. Click on the selection and move the group of fi elds down about half an inch.

 3.  Click the In Production fi eld from the Field List pane. Drag it to the grid and place it to 
the right of the Description fi eld.

 4. Drag the ID fi eld to the grid and place it above the Description fi eld.

 5.  Press and hold the Shift key and select the ID fi eld control, if necessary. Still holding 
the Shift key, select the Description, In Stock, and Price fi eld controls so that all four 
are selected.

 6.  On the Arrange tab, in the Table group, click the Stacked button. The ID control is 
added to the bottom of the stacked layout.

 7.  On the Arrange tab, in the Position group, click the Control Margins button and select 
Narrow from the menu, as shown in Figure 8-45.The margins within the fi eld control 
and label are formatted using the Narrow option.

Figure 8-45

Control Margins button 
and menu

Narrow option selected

 8.  On the Arrange tab, in the Position group, click the Control Padding button and select 
Wide from the menu, as shown in Figure 8-46.

Figure 8-46

Control Padding button 
and menu

Wide option 
selected

 9.  Select the ID fi eld control and click Select Row in the Rows & Columns group. Notice 
the ID label and fi eld control are both outlined in orange. Click the Move Up button 
three times to move it to the top of the layout.

 10.  Move the In Stock label and fi eld control to the bottom of the layout.

 11.  Try to move the Price control into place under the In Production fi eld. It won’t move 
out of the layout.

3.3.3

How do you apply form 
arrange options by 

repositioning and formatting 
controls and records?

c08UseControlsinReportsandForms.indd Page 211  8/12/11  9:38 PM user-f463c08UseControlsinReportsandForms.indd Page 211  8/12/11  9:38 PM user-f463 Volume/202/es/JWCL558Volume/202/es/JWCL558



 212 Lesson 8

 12. Select the Price label and fi eld control if they aren’t selected already.

 13.  On the Arrange tab, in the Table group, click the Remove Layout button. Notice the In 
Stock label and fi eld control automatically move up to occupy the area where the Price 
label and fi eld control were when they were part of the layout.

 14. Drag the Price control into place under the In Production control.

 15. Save and close the form.

PAUSE. LEAVE the form open to use in the next exercise.

To select multiple controls, hold down the Shift key and then click the controls.

Arranging and Anchoring Controls
In this exercise you practice arranging controls within a layout using a variety of arrangement 
tools.

STEP BY STEP Arrange and Anchor Controls within a Layout

USE the database open from the previous exercise.

 1. Click the Inventory table in the Navigation pane to select it.

 2.  On the Create tab, in the Forms group, click the Form button. A new form containing 
all the fi elds from the Inventory table is created in Layout View. Notice the stacked 
control layout is the default.

 3. Switch to Design View.

 4. Click the ID control to select it.

 5.  On the Arrange tab, in the Merge/Split group, click the Split Horizontally button. Notice 
the ID fi eld control splits into two columns with the right-most column outlined by 
dashed lines.

 6.  Click the In Production fi eld control and drag it to the right of the ID fi eld control to 
place it next to it. Your screen should resemble Figure 8-47.

Take Note

5.3.3

How do you apply report 
arrange options by 

repositioning and formatting 
controls and records?

In Production control dragged to this locationFigure 8-47

In Production control 
next to ID control

 7.  Click the In Stock fi eld control to select it. Press and hold the Shift key and select the 
In Stock control label. On the Arrange tab, in the Move group, click the Move Down 
button once. The In Stock fi eld control and label move to the bottom of the layout.
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 8.  Click the Description fi eld control to select it. Press and hold the Shift key and select 
the cell below the Description fi eld control you just selected. Both the Description fi eld 
control and cell below should be outlined in orange. On the Arrange tab, in the Merge/
Split group, click the Merge button. The Description fi eld control and cell have now 
merged into one, as shown in Figure 8-48.

Figure 8-48

Description fi eld control 
merged with cell

 9.  Click the In Stock fi eld control to select it. On the Arrange tab, in the Rows & Columns 
group, click the Insert Below button twice. Two empty cells are added under the In 
Stock control.

 10.  Click the In Stock fi eld control to select it. On the Arrange tab in the Rows & Columns 
group, click the Select Row button. Both the In Stock label and fi eld control should be 
selected.

 11.  On the Arrange tab, in the Move group, click the Move Down twice to move the In 
Stock control to the last cell row at the bottom of the layout, as shown in Figure 8-49.

Figure 8-49

In Stock control moved to 
bottom of layout

In Layout View, you can also use the tools on the Arrange tab to arrange controls within a layout 
for both forms and reports.

Take Note

3.3.3

How do you arrange controls 
on forms by repositioning and 

formatting controls?

5.3.3

How do you arrange controls 
on reports by repositioning 
and formatting controls?

3.3.1

How do you arrange controls 
on forms by using the table 

functions?

3.3.2

How do you arrange controls 
on forms by using the move 

table command?
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 12.  Click the Description fi eld control to select it. On the Arrange tab in the Position group, 
click the Anchoring button. The Anchoring menu appears. Click the Stretch Down 
and Across option, as shown in Figure 8-50. The Description fi eld control will now 
automatically resize to display all the containing text if the form window is resized in 
Form View.

Stretch Down and Across option selected

 13.  Switch to Form View to display the new arrangement of the controls and resize the 
form window to see the Description fi eld control stretch and shrink in conjunction with 
the window size.

As you learned in a previous exercise, you could resize the fi eld controls to make them more 
consistent with the data they display. For example, in this exercise, some of the data in the In 
Stock fi eld control is not completely shown within the fi eld control. The control can be easily 
and appropriately resized in Layout or Design View. You will have the opportunity to do this in 
an exercise at the end of this lesson.

 14. Save the form as Modifi ed Inventory Form and close it.

PAUSE. LEAVE the database open to use in the next exercise.

ARRANGING CONTROL ALIGNMENT, SIZE, AND POSITION
You can change the alignment, size, or position of controls and associated labels. Aligning, siz-
ing, and positioning commands on the Arrange tab gives you more options for improving the 
look of controls and labels in forms and reports. The Sizing & Ordering group, present on the 
Arrange tab only in report or form Design View has commands for aligning labels and controls 
to the grid (the intersecting horizontal and vertical lines, and points that appear in Design 
View) to allow for precise position. For example, you can precisely align a group of controls and 
related labels using the align To Grid command to ensure all the labels’ upper-left corners align 
to their nearest grid points. This will help ensure the organization of your controls is consistent 
throughout. In this exercise, you arrange the alignment, size, and position of controls and labels.

You can also align multiple controls and labels at one time so their left, right, top, and bottom 
borders are perfectly aligned to each other using the align left, right, top, and bottom commands.

Also in the Sizing & Ordering group, you can use the commands to adjust the size of controls and 
labels to Size to Fit, Size to Grid, Size to Tallest, Size to Widest, Size to Shortest, or Size to Narrowest.

Additionally you can use the Bring to Front and Send to Back commands to move objects in 
front or to the back of other objects. Also in the Sizing & Ordering group, you can use the 
commands to increase or decrease horizontal or vertical spacing using the Equal Horizontal, 

Take Note

5.3.1

How do you arrange controls 
on reports by using the 

table functions?

5.3.2

How do you arrange controls 
on reports by using the move 

table command?

The Bottom Line

Figure 8-50

Anchoring menu
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Equal Vertical, Increase Horizontal, Decrease Horizontal, Increase Vertical, and Decrease 
Vertical commands.

Finally, the Sizing & Ordering group contains toggle commands for showing or hiding the Grid, 
the Ruler, and enabling or disabling Snap to Grid—allowing you to precisely arrange a label 
when you move the associated control by enabling Access to automatically align the upper-left 
corner of a label to its closest grid point—as well as Group and Ungroup commands that allow 
you to group several controls together so you can move or modify them all at once.

STEP BY STEP Arrange Alignment, Size, and Position

USE the database open from the previous exercise.

 1.  Open the Stacked Form form in Design View.

 2. Select the Price label and control.

 3.  On the Arrange tab, in the Sizing & Ordering group, click the Size/Space button. In the 
Size category on the menu that appears, click the To Fit button.

 4.  Select all the controls in the stacked layout, (the labels and controls for the ID, 
Description, and In Stock controls).

 5. On the Arrange tab, in the Table group, click the Remove Layout button.

 6.  All the controls and labels should be still selected. On the Arrange tab, in the Sizing 
& Ordering group, click the Size/Space button. In the Size category on the menu that 
appears, click the To Fit button.

 7.  With the controls and labels still selected, on the Arrange tab, in the Sizing & Ordering 
group, click the Align button. In the menu that appears, click the Right button. The 
labels are right-aligned to the controls. Click on a blank space on the design grid to 
deselect all the highlighted controls and labels.

 8.  Press and hold the Shift key and click on both the labels and controls for the In 
Production and ID controls.

 9.  With the controls and labels still selected, on the Arrange tab, in the Sizing & Ordering 
group, click the Align button. In the menu that appears, click the Bottom button. The In 
Production control is bottom-aligned with the ID control.

 10.  With the controls and labels still selected, press and hold the Shift key and select the 
Price label and control.

 11.  On the Arrange tab, in the Sizing & Ordering group, click the Size/Space button. In the 
Spacing category on the menu that appears, click the Decrease Horizontal Spacing 
button until your screen looks similar to Figure 8-51.

Figure 8-51

Form with decreased horizontal 
spacing between controls
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 12.  Click on a blank space on the design grid to deselect all highlighted controls and
labels. Press and hold the Shift key and click on both the labels and controls for the
Description and Price controls.

 13.  With the controls and labels still selected, on the Arrange tab, in the Sizing & Ordering
group, click the Align button. In the menu that appears, click the Bottom button.
The Price control is bottom-aligned with the Description control. Your screen should
resemble Figure 8-52.

Figure 8-52

Form with bottom 
aligned controls

 14. Click on a blank space on the design grid.

 15.  On the Arrange tab, in the Sizing & Ordering group, click the Size/Space button.
In the Grid category on the menu that appears, click the Grid button. The design
grid disappears.

 16. Click the Grid button again. The design grid appears.

 17.  Click on a blank space on the design grid and drag to draw a box around the labels
and controls so they are all selected, or press and hold the Shift key and select each
label and control.

 18.  On the Arrange tab, in the Sizing & Ordering group, click the Align button. In the menu
that appears, click the To Grid button. Notice the control and labels slightly move. The
upper-left corners of all the labels are now aligned to their nearest grid points.

 19.  On the Arrange tab, in the Sizing & Ordering group, click the Size/Space button. In the
Grid category on the menu that appears, click the Ruler button. The rulers disappear.

 20. Click the Ruler button again. The rulers reappear.

 21. Save and close the form.

PAUSE. CLOSE the database.

3.3.3

How do you arrange controls 
on forms by repositioning 

and formatting?

5.3.4

How do you arrange controls 
on reports by aligning to 

the grid?
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Knowledge Assessment

Matching

Match the term in Column 1 to its description in Column 2.

Column 1 Column 2

1. control a.  a control that displays the result of a calculation
or expression

2. unbound control b.  help you create controls such as command buttons, list
boxes, combo boxes, and option groups

3. bound control c.  a layout in which the controls are arranged in rows and
columns, with labels across the top

4. calculated control d.  a control that doesn’t have a source; it displays
information such as lines, shapes, or pictures

5. Expression Builder e.  controls that are arranged vertically with a label on the
left and the control on the right

6. Control Wizards f.  layouts that align controls horizontally and vertically to
give your report or form a unique appearance

7. conditional formatting g.  an object that displays data, performs actions, and lets
you improve the look and usability of a form or report

8. control layouts h.  a control that uses a fi eld in a table or query as the
data source

9. tabular layout i.  means to change the appearance of a control or the
value in a control when certain conditions are met

 10. stacked layout j.  provides the names of the fi elds and controls in a
database, lists the operators available, and has built-in
functions to help you create an expression

True/False

Circle T if the statement is true or F if the statement is false.

T  F 1.  The easiest way to create a bound control is to double-click or drag a fi eld
from the Property Sheet to the report.

T  F 2. You can bind a control to a fi eld using the Property Sheet.

T  F 3. You can turn off Control Wizards.

T  F 4. Display formatting can be applied to controls and labels in a form or report.

T  F 5. You can specify only one condition for conditional formatting.

T  F 6.  You can switch an entire control layout of a report or form from one type to
the other.

T  F 7.  Control padding adjusts the amount of space between a control and the
gridlines of a layout.

T  F 8.  The Remove Layout command in the Table group removes a control from a
form or report.

T  F 9. You can set a tab order for each section of a form or report.

T  F 10. Tab order refers to the order of tabs displayed in a dialog box.
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Competency Assessment

Project 8-1: Refi ne the Alpine Ski House Report

You have learned a great deal about reports and forms while working as an administrative assistant 
at the Alpine Ski House. Refi ne the basic report you created previously so you can display it proudly 
at the front desk.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN the Alpine database.

 2. SAVE the database as AlpineXXX (where XXX is your initials).

 3. Open the Report Design report.

 4. Switch to Design View.

 5. Select all four controls in the report.

 6. On the Arrange tab, in the Table group, click the Tabular button.

 7.  On the Arrange tab, in the Position group, click the Control Margins button, and select 
Narrow from the menu.

 8.  On the Arrange tab, in the Position group, click the Control Padding button, and select 
Medium from the menu.

 9.  On the Design tab, in the Header/Footer group, click the Title button. A title is inserted 
in the report header.

 10. Key Alpine Ski House Rooms Report and press Enter.

 11.  On the Design tab, in the Header/Footer group, click the Logo button. Navigate to the 
student data fi les for this lesson and select Winter. Click OK.

 12.  On the Format tab, in the Background group, click the Background Image button. Open 
the folder that contains the data fi les for this lesson and select winterbackground. 
Click OK.

 13.  Press and hold the Shift key and click on all four labels and controls to select them.

 14.  On the Format tab in the Font group, click the Font Color menu button. Select the dark 
blue color called Dark Blue, Text 2 in the fi rst row and fourth column of the Access 
Theme Colors section.

 15.  Make sure all the controls are still selected. On the Arrange tab, in the Table group, 
click Remove Layout.

 16.  With the controls still selected, click and drag them together up to position just below 
the Detail section bar.

 17.  Scroll down and position the mouse pointer over the Page Footer section bar. Drag the 
section bar up to position just below the controls. Your screen should look similar to 
Figure 8-53.

          The Alpine fi le for 
this lesson is available 
on the book companion 
website or in WileyPLUS.

          The winterback-
ground.jpg fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.

          The Winter fi le for 
this lesson is available 
on the book companion 
website or in WileyPLUS.
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Figure 8-53

Report design
18. Save and close the report.

CLOSE the database.

Project 8-2: Format the Soccer Roster
Since you have increased your Access skills, you decide to improve on the soccer roster you created at 
the beginning of the season. There have been a few changes anyway, so you need an updated version.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN SoccerData from the data fi les for this lesson.

 2. SAVE the database as SoccerDataXXX (where XXX is your initials).

 3. Open the Roster report.

 4. Switch to Design View.

 5.  Press and hold the Shift key and click on all the labels in the Page Header section to 
select them.

 6. On the Format tab, in the Font group, click the Bold button.

 7. Select the title, Roster, and key Soccer Roster.

 8. On the Format tab, in the Font group, click the Font menu and select Arial Black.

 9. On the Format tab, in the Font group, click the Font Size menu and select 22.

 10.  On the Arrange tab, on the Size/Space menu in the Sizing & Ordering group, click the 
To Fit button.

 11.  Press and hold the Shift key and click on all the controls in the Detail section. On the 
Arrange tab, on the Align menu in the Sizing & Ordering group, click To Grid.

 12. Delete the report image.

 13. On the Design tab, in the Header/Footer group, click the Logo button.

 14. Navigate to the student data fi les for this lesson and select Soccer.jpg.

 15. Save the report and view it in Report View.

CLOSE the database.

          The SoccerData fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.

          The soccer fi le for 
this lesson is available 
on the book companion 
website or in WileyPLUS.
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Profi ciency Assessment

Project 8-3: Create the Fourth Coffee Order Summary Form
In your part-time job at Fourth Coffee, you are often involved in taking and fi lling orders. Create a 
summary table to help make your job easier.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN Coffee Data from the data fi les for this lesson.

 2. SAVE the database as CoffeeDataXXX (where XXX is your initials).

 3. Select the Order Summary table in the Navigation pane.

 4. Create a simple form using the Form button.

 5. Insert a Date and Time control with the format 00/00/0000.

 6.  Delete the Paid control and create a Yes/No option group control using check boxes 
with Paid as the caption. Set the value for Yes as �1 and the value for No as 0.

 7. Delete the Attachment fi eld.

 8.  Resize and arrange the controls to look similar to the form in Figure 8-54. Remember 
to remove the control layout formatting so that you can move individual controls.

          The Coffee Data fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.

 9. Save the form as Order Summary.

 10. Check your work in Form View.

 11. Close the form.

CLOSE the database.

Project 8-4: Create the Alpine Ski House Reservations Form
Entering data in the table is becoming cumbersome, so you decide to create a form you can use to 
enter reservation data.

USE AlpineXXX database, which you saved in a previous exercise.

 1. Click the Reservations table in the Navigation pane to select it.

 2. Create a new form using Design View.

Figure 8-54

Order Summary form
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Figure 8-55

Reservations form

 3. Insert a title control. Change the title to Alpine Ski House Reservations Form.

 4.  Insert a logo control using the Penguins.jpg image from the student data fi les from this 
lesson.

 5.  Add the following bound controls to the design grid: Customer ID, Room, Rate, Check-
In Date, Check-Out Date, and Notes.

 6. Select all the controls and apply the Stacked control layout.

 7.  Position the controls in the upper-left corner of the Details section, remove the stacked 
layout and resize the Notes control, as shown in Figure 8-55.

Mastery Assessment

Project 8-5: Refi ne the Alpine Ski House Reservations Form
The reservations form you created is very helpful; however, you need to add more functionality to the 
form using calculated controls and Control Wizards.

USE the form open from the previous exercise.

 1.  Add an Option group control on the right side of the form. Use the Control Wizard to 
create the option box for the Credit Card on File fi eld. Using the Option Group Wizard, 
add two Labels, one for Yes and the other for No. Set the value for Yes to �1 and the 
value for No to 0. Use option buttons, and label the control Credit Card on File.

 2. Add an unbound text box control below the Credit Card on File fi eld.

 3. Open the Property Sheet and click the Build button in the Control Source property.

 4. Create an expression to subtract the Check-In Date from the Check-Out date.

 5. Key Number of Nights as the label. (Note the default label number, such as Text##.)

 8. Save the form as Reservations Form and leave it open for use in the next exercise.

LEAVE the database open for the next project.

          The Penguins fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.
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 12. Save the form and switch to Form View.

CLOSE the database.

Project 8-6: Fix the Angel Project Contact Information Form
A volunteer did some work on the Angel Project database while you were on vacation. The Contact 
Information form has a few problems that you need to fi x.

GET READY. LAUNCH Access if it is not already running.

 1. OPEN AngelData from the data fi les for this lesson.

 2. SAVE the database as AngelDataXXX (where XXX is your initials).

 3. Open the Contact Information Form.

 4. Change the layout from tabular to stacked.

 5. Bind the unbound control to the City fi eld.

 6. Fix the control tab order.

 7. Save and close the form.

CLOSE Access.

Figure 8-56

Revised Reservations form

          The AngelData fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.

table with fi elds like Name, Description, Store, and Price. 
Use what you’ve learned in this lesson to create a form with 
controls for each fi eld. Enter the data for fi ve toys into your 
form. For extra practice, create a report that displays a sum-
mary of all your data.

INTERNET READY
What are your favorite toys? Maybe you have 

some favorites from childhood or perhaps you have some 
favorite grown-up toys, such as electronic gadgets. Search 
online stores for details about the toys. Create a database 

 6. Add an unbound text box control beside the Notes control.

 7. Open the Property Sheet and click the Build button in the Control Source property.

 8. Create an expression to multiply the Number of Nights (or Text##) by the Rate.

 9. Key Rate Subtotal as the label.

 10. Change all the controls and labels you added with black text to the red color.

 11. Switch to Layout View. Your screen should look similar to Figure 8-56.
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